Jump to content

[1.7.2] ATK Propulsion Pack - "SRB's for all your SRBy needs" - Updated 14/06/19


Recommended Posts

  • 4 weeks later...
I know we've already got the STAR 37FM in the pack but it would be nice to see the Star 37B, Star 37D, and Star 37E (I think those equate to the TE-364-2, TE-364-3 and TE-364-4 used on the Thor/Delta family). And maybe the Star 26 (Burner IIA).
Link to post
Share on other sites
  • 3 months later...
  • 2 weeks later...
  • 2 months later...
  • 1 year later...

This mod works perfectly with ksp 1.3.1.

A while back, ksp implemented SRBs thrust profile with the thrustCurve setting, so I calculated the parameters for a realistic thrustCurve for all the parts in this beautiful mod. With those numbers I compiled a patch to add the realistic thrust profiles.

Z4iJAv8.png

Thrust profile for the Star15B shown in orange over the profile provided by ATK.

There is also a RealPlume-stock patch (for the Star family) and a TweakScale patch.

Google drive link for patches

These patches require Module Manager to work!

Link to post
Share on other sites
  • 1 month later...
  • 4 weeks later...
  • 1 year later...
6 minutes ago, Kartoffelkuchen said:

Version 4.0 released!

  • KSP 1.7.2 (and also 1.6.1 for RO) support
  • New GEM-40 model & textures (Air- & Ground-lit)
  • Added GEM-60, GEM-63, GEM-63 XL
  • New model for the Star 48B and Star 48BV
  • General rebalancing of the parts

PyjqiTG.png

 

DOWNLOAD

Yay! New SRB's for me to test thank you!!! <3

Link to post
Share on other sites
  • 2 months later...

Hey,

I'm getting this Errors in my logs:

Quote

190831T164710.999 [ERROR] [PartReader.ReadTextures] Texture 'ATK_Propulsion_Pack/Star 30BP/Star 30BP_model000' not found!
190831T164711.131 [ERROR] [PartReader.ReadTextures] Texture 'ATK_Propulsion_Pack/Star 5C/model000' not found!

190831T165137.311 [ERROR] [PartLoader.CompileModel] PartCompiler: Cannot clone model 'ATK_Propulsion_Pack/Castor30' as model does not exist

Are they a problem?

 

My Logs: https://www.tancredi.nl/downloads/logs.zip

Do you need more information?

Link to post
Share on other sites
6 hours ago, N3N said:

Hey,

I'm getting this Errors in my logs:

Are they a problem?

 

My Logs: https://www.tancredi.nl/downloads/logs.zip

Do you need more information?

Well, is everything correctly displayed in the game? If yes, no worriee, if no, I'll have a look at it. :P

Thanks for directly providing a log file though :)

Link to post
Share on other sites
10 hours ago, Kartoffelkuchen said:

Well, is everything correctly displayed in the game? If yes, no worriee, if no, I'll have a look at it. :P

Thanks for directly providing a log file though :)

Hello,

I will try more things with this mod, but for now I can say:

The first two errors are "maybe", because there is an absence of ".dds" somewhere.

And for the third one, I can't find a "Castor30" in-game, maybe because there is a problem with the model.

Edited by N3N
Link to post
Share on other sites
  • 3 months later...
On 9/1/2019 at 6:50 PM, N3N said:

Hello,

I will try more things with this mod, but for now I can say:

The first two errors are "maybe", because there is an absence of ".dds" somewhere.

And for the third one, I can't find a "Castor30" in-game, maybe because there is a problem with the model.

you had need install antares rocket mod for R&k

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...