TheShadow1138

[PART] [1.7.3+] ShadowWorks - Stockalike SLS, Delta IV, and More v2.0.1 [8/7/2019]

Recommended Posts

6 hours ago, CocaoGames said:

ive done what you have said (apart from the rea chutes) i have real shutes installed, however the rocket still snap. from what i saw the capsule seems to sink kind of into the decoupler.

Aso great job on all the rockets, they look amaizing.

What other mods are you using?  I hate that the rocket is not flyable for you, and I'd like to help you get it working.  Is the Block I SLS the only one having this issue?  Are you able to launch the Block II SLS, or do all the rockets with the Orion snap?

Share this post


Link to post
Share on other sites
10 hours ago, TheShadow1138 said:

What other mods are you using?  I hate that the rocket is not flyable for you, and I'd like to help you get it working.  Is the Block I SLS the only one having this issue?  Are you able to launch the Block II SLS, or do all the rockets with the Orion snap?

Is there a way to send a screenshot of my mod list? ill try launch other rockets with  orion on

Share this post


Link to post
Share on other sites
9 hours ago, CocaoGames said:

yep all the rockets with orion break

So it is the Orion that seems to be messing with things.  Try this:  Remove the parachute, and do not replace it.  Launch without the parachute just to see if it flies as expected, and if all goes well and you make it to orbit, just revert to the VAB.  If it flies okay without the parachute, then I'd delete the "_ShadowWorks_RealChutes.cfg" file.  I haven't kept up with any possible changes to RealChute and it's possible the config I have is outdated.

10 hours ago, CocaoGames said:

Is there a way to send a screenshot of my mod list? ill try launch other rockets with  orion on

You could upload a screenshot to an image hosting site like Imgur, and then post it here.  Unfortunately the forums don't allow direct uploads of images.

Share this post


Link to post
Share on other sites

It works! Thank you so much for your help, you have done a great job on this mod, i was just looking for the sls but your pack has added so much more. well done!

Share this post


Link to post
Share on other sites
On 11/18/2018 at 6:39 AM, CocaoGames said:

It works! Thank you so much for your help, you have done a great job on this mod, i was just looking for the sls but your pack has added so much more. well done!

That's great!  So it was the parachute then I take it.  I'll have to double check RealChute before I release the next update, which I promise is coming, I've been working some more recently and getting some things actually in-game.

Share this post


Link to post
Share on other sites
3 minutes ago, CocaoGames said:

Also is there nay launch towers for this mod? mainly for the delta rockets.

any*

I haven't made any.  I know there is a launch pad mod that I can't remember the exact name of at the moment that may have Delta launch pads, but I'm not sure.  Maybe, and I stress maybe, once I've released the next update I'll look into adding a launch pad or two.

Share this post


Link to post
Share on other sites

Shadow just wondering if you can create an actual Orion Parachute system? 

Share this post


Link to post
Share on other sites
31 minutes ago, Mukita12 said:

Shadow just wondering if you can create an actual Orion Parachute system? 

I have wanted to redo the parachute because the lines don't line up with the part correctly so, I can certainly look into it.

Share this post


Link to post
Share on other sites
25 minutes ago, TheShadow1138 said:

I have wanted to redo the parachute because the lines don't line up with the part correctly so, I can certainly look into it.

ok

Share this post


Link to post
Share on other sites
12 hours ago, Virtualgenius said:

@TheShadow1138  just enquiring as to whether your goinng to update to 1.6.1

Since this is just a parts mod, it should work with 1.6.1 even though it isn't explicitly listed as such.  Everything should work fine, but you can post here if you have any issues.

Share this post


Link to post
Share on other sites
Posted (edited)
And I have a problem. I wanted to build Orion, but I found that the parachute was not working. What to do?
Edited by Greg Cooper

Share this post


Link to post
Share on other sites
14 hours ago, Greg Cooper said:

And I have a problem. I wanted to build Orion, but I found that the parachute was not working. What to do?

Most of the time it's related to the "_ShadowWorks_RealChutes.cfg" file.  Try deleting that RealChutes config from the ShadowWorks folder.  This should no longer happen, but it somehow keeps cropping up.  Deleting that file should fix the problem.

Share this post


Link to post
Share on other sites

I am actively working on the mod once again.  I have all of Jupiter and Altair Lander parts in KSP, I just need to finish up their cfg files, and convert the textures to DDS.  I'm currently working on the IVA for the Altair lander, and decided to finally do an actual interactive glass cockpit for the IVA.  I've discovered, however, that RPM is no longer being actively developed.  Would people prefer RPM, or MOARdv Avionic Systems (the RPM replacement)?

Also, since it's been so long I am including some other surprises that will be revealed when everything is done.

Share this post


Link to post
Share on other sites
58 minutes ago, TheShadow1138 said:

I've discovered, however, that RPM is no longer being actively developed.  Would people prefer RPM, or MOARdv Avionic Systems (the RPM replacement)?

MAS most definately... MAS is finally completed... and *touchscreens*... :P

Share this post


Link to post
Share on other sites

Here are a couple more screenshots from the upcoming update.

Full Mirrored Finish (not sure if this is the best idea)

CQiVYdP.png

On the launch pad:

EryzuTx.png

Delta IV Medium on the pad:

57T7hQU.png

Delta IV Heavy in the VAB:

O2phkC3.png

 

Share this post


Link to post
Share on other sites

Some more screenshots as testing continues.  I'm pretty happy with how things are going, just a couple more tweaks and it may just be ready.  All craft files that use new parts will, of course, be remade.  I've also finally gone through and given most of the parts names using the originally intended Egyptian pantheon theme (as I don't recall seeing many mods using them, so what the heck), so I will be using those names going forward.

First full flight of the Osiris (Orion) and Horus (Altair) lander on the Block IB Amun-Ra (SLS):

0l6y4E9.png

FvBjLhP.png

After undocking to head down to the surface:

GnW1GdY.png

Success!

EeLNwZE.png

Successful redocking:

HYcGM31.png

Re-entry with Kerbin reflected in the heatshield:

BvyP52O.png

Some of the remade launchers:

Block I Amun-Ra (SLS)

rQ8sn8u.png

Apophis I (Ares I)

05tSIT4.png

Apophis II (Ares II)

dfoxuGz.png

Amunet STS Stack:

levtRPI.png

Share this post


Link to post
Share on other sites
Posted (edited)

Announcing...

Release of Version 2.0!!!!!!

Spacedock Download

An extensive overhaul of nearly every part; new models, new textures, new part modules, and new aliases for the parts.  I'm quite pleased with how they all turned out, and even though they may not be things of perfection, the MOARdV Avionics Systems enabled IVAs for the Osiris (Orion) and Horus (Altair) look pretty good to me, and they function!

A full change log can be found in the OP, on Spacedock, and in the download itself.

kJAA0iA.png

aKLJDW4.png

Happy Launchings!

Edited by TheShadow1138

Share this post


Link to post
Share on other sites

Great mod. Just one problem I have found. The legs for the lander are not in my tech Tree which I have everything unlocked. Using community tech tree. If I load your provided craft and try to launch I get the part is not researched yet message.

Share this post


Link to post
Share on other sites
50 minutes ago, NapalmPK said:

Great mod. Just one problem I have found. The legs for the lander are not in my tech Tree which I have everything unlocked. Using community tech tree. If I load your provided craft and try to launch I get the part is not researched yet message.

The "TechRequired" parameter is set as "utility" in the landing legs config file.  Try opening the config file (AltairLandingLeg.cfg) and changing it to "advLanding" (without the quotes of course).  Not sure if the tech tree progression removed "utility" as a tech level or not.  Also, I've never use the Community Tech Tree mod, so I'm not sure if that is causing issues, but I'm not sure why it would.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.