Sigma88

Galactic Neighborhood

Recommended Posts

BTW, just to be clear...

This mod itself does not really require a lot of RAM.

It's the number of planet packs you decide to use that will affect RAM usage the most ;)

Share this post


Link to post
Share on other sites
I think those guys would kill themselves if I just proposed putting this on CKAN. :D

jokes aside, for now the mod is still in flux so I won't ask for CKAN support.

Since CKAN is open to anyone to edit, there's always the possibility that someone will add the metadata for GN :)

anyway, I always try to make the installation/uninstallation process as easy as possible. ;)

It's never the installation that bothers me, it's the ease of keeping up with updates. Ah well, starting a new science career today, time to throw this in. Though, I have to admit I'm also kinda wanting to see K+ in here as well, fingers crossed!

Share this post


Link to post
Share on other sites
It's never the installation that bothers me, it's the ease of keeping up with updates. Ah well, starting a new science career today, time to throw this in. Though, I have to admit I'm also kinda wanting to see K+ in here as well, fingers crossed!

do you use KSP-AVC? it's a really nice way to keep track of which mod is out-of-date

it's not CKAN, but better than noting :)

Share this post


Link to post
Share on other sites

Yes, I also use KSP-AVC, better than nothing, I'm just lazy and CKAN panders to that, lol :sticktongue: I'm fine waiting on CKAN until things get more stable, though.

Ok, so I've noticed a couple things here.

One: Are you sure the Kerbin system isn't moved around at all? I'm noticing the KSC doesn't have a transmitter now when using RemoteTech, so I'm guessing the coordinates are off. Minor inconvenience, but I see no other reason for satellites without RemoteTech :P In the interim I'll probably just remove the probe control necessity from RemoteTech as a work around.

Two: Another positioning thing. When starting a new career (science), there are several stars RIGHT next to Kerbin (I can probably figure out specifically which ones in which planet packs if you like). Again, a minor inconvenience, if you hit Mission Control, and scroll way the heck out, they eventually fall into their real orbits around the galactic core, and if you exit from Mission Control, problem fixed. If you try to zoom back in, they sometimes drop back in next to Kerbin. I'm not sure if anybody else has noticed this yet or not, like I said, I'm lazy.

These MIGHT be 64 bit problems, as I'm peaking out at 11.7gigs of memory in use, but the RT was working right before the Galactic Neighborhood / Planet Packs installs. If they are, I understand of course that can't be your concern.

EDIT: Just noticed "This post about OtherWorlds", saw my foldering for OtherWorlds was wrong as well (My Kronkus defaulted correctly). Changed it, will reload KSP tomorrow and let you know if that fixed the system positioning problem. KSP now takes about 10 minutes to load, and I need to sleeeeeeep.

Edited by Lells

Share this post


Link to post
Share on other sites
Are you sure the Kerbin system isn't moved around at all? I'm noticing the KSC doesn't have a transmitter now when using RemoteTech, so I'm guessing the coordinates are off. Minor inconvenience, but I see no other reason for satellites without RemoteTech :P In the interim I'll probably just remove the probe control necessity from RemoteTech as a work around.

you can see the code for yourself here

this is the kerbin part:

    @Body[Kerbin]    {
@Orbit
{
@referenceBody = StockSun
semiMajorAxis = 13599840256
}
}

as you can see, the only thing I change is the reference body. so, it doesn't orbit the center of the universe anymore (because that is the galactic core now) but it orbits a star which looks exactly like the stock sun.

maybe there's some issue with some of the planet packs you have installed... idk honestly

Another positioning thing. When starting a new career (science), there are several stars RIGHT next to Kerbin (I can probably figure out specifically which ones in which planet packs if you like). Again, a minor inconvenience, if you hit Mission Control, and scroll way the heck out, they eventually fall into their real orbits around the galactic core, and if you exit from Mission Control, problem fixed. If you try to zoom back in, they sometimes drop back in next to Kerbin. I'm not sure if anybody else has noticed this yet or not, like I said, I'm lazy.

never seen this issue

These MIGHT be 64 bit problems, as I'm peaking out at 11.7gigs of memory in use, but the RT was working right before the Galactic Neighborhood / Planet Packs installs. If they are, I understand of course that can't be your concern.

If that's the case (64 bit windows) I can't help you. issues with that version of the game are beyond my capabilities :) sorry

unless you meant 64 bit linux, in which case it shouldn't be a problem (I think... no idea honestly)

Share this post


Link to post
Share on other sites

It looks a lot like this one from a few pages back, except a star is on the horizon. I think the first time it might have been Helios? I've been trying to load up KSP, but I think I need a reboot. I'll post screenshots/a link to video tomorrow afternoon.

Share this post


Link to post
Share on other sites
It looks a lot like this one from a few pages back, except a star is on the horizon. I think the first time it might have been Helios? I've been trying to load up KSP, but I think I need a reboot. I'll post screenshots/a link to video tomorrow afternoon.

well, if you are experiencing the bug in 64-bit windows there's nothing I can do to help you

If you can manage to reproduce it with 32-bit windows then it means there's some issue I have missed :)

but I think it may be a combination of reparenting kerbin + 64bit

Share this post


Link to post
Share on other sites
well, if you are experiencing the bug in 64-bit windows there's nothing I can do to help you

If you can manage to reproduce it with 32-bit windows then it means there's some issue I have missed :)

but I think it may be a combination of reparenting kerbin + 64bit

Understood, but I did manage to take some screenshots. I'm guessing an issue with reparenting as well, at least one of the planet packs seems to be putting things down at distances from Kerbin's sun as it stands now, rather than at the Galactic Core. It isn't until I zoom out all the way to where the planets/systems SHOULD be in the GN, that the parenting issue corrects itself. Like I said, it's not exactly a game breaker, just something I noticed upon starting a new science career, that is easily worked around. I'd love to test it in 32 bit Windows, but at a 7-11 gig memory loadout right now, that's frankly impossible to exactly duplicate with all the mods being used, etc. Anyways. Take a look at the images at least, and see if you agree, or maybe there IS a minor issue handling one of the planet packs that nobody else had noticed yet? Don't kill yourself over it though, I understand you've probably got bigger fish to fry, and I'm hoping a newer version of Kopernicus manages to alleviate the various reparenting issues that arise at is. Being able to get solar from ANY star would be amazing.

EDIT: It seems to be focused on bodies from Sido's Urania Planet Pack

Javascript is disabled. View full album
Edited by Lells

Share this post


Link to post
Share on other sites
So how will this effect solar panels?

They will not work properly. But that's a known kopernicus issue, a fix will come eventually. After ksp 1.0.5 release.

Share this post


Link to post
Share on other sites

Even using the workaround, I'm getting the "deep space" KSP bug with RSS as the only planet pack installed. I'd give you logs if I knew how to do that without KSP auto-generating them from crashing.

Edit:

Other mods installed:

//Glitter\\

EVvisualEnhancements - 7-4 [.24]

Texture Replacer - 2.4.10 [1.0.4]

Chatterer - 0.9.6 [1.0.4]

Dist Obj Enh - Oct 15 2015 [1.0.4]

CollisionFX - 2015-05-14 [1.0.x]

ShipEffects (Maintainence) - 1.0.3 [1.0.4]

//Core\\

Kopernicus - 0.4 [1.0.4]

GN - 0.0.7 [1.0.4]

Interstellar Extended - 1.5.16 [1.0.4]

Tweakscale - 2.2.4 [1.0.4]

Hyperedit - 1.4.1 [1.0]

FerramAR - 0.15.5.1 [1.0.4]

//Meta\\

Filter Extensions - 2.4.1 [1.0.x]

ATManagement - 5-0 [1.0]

Toolbar - 1.7.9 [1.0.2]

Module Manager - 2.6.8

KSP AVC - 1.1.5 [1.0.4]

GCMonitor - 1.2.7 [1.0.x]

//Planet Packs\\

RSS - (masterzip)

Edited by Sutternalt

Share this post


Link to post
Share on other sites
Even using the workaround, I'm getting the "deep space" KSP bug with RSS as the only planet pack installed. I'd give you logs if I knew how to do that without KSP auto-generating them from crashing.

could you pm me a screenshot of the content of your gamedata folder?

Share this post


Link to post
Share on other sites
Done.

Also, you may (may) want to consider Ktolemy as one of your planet packs.

I doubt that will happen, as it would take a long time to set up, and it is moving away from the idea of this mod.

Share this post


Link to post
Share on other sites
Done.

Also, you may (may) want to consider Ktolemy as one of your planet packs.

I doubt that will happen, as it would take a long time to set up, and it is moving away from the idea of this mod.

Yeah, ktolemy is cool but merging it in GN will require a lot of thinking

I'm not ready to rule it out tho ;)

Share this post


Link to post
Share on other sites
v10.3 the "Thanks Everybody!" update

  • RSS itself now contains groundstation definitions for RemoteTech, with the full networks appearing when RealismOverhaul is installed (via NEEDS--the files are here). Thanks Peppie, regex!
  • Patch AntennaRange antenna ranges, if that's installed. Thanks Kerbas-ad-astra!
  • Update CustomAsteroids config. Thanks Ascraeus1!
  • Various compatability patches thanks to Sigma88.
  • Fix some typos in body descriptions, biomes. Thanks Trollception et al!
  • Fix Mars scaled space fades. Thanks Raidernick!
  • Fix science altitude thresholds. Thanks Laie!
  • Update to Kopernicus 0.4

RSS Compatibility

Real Solar System v10.3 is fully compatible with GN!

Don't forget to download RSS-Textures as well!

Many thanks to NathanKell for implementing the changes that made this possible!

Edited by Sigma88

Share this post


Link to post
Share on other sites

Another thing I ran into. Don't know where to post that.

I have no KSC on Kerbin, but alot of KSC dots on Kibren (Alternis Kerbol Rekejiggered):

kOhAGtk.png

fdMXjdZ.png

How can I fix this?

(Cross post http://forum.kerbalspaceprogram.com/threads/133562-Kopernicus-1-0-4-Alternis-Kerbol-Rekerjiggered-1-4-Laythe-and-Atmosphere-Tweaks?p=2273558&viewfull=1#post2273558)

Share this post


Link to post
Share on other sites
Another thing I ran into. Don't know where to post that.

I have no KSC on Kerbin, but alot of KSC dots on Kibren (Alternis Kerbol Rekejiggered):

http://i.imgur.com/kOhAGtk.png

http://i.imgur.com/fdMXjdZ.png

How can I fix this?

(Cross post http://forum.kerbalspaceprogram.com/threads/133562-Kopernicus-1-0-4-Alternis-Kerbol-Rekerjiggered-1-4-Laythe-and-Atmosphere-Tweaks?p=2273558&viewfull=1#post2273558)

I haven't looked at RT compatibility, and probably won't have time to do it in the near future.

If someone has a cfg I'll be happy to link it here

Share this post


Link to post
Share on other sites

It's a sign: You should be playing Alternis Kerbol Rekerjiggered! :P

Why it would pick Kibren to put it around instead of some other Kerbin analogue beats me. I too do not play with remote tech, so there exists no compatibility with AKR.

Share this post


Link to post
Share on other sites

I'm not exactly sure how I should install planet packs and such.

I have Outer Planets Mod and New Horizons installed. I've tried just putting them in the gamedata but the game crashes, then I put each pack in their designated folders in the Galatic Neighborhood folder (C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\GalacticNeighborhood\PlanetPacks\NHSystem , C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\GalacticNeighborhood\PlanetPacks\OPMSystem).

When doing that I can start the game but can't see anything besides the HUD and the Sky Box.

Please help. Thank you.

Share this post


Link to post
Share on other sites
I'm not exactly sure how I should install planet packs and such.

I have Outer Planets Mod and New Horizons installed. I've tried just putting them in the gamedata but the game crashes, then I put each pack in their designated folders in the Galatic Neighborhood folder (C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\GalacticNeighborhood\PlanetPacks\NHSystem , C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\GalacticNeighborhood\PlanetPacks\OPMSystem).

When doing that I can start the game but can't see anything besides the HUD and the Sky Box.

Please help. Thank you.

the first thing you did was the right way, install each mod in the GameData folder

you should move your whole KSP folder outside program files tho, KSP doesn't like when mods are run from there ;)

if it still crashes it may be you are getting over the RAM limit

Share this post


Link to post
Share on other sites
the first thing you did was the right way, install each mod in the GameData folder

you should move your whole KSP folder outside program files tho, KSP doesn't like when mods are run from there ;)

if it still crashes it may be you are getting over the RAM limit

This is what I'm getting with only running 1 planet pack (New Horizons)

- - - Updated - - -

Never mind I've fixed it that I can now go into building and all of that, but when going to a map view I can't find the New Horizons system at all.

Share this post


Link to post
Share on other sites
This is what I'm getting with only running 1 planet pack (New Horizons)

- - - Updated - - -

Never mind I've fixed it that I can now go into building and all of that, but when going to a map view I can't find the New Horizons system at all.

could you post a screenshot of what you see in the tracking station? (try to zoom out in order to get all the systems in the screen)

Share this post


Link to post
Share on other sites
could you post a screenshot of what you see in the tracking station? (try to zoom out in order to get all the systems in the screen)

This is what I see after zooming out as much as I can.

45RET79.png

Share this post


Link to post
Share on other sites

ok, you have an installation issue. game didn't load the mods correctly so reverted back to stock system

you should check that you have installed every mod correctly.

(try starting with a clean install and adding some mods at a time)

also, have you moved outside the ProgramFiles folder?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.