Sigma88

Galactic Neighborhood

Recommended Posts

2 minutes ago, Sigma88 said:

no that's perfect :D

a couple of words of advice:

1- I'm currently working on bringing up to speed GN to 1.0.5 and the new version is a bit different from the old one, download the dev.version if you want to see the new stuff, but be warned that it's constantly being updated. you can follow it on github to see what changes I apply

2- the code is a bit convoluted and it fits together with my other mods like a puzzle, if you are having issues linked to how GN works feel free to ask for suggestions.

Okay! Thanks for the advice...

 

-EDIT- 

it might actually be hard to transfer over the blackhole, all because it has its own plugins, and... yeah... its a big mess right now...

Edited by TheJangleMan

Share this post


Link to post
Share on other sites
28 minutes ago, TheJangleMan said:

Okay! Thanks for the advice...

 

-EDIT- 

it might actually be hard to transfer over the blackhole, all because it has its own plugins, and... yeah... its a big mess right now...

GN blackhole is nothing special, your black hole has "name = Sun" so you can safely delete my black hole and all GN stars will orbit yours

Edited by Sigma88

Share this post


Link to post
Share on other sites
1 minute ago, Sigma88 said:

GN blackhole is nothing special, your black hole has "name = Sun" so you can safely delete my black hole and all GN stars will orbit yours

oh XD but the problem I'm having is that all of my galaxies arent orbiting my blackhole, they are just orbiting the default sun... :/

Share this post


Link to post
Share on other sites

I'm no modder, but why not just have your as a separate folder and is compatible with GN that way if us end users want to uninstall one or the other, we don't have to remove both then re download the one we wanted to keep.

Share this post


Link to post
Share on other sites
Just now, TheJangleMan said:

oh XD but the problem I'm having is that all of my galaxies arent orbiting my blackhole, they are just orbiting the default sun... :/

My suggestion would be to fix your mod first and then go on to fix compatibility with GN.

trying to do both at the same time can be tricky

Share this post


Link to post
Share on other sites
38 minutes ago, TheJangleMan said:

no no no, nothing from your mod will go into mine, I'm just going to make a seperate download link that you just drag the files that contain only my stuff in my mod into the file that your planets and crap are located, but if you think this is a bad idea, tell me... :P

 

Share this post


Link to post
Share on other sites
Just now, Sigma88 said:

My suggestion would be to fix your mod first and then go on to fix compatibility with GN.

trying to do both at the same time can be tricky

Do you have any ideas on how to fix this problem? I'm just stumped :/

Share this post


Link to post
Share on other sites
Just now, TheJangleMan said:

Do you have any ideas on how to fix this problem? I'm just stumped :/

I have not looked at the cfgs of your mod so I have no idea of what is going wrong :D

Share this post


Link to post
Share on other sites
Just now, Sigma88 said:

I have not looked at the cfgs of your mod so I have no idea of what is going wrong :D

well, if you have any spare time, that would be great, even though I know you said you wouldnt do stuff like that... I'll keep trying to figure it out on my own for now :/ 

 

Share this post


Link to post
Share on other sites
1 hour ago, Sigma88 said:

I have not looked at the cfgs of your mod so I have no idea of what is going wrong :D

I updated it, And I was told it works... sooooo... HMMM I'll just wait a bit and see if I get any comments about it not working, lol

Share this post


Link to post
Share on other sites

Is it possible to have the opm planets appear in the starting solar system? 

Share this post


Link to post
Share on other sites
35 minutes ago, Errol said:

Is it possible to have the opm planets appear in the starting solar system? 

It is possible if you write a mm patch for doing it.

I won't do it in the mod because no planet pack should get the priority over the others ;)

something like this:

@Kopernicus:FINAL
{
	!Body:HAS[#name[Helio*]] {}
	@Body,*
	{
		@Orbit:HAS[#referenceBody[Helios]]
		{
			@referenceBody = Sun
		}
	}
}

 

Edited by Sigma88

Share this post


Link to post
Share on other sites
2 hours ago, Sigma88 said:

160Aht is possible if you write .a mm patch for doing it.

I won't do it in the mod because no planet pack should get the priority over the others ;)

something like this:


@Kopernicus:FINAL
{
	!Body:HAS[#name[Helio*]] {}
	@Body,*
	{
		@Orbit:HAS[#referenceBody[Helios]]
		{
			@referenceBody = Sun
		}
	}
}

 

Thank you so much! Man, my 1.1 Carreer Save is going to be epic!

Share this post


Link to post
Share on other sites

I'm having the classic "select non-Kerbol SOI target and explode from overheating" bug. I've seen it before on the forums but i don't remember where, so i figured since this mod is probably the one causing it I'll complain here :P. Anyone care to direct me to the solution?

Share this post


Link to post
Share on other sites
59 minutes ago, Esquire42 said:

I'm having the classic "select non-Kerbol SOI target and explode from overheating" bug. I've seen it before on the forums but i don't remember where, so i figured since this mod is probably the one causing it I'll complain here :P. Anyone care to direct me to the solution?

Sorry I have never seen this bug.

Could you explain step by step how to reproduce the bug?

Possibly, on a clean install with only the following mods installed:

-modulemanager

-kopernicus

-galactic neighborhood

-hyperedit (if you need it)

 

Thanks :)

Share this post


Link to post
Share on other sites
10 hours ago, Sigma88 said:

Sorry I have never seen this bug.

Could you explain step by step how to reproduce the bug?

Possibly, on a clean install with only the following mods installed:

-modulemanager

-kopernicus

-galactic neighborhood

-hyperedit (if you need it)

 

Thanks :)

Step 1: Hyperedit a craft into 650km orbit (haven't tried it with launching yet mainly because I wanted to test out some warp drives)

Step 2: Zoom out past Kerbol. I didn't have to even target anything this time. On the more modded install I had to.

Here's a link with screenshots and logs. Thanks 

https://www.dropbox.com/sh/8s9q6w4aaz2i2q3/AAAQX27FijTIkKOhvuG85dO2a?dl=0

 

Share this post


Link to post
Share on other sites
1 minute ago, Esquire42 said:

Step 1: Hyperedit a craft into 650km orbit (haven't tried it with launching yet mainly because I wanted to test out some warp drives)

Step 2: Zoom out past Kerbol. I didn't have to even target anything this time. On the more modded install I had to.

Here's a link with screenshots and logs. Thanks 

https://www.dropbox.com/sh/8s9q6w4aaz2i2q3/AAAQX27FijTIkKOhvuG85dO2a?dl=0

 

did you save and reload? or just hyperedited and timewarped?

Share this post


Link to post
Share on other sites
2 minutes ago, Sigma88 said:

did you save and reload? or just hyperedited and timewarped?

Just Hyperedited. No time warp, nothing. You can see the timestamps on my screenshots. Typically I'd have to target something outside the SOI of Kerbol to get this.

Share this post


Link to post
Share on other sites
2 minutes ago, Esquire42 said:

Just Hyperedited. No time warp, nothing. You can see the timestamps on my screenshots. Typically I'd have to target something outside the SOI of Kerbol to get this.

hyperedit can make a mess sometimes, you should try to save and reload after having moved the ship with hyperedit

I'll try to reproduce the bug. Did you use GN latest release or the latest pre-release?

Share this post


Link to post
Share on other sites
Just now, Sigma88 said:

hyperedit can make a mess sometimes, you should try to save and reload after having moved the ship with hyperedit

I'll try to reproduce the bug. Did you use GN latest release or the latest pre-release?

I'll try that in a bit. Latest release, not pre-release. I like stability :)

3 minutes ago, Sigma88 said:

hyperedit can make a mess sometimes, you should try to save and reload after having moved the ship with hyperedit

I'll try to reproduce the bug. Did you use GN latest release or the latest pre-release?

Also, I'm getting weird atmospheric effects now. The sun is in the sky and it's morning but the sky is dark.

Share this post


Link to post
Share on other sites
3 minutes ago, Esquire42 said:

I'll try that in a bit. Latest release, not pre-release. I like stability :)

Also, I'm getting weird atmospheric effects now. The sun is in the sky and it's morning but the sky is dark.

the pre-release has some fixes for 1.0.5

it's probably more stable than the latest release (which is not compatible with kopernicus 0.6 or ksp 1.0.5) :D

Share this post


Link to post
Share on other sites
13 minutes ago, Sigma88 said:

the pre-release has some fixes for 1.0.5

it's probably more stable than the latest release (which is not compatible with kopernicus 0.6 or ksp 1.0.5) :D

I'll try that then. Explosion-wise it's still happening whether i quick save/quickload or exit to the space center and go back in. The sun thing also seems to only happen in the space center

EDIT: I'd love to try the dev version but for some reason it's not loading. Double checked the path, I'm thinking it's something to do with the "Dev stuff" folder in it, but

Edited by Esquire42

Share this post


Link to post
Share on other sites
16 minutes ago, Esquire42 said:

I'll try that then. Explosion-wise it's still happening whether i quick save/quickload or exit to the space center and go back in. The sun thing also seems to only happen in the space center

EDIT: I'd love to try the dev version but for some reason it's not loading. Double checked the path, I'm thinking it's something to do with the "Dev stuff" folder in it, but

oh did I leave that in? yeah delete that folder sorry

EDIT: there is no devstuff folder in the download, you need to go here and download the GN v0.0.8b pre-release by clicking on "Galactic-Neighborhood.v0.0.8b.zip"

Edited by Sigma88

Share this post


Link to post
Share on other sites

Does anyone know if there is a mod with wormholes or mass relays that could work with this? I want to create an ftl network between the systems, but ESLD is broken and the FTL drive is outdated.

Also good luck with the PhD Sigma

Share this post


Link to post
Share on other sites
Just now, iliketrains0pwned said:

Does anyone know if there is a mod with wormholes or mass relays that could work with this? I want to create an ftl network between the systems, but ESLD is broken and the FTL drive is outdated.

Also good luck with the PhD Sigma

There are some ftl drive mods, but no wormholes that I know of honestly

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.