Sigma88

Galactic Neighborhood

Recommended Posts

On 12/17/2017 at 11:12 AM, Djohaal said:

I've managed to run GN fine with graphics mods so far. Scatterer conveniently includes a illumination source flag in its configs, which can be toggled individually for each planet.

  Reveal hidden contents

86AJmBV.png?1

In other news, gotta love emergent bugs interactions between mods. 

lol. Im guessing in the pic, its supposed to the 'The Sun' and not the galactic core? On that note, when I go into EVEs alt-zero manager and pan to the shadow manager and try and select the sun, it pans to the core even tho visually and functionally, the sun is still working properly. prolly has to do with JadeofMaars mention of how scatterer and eve work in defining what the Sun is. in the galacticcore.cfg it shows the core as 'Sun' and in the StockSun.cfg it shows the Sun as 'The Sun'. more specifically, theres this:

stock sun.cfg

blah blah blah lol...

// Custom Settings
            displayName = The Sun
            sphereOfInfluence = 2e12

 

In Eve, the search is for 'Sun', at least in the GUI(not sure about the code) so for now I can see why it'll pan to the core  :). I'm sure its similar with Scatterer. Im curious tho, how many planets does scatterer support for this'illumination source flag'? 

Share this post


Link to post
Share on other sites

This does not appear to function at all, I launch the game fine, but the additional star systems do not appear.

Share this post


Link to post
Share on other sites
1 hour ago, ItsJebK said:

This does not appear to function at all, I launch the game fine, but the additional star systems do not appear.

What are you expecting? If you install Galactic Neighborhood and no supported planet packs, you only get the Neighborhood itself which is about a dozen lonely stars. The mod itself is only half of what you're looking for. When you install its supported planet packs they will get their own stars or will populate some of the lonely default ones.

If nothing changes at all, like you didn't even install it, then there's a problem.

Share this post


Link to post
Share on other sites
18 hours ago, JadeOfMaar said:

What are you expecting? If you install Galactic Neighborhood and no supported planet packs, you only get the Neighborhood itself which is about a dozen lonely stars. The mod itself is only half of what you're looking for. When you install its supported planet packs they will get their own stars or will populate some of the lonely default ones.

If nothing changes at all, like you didn't even install it, then there's a problem.

That is exactly what happens, my friend.

Nothing changes at all.

Edited by ItsJebK

Share this post


Link to post
Share on other sites
1 hour ago, ItsJebK said:

@JadeOfMaar Yes. The only other mod I run is KSP Interstellar.

Ah. Well at this point you have to click Sigma's signature link(s) and talk to him off-site (Discord or GitHub). :/ 

Share this post


Link to post
Share on other sites

I just realized I had infact downloaded the wrong version of Kopernicus. Apologies for wasting your time.

Share this post


Link to post
Share on other sites

@Sigma88 KSPIE now  offers a way to do a grand tour of the galactic neighborhood, the Bussard Ramjet which can collect it fuel from either interstellar space, above  atmospheres or directly from the local star. Notice that near the edge of every star system Area of Influence  there is an area where the solar wind gradually stop and is compressed into a hydrogen wall.

Share this post


Link to post
Share on other sites

Hi Sigma, I have a problem with Galactic Neighborhood and Scansat. In fact i saw that in the Archives menu i cant find The Sun system, only Galactic Core and few stars. I dont care about this menu but with Scansat im unable to change the big map's reference body and this is really annoying. Is this a known bug ? Is there a way to get rid of it ? Thanks for your feed back and updates you rock

Edited by Djackmix

Share this post


Link to post
Share on other sites

hey how does one get OPM to orbit Kerbol again?

Share this post


Link to post
Share on other sites
On 29.1.2018 at 6:23 AM, Aleksey Pschenichnikov said:

It broke my lighting.

Have the same problem: Lighting in the KSC Overview stays at nighttime the entire day. It's fine on launchpad (normal 6 hours day/night cycle) but as soon as you launch something, the planet and the vessel get gradually darker until both look like it's pitch black night. Once the vessel leaves the atmosphere (so around 70km above ground) the planet returns back to normal, but not the vessel. It also doesn't matter if launched at 0:00 or 3:00, the behaviour of the lighting is exactly the same.

This is on an install with only Kopernicus, ModularFlightIntegrator and GalacticNeighborhood, as i was afraid one of my many other mods would be the reason. Problem doesn't appear anymore once i delete GN.

Or, probably nevermind: I just read Sigma88's signature to see what files he needs, and then saw on his discord that he published a new version just an hour ago. I'll check that out first once im off work.

 

Edit: Just in case if this helps, it appears to be a problem between Kopernicus 1.3.1-3 and GalacticNeighborhood, as everything works fine when Kopernicus 1.3.1-2 is used.

 

Edited by elpollodiablo

Share this post


Link to post
Share on other sites

Currently, im running this(v 0.4.6), scaterrer, EVE, SVE and lots of other mods and after changing "The Sun" to "StockSun" in scaterrer's planetsList my graphics&game seems mostly fine. My major problem is the same @Djackmix has. 
Will see how it will work with v 0.4.7 \w Kopernicus 1.3.1-3

Share this post


Link to post
Share on other sites

hi everybody,

GN was never updated for kopernicus 1.3.1-3 so that's why the lighting was off

 

I've now released a new update that solves this issue.

it also adds new planet packs and now I also wrote an automated installer that can help you install planet packs with GN (and save some ram)

 

you'll find more info in the github wiki

 

if you have bugs to report or need support, please use github because I don't look at the forum very often

Share this post


Link to post
Share on other sites
15 minutes ago, Jeb's Pirotecnics Guy said:

What does GN auto installer do

Whatever it does, It isn't working

here are the installation instructions

https://github.com/Sigma88/Galactic-Neighborhood/wiki/How-To-Install

 

if you still have issues, make sure you ask on github because I usually don't check this thread

Edited by Sigma88

Share this post


Link to post
Share on other sites

So, not sure if this belongs here, the BK or AK thread, but I have GN installed, as well as OWR. When I install AK, the BK star is also spawned, along with Eden in its orbit. Log and screenies

 

I have migrated the OWR pp to within a GN/Planetpack sub folder without issues. all I needed to do was redirect the paths in all the cfgs :). But trying the same with this pack, gave me this strange outcome. I dont really mind the star being there, or eden. But its just a little confusing. Im not positive what the star in BK is called. but, with GN installed, its name will be converted to Novus. the correlation I see is with Eden being there. But I have no scrape of BK even being installed. Interesting right?

the AK folder has an Eden texture, but located in the EVE/texture subfolder, but I didnt see any cfgs for eden..or a 'novus'. Eden also looks almost if not EXACTLY like Kerbin. I dont have EVE installed so any cfg regarding it is skipped?

 

UPDATE: Ive removed all my editing for OWR and AK, reinstalled AK completely stock, same outcome.

UPDATE: in the add star and planet fix cfg, ive replaced :NEEDS[!BK] with/or added :NEEDS[!BeforeKerbin] so it looks like this : @Kopernicus:AFTER[!BeforeKerbin] in the planet fix cfg OR @Kopernicus:AFTER[Kopernicus]:NEEDS[!BeforeKerbin] in the addstar cfg

im guessing the planetpacks used to be named AK/BK or something along those lines, but ive gotten Novus and Eden to not spawn anymore.

Edited by Jesusthebird

Share this post


Link to post
Share on other sites
9 minutes ago, BlackWing Pilot said:

Are this mod is compatible with kerbal star system?

No

Share this post


Link to post
Share on other sites

Is there a way to fix the sentinel telescope for the stars

since the code only lets the telescope work around the sun

but the sun in this mod is not the sun anymore so is there a way to fix it

Share this post


Link to post
Share on other sites
35 minutes ago, Jeb's Pirotecnics Guy said:

Is there a way to fix the sentinel telescope for the stars

since the code only lets the telescope work around the sun

but the sun in this mod is not the sun anymore so is there a way to fix it

I don't think so, it is probably hardcoded to work only around the central body

Share this post


Link to post
Share on other sites

I don't know what is going on, but whenever I start the game up with Galactic Neighborhood, it will load everything until it say Squad/.../PodCockpit and then it will just crash. I have deleted everything and slowly start to put my mods back, and when placing this mod in my folder, it causes the problem. Everything (except GPP and GEP, but still causes problem with them uninstalled) is updated, but this problem still persists. Here is the output log.

https://www.dropbox.com/s/cgjhblx1jlwmgp7/output_log.txt?dl=0

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.