alexustas

'MK1-2 Pod' IVA Replacement by ASET[v0.3]

Recommended Posts

I haven't try these switches with mechjeb so I'll try that that! Oh and this is 1.0.5. 

Edited by Kram45

Share this post


Link to post
Share on other sites
6 hours ago, blorgon said:

The most recent posted link is broken. Anybody have a link?

I couldn't find a link so I downloaded Chaka Monkey mod pack and got it from there.

Share this post


Link to post
Share on other sites
10 hours ago, Kram45 said:

I couldn't find a link so I downloaded Chaka Monkey mod pack and got it from there.

Awesome. Downloaded and pulled the MK1-2 from the zip. Thanks for the heads-up!

Share this post


Link to post
Share on other sites
1 hour ago, blorgon said:

Awesome. Downloaded and pulled the MK1-2 from the zip. Thanks for the heads-up!

Np :wink:

Share this post


Link to post
Share on other sites

Sooo, I tried the old version and the IVA itself works ok, the problem is that it throws some exceptions and errors which tank the framerate and spam the debug. I guess fixing this wouldn't be hard, so let's hope the update will come soon.

gakqf00.jpg

Edit: This is an issue with HulCam (at least for me!) and you gotta delete it. Not sure if anybody is else is having this problem.

Edited by Ghosty141

Share this post


Link to post
Share on other sites

@alexustas  I haven't seen a post about porting this up to 1.1.x yet, so I just have to ask.

Is this on your to-do list?

On 3/30/2016 at 2:10 PM, Kram45 said:

I haven't try these switches with mechjeb so I'll try that that! Oh and this is 1.0.5. 

As far as I know, these particular switches are all just for show and to give your Kerbals something to distract... ahem, to play with... er, to do on their long, boring voyages.

Maybe someday KSP will add simulated systems to the game, but for now, these don't do anything but look cool and finish out the IVA.

Share this post


Link to post
Share on other sites
22 hours ago, WildBillKerbin said:

As far as I know, these particular switches are all just for show and to give your Kerbals something to distract... ahem, to play with... er, to do on their long, boring voyages.

Maybe someday KSP will add simulated systems to the game, but for now, these don't do anything but look cool and finish out the IVA.

Thanks!

Edited by Kram45

Share this post


Link to post
Share on other sites

Just a friendly reminder: This mod doesn't need updating since it's an IVA. The ASET props pack works with Raster Prop Monitor which is the only mod that needs updating. The functions it supports is a different story (VesselViewer, SCANsat, TAC LS, Engine Ignitor, MJ and the rest). Make sure your RPM is up to date along with the other function mods, if available. And FYI: Alex has already said that he's in the process of updating his mods on the ALCOR Pod thread. So please, relax with the "Are you going to update?". If there is a legitimate problem, post a log as per protocol. 

Share this post


Link to post
Share on other sites

@ComatoseJedi Indeed it does work in 1.1.x!  Thank you for pointing that out.  I installed it manually and was very pleasantly surprised.

What does it take to get mod uploaded to SpaceDock or gethub and getting the CKAN metadata updated for version 1.1.2 (or 1.1.99 if possible)?

Edited by WildBillKerbin

Share this post


Link to post
Share on other sites
On 5/1/2016 at 0:18 AM, WildBillKerbin said:

@ComatoseJedi Indeed it does work in 1.1.x!  Thank you for pointing that out.  I installed it manually and was very pleasantly surprised.

What does it take to get mod uploaded to SpaceDock or gethub and getting the CKAN metadata updated for version 1.1.2 (or 1.1.99 if possible)?

I wouldn't suggest uploading someone else's work to SpaceDock. Especially without consent or hasn't been updated. I've seen several mods on SpaceDock that I know for certain that hasn't been updated for the current build of the game. It just leads to more problems that fills the mod maker's thread with "this doesn't work why was it on SpaceDock with the current build". CKAN is another story, because it gathers mods instead of being submitted. I don't use CKAN anymore, but I have used it and I can say it causes more problems than it solves. Unless you KNOW for certain the mods you are getting are the ones you've been keeping track of on the forums.

Manually installing your mods, including this one, makes you read the instructions on the dependencies it needs in order to work. If you don't make mods, at least have the common knowledge to know how mods work so you can help other people who tend to not know how mods work. 

Share this post


Link to post
Share on other sites
On 5/1/2016 at 8:17 PM, ComatoseJedi said:

Just a friendly reminder: This mod doesn't need updating since it's an IVA. The ASET props pack works with Raster Prop Monitor which is the only mod that needs updating. The functions it supports is a different story (VesselViewer, SCANsat, TAC LS, Engine Ignitor, MJ and the rest). Make sure your RPM is up to date along with the other function mods, if available. And FYI: Alex has already said that he's in the process of updating his mods on the ALCOR Pod thread. So please, relax with the "Are you going to update?". If there is a legitimate problem, post a log as per protocol. 

Thank you very much for this reminder.   I had not realized that it was going to work.   I needed to replace the nav-ball texture with one from RPM, but that was explained on the first few pages of the thread.     I was able to complete my first ALL-IVA mission in my "new" apollo-like craft. 

Edited by nukeboyt

Share this post


Link to post
Share on other sites

OK so ran into problem today and idk what exactly is causing it.  The attitude screen is missing the digital ball, everything else seems to work fine, and even the attitude screen has all its read outs nav icons, numbers showing speeds, alt pitch roll, etc just the navball itself is missing, checked other pods and the mk1 iva replacement is having same issue, but stock cockpits the like mk2 space plane works fine, so it doesn't "seem" to be rpm.  Anyone else had trouble or any idea on where to trouble shoot?

Share this post


Link to post
Share on other sites
1 hour ago, ironhawx said:

OK so ran into problem today and idk what exactly is causing it.  The attitude screen is missing the digital ball, everything else seems to work fine, and even the attitude screen has all its read outs nav icons, numbers showing speeds, alt pitch roll, etc just the navball itself is missing, checked other pods and the mk1 iva replacement is having same issue, but stock cockpits the like mk2 space plane works fine, so it doesn't "seem" to be rpm.  Anyone else had trouble or any idea on where to trouble shoot?

Ok so RPM can be customized on a per craft basis, the RPM pages are set by the mod author. ASET stuff in particular uses custom assets, so even though the stock navball for RPM works for other craft it can have an issue with certain IVA's specifically. The mod author is around but these IVAs haven't been updated in a while so those custom pages have issues with certain elements, likely a mod that is trying to display incompatible graphic elements onto the custom navball. 

 

So basically check your mod directory for anything that would touch the navball: Waypoint manager, docking alignment indicator, Enhanced Nav Ball, etc. Unfortunately once you find which it is you have to either live without it, wait for the IVA author to update the MFD pages or attempt to do so yourself. 

 

e. just saw this now myself, was being caused by the Ven Stock revamp

Edited by Terrible Inclinations

Share this post


Link to post
Share on other sites
2 hours ago, ironhawx said:

navball itself is missing

Copy (and replace) "NavBall000.dds" from "\GameData\JSI\RasterPropMonitor\Library\Components\NavBall" into "\GameData\ASET\ASET_Props\MFDs\ALCORPFD"

Share this post


Link to post
Share on other sites

ya its working now don't ask me what happened, idk if mods got installed out of order or what, but i removed b9 set, launched game and navball was back, put b9 back in and navball still there, so go figure.

Share this post


Link to post
Share on other sites

Is there a way to install the MFDs in a different pod?

Share this post


Link to post
Share on other sites
On 13/5/2016 at 6:27 PM, dlrk said:

Is there a way to install the MFDs in a different pod?

You mean the displays of a pod RPM's ready? If that's the case, the only way I manage to do so is by replacing part of RPM's mdf40x20.cfg with ASET's ALCORMDF40x20.cfg. But I assume it's not the best way (nor elegant) to do it. 

Edited by Guderina

Share this post


Link to post
Share on other sites

I *LOVE* this pod but have one usage issue. I cannot for the life of me locate maneuver planning in the MFDs - circularize, Hohmann trasfer to target, etc. I have MechJeb installed & MOARdV has said that RPM does support it. Have these features been enabled in this pod?

Edited by Bombaatu

Share this post


Link to post
Share on other sites
2 hours ago, Bombaatu said:

I *LOVE* this pod but have one usage issue. I cannot for the life of me locate maneuver planning in the MFDs - circularize, Hohmann trasfer to target, etc. I have MechJeb installed & MOARdV has said that RPM does support it. Have these features been enabled in this pod?

I am pretty sure that they have NOT YET been enabled in this pod.   So if those features are important to your IVA operations, you will have to use a pod that uses the "plain" RPM screens.

Share this post


Link to post
Share on other sites
27 minutes ago, nukeboyt said:

I am pretty sure that they have NOT YET been enabled in this pod.   So if those features are important to your IVA operations, you will have to use a pod that uses the "plain" RPM screens.

No, I can get around it; was just curious.

Share this post


Link to post
Share on other sites

Anyone tried this with [1.1.3] if so let me know how it goes.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.