Shadowmage

[WIP][1.7.x] SSTULabs - Low Part Count Solutions (Orbiters, Landers, Lifters) - Dev Thread [11-18-18]

Recommended Posts

On 6/28/2018 at 8:49 PM, mechanicH said:

One day if KSP runs on all my CPU cores ill put it back up.

A nice statement with a slight touch of a message to the KSP devs and the Unity devs as well... :D

Share this post


Link to post
Share on other sites

@mechanicH

Not sure on 1.4.x as I am not playing that yet with other mods, but works fine in 1.3.1. No doubt they will update it sooner or later.

You could weld the parts on the trusses you made together into one part using the UbioZur Welding mod. Will save massively on part counts.

Edited by Jimbodiah

Share this post


Link to post
Share on other sites

@Jimbodiah you know I did try that but that weld mod is incredibly unstable. Kept crashing my game and ruining my save files.  Maybe I’m not using it correctly. So I’m gonna stay clear of it for now. They need a proper tutorial for it. 

Share this post


Link to post
Share on other sites

I'm a bit lost with the two file to download from the Release part. I can't find the dependencies + installation guide. I'm probably blind but can anyone help me with that?

 

Share this post


Link to post
Share on other sites
46 minutes ago, FrancoisH said:

I'm a bit lost with the two file to download from the Release part. I can't find the dependencies + installation guide. I'm probably blind but can anyone help me with that?

 

there are two files because the PBR are optional and activate the "reflection" visuals that Shadowmage made work in KSP. His parts can be painted in all colors and have adjustable metallic textures. Your gameDataFolder should have the 000-TexturesUnlimited folder, SSTU folder and SSTU-PBR as well as moduleManager.dll, CommunityResourcePack and KSPWheel (seems to be the dependencies for all to work). You should also start the game with glcore command.
Go HERE:

 

Edited by Agustin

Share this post


Link to post
Share on other sites

Will you be adding european engines like the Vulcain series and the HMB-7, Aestus and Vinci upper stage engines?

Share this post


Link to post
Share on other sites
4 hours ago, Tonas1997 said:

Will you be adding european engines like the Vulcain series and the HMB-7, Aestus and Vinci upper stage engines?

The goal I think was to have engines within certain performance ranges available more than populating all extant engines with slightly different thrust/Isp.

Share this post


Link to post
Share on other sites

Quick question - does the newest version of SSTU still have the tank mass upgrades?  In my 1.3.1 career, I frequently used the lightweight and superlightweight options in the late game.  I can't seem to find the tank mass upgrades in any of the nodes in the R&D center in my new 1.4.4 career.

No worries either way - just looking to see if the feature is still around or if I need to begin a mod compatibility bug hunt.

Update: Well, the various tank options are there in the config file, so it looks like they're intended to be there.  Can anyone else using SSTU confirm whether the tank upgrades are present in their save?  In other words, is it just me? :/

Edited by Norcalplanner

Share this post


Link to post
Share on other sites
16 hours ago, Norcalplanner said:

Quick question - does the newest version of SSTU still have the tank mass upgrades?  In my 1.3.1 career, I frequently used the lightweight and superlightweight options in the late game.  I can't seem to find the tank mass upgrades in any of the nodes in the R&D center in my new 1.4.4 career.

No worries either way - just looking to see if the feature is still around or if I need to begin a mod compatibility bug hunt.

Update: Well, the various tank options are there in the config file, so it looks like they're intended to be there.  Can anyone else using SSTU confirm whether the tank upgrades are present in their save?  In other words, is it just me? :/

Seems possible that the code for managing those was broken during the update to 1.4; I'll make note of it in the issues list and investigate when next I have time for development.

Share this post


Link to post
Share on other sites
1 hour ago, Shadowmage said:

Seems possible that the code for managing those was broken during the update to 1.4; I'll make note of it in the issues list and investigate when next I have time for development.

Thanks in advance for all your help. :)

Share this post


Link to post
Share on other sites
On 7/4/2018 at 5:10 PM, tater said:

The goal I think was to have engines within certain performance ranges available more than populating all extant engines with slightly different thrust/Isp.

Understandable, I just think it would be cool to have a bit more engine variety (for example, there are 7 Merlin variants and no european ones).

Share this post


Link to post
Share on other sites
4 minutes ago, Tonas1997 said:

Understandable, I just think it would be cool to have a bit more engine variety (for example, there are 7 Merlin variants and no european ones).

There's some efficiency that can be applied for variants of the same engine family - large parts of the model and texture can be reused which reduces the work required to add them by a lot.  So maybe that's not the best example...

Share this post


Link to post
Share on other sites

SSTU is being buggy for me as i cannot place any parts on parts now can i remove them...

i am using -force-gl11 ( i think?) option

Share this post


Link to post
Share on other sites
2 minutes ago, Abpilot said:

SSTU is being buggy for me as i cannot place any parts on parts now can i remove them...

i am using -force-gl11 ( i think?) option

There is no -force-gl11 options.  There's -force-d3d11 and -force-glcore

But that doesn't sound like it's related to the issue you're having.  No way to tell what the issue is without logs though.  If you don't know what those are or how to get them, please read the "HOW TO GET SUPPORT" link in my signature.

Share this post


Link to post
Share on other sites

I'm interested in the possibility of making the configurable MFT tanks passable by Kerbals. Subtracting the available volume by a 1.25m tunnel the full length of the tank would be only fair.

Apologies if this has already been addressed.

(Right now I have to clip the tanks in to the sides of pressurized crew tunnels.) 

Edited by Teslamax

Share this post


Link to post
Share on other sites

Just a general update -- yes, I'm still around.  Had a few things happen at work, and have had to pick up the duties of another department.... so my already busy schedule has become far overloaded.  This has left not much time (and very little brain power) to devote to modding.  Kind of irritates me, as at this point the mod likely only needs 5-6 hours worth of solid work to get it back to release status... but trying to find that time (when I'm not worn down by work/life) has been impossible lately.  Hopefully this situation will not go on for too much longer, and I'll be able to finish up the current rewrite stuff, and move back onto developing new stuff (mostly just new parts, the plugin is quite capable).  So, please be patient;  I fully intend on finishing up what I started with the rewrite.

 

On 7/8/2018 at 9:29 AM, Teslamax said:

I'm interested in the possibility of making the configurable MFT tanks passable by Kerbals.

Should be entirely possible, but not sure that I would include it in the default releases.

The first option that comes to mind to enable it would be to copy the MFT-A model definitions, give them a new unique name, and specify their volume such that it would represent the tank minus the crew tunnel.  Would use the same models, but the volume would be adjusted properly.  These models could then be added to the existing MFT-A part as a new variant.  Total time to do the work - likely 2-3 hours.

The second option would be to add a new 'tank type modifier' that simply reduced the available raw volume by a percentage.  It wouldn't be exact (and could be quite off for some models), but would be much quicker to implement.  Simply define the new modifier type, specifying the values as appropriate (IIRC its tankVolumeModifier that would be adjusted), and then add that modifier as an option to the tanks/part configs.  Total time to do the work - 10-15 minutes.

Both of those options are entirely config based and would not require any changes to the existing plugin code, and could even be done through an MM patch.

Share this post


Link to post
Share on other sites

These parts look kind of familiar...

 

Share this post


Link to post
Share on other sites
On 7/16/2018 at 12:23 AM, jack gamer said:

I get this weird bug or some sort.

Interesting -- looks like the IVA still needs to have its position updated to match the model.  Please open a ticket on the Github issues page, and I'll try and look into it for the next release.

Share this post


Link to post
Share on other sites
1 hour ago, Shadowmage said:

Interesting -- looks like the IVA still needs to have its position updated to match the model.  Please open a ticket on the Github issues page, and I'll try and look into it for the next release.

ok

Share this post


Link to post
Share on other sites
Album a/p1Kn7ao will appear when post is submitted

I use SSTU procedural tanks on a few craft. A few days ago, things were fine. Today, the masses of the tanks are negative while dry (and sometimes while wet). The tanks are the only parts exhibiting this phenomenon.

This causes insane issues. It's as if an anchor is dragging the craft down or stuck to an invisible 3-D coordinate. None of my rockets (with the parts) will launch.

The negative masses are listed in the VAB. Switching the tank material *does* change the dry mass of the tanks in my case as does whether the MUS tank has solar arrays, etc. (It seems as if the fuel itself may have negative mass as well.)

I do have many other mods installed but I didn't change any thing in my install so I'm at a loss. (Afaik, just a Windows update...)

 

I am using KSP 1.4.3

I'll try reinstalling STU in case the configs got corrupted. The reinstall had no effect.

Edited by Teslamax

Share this post


Link to post
Share on other sites

I can confirm I also have seemingly random fuel tanks having negative mass.

Share this post


Link to post
Share on other sites
On 7/18/2018 at 2:25 AM, Teslamax said:
Album a/p1Kn7ao will appear when post is submitted

I use SSTU procedural tanks on a few craft. A few days ago, things were fine. Today, the masses of the tanks are negative while dry (and sometimes while wet). The tanks are the only parts exhibiting this phenomenon.

This causes insane issues. It's as if an anchor is dragging the craft down or stuck to an invisible 3-D coordinate. None of my rockets (with the parts) will launch.

The negative masses are listed in the VAB. Switching the tank material *does* change the dry mass of the tanks in my case as does whether the MUS tank has solar arrays, etc. (It seems as if the fuel itself may have negative mass as well.)

I do have many other mods installed but I didn't change any thing in my install so I'm at a loss. (Afaik, just a Windows update...)

 

I am using KSP 1.4.3

I'll try reinstalling STU in case the configs got corrupted. The reinstall had no effect.

 

17 hours ago, T-10a said:

I can confirm I also have seemingly random fuel tanks having negative mass.

 

Thanks for the report and confirmation.  If you could please open a GitHub issues ticket with the relevant details, along with the steps necessary to trigger the issue, I will do my best to get it fixed for the next release.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.