Shadowmage

[WIP][1.7.x] SSTULabs - Low Part Count Solutions (Orbiters, Landers, Lifters) - Dev Thread [11-18-18]

Recommended Posts

Posted (edited)

is just me or the interstage node on MFT-A doesn't work anymore?

Edited by AliceM

Share this post


Link to post
Share on other sites

Hello. Are craft files still not available for latest version? Really looking forward to this mod. Thanks!

Share this post


Link to post
Share on other sites

Hello!
I don't know if this is an issue or not. The modular heat shield sizes can't be unlocked as far as i am aware without researching the entire tree. I have the 1.25m but i can't seem to unlock any further sizes despite having almost unlocked every single node.

Thanks! :)

 

Share this post


Link to post
Share on other sites
hi,
I wanted to know if you will change the texture of the Ship Series C to add termic tile on the front?

spacecraft_orion.jpg

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/21/2019 at 9:45 AM, korych said:

Hi!

Why didn't you fix this problem?

joxiscreen_2268099_31338972.png

565jpg_2413522_31338969.jpg

What problem?  Link to the bug report/issue ticket?  (images != link)

And, if you bothered to read the ticket, I _did_ fix one of them, and then noticed that the other two needed fixing after I had published the release.  Which is why the ticket is still open.  If you care that much, put together a PR to fix it and I'll merge it in for the next release.

But bugging me in such a fashion about absolutely trivial stuff like this is only going to accomplish one thing.  Welcome to my ignore list.  Thanks for playing.

 

 

On 3/23/2019 at 7:18 PM, noxeeternal said:

Hello. Are craft files still not available for latest version? Really looking forward to this mod. Thanks!

Nope, mod is still in active development.  I will not provide craft files until mod is 'finished'... and likely not even then as I don't believe in using others craft designs.

 

On 3/24/2019 at 5:03 AM, Panther1 said:

Hello!
I don't know if this is an issue or not. The modular heat shield sizes can't be unlocked as far as i am aware without researching the entire tree. I have the 1.25m but i can't seem to unlock any further sizes despite having almost unlocked every single node.

Thanks! :)

 

Please report the issue on the bug tracker.

 

5 hours ago, Hiroshidan said:

hi,
I wanted to know if you will change the texture of the Ship Series C to add termic tile on the front?

spacecraft_orion.jpg

Not as a provided option.  You are free to make and provide your own textures for it if you desire, and the mod will gladly use them.

 

Edited by Shadowmage

Share this post


Link to post
Share on other sites
On 3/22/2019 at 12:21 PM, AliceM said:

is just me or the interstage node on MFT-A doesn't work anymore?

I haven't personally noticed any issues, but could be that I simply haven't tested it.  You are referring to the interstage node that is present when adapters are in use, correct?

Share this post


Link to post
Share on other sites
7 hours ago, Shadowmage said:

I haven't personally noticed any issues, but could be that I simply haven't tested it.  You are referring to the interstage node that is present when adapters are in use, correct?

i was trying engine mount in MFT, mountInterstage node is there, but the position is wrong. 

noseInterstage just doesn't exist, but i never used in previous version,  so...

 

Share this post


Link to post
Share on other sites
10 hours ago, AliceM said:

i was trying engine mount in MFT, mountInterstage node is there, but the position is wrong. 

noseInterstage just doesn't exist, but i never used in previous version,  so...

 

Thanks for the report and confirmation.  I've opened an issue ticket on the subject, and will investigate / fix up for the next release.   https://github.com/shadowmage45/SSTULabs/issues/772

Share this post


Link to post
Share on other sites

do the centrifuges for orbital stations count as habitats for USI life support? 

Share this post


Link to post
Share on other sites
On 3/31/2019 at 11:19 PM, 123nick said:

do the centrifuges for orbital stations count as habitats for USI life support? 

At one point, yes, but the USI-LS patches have not been updated in ages, so really no clue at this point.

Share this post


Link to post
Share on other sites
On 4/1/2019 at 7:19 AM, 123nick said:

do the centrifuges for orbital stations count as habitats for USI life support? 

You can reverse engineer a patch file by looking at the Stockalike  Station Parts mods Patch files. This mod has its own centrifuge in a similar size.

That's what i did when i tried out USI

Share this post


Link to post
Share on other sites
On 4/3/2019 at 9:08 AM, Columbo said:

You can reverse engineer a patch file by looking at the Stockalike  Station Parts mods Patch files. This mod has its own centrifuge in a similar size.

That's what i did when i tried out USI

so you made your own patch file for the centrifuges for USI-LS? do you still have it? id make a patch, but doesnt SSTU have procedural parts that can have varying stats depending on size and configuration?

Share this post


Link to post
Share on other sites
9 hours ago, 123nick said:

so you made your own patch file for the centrifuges for USI-LS? do you still have it? id make a patch, but doesnt SSTU have procedural parts that can have varying stats depending on size and configuration?

Yes, i did only 3 Parts i think, but i don't have it anymore since i deleted that install because i rather use TAC-LS. 

How you modify a part in-game should not mess with the habitation stats you set in the patch file because they are just fixed numbers. You would just set the patch file to what ever you feel like is balanced. It's not that hard if you look at other mod's patch files (like the before mentioned station parts mod).

Share this post


Link to post
Share on other sites

havent flown an ares shortstack in forever, since the update to 1.6.x...when did this see full 1.6.x compatibility?

Share this post


Link to post
Share on other sites

Just a heads up that I'll be putting out an official 1.7 recompile/release over the weekend.  Aside from the recompile it will likely contain a handful more fixes for recently reported issues, but won't have anything more substantial.  Should be a direct update and should not be game/save/craft breaking in any way.

 

Share this post


Link to post
Share on other sites
Good afternoon, look I use many mods, more than 150, your mod is wonderful, but even running on 64bit on windows I still have trouble making the whole game open.

 There must be a series of incompatibilities with my other mods or I'm doing something wrong.

PS:I'll give you the log.

Share this post


Link to post
Share on other sites

Hi,

I downloaded the mod and it seems that all things are kind of "dark" / "black", as if they had no right texture. I also wanted to know how to turn off the chrome of objects

Share this post


Link to post
Share on other sites
1 hour ago, rib3irojr said:

Hi,

I downloaded the mod and it seems that all things are kind of "dark" / "black", as if they had no right texture. I also wanted to know how to turn off the chrome of objects

Make sure you installed ModuleManager, TexturesUnlimited and all other dependencies . You should be able change colors and metallic properties of most parts in the editor.

if that doesn’t help see first post for issue reporting instructions.

Share this post


Link to post
Share on other sites

Yes, I've installed all dependencies, but continues what I talked.

Just now, rib3irojr said:

Yes, I've installed all dependencies, but continues what I talked.

And I'm using the -force-d3d11 too

Share this post


Link to post
Share on other sites
2 hours ago, rib3irojr said:

Yes, I've installed all dependencies, but continues what I talked.

And I'm using the -force-d3d11 too

 

2 hours ago, rib3irojr said:

Please provide a link to an uploaded KSP.log file -- there is definitely something not loading properly in your install, though I couldn't say what just from screenshots.  You may upload this log file to various file-sharing sites (pastebin, dropbox, etc), and then post the link here.

Share this post


Link to post
Share on other sites
7 hours ago, Shadowmage said:

 

Please provide a link to an uploaded KSP.log file -- there is definitely something not loading properly in your install, though I couldn't say what just from screenshots.  You may upload this log file to various file-sharing sites (pastebin, dropbox, etc), and then post the link here.

https://drive.google.com/file/d/1m-eWkJ57HUiQg-_2HIZdP5JWYcgaQpVR/view

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.