Jump to content

[WIP][1.8.x] SSTULabs - Low Part Count Solutions (Orbiters, Landers, Lifters) - Dev Thread [11-18-18]


Recommended Posts

This mod just keeps getting better and better. Too bad the game itself is responding less and less to clicks in the VAB, flight, and menu's every. single. update. And my stupid PC keeps shutting itself off every couple hours ever since i got a new GPU >:I

 Also, a small note if this isn't already known, or isn't a problem that anyone else is experiencing, but when the game is loading up, the last thing to load, being "SC-C-CM-IVA", hangs for a couple minutes or so, noticeably longer than any parts have in the past. Usually the last part to load only hangs for a second before it's all over with.

 

Link to post
Share on other sites
2 minutes ago, StickyScissors said:

This mod just keeps getting better and better. Too bad the game itself is responding less and less to clicks in the VAB, flight, and menu's every. single. update. And my stupid PC keeps shutting itself off every couple hours ever since i got a new GPU >:I

 Also, a small note if this isn't already known, or isn't a problem that anyone else is experiencing, but when the game is loading up, the last thing to load, being "SC-C-CM-IVA", hangs for a couple minutes or so, noticeably longer than any parts have in the past. Usually the last part to load only hangs for a second before it's all over with.

 

Cant say I have those problems. I have gotten the response issue thing but that was before I even installed SSTU. I have a feeling it has something to do with KIS. As for the hanging on the SC-C-CM-IVA. I dont get that.

Link to post
Share on other sites
26 minutes ago, StickyScissors said:

Also, a small note if this isn't already known, or isn't a problem that anyone else is experiencing, but when the game is loading up, the last thing to load, being "SC-C-CM-IVA", hangs for a couple minutes or so, noticeably longer than any parts have in the past. Usually the last part to load only hangs for a second before it's all over with.

What looks like the last IVA loading is actually all the plugins doing their startup process, the bar just doesn't reflect that.

Edited by TheRagingIrishman
Link to post
Share on other sites

The engines are balanced for stock KSP. They need patching to work in RSS as they lack thrust/isp for 10x systems (see my patches for a simple RSS patch).

I don't find the hypergolic engines OP, maybe the SuperDraco for it's size/weight, but I tend to get more out of the modern LF/O (merlins etc) engines than any hypergolics. The modular SRB are powerful because you can make them larger than the small stock SRBs. If you would use tweascale and enlarge the stock boosters, they perform the same. The Hydrolox engines have really high ISPs, as in real life, but require larger (yet lighter) tanks to carry the LH. For orbital propulsion I always go for LH/O due to the ISP.

 

Quote

And my stupid PC keeps shutting itself off every couple hours ever since i got a new GPU >:I

Are you overclocking it? Otherwise your power supply might now be handling it well, or the heat from the GPU is not removed from the case causing thermal shutdown.

Edited by Jimbodiah
Link to post
Share on other sites
46 minutes ago, Lukas1 said:

Why RS 25, doesn't want stock fuel?

I think Shadowmage tried using all stock fuels at the beginning, and everything was just really off.  So a couple of additional fuel types were introduced.

Link to post
Share on other sites
Just now, Lukas1 said:

This is strange, because the other engines (RD, Merlin) work well on the stock fuel

That is because Shadowmage explicitly configured some engines to use a real world configuration and expands on the stock fuels for that reason.

Link to post
Share on other sites
3 minutes ago, Theysen said:

That is because Shadowmage explicitly configured some engines to use a real world configuration and expands on the stock fuels for that reason.

Where I can find configurations for stock fuel? 

Link to post
Share on other sites
4 hours ago, Lukas1 said:

Where I can find configurations for stock fuel? 

You can't, or you can write a patch. There are various hydrolox engines, and the trade off of higher Isp is a lower density propellant.

 

If any argument could be made about fuels (I've seen discussions on the forum about what LFO really is) it might be that LFO should be hypergolic, in which case he'd need to make the Merlins, F1, and others use a new fuel. Multiple fuels with trade offs is the point, though.

Link to post
Share on other sites
2 hours ago, Bit Fiddler said:

do the centrifuge parts add torque to a craft in flight?  I am seeing some weird spin on a station I put up after I inflated the centrifuge ring and it starts to turn.

No, it is an animation only.  Has no physics interaction aside from that of its colliders. 

Is there part-clipping in use on your craft?  Anything 'loose' that could be bumping into things (unattached parts in cargo bays)?  Have you tried hitting alt-x to zero out the trim settings?

(Really have no idea what could be causing it, just checking on some of the stuff I've seen cause problems in the past)

 

 

Link to post
Share on other sites

Spent a bit of time over the weekend working through the back-log of issues from the tracker.  Mostly spent time trying to figure out why the shaders don't work in OpenGL on windows (but apparently works fine on OSX?  anyone using SSTU on a linux variant that could confirm if they work there?).

Honestly I'm stumped on the shaders.  They don't throw out any errors during compilation in Unity, or assignment in KSP.  They work fine in the Unity editor (when it is force-loaded in OpenGL mode).  However all three of my custom shaders fail to one degree or another when used in KSP in OpenGL mode -- the solar and recoloring/masked shader both render as black/no-lighting, while the icon shader renders some light-blue texture on everything.

But...at least that gives me a place to continue my investigations -- the icon shader renders -something-, so I can likely work back from there to see why/where things stop working correctly.

Sadly, the testing process is going to be long and painful as I cannot use the Unity editor for testing (which is where rapid-development testing stuff should logically be done); apparently there is some difference between the editor in OpenGL mode and KSP running in OpenGL mode.

And all this... is to fix some icon problems on OSX; which supposedly uses OpenGL, though strangely the OpenGL specific code I put in doesn't effect it (though does seem to effect OpenGL on windows?).  Ahh, such fun dealing with shaders and platform specific hackery when you don't have any platforms at hand to do testing on.

 

 

On to the actual progress -- made up the glow textures for the LM engines:

 

WaP9faH.png

Figured out some a nice procedural system for making the glow textures, including the noise and banding.... so will be applying that system to new glow textures in the future.  Quick, easy, looks good, and highly configurable for different glow texture outputs.  Basically it comes down to treating the red and green channels separately (using additive blending), which gives some very fine-grained control for the overall resulting combined output.

This finishes up the reworked LM engines, and they will definitely be available with the next full release (LMDE available in dev branch now if anyone wants to try it out, LMAE will be available in dev soon).

 

 

And also started working on the SC-D set of pods.  Going to -try- to work all three into a single part series (early career pods) (and going to try and share textures wherever possible).  Might as well give some options for early craft design.

VA = 1.875m (bot) x 1.25m (top)
TKS = 2.5m (bot) x 1.875m (top)
Gemini = 1.875m (bot) x 0.625m (top)
Gemini-SM = 2.5m (bot) x 1.875m (top)
Mercury = 1.25m (bot) x 0.625m (top)

 

3h1MVH1.png

They are all going to be labeled as SC-D for now, probably end up being SC-D-VA, SC-D-Gemini, and SC-D-Mercury for the full part/series names.  At some point in the future I'm going to rename/relabel/regroup all of the ShipCore parts into something a bit more organized (probably during the next major KSP update, 1.4, if it ever happens).

Obviously very early in the modeling stages, just getting the rough geometry laid out for now.  Not sure exactly how I'll be working through the parts (what order/etc)... but I'm sure I'll post more info as I get it figured out :)

Link to post
Share on other sites
14 hours ago, Lukas1 said:

This is strange, because the other engines (RD, Merlin) work well on the stock fuel

LFO is considered to represent kerolox (kerosene and liquid oxygen) in the real world. The F1 and Merlin engines all use kerolox, but engines like the RS25, J2 and RL10 use cryogenic fuel (liquid hydrogen and liquid oxygen). Seeing as these latter engines all have much higher ISP,  it would make them a bit overpowered when running on the same fuel. Hence the other fuel types were introduced (also already used in other mods like Nertea's cryo engines).

Edited by Jimbodiah
Link to post
Share on other sites

Finally, after nearly two days of searching/reading/researching, I managed to get the SSTU custom shaders working in OpenGL on Windows:

TBLhoBL.png

 

Now to figure out and fix the icon problems that started this whole endeavor....

Link to post
Share on other sites

Huh, I guess making a KSP-sized gemini isn't easy.  The capsule and service module are 90 and 120 inches wide respectively, which would translate to roughly 1.5m and 2m at 64% scaling, but neither of those are standard sizes.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...