Jump to content

[WIP][1.8.x] SSTULabs - Low Part Count Solutions (Orbiters, Landers, Lifters) - Dev Thread [11-18-18]


Recommended Posts

11 minutes ago, tater said:

Was horsing around with the "make everything metal" patch @Electrocutor posted in the TU thread...

5xNrArA.png

 

That is quite impressive looking.

(yes, engines are still on the PBR conversion list... but as they are using unique textures rather than the recoloring system... it takes a substantial amount of effort to redo each one)

Link to post
Share on other sites

That was not meant to push on your limited time, it's just gonna be pretty cool when your engines look like the real thing on the factory floor. Seriously cool. I scaled that booster to real F9*0.64, BTW, looks perfect!

Link to post
Share on other sites

Nearly finished... need to clean up the lower struts and footpad geometry, and rig the suspension/wheel collider.

bxOvnk0.png

IXQmV4c.png

As can be seen, the leg tightly integrates with the existing framework on the fuel tanks.  The other struts that go towards the interior also connect with the interior framework on the tank (not visible from angle shown).  The struts at the top connect to the tops of the fuel tanks (or clip into the sides of the tanks on longer tank variants).

(just noticed I'm going to have to adjust things slightly to let it work in 4-way symmetry... but shouldn't be take too much to clean that up)

 

Link to post
Share on other sites
8 minutes ago, Jimbodiah said:

I thought maybe there might have been some parts moving up, but it only pivots at the top I see. Looking cool!!!!!   Can;t wait!

Not on this one :)

Actually... here you go, fuel tank removed for clarity:

eTQ28ZJ.gif

Those little hanging latch pieces actually latch closed during the last frames of the animation... (and aren't hanging in mid-air when it is properly attached to a fuel tank).

Link to post
Share on other sites
18 minutes ago, Jimbodiah said:

So, available in tomorrow's release :wink::wink::D 

Haven't seen it on the todo list, or the dev build so I will assume it's for later.

Still, it looks really awesome!

Link to post
Share on other sites
21 hours ago, tater said:

That was not meant to push on your limited time, it's just gonna be pretty cool when your engines look like the real thing on the factory floor. Seriously cool. I scaled that booster to real F9*0.64, BTW, looks perfect!

I know :)  Still its a reminder of the sad state that the textures are currently in.... so.. much... work...

 

35 minutes ago, Jimbodiah said:

So, available in tomorrow's release :wink::wink::D 

 

14 minutes ago, tater said:

Haven't seen it on the todo list, or the dev build so I will assume it's for later.

Still, it looks really awesome!

 

Heh, thats just the first leg.  Still at least two more variants to create before any of them will be available.  Plus texturing time.  I might export some un-textured prototypes in the interim (to allow for starting on the config files and in-game testing), but will likely be at least a few weeks before they will be available in public releases in non-dev-prototype form.

Doing them all simultaneously/consecutively to help with consistency between them, and hopefully allow for some texture re-use and/or shared texture sheets.  Not sure if these parts will be recolorable, or what kind of texture(s) they will have (standard, gold foil, etc).

Link to post
Share on other sites
21 minutes ago, mesocyclone said:

Maybe I'm too dumb, but I can't seem to find the "Configure Container" option in order to add RocketParts. Currently playing 1.2.2. RSS...

One, at the top of the right click there is a "Fuel Type" slider. Rocket parts is second from the right (click left arrow twice) from default LFO.

Two, right click has a "Configure Containers" button, click that, and scroll down the alphabetical list. (this is if you want a mixture of fuel types, otherwise the Fuel Type is the easiest)

Edited by tater
Link to post
Share on other sites
44 minutes ago, mesocyclone said:

Maybe I'm too dumb, but I can't seem to find the "Configure Container" option in order to add RocketParts. Currently playing 1.2.2. RSS...

If you are playing with full RO (and not just RSS), or otherwise have RealFuels installed.... the RealFuels system overrides the SSTU fuel container handling system.  If that is the case, you'll have to look into how to use RealFuels to configure for those resources, or otherwise find a way to disable RealFuels patches for those parts (it may even be a patch in the SSTU/ModIntegration folder).

And as you mention 1.2.2 -- are you sure you have the proper SSTU version for that version of KSP?

Link to post
Share on other sites

Thank you so much for this addon! It has been my favorite since I started using it in 1.2.

I just returned to KSP after a few months and after installing SSTU on a fresh install, all core and tank parts do not have textures. I've deleted and re-copied everything in the GAMEDATA folder but still no textures are shown. Any ideas?

Thanks! 

Link to post
Share on other sites
1 hour ago, korych said:

And problem №2. On CM PBR can not change the main colors.

PBR texture sets are not recolorable.  Nothing wrong there.

1 hour ago, korych said:

This module (Apollo) have problem with cabin lights.

Thanks, will look into it.  In the future, the proper place to submit bug reports is through the Github repository Issues tracker system -- https://github.com/shadowmage45/SSTULabs/issues

11 hours ago, DScamp said:

Thank you so much for this addon! It has been my favorite since I started using it in 1.2.

I just returned to KSP after a few months and after installing SSTU on a fresh install, all core and tank parts do not have textures. I've deleted and re-copied everything in the GAMEDATA folder but still no textures are shown. Any ideas?

Thanks! 

As @Jimbodiah stated, make sure you have the 000_TextureUnlimited folder in your GameData as well as SSTU.

Otherwise, I'll need to see your KSP.log file, as that will likely have hints as to what is going on.

Link to post
Share on other sites
5 hours ago, Jimbodiah said:

What ksp version are you running? You need 1.3.1 for the latest SSTU version.

Also check that you have the 000_texturesunlimited folder installed.

Thanks @Jimbodiah, running 1.3.1 and all the SSTU folders are in the GAMEDATA folder.

2 hours ago, Shadowmage said:

As @Jimbodiah stated, make sure you have the 000_TextureUnlimited folder in your GameData as well as SSTU.

Otherwise, I'll need to see your KSP.log file, as that will likely have hints as to what is going on.

Thanks Shadowmage! I have included my .log

KSP.log

Thanks guys!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...