Jump to content

[WIP][1.8.x] SSTULabs - Low Part Count Solutions (Orbiters, Landers, Lifters) - Dev Thread [11-18-18]


Recommended Posts

You don't need reaction wheels. The engine gimbals should take care of any vectoring you might need. Are you building VERY long rockets perhaps? Rockets flipping is usually a problem of not enough thrust or too much drag while turning, causing the rocket to flip. You could try some wings at the bottom (and top if that wasn't enough) to see if it's an aerodymic problem. Also press F12 to see the aerodynamic forces when it flips.

Edited by Jimbodiah
Link to post
Share on other sites
38 minutes ago, Starwaster said:

The ISS does...

Pretty sure theirs aren't magical, and actually work with physics, and don't break conservation of energy.  Yes, stored momentum based attitude control is a thing (and gyroscopic stabilization).  No, it doesn't magically run on electricity alone, forever.

 

Mostly, I have a problem with the abuse of 'magic reaction wheels' to combat rocket design issues.  Want to use a tiny reaction wheel in space to make it more 'gamey'?  Go for it.  Want to use them to man-handle a rocket into orbit? find a better way....

Link to post
Share on other sites
46 minutes ago, Shadowmage said:

Pretty sure theirs aren't magical, and actually work with physics, and don't break conservation of energy.  Yes, stored momentum based attitude control is a thing (and gyroscopic stabilization).  No, it doesn't magically run on electricity alone, forever.

That's better.

Edited by Starwaster
Link to post
Share on other sites

RCS and a small reaction wheel for orbittal stuff. Lifters only require a little gimballing, if it flips there is something wrong with your flying or maybe even a aerodymanic bus (stuff not shielded with fairings). Reaction wheels on a launcher are useless and should never be required.

Link to post
Share on other sites

Shadowmage, is it possible to get just the decoupler segment of the Orion CSM so we can make our own CSMs if we have specific requirements? 

I love the CSM you've made, but I like to mess around with designs a bit.

Link to post
Share on other sites
9 minutes ago, falken said:

Shadowmage, is it possible to get just the decoupler segment of the Orion CSM so we can make our own CSMs if we have specific requirements? 

I love the CSM you've made, but I like to mess around with designs a bit.

I'm assuming you are talking about the upper portion of the SM, where it flares out and couples to the CM?  I.E. so that you can make your own 'orion' styled service-modules?

Either way -- I don't generally make single-use parts like that.  If I were to do anything of that sort, it would likely be as an end-cap option for the hypothetical 'Modular Service Module' part (that.. maybe... someday... I'll actually be able to make).

Link to post
Share on other sites
42 minutes ago, Hoddd9000 said:

I'm getting an error saying I should run DirectX9 instead of Direct3D9. What does this mean?

I"m guessing that is the TexuresUnlimited Graphics API check.  If so, it is actually telling you NOT to use DX9/D3D9  (they are the same thing).  Instead you should be using DX11 or OpenGL --

 

Link to post
Share on other sites

I'm back to playing KSP after some time away and I'm having a bit of difficulty getting this mod to work with the latest version of KSP. I noticed you said that it needs to be recompiled in order to be used with the latest version of TU, but I seem to be doing that wrong.

 

Every time I run the build bat I get an error: "Unhandled Exception: System.IO.DirectoryNotFoundException: Could not find a part of the path" followed by the path where the build was run from with "\Build\GameData" at the end.

 

I've no experience with modding in KSP other than simply installing mods, so I'm not sure exactly how building mods here works, I'm probably missing a few steps but searching around hasn't helped much. I did try running both master and dev branches of SSTU with the current version of KSP, with DX11 and the fixes for that, and ended up with a few parts working, a few missing textures and many with blank icons.

 

 

 

 

 

Link to post
Share on other sites

@Nosin Until I can get SSTU fully updated (its a big mod, takes forever), you will have to use the KSP 1.4.X versions of TU.  It will all more or less work fine in KSP 1.5+, but of course you won't get access to the new features.  Apparently there was an unintentional method signature change that made the new TU incompatible with the SSTU plugin  (never would have thought that adding an optional parameter with a default value would break a method signature.... but apparently C# doesn't do virtual overloading like I thought it did).

I will offer zero support for manually compiled versions, nor can I give any support on setting the project up (once you get it it set up, I'm more than willing to discuss code changes/etc, but I cannot teach someone how to use VS).

13 minutes ago, Nosin said:

I did try running both master and dev branches of SSTU with the current version of KSP, with DX11 and the fixes for that, and ended up with a few parts working, a few missing textures and many with blank icons.

Yep, the SSTU dev branch is in the middle of being updated.  Expect that it will be 'broken' until that update is finished.

 

TLDR:  Just wait for the official update, or stay on the previous version of KSP.

Link to post
Share on other sites

Thanks for the fast reply. Its been a while since I've played with VS or coding, but while I wait for the people who know what they are doing to update everything I may as well dust off the old development environment and see if I cant break something even more. Either the mod will be updated or I'll remember how to code and get some hack-fix going on my end, might as well learn how to play with KSP mods. And yes, I completely understand why you don't support manually compiled mods and that setting up VS is outside the scope of support as well.

Link to post
Share on other sites
5 hours ago, Nosin said:

Thanks for the fast reply. Its been a while since I've played with VS or coding, but while I wait for the people who know what they are doing to update everything I may as well dust off the old development environment and see if I cant break something even more. Either the mod will be updated or I'll remember how to code and get some hack-fix going on my end, might as well learn how to play with KSP mods. And yes, I completely understand why you don't support manually compiled mods and that setting up VS is outside the scope of support as well.

To save you the trouble; I've recompiled the SSTUTools.dll vs. the KSP 1.5 libraries (and the updated TU); it is available from the dev-branch.  Be warned however, that there were some changes to KSP resource handling code that I have not yet made accommodations for (so... it might not work properly... but should at least load).

https://github.com/shadowmage45/SSTULabs/tree/dev/GameData/SSTU/Plugins

Link to post
Share on other sites
59 minutes ago, Shadowmage said:

To save you the trouble; I've recompiled the SSTUTools.dll vs. the KSP 1.5 libraries (and the updated TU); it is available from the dev-branch.  Be warned however, that there were some changes to KSP resource handling code that I have not yet made accommodations for (so... it might not work properly... but should at least load).

https://github.com/shadowmage45/SSTULabs/tree/dev/GameData/SSTU/Plugins

Hey, thanks for that.

Out of wanting to get this mod up working with my current install I've been playing around with VS and git cloning and all sorts of fun for an hour or so, its been fun really. I haven't really touched the dev side of anything really in a long time. I did manage to load up the dev branch into VS, change the dependencies and rebuild the dll for current libraries, but beyond that, I don't have enough understanding of the structure of the mod or the slightest experience working with unity.

Your updated dll seems to have fixed the major issues I've seen, though my client is still rather upset with me about some of it, probably some of that is artifact from my own messing about. I'll be trying a minimal install to see how things go. I'm sure it'll be enough to mess with for a while.

Anyhow, thank you again for taking the time to do that, I'll be waiting patiently (at least outwardly lol) for the proper release whenever it comes.

Edited by Nosin
Link to post
Share on other sites

Hey. 

Using KSP 1.4.5 and latest released SSTU ( 0.8.43.155? )

Currently noticed a odditity with regards to USI-LS and the command/lander pods and the Service modules. 

In the VAB the Command modules all state (in part Menu info RMB) that they have supplies/mulch but when the part is used no USI-LS resources show. Same with Service modules. 

With the lander core parts, I get supplies shown for the LC2 after part is selected but not shown in the part menu info. LC3 shows no USI-LS info in part menu or after its been selected for use. 

I understand you're getting SSTU ready for 1.5 so there may not be a fix in a release for my version of ksp, but if someone could help me out I would much appreciate it. Should be able to do upload a log tomorrow if its needed (sorry I can't do it now). 

 

Edited by rakol
Link to post
Share on other sites
42 minutes ago, rakol said:

Currently noticed a odditity with regards to USI-LS and the command/lander pods and the Service modules. 

Sorry, I really haven't played around with USI in many moons.  Very likely (almost certain) that RoverDude has changed stuff in the mod that has not been updated in the patches for SSTU.

Is it just the LC parts that are impacted, or are there issues with the StationCore and ShipCore parts as well?

 

General development update:

Hard at work converting SSTU's textures and configs to work with the new TU version.  The SSTU-PBR expansion is being merged into the main mod, and legacy shader support is being removed (PBR will be the default, and only, option that ships with SSTU).

This means that I'm having to swap the RGB <-> A channels for any part that was previously recolorable (as I had SPEC.RGB MET.A setup, which is opposite of Unity Standard).  As a bonus, I'm merging the AO maps into the MET map wherever possible, which should result in a fairly decent overall size reduction in the mod.  Some parts will still use stand-alone AO (because their MET map is re-used), but the large majority are being merged.

If all continues to go well, I should hopefully be able to have an updated SSTU available this weekend.  There really shouldn't be much 'breakage' with this update, aside from the changes to default rendering.

Link to post
Share on other sites

My new(er) machine arrives Wednesday. While just a holdover until I get a 2018 level machine, it still benchmarks 2X the machine I had been playing on, and has a substantially better GPU into the bargain...

First thing I'll do is crank up KSP! Woot!

Link to post
Share on other sites
2 hours ago, eagle92lightning said:

Where is the shuttle piping at?

What is 'shuttle piping' and what is its function?

(if you are referring to just some visual stuff -- sorry, I don't cater specifically to replicas, so parts are modeled in fairly generic fashion)

Link to post
Share on other sites
22 hours ago, Shadowmage said:

Sorry, I really haven't played around with USI in many moons.  Very likely (almost certain) that RoverDude has changed stuff in the mod that has not been updated in the patches for SSTU.

Is it just the LC parts that are impacted, or are there issues with the StationCore and ShipCore parts as well

LC2 pod: No Supplies listed in part menu, but supplies when selected.

LC3 and LC5 no supplies in part menu or when selected.

All the Command Modules. Supplies listed in part menu but no supplies when selected. 

Service Modules (Orion and Apollo) Supplies listed in part menu but no supplies when selected. 

Shuttles no supplies listed or loaded. 

Station parts: no supplies listed or loaded. 

 

So basically everything is impacted either partially or fully. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...