Jump to content

[WIP][1.8.x] SSTULabs - Low Part Count Solutions (Orbiters, Landers, Lifters) - Dev Thread [11-18-18]


Recommended Posts

On 11/30/2018 at 6:19 PM, Shadowmage said:

I'm certainly willing to take whatever help is offered, if you were interested, but thought I should mention that it is far more involved than just standard/simple texturing work.

Sure thing, sir! I´ll try to help however I can as soon as I fix my "technology" problems.
Yeah, I can say I have a  bit of knowledge regarding  the bunch of effort needed for mods an game-extras, as I used to create a few small parts and stupid vehicles for Operation Flashpoint, probably more than 15 years ago.... but I´m sure that those didn´t need not even 30% of the drawing/programming necessary for KSP nowadays :D .

::::::::::::::::::

EDIT:  thank the good-Kraken for you modder´s forum signature! I´ve just realized the bunch of stuff you create and I didn´t know!

Edited by Cataclism
Link to post
Share on other sites
9 hours ago, tater said:

 

Unrelated to that, but related to a career play through, I continue to have some issues with the solar panels on some SSTU stations not satisfying contract obligations. My work around is to always stick a stock panel or 2 (the tiny, flat ones) on every station just to be safe. I forgot this earlier this morning, and had to cheat the contract satisfied.

Ha! thanks for posting that RIGHT before I thought to ask the question Tater.   Same issue.  I have a 12 part SSTU station in orbit with SSTU solar panels and still can't get the contract to trip.   (All DOS/TKS derived.)

Link to post
Share on other sites
1 hour ago, Pappystein said:

Ha! thanks for posting that RIGHT before I thought to ask the question Tater.   Same issue.  I have a 12 part SSTU station in orbit with SSTU solar panels and still can't get the contract to trip.   (All DOS/TKS derived.)

Could be contract configurator - its out of date and in need of a refactoring, and a lot of other contract packs malfunction now

Link to post
Share on other sites
8 hours ago, DylChill616 said:

How do I put kerbonauts into the inflateable habitat modules? It says it includes accommodations for x crew but it won’t let me put anyone in it. I feel really stupid about this so a little help would be nice :)

When it's deflated, there is no room for crew.

You need to deploy it, then add crew. Just like in RL, space stations are not sent up with crew, they are sent up, then crew are brought to the station in another spacecraft (Soyuz, Apollo, Shuttle, etc).

Link to post
Share on other sites
14 hours ago, Murdabenne said:

Could be contract configurator - its out of date and in need of a refactoring, and a lot of other contract packs malfunction now

I don't have Contract Configurator installed but thanks for the idea to check!

Link to post
Share on other sites
10 hours ago, DylChill616 said:

How do I put kerbonauts into the inflateable habitat modules? It says it includes accommodations for x crew but it won’t let me put anyone in it. I feel really stupid about this so a little help would be nice :)  

I know its kinda obvious, but Is it inflated?  Until that's done, No Bueno for occupancy.

Link to post
Share on other sites
5 hours ago, korych said:

Make it possible to change the color of the solar panels. The blue color panels on servise module was good.

Please.

Most station solar panels are actually GOLD with a little blue in color...   The Colors Shadowmage chose are actually Closer to real life than what most people think.   Soviet panels were Yellow-Gold-Blue in color except on the Soyuz module itself.   ISS panels are Gold-Copper with blue highlights.  For a game Shadowmage is pretty darn accurate with the correct colors in those cases.

I am unsure but Shadowmage can answer this.  I think if PBR type re-coloring was given to the solar panels then they would loose a LOT of their visual detail.

B0BgZ7JIMAAXIjT.jpg

716ef5a8f5bb523e8cab64fbfce3ac5e.jpg

Only from nearly directly on do you even see any blue in them.

 

Link to post
Share on other sites
15 hours ago, Pappystein said:

Ha! thanks for posting that RIGHT before I thought to ask the question Tater.   Same issue.  I have a 12 part SSTU station in orbit with SSTU solar panels and still can't get the contract to trip.   (All DOS/TKS derived.)

@Pappystein and @tater, I would guess that the contract is checking for the stock solar panel module, not just if the station can produce power. The last time I checked, SSTU used a custom solar panel part module.

Link to post
Share on other sites
On 12/1/2018 at 9:40 AM, tater said:

Unrelated to that, but related to a career play through, I continue to have some issues with the solar panels on some SSTU stations not satisfying contract obligations. My work around is to always stick a stock panel or 2 (the tiny, flat ones) on every station just to be safe. I forgot this earlier this morning, and had to cheat the contract satisfied.

Interesting; thought I had caught and fixed all the instances for contracts.  Hmm.. perhaps I missed it on the ModularPart module (which manages the StationCore parts), but I know that I fixed that issue for the stand-alone solar panels.

Will make note of it, and should be able to have it fixed for the next release.   ---> https://github.com/shadowmage45/SSTULabs/issues/758

Link to post
Share on other sites

Something I wanted to do for a while:

izEWTXw.png

The hatch is from

This allows the windows to be sideways, and still have cool egress. Really need a better solution for gear/cradle, but very cool. I used a vertical landing, then tipped it, partially overpowered KSP SAS, partially there is a thruster under the airlock.

2 minutes ago, Shadowmage said:

Interesting; thought I had caught and fixed all the instances for contracts.  Hmm.. perhaps I missed it on the ModularPart module (which manages the StationCore parts), but I know that I fixed that issue for the stand-alone solar panels.

Will make note of it, and should be able to have it fixed for the next release.   ---> https://github.com/shadowmage45/SSTULabs/issues/758

I'll try and nail down which part it was. I can take a station contract, and cheat various SSTU stations to orbit and see which work before reverting ( not til tonight).

Link to post
Share on other sites
On 12/2/2018 at 10:38 AM, Pappystein said:

I think if PBR type re-coloring was given to the solar panels then they would loose a LOT of their visual detail. 

Pretty much this ^^.  While I could make them recolorable, they would lose a lot of the detail in the process.  Its not just some switch that can be turned on -- the parts/textures have to be authored with recoloring in mind to begin with, and even then there are massive limitations on what kind of coloring/effects it can accommodate.

On 12/2/2018 at 10:38 AM, Pappystein said:

The Colors Shadowmage chose are actually Closer to real life than what most people think.

I woud hope so :)  I spent a long time staring at pics of the ISS solar panels under different light conditions to try and figure out the physical properties so that I might properly replicate them with the PBR textures/shaders.

Link to post
Share on other sites

When I tried out that airlock mod last night, I bothered to hit the button to see the cut-away view, since he made IVAs. It fits easily inside the COS parts, and the SSTU COS parts have pretty low crew values for their size, so even with roleplaying it makes sense.

The only kooky bit was that the SSTU IVA is defaulted to the shuttle as airliner internal (?) I think (don't use plane parts, unsure, but rows of seats).

For the COS parts, the hitchiker would work great as a default IVA, so I reset it to that, and it fits nicely as they are all 2.5m cans. Certainly makes little difference, I'd not have even looked at the IVA except for the new mod (that's what you do with IVAs, right? Get a new mod, look at IVA if it has one, never look at it again, lol).

I was actually thinking of making a patch once I get LS back in my game that makes a copy of some of the COS parts with 1 more crew, each (smallest to 2, medium to 4, etc). Station contracts are always 5 or 10 crew, often with a lab, and I end up needing more parts than I would like to fulfill requirements. Once LS is in play, I could make them hold an extra person, but for a lower timeframe.

It's fun to play again.

 

Something that occurred to me was the stock science box part. That part has a few added lines to ModuleScienceContainer that must allow the whole "collact all" functionality. That would be really useful, along with transfer (if that's a thing) for command parts.

I'll mess with that tonight as well.

I'd like the lander to be able to "collect all", then when docked back in orbit, to be able to transfer. As it stands, I collect loads of science data, dock, then transfer all but 1 crew, then EVA the other to collect the data and place it in the capsule.

Link to post
Share on other sites
40 minutes ago, tater said:

 

I'll try and nail down which part it was. I can take a station contract, and cheat various SSTU stations to orbit and see which work before reverting ( not til tonight).

I will simplify it a bit.  DOS parts TKS, PWR, CORE/HAB/LAB and Entertainment are in my station with solar panels...  Still hasn't tripped.   I have not unlocked much of the COS parts yet (the science from THAT first station launch was going to power the COS unlock....

Basically none of the TKS derived parts seem to populate as having Solar panels but I have not launched ALL the TKS derived parts yet..

Edited by Pappystein
Link to post
Share on other sites
3 hours ago, Starwaster said:

@danger cow maybe because it's D3D 9. Texture Unlimited does warn that D3D9 isn't supported and that textures might not render properly. As it happens, it works for me on 9 (though things look too shiny that shouldn't be and it looks better on 11) but YMMV.

Try forcing D3D 11 or OpenGL

i did

 

Link to post
Share on other sites
8 hours ago, danger cow said:

i did

 

There are tons of errors in your log; none directly related to SSTU or TU (which would be where the errors were normally found if caused by SSTU/TU).

At this point I would guess that there is a mod conflict in play; something preventing TU from loading/using its shaders/textures properly.  The best way to test this would be to start a clean KSP install, and then load only the specific mods for testing -- SSTU + its dependencies.  If it works in a 'clean' install, then you know one of your other mods was causing a conflict.  Start adding mods back in one by one until the issue shows up; at that point the last-added mod is the likely culprit of the problems.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...