Crzyrndm

[1.3] Procedural Wings

Recommended Posts

Anyone know how to incline a wing on another without having a seem? 

Share this post


Link to post
Share on other sites
46 minutes ago, ISE said:

Anyone know how to incline a wing on another without having a seem? 

Yup, use your "rotation" and "offset" tools in the VAB or SPH to rotate, as well as move the parts. You can then align them to your hearts content. I do this on my P-wing fuselage aircraft and tanks.

Share this post


Link to post
Share on other sites
15 hours ago, V8jester said:

Yup, use your "rotation" and "offset" tools in the VAB or SPH to rotate, as well as move the parts. You can then align them to your hearts content. I do this on my P-wing fuselage aircraft and tanks.

Haha, ya I know how to that, but you how like in KBPS the tubes/corridors can auto connect to each other with no seems? 

Share this post


Link to post
Share on other sites

Hi,

I have an issue with 1.1.3 Pwings 11.1.

I am trying to use them with OPT Spaceplane parts - Humpback which is huge. However regardless of how thick i make them (Both Mark 2 and SP+) just before takeoff they snap off (i assume as they are huge they get ripped off due to vertical lift forces). I tried modifying the parts::

    breakingTorque = 800 (originally 100) - OPT uses 600-800 for comparison and they dont get ripped off
    breakingForce = 800 (originally 100)

(which is more inline with other OPT wings), BUT do i need to rebuild the whole plane or will this change be applied to wings regardless of the fact i modified the part.cfg afterwards.

 

Second question is even AM i fixing the correct values ? or ?

I do not have the picture of the pwings on aircraft as i have never been able to take off (will repost SPH pic in a couple of hrs) but for the time being this is what the plane looks like with OPT wings i am trying to replace (as for Landing on Laythe i need bigger lift surfaces as i want a glider rather than dart (which is now))

XvSem7g.png

The side tanks are 2,5m just for scale

Edited by Grunf911

Share this post


Link to post
Share on other sites
17 hours ago, markinturamb said:

Are Procedural Panels still part of the plan to be included?

Yes. There are some issues that I don't have a solution for yet though so nothing for release

10 hours ago, Grunf911 said:

Hi,

I have an issue with 1.1.3 Pwings 11.1.

I am trying to use them with OPT Spaceplane parts - Humpback which is huge. However regardless of how thick i make them (Both Mark 2 and SP+) just before takeoff they snap off (i assume as they are huge they get ripped off due to vertical lift forces). I tried modifying the parts::

    breakingTorque = 800 (originally 100) - OPT uses 600-800 for comparison and they dont get ripped off
    breakingForce = 800 (originally 100)

(which is more inline with other OPT wings), BUT do i need to rebuild the whole plane or will this change be applied to wings regardless of the fact i modified the part.cfg afterwards.

 

Second question is even AM i fixing the correct values ? or ?

I do not have the picture of the pwings on aircraft as i have never been able to take off (will repost SPH pic in a couple of hrs) but for the time being this is what the plane looks like with OPT wings i am trying to replace (as for Landing on Laythe i need bigger lift surfaces as i want a glider rather than dart (which is now))

The side tanks are 2,5m just for scale

BreakingTorque/Force are overriden by the plugin so no, changing that will have no effect on the issue (and they should already be scaled up significantly by the plugin). The variable you want to set is "connectionFactor" in the wing module (default is 150, higher == stronger) which scales that connection force

Edited by Crzyrndm

Share this post


Link to post
Share on other sites
13 hours ago, Crzyrndm said:

BreakingTorque/Force are overriden by the plugin so no, changing that will have no effect on the issue (and they should already be scaled up significantly by the plugin). The variable you want to set is "connectionFactor" in the wing module (default is 150, higher == stronger) which scales that connection force

That would explain the million wing breaks that i was experiencing. However where do i set that connectionFactor. It is not in part.cfg for the given wing.

- is it already somewhere ? if so where ? (its not in part.cfg - this is 1.1.3 version so 11.1)

- do i add it somewere ? if so where ? - Gamedata - pwing - wing - part.cfg, OR .craft file or somewhere else, please be specific

 

EDIT: I found it in pWings.dll, but i can not edit .dlls. Is there a simple editor that woudl allow me to edit it ?

 

If this works you will get credit on my next engineering vid  ( the one building Laythe -  Rover-Base - deploying SSTO  - wow that was a mouthfull) :-). I literally cant play without pwings :-)

Edited by Grunf911

Share this post


Link to post
Share on other sites

Hi!

My RSS 1.2.2 install of B9 Procedural Wings has parts limited to 16m in size. Sometimes, I need to extend the wings to even greater sizes. How do I do this?

I cannot find any setting in the .cfg files that might affect the maximum part size...

Thanks!

Share this post


Link to post
Share on other sites
10 hours ago, Grunf911 said:

That would explain the million wing breaks that i was experiencing. However where do i set that connectionFactor. It is not in part.cfg for the given wing.

- is it already somewhere ? if so where ? (its not in part.cfg - this is 1.1.3 version so 11.1)

- do i add it somewere ? if so where ? - Gamedata - pwing - wing - part.cfg, OR .craft file or somewhere else, please be specific

you just add the line of text to the part.cfg file inside the pwing module. It's not there at the moment because everything just uses the default of 150

PART
{
	...
    MODULE
    {
    	...
    	connectionFactor = 150 // just add this line
    }
}

 

Share this post


Link to post
Share on other sites
17 hours ago, Crzyrndm said:

connectionFactor = 150

Ok getting there just few more questions please

1. Ok, but do i need to rebuild the craft (in  SPH) or not (or just reload the game with new values in part.cfg) ?

2. also there are 2 modules (lifting surface and wing manipulator). Does it matter where i put it ?

3. What is the max value is 600 ok ?

EDIT: I tried with values 300 and 600 with no use,

    MODULE
    {
        name = WingManipulator
		connectionFactor = 1000
    }
	MODULE
	{
		name = ModuleLiftingSurface
		useInternalDragModel = True
		deflectionLiftCoeff = 2.0
		dragAtMaxAoA = 0.5
		dragAtMinAoA = 0.0
	}

Here is what happens:

I have even tried to rebuild the craft after updating values (as i thought they get modified in the .craft file once you put in the part) - not sure how it works

 

@Crzyrndm - my thoughts are that due to high mass and big wings strong forces ensue:

1. To lift wings up

2. The mass to keep it on the ground.

 

...however what is puzzling to me is why always right wing breaks and never the left one ?

(could it be that connectionFactor is only applied to the wing being edited and not the mirrored one ?) (im just speculating as i find it strange)

 

Edited by Grunf911

Share this post


Link to post
Share on other sites

connection factor would be set by the cfg so it shouldn't matter which wing was edited (you can check the .craft to see if it is in both wing modules to verify if you want)

The only thing I can think of is to look in the log and see what it says about why the joint broke. It's obviously loading it somehow, but I've seen much higher wing loadings operate without issue before

Share this post


Link to post
Share on other sites

The only error i see is this one:

// After I launch my craft.

[Error]: Ignore collision failed. Both colliders need to be activated when calling IgnoreCollision

Also i am using FAR 0.15.7.2 - Could that one be causing the issue as i believe you mentioned somewhere that some lower FAR versions cause issues in mirrored meshes. If so how can i check it ?

BTW, sent u a PM

Edited by Grunf911

Share this post


Link to post
Share on other sites

In the log file i found this:

KerbalJointReinforcement: extents could not be properly built for part PWing - SP+
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

 

Share this post


Link to post
Share on other sites

FINALLY MANAGED TO GET IT TO WORK (sorry for shout but soooo excited :-) )

 

Take a look at my new Heavy SSTO designated - SPL - SSTO - Laythe - Cargo Mk3g - Bast (Based on Egyptian deity Bastet - a lion warrior goddess that was later named a protector of cats, mothers and family)

xJ8wGFn.png

I hope Bast shall be a good mother to our future Laythe mobile base :-)

Share this post


Link to post
Share on other sites

how do i use these wings i looked at the forum there were no instructions.

Share this post


Link to post
Share on other sites
4 hours ago, Jim123 said:

how do i use these wings i looked at the forum there were no instructions.

The instructions are on the first post of this thread, Click where it says "Reveal Hidden Contents".

 

Thanks for the new release @Crzyrndm!

Share this post


Link to post
Share on other sites

@Crzyrndm thank you for update!

The wings seem to work fine on the most, but something strange happens with control surfaces symmetry. When I try to deploy symmetrically attached control surfaces, I get something like this:

fDt0YQg.jpg

At the same time all-moving control surfaces seem to work just fine.

Edited by Shnyrik

Share this post


Link to post
Share on other sites

Known issue caused by the way these wings have to be setup for symmetry to work in every other case. I have not found a way around it :(

 

Edited by Crzyrndm

Share this post


Link to post
Share on other sites
1 hour ago, Crzyrndm said:

Known issue caused by the way these wings have to be setup for symmetry to work in every other case. I have not found a way around it :(

 

On this note I have noticed when you assemble a ship with lots of P-wings like pictured below. If you pull the sub assembly off the root part to do other work and then reattach. On occasion the wings "Top" and "Bottom" surfaces will flip. Causing a white surface to now show the black heat tiles texture. Not sure if this is any relevant help.... but It's something I noticed.

screenshot9_zpsz9tuwwon.png~original

Share this post


Link to post
Share on other sites
9 hours ago, V8jester said:

On occasion the wings "Top" and "Bottom" surfaces will flip

The same thing with loading 1.2.2 crafts with procedural wings in 1.3.

In 1.2.2 those control surfaces were attached symmetrically, but when loaded in 1.3 they look so:

bTGwQU3.png

Share this post


Link to post
Share on other sites

Yep, got that flipping loading 1.1.3 craft in 1.2. Rotating the bad wing fixes both.

 

@Crzyrndm run into an issue with pwings and engineer report / pad limit size. Looks like they have a minimum size of 4m (8m total) and don't go under that. is IPartSizeModifier not working right?

Share this post


Link to post
Share on other sites

I haven't been able to reduce it under that value from what I can recall (doesn't like negative inputs?). It has been a while since I was trying to fix that so I could be wrong (I seem to recall that I did manage a -ve vessel size at one point...)

https://github.com/Crzyrndm/B9-PWings-Fork/blob/master/B9 PWings Fork/WingProcedural.cs#L3928

Also looks like the non-B9 implementation still returns absolute instead of offset from the default size. Oops

https://github.com/Crzyrndm/ProceduralWings/blob/master/Source/WingManipulator.cs#L670

Edited by Crzyrndm

Share this post


Link to post
Share on other sites
5 hours ago, NathanKell said:

run into an issue with pwings and engineer report / pad limit size. Looks like they have a minimum size of 4m (8m total) and don't go under that

It looks, the engine in some ways behaves as if they were of standard 4m size. For example, when you put a procedural surface under your plane and then launch it, the engine will put it 4 meters above the runway.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.