Jump to content

[1.1.3] Kerbal Animation Suite


Recommended Posts

Try it again, but this time, set the duration in the properties tab BEFORE adding keyframes. I think the duration was set to 0 seconds long, therefore any keyframes would technically be at the same time in the animation, and overwrite each other.

Have another look at the first image of my last album. I specified in the caption I'm setting the name and length prior to creating the first keyframe, unless just typing in the number and switching focus off the text box doesn't do it? Do I have to close the properties window for it to save? To be honest I didn't even think the clip length mattered, since there are no numbers on the timeline I assumed any keyframe would just be a value between 0 and 1 which would correspond to the length of the clip (a keyframe at 0.5, placed halfway along the timeline, would be at 0:05 for a 10 second animation or 0:30 for a 60 second one). Even if the clip length is 0s with a couple keyframes in it, clicking each keyframe should just load a pose - right now I think it's trying to automatically interpolate or something...

yea I am completely epic failing at this. I dunno. Here look at this anim. I had the kerbal in a nice cross-armed pose for the second keyframe, clicked save, exited the editor and reloaded the animations, nothing played when I selected it. reload the anim in the editor and clicking on both keyframes just shows a default pose??

Edited by Gaiiden
Link to post
Share on other sites

Do you think it would be possible to add a skeletal overlay on the kerbal for easier positioning, just click on a point an rotate it or move it like like how you would on a part the sph or vab for example. I'm a very visual person so this would help out a lot.

Example (the blue part)

image002.jpg

p.s Thanks for making me an official guinea pig XD

Edited by SpriteCoke
Link to post
Share on other sites

I saw this on Reddit a few months back and fell in love with it. Good to see it's been updated to work with 1.0. :)

EDIT: I, as well as a few other people, have been having trouble with the facial expressions. Is changing a Kerbal's expression, or making them move their mouths to talk, impossible? I can open their mouths but it just shows their bottom teeth and it looks goofy.

The facial bones are weird. You should never rotate them, just translate them up and down. Ive gotten them to work before, so they should work now, unless anything changed in 1.0.4/1.0.3.

I can't translate 'em, only rotate them.

Edited by yorshee
Link to post
Share on other sites
  • 2 weeks later...
I already knew all of this. I just need to know how to disable the expression system so we can animate their mouths properly.

The expressions? on IVA kerbals appear to be embedded in the animations attached to the Unity Legacy Animator.

If I turn off the Animator all movement stops including their faces, head, arms, legs.

There are a couple of classes related to expressions AI, etc, but I thought they were only related to EVA kerbals.

I will investigate further.

Link to post
Share on other sites

I asked danRosas about the expressions, and he said that they're handled by a kebalExpressionSystem object for both IVA and EVA, unfortunatley, I can only find the kerbalExpressionSystem object for IVA.

Also, I'm pretty sure that the bug where people can't animate kerbal faces is related to the kerbalExpressionSystem powered by an Animator component, and the regular animations, powered by an Animation component, conflicting, I just can't figure out how to disable it on EVA. :(

I hope you have better luck, because I've been stuck on this for a while.

Link to post
Share on other sites
I asked danRosas about the expressions, and he said that they're handled by a kebalExpressionSystem object for both IVA and EVA, unfortunatley, I can only find the kerbalExpressionSystem object for IVA.

Also, I'm pretty sure that the bug where people can't animate kerbal faces is related to the kerbalExpressionSystem powered by an Animator component, and the regular animations, powered by an Animation component, conflicting, I just can't figure out how to disable it on EVA. :(

I hope you have better luck, because I've been stuck on this for a while.

I'll see what I can find and report back to you.

EDIT: I have found a KerbalExpressionSystem class/object for both IVA/EVA. You can find it a number of ways:

This class is an extension of MonoBehaviour so all instances can be found with:


foreach (kerbalExpressionSystem kes in Resources.FindObjectsOfTypeAll<kerbalExpressionSystem>())

A single instance is instantiated per kerbal attached to their kerbal class. (kerbalref). So can be found with:


foreach (kerbalExpressionSystem kes in kerbal.gameObject.GetComponentsInChildren<KerbalExpressionSystem>())

where kerbal is the Kerbal class/kerbalref attached to the protocrewmember, etc. So you could check if it's an EVA kerbal first,

Get the crew protocrewmember.kerbalref from the vessel.GetVesselCrew() list, a number of ways you could do it.

Within the class there a number of useful vars as well:

Bool isIVAController is true if attached to IVA kerbal or false if attached to EVA kerbal.

KerbalEVA kerbalEVA is null if on IVA kerbal or set to the kerbalEVA partmodule if on an EVA kerbal.

Part evaPart contains the EVAPart when attached to a kerbal in EVA

Edited by JPLRepo
Link to post
Share on other sites
(kerbalref)

Oh wow, that helps a lot. I had already found it for IVA, but for EVA, I was looking for the kerbalExpressionSystem in the KerbalEVA's object, and I didn't think to look in the kerbalRef. Should be able to fix that mouth animating bug now. Thanks!

Edited by MrHappyFace
grammar
Link to post
Share on other sites
Oh wow, that helps a lot. I had already found it for IVA, but for EVA, I was looking for the kerbalExpressionSystem in the KerbalEVA's object, and I didn't think to look in the kerbalRef. Should be able to fix that mouth animating bug now. Thanks!

NP. How about extending this mod to animate IVA kerbals as well then? :wink:

Link to post
Share on other sites
  • 3 weeks later...

Daniel (danRosas) made some changes to the Kerbal rig for the animations. A small revision of the mouth made it easier to move the mouth around. The mouth is now a joint based rig

This was announced in today's devnotes. It seems like it might fix some of the bugs animating the face that we've been experiencing. :D

Link to post
Share on other sites

I'm using TextureReplacer with this. By default my Kerbals have no helmets when around the base. When I activate this mod, my Kerbal has no helmet. When I deactivate it to go back to my scene, the helmet appears. If I toggle the helmet with this mod's GUI, it only stays off while the mod GUI is up. The helmet always comes back after I go back to the scene. Is there a way to keep the helmet from ever appearing? Or a way to toggle it without the GUI? I glanced at the source code but did not see an immediate solution in there.

Edited by Felbourn
Link to post
Share on other sites
I'm using TextureReplacer with this. By default my Kerbals have no helmets when around the base. When I activate this mod, my Kerbal has no helmet. When I deactivate it to go back to my scene, the helmet appears. If I toggle the helmet with this mod's GUI, it only stays off while the mod GUI is up. The helmet always comes back after I go back to the scene. Is there a way to keep the helmet from ever appearing? Or a way to toggle it without the GUI? I glanced at the source code but did not see an immediate solution in there.

In the editor, there's a button to toggle the helmet, and I have it automatically set the helmet back to enabled when you exit the animator, so that your kerbals don't accidentally have incorrect helmet info. You should probably just turn the helmet back on with TextureReplacer before animating, and use that button if you want to animate with the helmet off.

Link to post
Share on other sites

Oh, I didn't even know TR had a GUI button to toggle it too. I thought it was set by CFG only (which is how I have mine defaulted to off). I'll search for that button now!

- - - Updated - - -

Actually, correction, I didn't know TR even had a GUI! I'm not seeing a toolbar button nor an app bar button. Maybe I am missing a change I need in my CFGs. I'll look.

- - - Updated - - -

Ohh I do remember this TR GUI. The problem is it's only accessible from the space center view. It's not available in flight. What is happening to me is:

* I enter the flight scene. My Kerbal has no helmet.

* I activate the animation GUI. The Kerbal floats in the air as expected, and has no helmet.

* I create an animation and save it.

* I close the animation GUI. The Kerbal goes back to the scene and stops floating in air. He now has a helmet.

However, I discovered the workaround for this. If you just leave to the space center scene and return back to the flight scene, the helmet disappears. It's a pain, but hopefully I won't need to be making new animations a lot.

Link to post
Share on other sites
-snip-

In TR, there should be an action in the Kerbal's rightclick menu that is for toggling the helmet. Just use that, I don't see why the space center GUI has anything to do with it.

EDIT: Apparently, there isn't a button in TR that does that, either I'm misremembering, or it was removed at some point. :(

Anyways, another fix I found is entering/exiting a pod, so you can do that if you don't want to leave the flight scene.

Edited by MrHappyFace
Link to post
Share on other sites
EDIT: Apparently, there isn't a button in TR that does that, either I'm misremembering, or it was removed at some point. :(

I thought I saw that option recently--but it might be the other way around, as in being able to put on the helmet from the right-click menu, but not being able to remove it. Now I want to experiment....

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...