Jump to content

[WIP][1.3.1] North Kerbin Dynamics - Nuclear Bombs and Heavy Ordnance Pack (and other things) v0.84b


harpwner
 Share

Recommended Posts

I'm having issues with this mod. From what I understand I have installed it correctly (pic below), and the missiles and bombs I can select and place on my ships in-game. Except when I launch a missile or drop a bomb, the explosion is just a normal explosion. Any help would be appreciated, thanks!

Directory: 

 

Link to comment
Share on other sites

1 hour ago, St4rCrush3r said:

I'm having issues with this mod. From what I understand I have installed it correctly (pic below), and the missiles and bombs I can select and place on my ships in-game. Except when I launch a missile or drop a bomb, the explosion is just a normal explosion. Any help would be appreciated, thanks!

Directory: 

 

Try re-installing the mod.

Edited by Mr. Quark
Link to comment
Share on other sites

14 hours ago, St4rCrush3r said:

I'm having issues with this mod. From what I understand I have installed it correctly (pic below), and the missiles and bombs I can select and place on my ships in-game. Except when I launch a missile or drop a bomb, the explosion is just a normal explosion. Any help would be appreciated, thanks!

Directory: 

 

You installed it wrong, inside that folder is a GameData folder, and you want to take the contents of the gamedata folder out of it, and put it into the KSP GameData folder (its the same for every mod)

Link to comment
Share on other sites

2 hours ago, acerarity said:

You installed it wrong, inside that folder is a GameData folder, and you want to take the contents of the gamedata folder out of it, and put it into the KSP GameData folder (its the same for every mod)

I don't see it.

AeToQHL.png

Edited by Snark
Fixed image link
Link to comment
Share on other sites

1 hour ago, TheUltimateJimbob said:

Hi, I have an issue where when I fire the missile it doesn't actually decouple but the rocket fires so It blows up my plane. Is this a well known issue and is there some way to fix it?

Well this is a new one I have never heard before.

Are you sure you are putting the missile on the rail, and the right way (Not half inside the pylon, or anything)

Link to comment
Share on other sites

Just now, acerarity said:

Well this is a new one I have never heard before.

Are you sure you are putting the missile on the rail, and the right way (Not half inside the pylon, or anything)

Yeah, I tried using both the attachment modes, different rails from other mods, and I tried offsetting the missile off the rail to prevent clipping. 

Link to comment
Share on other sites

9 hours ago, TheUltimateJimbob said:

Yeah, I tried using both the attachment modes, different rails from other mods, and I tried offsetting the missile off the rail to prevent clipping. 

There are 4 nodes on the BD rails, bottom, right, left, and the node for attaching the rail to the plane. Try placing the missiles on the rails via surface attach, rather then using the nodes. I have never heard of anybody having this glitch before (If its even a glitch), so you might be doing it wrong, post screenshots of the missile on the rails

Link to comment
Share on other sites

15 hours ago, acerarity said:

There are 4 nodes on the BD rails, bottom, right, left, and the node for attaching the rail to the plane. Try placing the missiles on the rails via surface attach, rather then using the nodes. I have never heard of anybody having this glitch before (If its even a glitch), so you might be doing it wrong, post screenshots of the missile on the rails

It appears that this is something that is actually universal to all missiles, so it's not just North Kerbin. What's weird is that the missiles work and fire normally on most of my planes. I usually don't use the nodes for placement so it's odd. 

 

The plane with 4 engines and the giant intake under the nose is the one where missiles don't decouple, while the MiG looking one does work. I have a few other planes with the issue of missiles and bombs that don't decouple but this is the most recent. I just hope there is a good identifiable reason the specific planes don't work so I can fix and avoid it later.

 

Edit: Sorry guys, it appears an auxiliary power unit from Red vs Blue continued caused the missiles to fail.

Edited by TheUltimateJimbob
Link to comment
Share on other sites

8 hours ago, UnlawfulWaffle said:

Every time I drop a nuke, even if I am very far away from the mushroom cloud, my ship overheats and blows up. Is there a way to fix this?

Nukes are after all dangerous, how far away is very far away? it matters .   As for steps toward not getting toasted again,  check the  cfg for the weapons blast radius and be a good deal further away than that when it goes off.  One of the nukes has a blast radius of over 7KM so local is not going to cut it

Link to comment
Share on other sites

9 hours ago, SpannerMonkey(smce) said:

Nukes are after all dangerous, how far away is very far away? it matters .   As for steps toward not getting toasted again,  check the  cfg for the weapons blast radius and be a good deal further away than that when it goes off.  One of the nukes has a blast radius of over 7KM so local is not going to cut it

I checked the cfg file and the B61 bomb had a blast radius of 0. I'm guessing that means forever. It doesn't make sense because if I am 20 km away from the B61 and it explodes I explode immediately.

Edit: The B61, B83, TSAR Bom-a, and Castle Bravo all have a blast radius of 0 meters. 0 meters? Either it goes on forever or the blast is nothing. I can't escape it?

Edited by UnlawfulWaffle
Checked config files, found more with a blast radius of 0 meters.
Link to comment
Share on other sites

On 19/05/2017 at 0:18 PM, UnlawfulWaffle said:

all have a blast radius of 0 meters. 0 meters

Nope, they don't you are failing to understand the arrangement of cfg modules,   B61 blastRadius = 4910,  B83 blastRadius = 7470, Castle Bravo  blastRadius = 11300, so that seems considerably more than zero. 

 

 

Edited by SpannerMonkey(smce)
attitude
Link to comment
Share on other sites

3 hours ago, SpannerMonkey(smce) said:

Nope, they don't you are failing to understand the arrangement of cfg modules,   B61 blastRadius = 4910,  B83 blastRadius = 7470, Castle Bravo  blastRadius = 11300, so that seems considerably more than zero. 

You only have to use one of these nukes once to realize that all is not right with, their operation, the effectiveness, the area of effect., the blast and heat functions,  I'm sure when H designed this code that he did not intend for objects at ground zero or close to, to remain undamaged while the damage at the periphery is way out of proportion.  

No slur or disrespect intended to H or the mod ( as  he's a very clever mod maker, smarter than me :) )  ,but right now, as gameplay goes, and  for those who are interested in setting up combat scenarios, the nukes are fairly useless ,  as a toy and a bit of fun fine, but expecting them to contribute to an enjoyable combat scenario is a little optimistic right now.   They certainly do not fit as a low yield battlefield nuke, not with areas of effect , spreading , as far as i've been able to tell in excess of 20KM

But then there's a reason only two have been officially used in anger, in the history of warfare, they have nasty side effects. SO perhaps they are just perfect as they are, and actually serve as a timely reminder of why nukes aren't really fun :P

 

Thank you for the help!

Edit: Oops, I didn't scroll down enough.:confused: I see it now, thank you.

Edit 2: This is what I mean, it doesn't make much sense that it is 21 km away and my plane explodes immediately after the nuke goes off.

 

Edited by UnlawfulWaffle
Link to comment
Share on other sites

18 hours ago, SpannerMonkey(smce) said:

Nope, they don't you are failing to understand the arrangement of cfg modules,   B61 blastRadius = 4910,  B83 blastRadius = 7470, Castle Bravo  blastRadius = 11300, so that seems considerably more than zero. 

 

Yeah, I experienced same problem before a 2 months, I fired cruise missile armed with nuclear warhead (Tomahawk so W80) and flew away. And it hit me 80km from the impack instantly destroying my plane. No idea what happened that day. :D It was Tomahawk from your PEW mode btw.

Edited by Toonu
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...