Jeast

[1.1.x] Canadarm v1.71 (5 June 2016)

Recommended Posts

Sorry my friend, but do not work for the focus window, I can not look out the window to watching in cargo hold. you can edit this error? so more, i not see two RasterPropMonitor, how in your video, when you work arm in cargo hold. if you can give to me your pack-mod that works. My version KSP 1.04.  Space-Shuttle 1.8.1 , Canadrm 1.51

Edited by Bust

Share this post


Link to post
Share on other sites

@Bust

Jeast used an own version of the Space Shuttle with a new internal sight. It is not released yet. By this time you can only use the Canadarm per external sight or RPM.

 

@lextacyNo, it use KAS-Magnets.

Share this post


Link to post
Share on other sites

Thank you my friend, that explain it! I will wait for your update, like at you on video.

Edited by Bust

Share this post


Link to post
Share on other sites

I am working on an updated arm. The interior is still being worked on as well. A bit slow, I know, but real life gets in the way sometimes :)

Share this post


Link to post
Share on other sites
7 hours ago, InfinityDeltaV said:

using ksp 1.1.1 all canadarm part texture is black

same for 1.1.2 also the stock Mk3 cargo bay does not have the node that used to be there for the shoulder.  Thanks for a great mod BTW!

Share this post


Link to post
Share on other sites
On 5/1/2016 at 11:07 AM, InfinityDeltaV said:

using ksp 1.1.1 all canadarm part texture is black

 

On 5/1/2016 at 6:32 PM, ParamedicPants said:

same for 1.1.2 also the stock Mk3 cargo bay does not have the node that used to be there for the shoulder.  Thanks for a great mod BTW!

Thanks for reporting! It seems it got broken since the 1.1.1 update. Fixing it atm!

 

@ParamedicPants

Are you sure you used the long CB? The CRG-100. Just tested it and the node is there.

Share this post


Link to post
Share on other sites

Fixed and updated to v1.61.

It seems that since 1.1.1 KSP doesn't support MBM anymore. I could not find notes on this but only changing the textures to something else did the trick.

Textures changed to DDS so this saves space and improves loading time as well :)

 

See 1st post for download link

 

Share this post


Link to post
Share on other sites

The Space Shuttle IVA is going to be available for testing soon as well!

Share this post


Link to post
Share on other sites

I have problem using this Canadarm. When I have it attached on my shuttle once fuel levels are low center of mass moves quite far behind the craft (and even more after I decouple external tank). I am not sure if that is the problem with this Canadarm version or with KAS, but once I removed Canadarm from the shuttle and flown it again with same payload center of mass stayed where it should be.

Share this post


Link to post
Share on other sites

Cockpit, cargo bay, engines and wings - stock

Nosecone, OMS and rear - Cormorant Aeronology

External tank - Fuel Tanks Plus

SRBs - KW Rocketry

 

Payload was combination of stock with few parts from CxAerospace and HabTech

 

Here is a craft file with canadarm mounted

Edited by Cuky

Share this post


Link to post
Share on other sites

@Cuky I have tried to replicate the problem, but I could not find it. I used stock parts (MK3) and placing the arm parts did not change anything to the CoM (center of mass). The arm parts itself are very light (mass of 0.03). Could the problem be caused by something else?

* I think I have found something. Did you mean that while ascending, the camera moves backwards behind the shuttle?

Edited by Jeast

Share this post


Link to post
Share on other sites

@Jeast Yes that was it. While ascending some when I was near 70km mark camera started shifting backwards, but it stayed level with the end of the engines. When I separated external tank it then went further behind. I will try new version and report if I still have the problem

Share this post


Link to post
Share on other sites

It works now, I have successfully deployed a satellite on a test mission using this Canadarm.

fiRSiSP.png

 

It was also quite fittingly the first time that I managed to land back on the runway with shuttle that was launched into orbit.

Share this post


Link to post
Share on other sites

Soooo... um, I make everything work fine, have KIS/KAS, IR, etc installed, arm moves around fine. But no matter what I do the magnet must be made out of old hub caps or something, cause it won't pick up, grab ANYTHING. Not sure what is going on there? I can kinda force it (Badly) if I alter the CFG file to way up the magnet force which shows the files are working but I can't actually pick up anything it seems otherwise... any suggestions?

Share this post


Link to post
Share on other sites

The arm looks great. 

However its not very functional as-is.

The default gear speed is WAY to slow, would take you 45min+ to install a station module a la STS style.

I can totally understand why you made it unable to surface attach, but making it only compatible with the added node in Mk3 cargo bay is kinda a huge missed opportunity (at least I could only get it to connect to the cargo node, no other parts at all). Great looking arm that I can't use on my orbital station or zero-g planetary bases....

Last is its holding power, unless your unloading satallites or smaller stations modules don't even bother trying to use this arm, the magnet will let go of your cargo. Not sure if the magnet is way to go...kinda supprised no one has tried to make a berthing style arm with the pipe port function from KAS/KIS...as you can 'connect undocked'. Probably some reason why it wont work ya.

 

Great looking mod, will probably keep it installed despite it shortcomings. Sure would love to see some other mounting options though at the least. 

Even something super-simple like pictured below for station mounting would be awesome

20160511_202229_zpsx43xpshz.jpg

Edited by KhaosCorp
idea

Share this post


Link to post
Share on other sites

Would it be possible to release this on Spacedock?  Also, do I understand correctly that v1.1.x means that it's anticipated to work on v1.1.2?  (I just wanna make sure I understand)

Edited by MisterFister

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.