Jeast

[1.1.x] Canadarm v1.71 (5 June 2016)

Recommended Posts

Anyone getting the end yaw for the end effector coming out of the joint and hovering weirdly away from the arm? Almost like the pivot is broken?

Share this post


Link to post
Share on other sites

Then your built of the Canadarm isn`t correct.

8 hours ago, thevegimobil said:

Anyone getting the end yaw for the end effector coming out of the joint and hovering weirdly away from the arm? Almost like the pivot is broken?

Then you connect them not correctly.

Share this post


Link to post
Share on other sites

Great Mod!

 

Having trouble attaching to my ISS...

 

Is there a node base part I can use and place as an attachment point?

 

Thanks

Share this post


Link to post
Share on other sites
1 hour ago, Kilo60 said:

Great Mod!

 

Having trouble attaching to my ISS...

 

Is there a node base part I can use and place as an attachment point?

 

Thanks

No, but you can use every part with an node like the little stock girder-module. You can attach it to this girder and then attach it to a modul of you station.

Share this post


Link to post
Share on other sites

Is there any way to remove one of the two long arms to shorten the Canadarm to better fit my Rovers?

 

Or any way to make a shorter overall version with the stock mod parts?

 

A9F49D6D6A7CBFC266E440A684D63B3599F59C93

 

Thanks!

Edited by Kilo60

Share this post


Link to post
Share on other sites
1 hour ago, Kilo60 said:

Is there any way to remove one of the two long arms to shorten the Canadarm to better fit my Rovers?

 

Or any way to make a shorter overall version with the stock mod parts?

 

Thanks!

Have you tried tweakscale? Also look at the infernal robotics part rework for more parts.

 

is that the Ares rover by @-ctn- ?

Share this post


Link to post
Share on other sites
3 hours ago, Spike88 said:

Have you tried tweakscale? Also look at the infernal robotics part rework for more parts.

 

is that the Ares rover by @-ctn- ?

I have tweaksacle installed and working but no option to shrink the Canadarm...

Where can I find the IR parts rework?

Thanks!

Yes, it is the Ares rover mod and love it!

Share this post


Link to post
Share on other sites
2 minutes ago, Kilo60 said:

I have tweaksacle installed and working but no option to shrink the Canadarm...

Where can I find the IR parts rework?

Thanks!

Yes, it is the Ares rover mod and love it!

 

Share this post


Link to post
Share on other sites
On 25.2.2018 at 1:00 AM, Kilo60 said:

I have tweaksacle installed and working but no option to shrink the Canadarm...

Where can I find the IR parts rework?

Thanks!

Yes, it is the Ares rover mod and love it!

This is because there is no Tweakscale-config for the Canadarm. Bu you easily can do it yourself. Make a new config, place it anywhere in GameData and insert the following:

@PART[carmend|carmendwrist|carmgrapple|carmlowerarm|carmshoulder|carmupperarm|carmwrist]:NEEDS[TweakScale]
{
    #@TWEAKSCALEBEHAVIOR[Science]/MODULE[TweakScale] { }
    %MODULE[TweakScale]
    {
        type = free
    }
}

 

Share this post


Link to post
Share on other sites
39 minutes ago, TheAceOfHearts said:

Doesn't seem to work for 1.4.1. It caused the game to crash on loading several times. 

The problem is not this Canadarm, the problem is Infernal Robotics which isn`t updatet to 1.4.1 yet. Wait a little bit. Also sirkut has a new project to get this Canadarm and some others to work.

 

Share this post


Link to post
Share on other sites

Do you know Infernal Robotics Next ?

The main reason why I started the project was, because I wanted to have a Canadarm and Canardarm-2 in the game. Including the redocking of the arm and attach it to other PDGFs. That wasn't possible in old IR, but is no problem in IR Next. Additionally I started to investigate docking ports, because I think PDGFs should (at least sometimes) act like dockingports (because the game removes things not docked to a vessel... so, switching vessels could ruin your day, when you're new space station part simply dissapears).

And... I wanted to include inverse kinematics to it (almost done). Oh and... add collisions to the scene so that you cannot move arms and parts attached to arms through your stations and things like that.

... I hope there is a way to try if IR Next could be used with your arm(s).

Share this post


Link to post
Share on other sites

It worked fine for me somehow on 1.4.2, i didnt install infernal robotics, i just used the one that is included with the download.

On 24/02/2018 at 7:39 PM, Kilo60 said:

Is there any way to remove one of the two long arms to shorten the Canadarm to better fit my Rovers?

 

Or any way to make a shorter overall version with the stock mod parts?

 

A9F49D6D6A7CBFC266E440A684D63B3599F59C93

 

Thanks!

this is a part for spaceshuttles so you can move the payload to the dockingport for easy docking on space stations.

1200px-Canadarm_1_-_STS-72.jpg

Share this post


Link to post
Share on other sites

and kerbal attachment system? did you use that?

Share this post


Link to post
Share on other sites

..keep getting a big fat goose egg on getting this to work.

Share this post


Link to post
Share on other sites

@RaiderMan I used KAS yes. What is not working for you, the canadarm in total ?

Edit: I see there is no Infernal Robitics file included. I will try to download the mod again to let you know how I got it to work.

Found it: First download your Module manager, KAS versions then download the core mod from this post

 

 

 

Edited by IceTitan

Share this post


Link to post
Share on other sites
On 6/1/2018 at 7:10 AM, Drakenex said:

Working perfect on 1.4.3 with IR 2.0.14

xObVUqk.png

 

Thank you, Sir. Just what I was looking for to know.

*Kudos*

Share this post


Link to post
Share on other sites

No "magnet" option on end part for KSP 1.6...?

 

Anyone else having issues getting this to work in 1.6 or 1.7 KSP?

 

Love this mod!

 

Thanks!

Share this post


Link to post
Share on other sites
1 hour ago, Kilo60 said:

No "magnet" option on end part for KSP 1.6...?

 

Anyone else having issues getting this to work in 1.6 or 1.7 KSP?

 

Love this mod!

 

Thanks!

In 1.6.x it works well. But I think you need the old KAS (legacy parts).

Share this post


Link to post
Share on other sites
On 4/14/2019 at 4:14 PM, Cheesecake said:

In 1.6.x it works well. But I think you need the old KAS (legacy parts).

Will the old legacy parts overwrite the new parts in KAS or can they be added separately?

 

Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.