RoverDude

[1.2] Karibou Expedition Rover [0.3.0]

Recommended Posts

general question for you guys, I am having issues climbing nearly every slope on the mun. its a pretty heavy rover (3x3) should I simply add more wheels? does that increase the power of the rover?

Share this post


Link to post
Share on other sites

When I downloaded the mod and opened KSP I only had the tabs in editor and none of the parts. Are there any dependencies for this mod to work?

Share this post


Link to post
Share on other sites
11 minutes ago, BelgarionNL said:

just google CKAN and install it that way. CKAN will also install dependencies.

Given that the standard advice when something happens from RoverDude is to uninstall the CKAN version and install manually, and see if the problem persists, I'm not sure this is great advice.  :wink:

CKAN is great when it works.  It doesn't always work correctly.  Knowing how to fix it then is a good idea.  The official download from GitHub includes all needed dependencies, in the correct versions.  If you're having trouble, start with that.  @Goat Master, if you put up a pic of your GameData and UmbraSpaceIndustries folders, we can check to make sure you've installed it correctly.

Share this post


Link to post
Share on other sites

I think whatever one feels about CKAN (personally I am entirely in favour), it is no bad idea to try a manual install when a CKAN install fails, but also vice versa.

Share this post


Link to post
Share on other sites

Only caveat I would add...

A manual install is at least guaranteed to get the right versions :wink:  And even though I maintain my own metadata, CKAN can be more than a bit... finnicky.. at times.

To be honest, the best, most reliable way to install any of my mods is to install them manually directly from the ZIP file into GameData, and then use KSP-AVC if you're unsure if you accidentally got a version out of whack.  KSP-AVC also makes support a LOT easier.

Share this post


Link to post
Share on other sites

Roverdude,

 

First of all let me compliment you on this mod, and all your mods as well. I enjoy using everything as it makes the immersion so much more. However, the brakes on the Karibou rover seem a bit light. I find myself having to drop the legs and retract the wheels to stop on slopes. Is there anything I can do to tighten up the brakes?

 

Thanks in advance!!

 

Using release version of KSP 1.1. Plus additional mods as well:

 

KSP: 1.1 (Win64) - Unity: 5.2.4f1 - OS: Windows 10  (10.0.0) 64bit
USI Tools - 0.7.1
ABookCase Orbital Reference System - 0.2
Chatterer - 0.9.8.1230
Color Coded Canisters - 1.4.3
Colorful Fuel Lines - 0.3.2
Community Resource Pack - 0.5
Contract Configurator - 1.10.4
Contract Pack: Field Research - 1.1.7
Contract Pack: Bases and Stations - 3.2.1
Contract Pack: Tourism Plus - 1.4.2
Contract Reward Modifier - 1.0.2.2
CapCom Mission Control On The Go - 1.0.2.1
Contracts Window Plus - 1.0.6.2
Firespitter - 7.2.1
Fuel Tanks Plus - 1.8.1
Interstellar Fuel Switch - 1.24
Kerbal Attachment System - 0.5.6.7
Kerbal Joint Reinforcement - 3.1.5
KerbalKonstructs - 0.9.6.1
Kerbal Inventory System - 1.2.7.6
KSP-AVC Plugin - 1.1.6.1
Lithobrake Exploration Technologies - 0.3.5
Modular Rocket Systems - 1.12.6
Pilot Assistant - 1.12.5
RealPlume - Stock - 0.10.6
Real Scale Boosters - 0.12.3
ShipManifest - 5.0.9
SpaceY Expanded - 1.1.8
SpaceY Lifters - 1.12.2
Kerbal Alarm Clock - 3.6.1
UbioWeldingLtd 1.1.0 Release - 2.3
USI Core - 0.2.1
Asteroid Recycling Tech - 0.8.1
USI Exploration Pack - 0.5.1
Karbonite - 0.7.1
Karbonite Plus - 0.6.1
Karibou - 0.2.1
Kolonization Core - 0.2.1
USI Survivability Pack - 0.5.1
USI Submarine Pack - 0.1.1
UKS - 0.40.1.1
WASDEditorCameraContinued - 0.6.6.2
Waypoint Manager - 2.5

Share this post


Link to post
Share on other sites
On 4/25/2016 at 10:35 AM, DStaal said:

Given that the standard advice when something happens from RoverDude is to uninstall the CKAN version and install manually, and see if the problem persists, I'm not sure this is great advice.  :wink:

CKAN is great when it works.  It doesn't always work correctly.  Knowing how to fix it then is a good idea.  The official download from GitHub includes all needed dependencies, in the correct versions.  If you're having trouble, start with that.  @Goat Master, if you put up a pic of your GameData and UmbraSpaceIndustries folders, we can check to make sure you've installed it correctly.

Well, since I'm not sure how to take a picture of my GameData, Here's what I did. I downloaded the mod, then (since I have many GameData folders already) I renamed the folder to Karibou [or KaribouRover] and placed it in the KSP GameData folder and all that showed up are the tabs.

Share this post


Link to post
Share on other sites
2 minutes ago, Goat Master said:

Well, since I'm not sure how to take a picture of my GameData, Here's what I did. I downloaded the mod, then (since I have many GameData folders already) I renamed the folder to Karibou [or KaribouRover] and placed it in the KSP GameData folder and all that showed up are the tabs.

First, If you are running windows you can use print screen, or even better in windows 7 or higher you can use the snipping tool.  Then use some service (imgur.com is my favorite and free) and paste the screenshot.  And then paste the link here.

But your text is enough.  You should have exactly ONE gamedata folder.  You should never rename any folders.  If you have a downloaded mod that has a gamedata folder then you copy the CONTENTS of that gamedata folder into your ksp gamedata folder.

your gamedata folder should look something like this:

IAG9HFM.png

Share this post


Link to post
Share on other sites
1 minute ago, goldenpsp said:

First, If you are running windows you can use print screen, or even better in windows 7 or higher you can use the snipping tool.  Then use some service (imgur.com is my favorite and free) and paste the screenshot.  And then paste the link here.

But your text is enough.  You should have exactly ONE gamedata folder.  You should never rename any folders.  If you have a downloaded mod that has a gamedata folder then you copy the CONTENTS of that gamedata folder into your ksp gamedata folder.

your gamedata folder should look something like this:

IAG9HFM.png

Ok I understand now, I do not run windows (I have a Mac and I am acutely aware of its VERY bad performance) but I sometimes get confused when theres many different files within, so that clears things up.  

Share this post


Link to post
Share on other sites

Alrighty @RoverDude! Got a bug coming right at you (twice, I posted it on your GitHub Repo, just want to see which one gets noticed). The bug is the wheels are VERY jittery on my version, 1.1.1, which makes the rover more of a stationary thing than something that moves. I think this is something to do with the new 'invisible struts thing' that 1.1.1 added on wheels n' stuff. Hope a hot fix gets released because I love this mod.

Share this post


Link to post
Share on other sites
2 hours ago, >The Amazing Spy< said:

Alrighty @RoverDude! Got a bug coming right at you (twice, I posted it on your GitHub Repo, just want to see which one gets noticed). The bug is the wheels are VERY jittery on my version, 1.1.1, which makes the rover more of a stationary thing than something that moves. I think this is something to do with the new 'invisible struts thing' that 1.1.1 added on wheels n' stuff. Hope a hot fix gets released because I love this mod.

i can second that, just made a fresh download of the karibou and experienced the same behavior!

Share this post


Link to post
Share on other sites

Could have sworn that the Karibou had the option to have its windows transparent earlier? Am I perhaps missing another mod that did this? (not thinking of the stock "ripped open" view).

Share this post


Link to post
Share on other sites
4 hours ago, >The Amazing Spy< said:

Alrighty @RoverDude! Got a bug coming right at you (twice, I posted it on your GitHub Repo, just want to see which one gets noticed). The bug is the wheels are VERY jittery on my version, 1.1.1, which makes the rover more of a stationary thing than something that moves. I think this is something to do with the new 'invisible struts thing' that 1.1.1 added on wheels n' stuff. Hope a hot fix gets released because I love this mod.

Show me a picture of your rover, because I can't replicate your issue (it works fine on my 1.1.1 install).  

1 hour ago, SkyKaptn said:

Could have sworn that the Karibou had the option to have its windows transparent earlier? Am I perhaps missing another mod that did this? (not thinking of the stock "ripped open" view).

That's from RPM, tho I'll be moving to the JSI transparent windows thingie in time

1 hour ago, mafs said:

i can second that, just made a fresh download of the karibou and experienced the same behavior!

See above.  Screenshot please.

Share this post


Link to post
Share on other sites

Alrighty... Here's ya picture: TCcqgrf.jpg

I'm not able to capture the jitter, but the wheels sort of bounce up and down unevenly and sometimes dip a bit through the ground.

Share this post


Link to post
Share on other sites
9 hours ago, >The Amazing Spy< said:

Hooray! 1.1.2 fixed this!

:)  can second that again! :) no jittering left.

also, it has a much more truck-like behavior now - in 1.0.5 it was way overpowered (but fun to drive :) ) - thank you for your great mods rover dude, 

next i have to check out the brilliant otter submarine - has to be part of my laythe mission equipment!

:) 

 

Share this post


Link to post
Share on other sites

Now THIS is good stuff!!!

 

Kinda wondered how long it would be before RoverDude made a rover =P

Been away from KSP (and all games) for some time now....come back to this wonderful bit of mod.

I have been fan of USI catalog since you started modding, but the Karibou is by far the USI mod I find most enjoyable and most useful.

 

Whats this about an Otter sub?....

 

A little of topic...but just curios about something RoverDude...

How much would it cost a fella to get the Karibou and select parts from Kolony mod exported in .stl format...for personal use only??

Share this post


Link to post
Share on other sites

Due simply to the parts that I have unlocked in the tech tree, the Karibou Control Module fits nicely into a 2.5m rocket that I'm building. However, the height of the module seems to be bugged.

Without the Karibou Control module, my rocket is 27.8m tall. As soon as I add the KCM, the height goes up to 43.7m.

Share this post


Link to post
Share on other sites

Sounds like a stock bug or something else is affecting it (parachutes sometimes do this).

Share this post


Link to post
Share on other sites

Good call, if I take the MK16-XL parachute off of the top of the craft the height no longer behaves this way.

How do I report such a bug? It's a stock bug that only seems to appear when I add a certain mod part to the craft.

 

edit: Actually, now the craft appears not to have the bug even with the parachute. I must have changed something else in redesigning it, so I'm not sure how to reproduce it. If it happens again I'll try to do more investigation on other parts immediately.

Edited by drhay53

Share this post


Link to post
Share on other sites

Fantastic Mod!  Thanks RoverDude for all the USI mods.

I have a possible bug, is anyone else having troubles getting the wheels to retract and extend again?

Never mind, patience is a virtue. It just takes longer than it used to! Keep up the good work.

Edited by JTiberK
Found the answer to my question.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.