Pak

[1.7.1] Cormorant Aeronology - Mk3 Space Shuttle

Recommended Posts

1 hour ago, altoshyft said:

Hi all, I'm currently having some issues with some black textures on the space plane technologies parts and have no idea why.

If anyone can help me out, it would be greatly appreciated, thank you.

Black_textures.jpg

Here is an image of what they look like.

Welcome to the forums! Not sure what happened to your pic but it is not displaying. Try uploading it to imgur and then posting a link to the imgur post.

Share this post


Link to post
Share on other sites
5 hours ago, Foxxonius Augustus said:

Welcome to the forums! Not sure what happened to your pic but it is not displaying. Try uploading it to imgur and then posting a link to the imgur post.

Thanks for the welcome. Here you go
https://imgur.com/2p1FcI4

Edited by altoshyft

Share this post


Link to post
Share on other sites
43 minutes ago, altoshyft said:

Thanks for the welcome. Here you go
https://imgur.com/2p1FcI4

Ahh, yeah that doesn't look right. The only advice I have is to delete the mod from your game data folder, it should just be the Cormorant Aeronology folder. Then re-install from a fresh download.

Share this post


Link to post
Share on other sites
7 hours ago, Foxxonius Augustus said:

Ahh, yeah that doesn't look right. The only advice I have is to delete the mod from your game data folder, it should just be the Cormorant Aeronology folder. Then re-install from a fresh download.

I managed to fix the issue by doing a fresh reinstall of the game, thanks for trying to help anyways! :)

Share this post


Link to post
Share on other sites
7 hours ago, Foxxonius Augustus said:

Ahh, yeah that doesn't look right. The only advice I have is to delete the mod from your game data folder, it should just be the Cormorant Aeronology folder. Then re-install from a fresh download.

I'm having a the same issue as well as a few orhers. Did a fresh install the other day as well, something is up with the parts from meep 

Share this post


Link to post
Share on other sites

I remember that I figured out a way how to fix it, but I can't exactly remember what I did. I think that I took some of the files from the Mr Meeb folder and replaced the ones in the cormorant aeronology folder, perhaps editing the configs to change the file paths.

I'll have to fiddle around with it again to try to figure out what I did.

Share this post


Link to post
Share on other sites
3 hours ago, Raptor22 said:

I remember that I figured out a way how to fix it, but I can't exactly remember what I did. I think that I took some of the files from the Mr Meeb folder and replaced the ones in the cormorant aeronology folder, perhaps editing the configs to change the file paths.

I'll have to fiddle around with it again to try to figure out what I did.

More than likely since I had moved around the KSP Folder to a different drive path, and that's when I started having this issue, though fixed now since I reinstalled KSP.

Share this post


Link to post
Share on other sites
On 12/5/2018 at 12:34 PM, Raptor22 said:

I remember that I figured out a way how to fix it, but I can't exactly remember what I did. I think that I took some of the files from the Mr Meeb folder and replaced the ones in the cormorant aeronology folder, perhaps editing the configs to change the file paths.

I'll have to fiddle around with it again to try to figure out what I did.

im thinking of trying to install the full pack and hope the textures are fixed.

Share this post


Link to post
Share on other sites

@Pak

I took the liberty to patch a patch (the: "CA_2-5x_scale.cfg"). There was an error in there which caused the patch to not apply to the SRBs. Hope it's useful!

Spoiler

//Cormorant Shuttle Pack 2.5x Rescale

@PART[ShuttleBottomLong]
{
	@MODULE[FSfuelSwitch]
	{
		@resourceAmounts = 2800;720,880;1200;1320
	}
}

@PART[ShuttleB]
{
	@MODULE[FSfuelSwitch]
	{
		@resourceAmounts = 2800;360,440;600;660
	}
}

@PART[CA_ETnose],[CA_ET_extension]
{
	@MODULE[FSfuelSwitch]
	{
		@resourceAmounts = 28800;9600,11740
	}
}

@PART[CA_ET]
{
	@MODULE[FSfuelSwitch]
	{
		@resourceAmounts = 35200;19200,23470
	}
}

@PART[CA_SRB4]
{

	@MODULE[ModuleEnginesFX]
	{
		@maxThrust = 3500
	}

	@RESOURCE[SolidFuel]
	{
		@amount = 14000
		@maxAmount = 14000
	}
}

@PART[CA_STME]
{

	@MODULE[ModuleEnginesFX]
	{
		@maxThrust = 1000
	}
}

@PART[CA_SRBnose]
{

	@MODULE[ModuleEngines]
	{
		@maxThrust = 55
	}

	@RESOURCE[SolidFuel]
	{
		@amount = 18
		@maxAmount = 18
	}
}

@PART[CA_boosterPack]
{

	@MODULE[ModuleEngines]
	{
		@maxThrust = 80
	}

	@RESOURCE[SolidFuel]
	{
		@amount = 10
		@maxAmount = 10
	}
}

 

Oh and btw, love what you have created here!

Share this post


Link to post
Share on other sites
1 hour ago, Kroslev Kerman said:

Will this ever be Compatible with Mechjeb?(Work with Mechjeb Ascent guidance)

What do you mean? It is compatible with MJ and it works well with ascent guidance. If you have a problem with MJ you must check the design of your Shuttle. It is known that the ascent guidance of MJ has some problems with shuttledesigns as it is made for normal launchers. It is not related to Cormorant as itself. So you must contact the MJ guys.

Share this post


Link to post
Share on other sites
7 hours ago, Kroslev Kerman said:

Will this ever be Compatible with Mechjeb?(Work with Mechjeb Ascent guidance)

Did you search this thread before asking that?  I have a video clearly showing this craft ascending using nothing but MechJeb.

Share this post


Link to post
Share on other sites
1 hour ago, xD-FireStriker said:

Has anyone fixed the broken textures?

There is no broken texture. Everything is working well.

Share this post


Link to post
Share on other sites
2 hours ago, xD-FireStriker said:

i uninstalled the parts in questions to try something so im going to need to do another install but im having the same issues as altoshyft

 

Then you didn`t install correctly.
How looks your GameData?

Are you using -force-d3d11?

Share this post


Link to post
Share on other sites
8 hours ago, Cheesecake said:

Are you using -force-d3d11?

Nope, have tryed TU and cant get GLCore or DX11 to work so im not forcing anything

8 hours ago, Cheesecake said:

Then you didn`t install correctly.
How looks your GameData?

 

Once i reinstall it i will show you

Share this post


Link to post
Share on other sites

It seems to me that only the parts from Shuttle Payload Tech are missing textures,at least the spacelab parts.
I believe that the payload tech parts were made by Mr.Meeb and with permission packed in by Pak, but i dont know if Pak has updated the textures as the Mr.Meebs latest release is for 1.2.
 

Share this post


Link to post
Share on other sites
4 hours ago, Amahlaka said:

It seems to me that only the parts from Shuttle Payload Tech are missing textures,at least the spacelab parts.
I believe that the payload tech parts were made by Mr.Meeb and with permission packed in by Pak, but i dont know if Pak has updated the textures as the Mr.Meebs latest release is for 1.2.
 

There is no need for updating the textures. If you correctly install this pack all parts will work nice and show in VAB/SPH.

Share this post


Link to post
Share on other sites

I docked a shuttle to my station yesterday, and it took 10 minutes of quickloading and messing around with SAS modes. Because the docking port on a shuttle is at the front of the cargo bay, it's off-axis and that makes it really annoying to dock. Does anyone have a working method that you are willing to share for docking a CA shuttle to a space station?

Also, a side note: The new manoeuvre node system introduced in 1.5 seems to disagree with the monopropellant OMS engines in this mod, but I think a lot of the issues with that new system are going to be fixed in 1.6. 

Share this post


Link to post
Share on other sites
16 hours ago, KSpaceR said:

Please help, how to instal for 1.5.1 version?

 

Extract the mod’s zip file: there should be a GameData folder in there. You want to put the contents of that folder into your KSP directory’s GameData.

So the folder structure should look like this: KSP > GameData > Cormorant Aeronology, Module Manager, Firespitter Core, Squad, SquadExpansion (if you have the DLC)

I hope that made sense, and welcome to the forums!

Edited by RealKerbal3x

Share this post


Link to post
Share on other sites

Does this mod work with earlier versions of ksp? such as 1.4.2. Because I downloaded it and had problems with textures on certain parts.

Share this post


Link to post
Share on other sites
7 hours ago, true.wizardry said:

Does this mod work with earlier versions of ksp? such as 1.4.2. Because I downloaded it and had problems with textures on certain parts.

You’ll need the specific versions of Firespitter and Module Manager for the version you’re using.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.