Pak

[1.7.1] Cormorant Aeronology - Mk3 Space Shuttle

Recommended Posts

8 hours ago, Captainamtrak456 said:

is there a Tutorial around on Youtube for Paint? To edit Decals and add my own names? I cant seem to find some!

Just type 'ms paint tutorial' into the search bar. There are a lot of helpful videos there. 

Share this post


Link to post
Share on other sites
Posted (edited)

Did they are a IVA mod the the MK2 block orbiter Shuttle?

Edited by josselin2196

Share this post


Link to post
Share on other sites
15 minutes ago, josselin2196 said:

Did they are a IVA mod the the MK2 block orbiter Shuttle?

@Pak hasn't done an an IVA for Block II yet, probably because IVAs are difficult and time-consuming to make.

Share this post


Link to post
Share on other sites

I've downloaded this mod and it does not work. I put it in the gamedata folder, and I looked to see the items... but they were not there. Im a macbook pro user using 1.7.1 Does anyone know how to help? I think its from my game version.

Share this post


Link to post
Share on other sites
4 minutes ago, pizzahat said:

I've downloaded this mod and it does not work. I put it in the gamedata folder, and I looked to see the items... but they were not there. Im a macbook pro user using 1.7.1 Does anyone know how to help? I think its from my game version.

Did you install the Mk 3 Shuttle Pack?  Its required and linked on the first post

Share this post


Link to post
Share on other sites
Posted (edited)
27 minutes ago, linuxgurugamer said:

Did you install the Mk 3 Shuttle Pack?  Its required and linked on the first post

I installed the links that said download from spacedock or curseforge. and the shuttle pack too.

 

Edited by pizzahat

Share this post


Link to post
Share on other sites
1 hour ago, pizzahat said:

I installed the links that said download from spacedock or curseforge. and the shuttle pack too.

 

Post a link to a log file

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/9/2019 at 6:50 PM, linuxgurugamer said:

Post a link to a log file

https://docs.google.com/document/d/11lA6zqg97P5JUy6D7lpl6MQjKpc71vVof-5EfNQvDy8/edit?usp=sharing thats the mmpatch, (it doesnt have a use i guess.) And heres my ksp.log file. https://docs.google.com/document/d/17Hm1gSzhgz2Aa6VjlElnpFloTBFAF-AWDnLnS2lS7ao/edit?usp=sharing

Edited by pizzahat

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/9/2019 at 4:39 PM, pizzahat said:

I installed the links that said download from spacedock or curseforge. and the shuttle pack too.

 

need to just use the commorant aeronology folders from both the shuttle lifting body and ca mk3 block II zip files. 

there isnt a gamedata folder in either of those so its kinda easy to lose track of the zip folder and the actual mod folders. 

so what you should wind up with is gamedata/commorant aeronology after adding both of the zip file contents. 

Edited by COL.R.Neville

Share this post


Link to post
Share on other sites
Posted (edited)

didnt work like always, 

im just going to download it again

 

sigh

 

1 hour ago, COL.R.Neville said:

need to just use the commorant aeronology folders from both the shuttle lifting body and ca mk3 block II zip files. 

there isnt a gamedata folder in either of those so its kinda easy to lose track of the zip folder and the actual mod folders. 

so what you should wind up with is gamedata/commorant aeronology after adding both of the zip file contents. 

 

Edited by pizzahat

Share this post


Link to post
Share on other sites
Posted (edited)

Im going to tell you the things i did;

I downloaded the mk3 and the cormorant file, merged them together (i put the mk3 file into the cormorant file.)

and im sorry if im being very dumb here, im new to modding. all i know how to do it change the kerbal roster file when there ded, and install mods...

Edited by pizzahat

Share this post


Link to post
Share on other sites
Posted (edited)
5 hours ago, pizzahat said:

Im going to tell you the things i did;

I downloaded the mk3 and the cormorant file, merged them together (i put the mk3 file into the cormorant file.)

and im sorry if im being very dumb here, im new to modding. all i know how to do it change the kerbal roster file when there ded, and install mods...

1. download Shuttle Lifting Body
2. open the .zip and then open the included folder "Cormorant Aeronology 1.5.1". There you find an folder "Cormorant Aeronology", firespitter.dll and ModuleManager.3.0.7.dll.
3. If you use KSP 1.6.x and newer then put only the folder "Cormorant Aeronology" into GameData because Firespitter and ModuleManager are old versions so you need to download them separately (click for downloadlinks)
4. download CA MK3 Block II
5. open the .zip and then open the included folder "CA_Block2_0.2". You will find an folder "Cormorant Aeronology" again.
6. Put this folder into Gamedata or the subfolders "Assets" and "Realplume" to GameData\Cormorant Aeronology. If asked merge the files and ready.

Your GameData now have the following content:
- Cormorant Aeronolgy
- Squad
- firespitter.dll
- ModuleManager.4.0.2.dll

Edited by Cheesecake

Share this post


Link to post
Share on other sites
Posted (edited)
7 hours ago, Cheesecake said:

1. download Shuttle Lifting Body
2. open the .zip and then open the included folder "Cormorant Aeronology 1.5.1". There you find an folder "Cormorant Aeronology", firespitter.dll and ModuleManager.3.0.7.dll.
3. If you use KSP 1.6.x and newer then put only the folder "Cormorant Aeronology" into GameData because Firespitter and ModuleManager are old versions so you need to download them separately (click for downloadlinks)
4. download CA MK3 Block II
5. open the .zip and then open the included folder "CA_Block2_0.2". You will find an folder "Cormorant Aeronology" again.
6. Put this folder into Gamedata or the subfolders "Assets" and "Realplume" to GameData\Cormorant Aeronology. If asked merge the files and ready.

Your GameData now have the following content:
- Cormorant Aeronolgy
- Squad
- firespitter.dll
- ModuleManager.4.0.2.dll

Okay, now that helped alot more...

thanks!

{pizzahat's case offically ended}

Edited by pizzahat

Share this post


Link to post
Share on other sites

I noticed that the Duo OSM part for the shuttle has a RCSx and RCSy module that use both the stock monoprop, but when Real Fuels is installed, only the dorsel RCS ports are being converted to use the RF fuels. Is there a way to update it to make both the x and y modules use RF?

OSMPodDUO.cfg (last 42 lines)

Spoiler

....
 

MODULE
    {
        name = ModuleRCSFX
        stagingEnabled = False
        thrusterTransformName = RCSy
        thrusterPower = 2.25
        
        enableYaw = false
        
        resourceName = MonoPropellant
        resourceFlowMode = STAGE_PRIORITY_FLOW
        runningEffectName = runningY
                
        atmosphereCurve
        {
            key = 0 240
            key = 1 100
            key = 4 0.001
        }
    }

    
    MODULE
    {
        name = ModuleRCSFX
        stagingEnabled = False
        thrusterTransformName = RCSx
        thrusterPower = 2.25
        resourceName = MonoPropellant
        resourceFlowMode = STAGE_PRIORITY_FLOW
        runningEffectName = runningX

        enableRoll = false        

        atmosphereCurve
        {
            key = 0 240
            key = 1 100
            key = 4 0.001
        }
    }

}//end part
 

 

RF's Cormorant_Aeronology.cfg (first 232 lines)

Spoiler

// Custom edited engines

@PART[ShuttleOMSDUO]:FOR[RealFuels_StockEngines] //CA - Orbital Manuevering Pods
{

  @cost = 198
  %entryCost = 890


  MODULE
  {
    name = ModuleEngineConfigs
    type = ModuleRCS
    techLevel = 3
    origTechLevel = 3
    engineType = L
    configuration = Hydrazine
    modded = false

    CONFIG
    {
      name = Hydrazine
      thrusterPower = 2.25
      heatProduction = 392
      PROPELLANT
      {
        name = Hydrazine
        ratio = 100
        DrawGauge = True
        %resourceFlowMode = STAGE_PRIORITY_FLOW
      }
      IspSL = 0.2740
      IspV = 0.7200
      throttle = 0

    }
    CONFIG
    {
      name = HTP
      thrusterPower = 2.025
      heatProduction = 392
      PROPELLANT
      {
        name = HTP
        ratio = 100
        DrawGauge = True
        %resourceFlowMode = STAGE_PRIORITY_FLOW
      }
      IspSL = 0.1770
      IspV = 0.4650
      throttle = 0

    }
    CONFIG
    {
      name = MMH+NTO
      thrusterPower = 2.25
      heatProduction = 392
      PROPELLANT
      {
        name = MMH
        ratio = 50.73477956613017
        DrawGauge = True
        %resourceFlowMode = STAGE_PRIORITY_FLOW
      }
      PROPELLANT
      {
        name = NTO
        ratio = 49.26522043386983
        %resourceFlowMode = STAGE_PRIORITY_FLOW
      }
      IspSL = 0.9600
      IspV = 0.9500
      throttle = 0

    }
    CONFIG
    {
      name = Nitrogen
      thrusterPower = 0.608
      heatProduction = 392
      PROPELLANT
      {
        name = Nitrogen
        ratio = 100
        DrawGauge = True
        %resourceFlowMode = STAGE_PRIORITY_FLOW
      }
      IspSL = 0.1001
      IspV = 0.1950
      throttle = 0

    }
    CONFIG
    {
      name = NitrousOxide
      thrusterPower = 2.138
      heatProduction = 392
      PROPELLANT
      {
        name = NitrousOxide
        ratio = 100
        DrawGauge = True
        %resourceFlowMode = STAGE_PRIORITY_FLOW
      }
      IspSL = 0.2000
      IspV = 0.5250
      throttle = 0

    }
    CONFIG
    {
      name = UDMH+NTO
      thrusterPower = 2.25
      heatProduction = 392
      PROPELLANT
      {
        name = UDMH
        ratio = 47.82321899736148
        DrawGauge = True
        %resourceFlowMode = STAGE_PRIORITY_FLOW
      }
      PROPELLANT
      {
        name = NTO
        ratio = 52.17678100263852
        %resourceFlowMode = STAGE_PRIORITY_FLOW
      }
      IspSL = 0.9500
      IspV = 0.9500
      throttle = 0

    }
    CONFIG
    {
      name = Aerozine50+NTO
      thrusterPower = 2.25
      heatProduction = 392
      PROPELLANT
      {
        name = Aerozine50
        ratio = 48.65771812080538
        DrawGauge = True
        %resourceFlowMode = STAGE_PRIORITY_FLOW
      }
      PROPELLANT
      {
        name = NTO
        ratio = 51.34228187919462
        %resourceFlowMode = STAGE_PRIORITY_FLOW
      }
      IspSL = 0.9600
      IspV = 0.9500
      throttle = 0

    }
    CONFIG
    {
      name = Helium
      thrusterPower = 0.029
      heatProduction = 392
      PROPELLANT
      {
        name = Helium
        ratio = 100
        DrawGauge = True
        %resourceFlowMode = STAGE_PRIORITY_FLOW
      }
      IspSL = 0.2030
      IspV = 0.4530
      throttle = 0

    }
  }


  !RESOURCE[LiquidFuel] {}
  !RESOURCE[Oxidizer] {}
  !RESOURCE[MonoPropellant] {}
  !RESOURCE[SolidFuel] {}
  !RESOURCE[XenonGas] {}
  MODULE
  {
    name = ModuleFuelTanks
    volume = 1250
    type = ServiceModule
    // dedicated = false
    TANK
    {
     name = Hydrazine
     amount = full
     maxAmount = 100.000000%
    }

  }


}

 

Share this post


Link to post
Share on other sites
1 hour ago, Pointblank66 said:

noticed that the Duo OSM part for the shuttle has a RCSx and RCSy module that use both the stock monoprop, but when Real Fuels is installed, only the dorsel RCS ports are being converted to use the RF fuels. Is there a way to update it to make both the x and y modules use RF?

I think you might have better luck over at the RF thread. The problem isn't what the RF patch is doing, it's not doing anything to the cited lines in the part configuration. It's setting up new modules and removing resources. It may be that an additional field is needed, but there is not any MM magic that can be tweaked from what I can see. 

It may be that the modulercsfx is being removed in another patch, and the new moduleEngineConfigs takes an optional thrust transform value, but there isn't anyway to know the syntax without delving into the RF docs/code. If so, you'd probably want a patch that has a pair of the new module nodes, one for each transform. 

Share this post


Link to post
Share on other sites

i am having a bug with the boosters where they are on when it loads and when they decouple blow up and i made sure they weren't clipping any answers?

Share this post


Link to post
Share on other sites

hello please somonne for update this mod i love him but he don't work on the last vers of ksp verry ty in advens fot the dev god whit make this :)

Share this post


Link to post
Share on other sites
16 minutes ago, ScaroWarrior said:

hello please somonne for update this mod i love him but he don't work on the last vers of ksp verry ty in advens fot the dev god whit make this :)

What exactly isn`t working for you? If you install the newest dependencies it should work well with KSP 1.7. For instructions look several post above yours.

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/10/2019 at 12:31 AM, josselin2196 said:

Did they are a IVA mod the the MK2 block orbiter Shuttle?

I made a Mk2 Block Shuttle and i found out about the missing IVA and the fact that it acts like a unmanned probe. When i edited the config to save my kerbals i also edited the Ultimate Shuttle MrGlass IVA to change the Mk2 Block IVA. All you have to do is change "@PART[mk3Cockpit_Shuttle]:NEEDS[AvionicsSystems]" to "@PART[B2_cockpit]:NEEDS[AvionicsSystems]" and now have a nice Shuttle IVA

If your wondering i ran out of electric charge so i couldn't do any thing in orbit, After i made the pod a command pod i deorbited with no SAS and limited RCA then botched the reentry.
RIP Bill, Bob, Jeb & Vall  
I could of saved them if i remembered the CERV can eject 

Edited by xD-FireStriker

Share this post


Link to post
Share on other sites

Hi, someone could help me? 

The liquid fuel tank explodes when i activate the two decoupler to drop the solid booster. 

It happens only if i use the decoupler of this mod, anyone kows why? 

Btw.. I love this mod

Share this post


Link to post
Share on other sites
Posted (edited)

have tried reinstalling many times but cant get this mod to work,parts dont show up in vab

 

 

Edited by JPVD9669

Share this post


Link to post
Share on other sites
4 hours ago, JPVD9669 said:

have tried reinstalling many times but cant get this mod to work,parts dont show up in vab

 

 

Then you didn`t installed it correctly. Look some posts above. There you can find an Installation guide by me.

Share this post


Link to post
Share on other sites
Posted (edited)

Not sure if this has been pointed out before, I got the following errors for the CA2.5 and Cryo Engines:

Quote

[ERR 2019-06-09 10:23:19.131] Cannot parse node name as tag list: encountered opening bracket in primary trailer on: Cormorant Aeronology/Patches/CA_2-5x_scale/@PART[CA_ETnose],[CA_ET_extension]
[ERR 2019-06-09 10:23:19.131] Cannot parse node name as tag list: encountered opening bracket in primary trailer on: Cormorant Aeronology/Patches/CryoEngines/@PART[CA_ETnose],[CA_ET_extension]

Not sure what the issue is.

Edited by Spike88

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.