Pak

[1.7.1] Cormorant Aeronology - Mk3 Space Shuttle

Recommended Posts

Posted (edited)

where in the mod file is the eva device thing? It's just that I am running low on space (i have a lot of mods) and i don't want to risk.

Edited by Rover 6428

Share this post


Link to post
Share on other sites
32 minutes ago, Rover 6428 said:

where in the mod file is the eva device thing? It's just that I am running low on space (i have a lot of mods) and i don't want to risk.

You mean the MMU (manned maneuvering unit)? It is in Cormorant-Aeronology\Assets\payloadUtilities\CAMMU.cfg

Share this post


Link to post
Share on other sites

Not sure if im just stupid or what, I can't figure out how I would add my own names to the shuttle or change the flags from the included two. Any help would be appreciated.

Share this post


Link to post
Share on other sites
49 minutes ago, Thomas Edison said:

Not sure if im just stupid or what, I can't figure out how I would add my own names to the shuttle or change the flags from the included two. Any help would be appreciated.

To add your own name, you need to edit the CA_decals file in the mod’s folder (can’t remember exactly where it is, just have a snoop around). It’s as simple as putting a text box over one of the empty spaces, typing your name of choice, and saving and closing the file.

As for actually adding the name to your shuttle, there’s a name plate part that you can add, and switch through the various default names until you find yours.

Share this post


Link to post
Share on other sites

Note, I personally love this mod, and without it my KSP experience would be very dull. But, I only play on RSS/RO, and the patch provided seems to be outdated, as the parts are still mostly listed as "non-RO" and use stock fuels. I would immensely appreciate if this was fixed. 

Share this post


Link to post
Share on other sites
1 hour ago, BadModder54 said:

Note, I personally love this mod, and without it my KSP experience would be very dull. But, I only play on RSS/RO, and the patch provided seems to be outdated, as the parts are still mostly listed as "non-RO" and use stock fuels. I would immensely appreciate if this was fixed. 

Goodmorning, originally I made the RO-patch, but it has been a while since I have been active on the forum, but thinking of coming back. :)
That said, I am not intending to continue writing code for CA, slaintemaith contacted me about a month ago if he could use and update my files, which I said yes ofcourse, so maybe you could contact him for some up-to-date files. 

Share this post


Link to post
Share on other sites

The mod just doesn't work. The parts don't appear in game after a correct installation..:/

Share this post


Link to post
Share on other sites

If they arent appearing, then its not a "correct installation". 

Share this post


Link to post
Share on other sites
1 minute ago, Barzon Kerman said:

If they arent appearing, then its not a "correct installation". 

I’ve installed it correctly.

Share this post


Link to post
Share on other sites
8 hours ago, Sammakko78 said:

The mod just doesn't work. The parts don't appear in game after a correct installation..:/

Tested in Sandbox? In career you may need to "buy" the tech first.

Share this post


Link to post
Share on other sites
16 hours ago, Sammakko78 said:

The mod just doesn't work. The parts don't appear in game after a correct installation..:/

Welcome to the forums, telling it 'just doens't work' and 'installed it correctly' isn't that helpfull. Please read this to see how people are able to help you with the right information to provide.

We can't magically look into your install.  

Share this post


Link to post
Share on other sites
43 minutes ago, DrLicor said:

Welcome to the forums, telling it 'just doens't work' and 'installed it correctly' isn't that helpfull. Please read this to see how people are able to help you with the right information to provide.

We can't magically look into your install.  

Well then learn magic.

Share this post


Link to post
Share on other sites

Welcome to the forum @Sammakko78.

The great members who understand and assist with mods and technical support already know magic. The link @DrLicor posted contains the required information for effective support and as mentioned it is extremely difficult to identify an issue with a modded KSP install when the only information given is 'it does not work". If you would like assistance please be respectful and provide the information requested.

Share this post


Link to post
Share on other sites
On 6/19/2019 at 4:56 PM, Cheesecake said:

You mean the MMU (manned maneuvering unit)? It is in Cormorant-Aeronology\Assets\payloadUtilities\CAMMU.cfg

Wait... if I  delete everything in the mod's folder but this .cfg, I get only the MMU? 

Share this post


Link to post
Share on other sites
4 hours ago, Daniel Prates said:

Wait... if I  delete everything in the mod's folder but this .cfg, I get only the MMU? 

No, there are more files for the MMU. This is only the config. But yes, you can delete all other files, except the MMU-files, and you get only the MMU.

Share this post


Link to post
Share on other sites
Posted (edited)
5 hours ago, Cheesecake said:

No, there are more files for the MMU. This is only the config. But yes, you can delete all other files, except the MMU-files, and you get only the MMU.

Would you mind telling me what they are?

You see, I think this is one of the best mods around. Specially so because it perfectly integrates real-life parts with stockalike parts, so it ranka high up there with tantares and bluesog DB, imho. But currently my mod build just got waaaaay to big and I am having to rationalize it somewhat.

Edited by Daniel Prates

Share this post


Link to post
Share on other sites
6 hours ago, Dutchbook said:

@Daniel Prates When in doubt about what mod files you can remove, you can always use The Janitor's Closet to not-load the assets you won't use. Saves a lot of time and uncertainty, not to mention RAM! :)

Oh yeah, I forgot about that! Great advice, I will give it a go! Many thanks. 

Share this post


Link to post
Share on other sites

Quick question, I already have the "main" shuttle hardware working in RO, but is there any RO configs for the "Block 2" shuttle by any chance? The CERV cockpit would be very useful if landing or launch got a little hairy. Thanks for your time! :0.0:

Share this post


Link to post
Share on other sites

Modular Launch pads v2.0, with the new shuttle pad, is now out.

A lot of the screenshots show it with benjee10's SOCK, but it was designed long before that appeared for the Cormorant shuttle :)

 

Share this post


Link to post
Share on other sites

Getting a few errors in the startup log:

[LOG 15:53:44.467] PartLoader: Compiling Part 'Cormorant Aeronology/Assets/CA_decals/CA_decalFlagReal/CA_decalFlagReal'
[ERR 15:53:44.470] PartCompiler: Cannot clone model 'Cormorant Aeronology/Assets/CA_decals/CA_decalFlagReal' as model does not exist

[ERR 15:53:44.470] PartCompiler: Model was not compiled correctly

[ERR 15:53:44.470] PartCompiler: Cannot compile model

[ERR 15:53:44.470] PartCompiler: Cannot compile part

[LOG 15:53:44.545] PartLoader: Compiling Part 'Cormorant Aeronology/Assets/CA_decals/CA_decalNameReal/CA_decalNameReal'
[ERR 15:53:44.547] PartCompiler: Cannot clone model 'Cormorant Aeronology/Assets/CA_decals/CA_decalNameReal' as model does not exist

[ERR 15:53:44.547] PartCompiler: Model was not compiled correctly

[ERR 15:53:44.547] PartCompiler: Cannot compile model

[ERR 15:53:44.547] PartCompiler: Cannot compile part

Looking in the folder, the files "CA_decalFlagReal.mu" and "CA_decalNameReal.mu" are in fact not there, and neither are any alternate textures.

Is this an unimplemented feature? I'm guessing I can just change the model referenced in the CFG to refer to the "CA_decalFlag.mu" and "CA_decalName.mu" and then edit a custom PNG with the names changed and it should work, right? If that's all it is, please let me know as I would love to have authentic names on the shuttles parked in my museums. :lol:

Share this post


Link to post
Share on other sites
On 8/26/2019 at 6:54 PM, TheKSPBeginner said:

@Pak could we get confirmation for 1.7.3 compatibility

Why don't you try it yourself? Even better, why don't you ask yourself why 1.7.3 would break anything? Better yet, why don't you ask yourself when the last time a slightly outdated parts mod was completely unusuable and game-breaking?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.