GregroxMun

[1.7.3] Alternis Kerbol Rekerjiggered v2.5.0 August 8th 2019

Recommended Posts

OK I think I've got all of the game breaking bugs fixed at the moment.

https://github.com/GregroxMun/Alternis-Kerbol-Rekerjiggered/releases/tag/2.3.0

16 Jan 2018, another ~30 minutes later: 2.3.0.4: Go through all broken planets and fix them. Duna and Eeloo were broken. The majority of these bugs seem to be related to my decision to swap file names around, which was pretty moronic in retrospect. Also fixed Minmus' white rocks. Sort of.
16 Jan 2018, half an hour later: 2.3.0.3: fix Dres being broken.
16 Jan 2018: 2.3.0.2: fix Kerbin tidal lock.

On 1/10/2018 at 7:38 AM, ToxicSerum said:

My screen goes black and the KSP loading symbol is spinning forever when trying to run this mod (in the menu this happens) cannot go ingame or anything

Crap. Well seeing as I at least can run the mod, I'm going to assume that it's a mod compatibility problem. Are you using any other planet mods? Are you certain you are using the prerequisites? (Kopernicus, ModuleManager, ModularFlightIntegrator). What is your mod list?

Share this post


Link to post
Share on other sites
4 hours ago, GregroxMun said:

OK I think I've got all of the game breaking bugs fixed at the moment.

Thanks for the hard work!  I hadn't yet seen any game-breakers, if it's any consolation.

Share this post


Link to post
Share on other sites

the github page has '2.3.0.4' as the current version. ckan has '2.3.0' with a max ksp version of '1.0.5' Can I assume Id need to install manually? I know this pack works in 1.3 and 1.3.1 so, thanks peeps. I just dont want to download from ckan and have it screw everything up. But I do prefer installing via ckan, this is why I ask.

Share this post


Link to post
Share on other sites
On 1/24/2018 at 9:06 PM, Jesusthebird said:

the github page has '2.3.0.4' as the current version. ckan has '2.3.0' with a max ksp version of '1.0.5' Can I assume Id need to install manually? I know this pack works in 1.3 and 1.3.1 so, thanks peeps. I just dont want to download from ckan and have it screw everything up. But I do prefer installing via ckan, this is why I ask.

Ignore ckan, install manually. I don't trust ckan. I can pretty well reason why it still says 2.3.0--it has to do with me editing the github release instead of making new ones, but it shouldn't be saying 1.0.5, AKR has been available on every major KSP version number since 1.0.4. 2.3.0 was for KSP 1.3.x.

Share this post


Link to post
Share on other sites
5 hours ago, GregroxMun said:

Ignore ckan, install manually. I don't trust ckan. I can pretty well reason why it still says 2.3.0--it has to do with me editing the github release instead of making new ones, but it shouldn't be saying 1.0.5, AKR has been available on every major KSP version number since 1.0.4. 2.3.0 was for KSP 1.3.x.

Ohh ok. Thanks for the reply. Yea i knew something was weird about it.  I'm thinking an AVC version file could resolve the release version issue? Tho I'm not sure what you would need to do to get the 'ksp version' updated through ckan? was just something I noticed while scouring through ckan

Share this post


Link to post
Share on other sites

Hi, so I've been trying out this planet pack, only for some reason I seem to have no groundstations? I'm not sure why it might be, but I have nothing except the KSC no matter my settings. I'm running a whole lot of other mods alongside it, but nothing that should interfere with Commnet, as I've run all these mods with different planet packs before and they've all functioned just fine.

Share this post


Link to post
Share on other sites
On 1/27/2018 at 7:38 AM, Queen Cassie said:

Hi, so I've been trying out this planet pack, only for some reason I seem to have no groundstations? I'm not sure why it might be, but I have nothing except the KSC no matter my settings. I'm running a whole lot of other mods alongside it, but nothing that should interfere with Commnet, as I've run all these mods with different planet packs before and they've all functioned just fine.

Can you reproduce this with only AKR and its prerequisites? I don't believe I've seen this problem.

Share this post


Link to post
Share on other sites

Kopernicus's last major update broke Minmus. (And everything with VertexPlanet). To fix, create a .cfg file in KSP/GameData called "VertexPlanetFix.cfg," open it with a text editor such as notepad, and copy the following into it:

 

@Kopernicus:FINAL 
{
    @Body,*
    {
        @PQS
        {
            @Mods
            {
                @VertexPlanet,*
                {
                    @SharpnessNoise
                    {
                        @Noise
                        {
                            |Noise = Noise:RidgedMultifractal

                            octaves = #$octaveCount$
                        }
                    }
                }
            }
        }
    }
}

Or download the config here. (Clicking this link leads to a direct download)

This config was written by @Thomas P. as a temporary fix. Any planet modders out there probably shouldn't use this as a permanent fix. I will have a proper fix ready for the next update of AKR.

Note, it still won't work in 1.4.1 until Kopernicus updates.

Edited by GregroxMun

Share this post


Link to post
Share on other sites

Update to KSP 1.4.x

68747470733a2f2f692e696d6775722e636f6d2f

68747470733a2f2f692e696d6775722e636f6d2f

68747470733a2f2f692e696d6775722e636f6d2f

Fixed Kopernicus compatibility for the latest versions of it, and KSP 1.4.x. You no longer need the VertexPlanet patch config.

Removed Kerbin's City Lights configuration for now.

Fixed Eve's PQS Material being so bright it almost ruined a cinematic.

https://github.com/GregroxMun/Alternis-Kerbol-Rekerjiggered/releases/tag/2.3.1

Share this post


Link to post
Share on other sites

Quick question: How would I get Sigma Dimensions to play nice with this mod? When I try installing it, the Scatterer menu for the main menu pops up, but I get an infinite load screen, which is honestly somewhat depressing.

Edited by Javascap

Share this post


Link to post
Share on other sites

I still love this planet pack to bits, glad to see it updated! 

Share this post


Link to post
Share on other sites

Can't click main menu buttons after installing Alternis. There are some errors in the log:
Note I don't have any BoulderCo folder, only the EVE plugin folder.

[LOG 07:07:39.594] [EVE TextureConfig]: Unable to parse config node:
OBJECT
{
	name = BoulderCo/Atmosphere/Textures/fair
	type = TEX_CUBE_2
	texN = BoulderCo/Atmosphere/Textures/fairN
	texP = BoulderCo/Atmosphere/Textures/fairP
}

[LOG 07:07:39.600] EVEManager: Issue loading TextureConfig! Error:
UnityEngine.UnityException: Unable to apply node! ---> System.NullReferenceException: Object reference not set to an instance of an object
  at Utils.CubemapWrapper..ctor (System.String value, UnityEngine.Texture2D[] textures, TextureTypeEnum cubeType, Boolean mipmaps, Boolean readable) [0x00000] in <filename unknown>:0 
  at Utils.CubemapWrapper.GenerateCubemapWrapper (System.String value, UnityEngine.Texture2D[] textures, TextureTypeEnum cubeType, Boolean mipmaps, Boolean readable) [0x00000] in <filename unknown>:0 
  at TextureConfig.TextureConfigObject.Apply () [0x00000] in <filename unknown>:0 
  at EVEManager.GenericEVEManager`1[T].ApplyConfigNode (.ConfigNode node) [0x00000] in <filename unknown>:0 
  at EVEManager.EVEManagerBase.Apply () [0x00000] in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at EVEManager.EVEManagerBase.Apply () [0x00000] in <filename unknown>:0 
  at EVEManager.EVEManagerBase.LoadConfig () [0x00000] in <filename unknown>:0 
  at EVEManager.GenericEVEManager`1[TextureConfig.TextureConfigObject].StaticSetup () [0x00000] in <filename unknown>:0 
  at EVEManager.GenericEVEManager`1[T].Setup () [0x00000] in <filename unknown>:0 
  at EVEManager.GlobalEVEManager.Setup (Boolean late) [0x00000] in <filename unknown>:0 

Mods:

KSP: 1.4.3 (Unix) - Unity: 2017.1.3p1 - OS: Linux 4.14 unknown 64bit
000_AT_Utils - 1.5.2
ClickThroughBlocker - 0.1.6.5
Filter Extensions - 3.2.1
TexturesUnlimited - 1.1.2.14
USI Tools - 0.12
ToolbarControl - 0.1.6.7
Antenna Helper - 1.0.4
AtmosphereAutopilot - 1.5.10
B9 Part Switch - 2.3.1
B9 Aerospace Procedural Parts - 0.50
BD Animation Modules - 0.6.5.4
CritterCrawlerRetractingVectoringEngines - 1.3.3.1
Better Science Labs Continued - 0.1.9.3
Bon Voyage - 0.13.3
Camera Focus Changer - 1.0.4
Community Category Kit - 3.0
Community Resource Pack - 0.10
CommunityTechTree - 3.3.2
Crew Light - 1.15
CustomBarnKit - 1.1.17
DMagic Orbital Science - 1.3.0.12
Progress Parser - 1.0.9
Airline Kuisine - 2.0.1
DistantObjectEnhancement - 1.9.1
DockingCameraKURS - 1.3.2
DynamicBatteryStorage - 1.3.1
Easy Vessel Switch - 1.6.6640.41793
EditorExtensionsRedux - 3.3.19.3
Environmental Visual Enhancements - 1.4.2.2
Firespitter - 7.9
HeatControl - 0.4.5
HideEmptyTechTreeNodes - 1.0.4
Interstellar Fuel Switch - 3.6
JSIAdvTransparentPods - 0.1.15
RasterPropMonitor - 0.30.4
Kerbal Attachment System - 0.6.4
Kerbin Environmental Institute - 1.2.9
Kerbal Inventory System - 1.12.6700.37736
KSP-AVC Plugin - 1.2.0.1
KSPWheel - 0.11.9.27
KerbNet Controller - 1.0.4
Kerbal Engineer Redux - 1.1.5.2
Kerbal Foundries - 2.2.6.16
Kerbal Inventory System - No Fun - 0.1.4.1
Kerbal Joint Reinforcement - 3.4.1
Kerbalism - 1.6
HyperEdit - 1.5.6
Feline Utility Rover - 1.2.6
<b><color=#CA7B3C>Kopernicus</color></b> - 1.4.3.2
LoadingScreenManager - 1.2.5
Maeneuver Node Evolved - 1.0.4
MechJebForAll - 1.3.0.2
ModularFlightIntegrator - 1.2.5
Docking Port Alignment Indicator - 6.8.2
NearFutureConstruction - 1.0.2
NearFutureElectrical - 0.10.1
NearFutureLaunchVehicles - 1.1.5
NearFutureProps - 0.3.3
NearFuturePropulsion - 1.0.1
NearFutureSolar - 0.8.11
NearFutureSpacecraft - 0.7.9
PatchManager - 0.0.16
Kerbal Planetary Base Systems - 1.6.4
Precise Maneuver - 2.4.1
Procedural Fairings - 1.4.3.4
DeepFreeze Continued... - 0.23.7
RLA_Reborn - 0.15.1
RealChute - 1.4.6
RetractableLiftingSurface - 0.1.5.2
SCANsat - 1.1.8.6
SETI-ProbeParts - 1.3.0.2
SSTULabs - 0.8.40.150
SXTContinued - 0.3.23.6
Science Relay - 1.0.5.1
SelectableDataTransmitter - 0.1.4.2
SensiblePumpsCont - 1.2.6.1
Simple Adjustable Fairings - Plugin - 1.1
Spacetux - 0.3.12.3
StationPartsExpansionRedux - 1.0.4
Surface Mounted Lights - 1.7.6641.38911
TAC Fuel Balancer - 2.18
TextureReplacerReplaced - 0.5.4
ThrottleControlledAvionics - 3.5.2
Tracking Station Evolved - 1.0.3
Alternate Resource Panel - 2.9.3
Kerbal Alarm Clock - 3.9.1
Transfer Window Planner - 1.6.3
<b><color=#ffffff>Tundra</color> <color=#0090ff>Exploration</color></b> - 1.1.3
TweakScale - 2.3.12
UbioWeldingLtd-Continued - 2.5.3
USI Core - 0.7
Asteroid Recycling Tech - 0.13
USI Exploration Pack - 0.11
Freight Transport Tech - 0.10
Malemute Rover - 0.6
NuclearRockets - 0.7
Universal Storage - 1.4
Waypoint Manager - 2.7.2
World Stabilizer - 0.9.2
[x] Science! - 5.15

 

Also tried to clear input locks in the debug windows, didn't help.

Here is my complete ksp.log: https://yadi.sk/d/4WOEQAd73XJvGN

Thanks! @GregroxMun

Edited by hendrack

Share this post


Link to post
Share on other sites
7 hours ago, hendrack said:

Can't click main menu buttons after installing Alternis. There are some errors in the log:
Note I don't have any BoulderCo folder, only the EVE plugin folder.

Also tried to clear input locks in the debug windows, didn't help.

Here is my complete ksp.log: https://yadi.sk/d/4WOEQAd73XJvGN

Thanks! @GregroxMun

I haven't seen the behavior you described attributed to Alternis Kerbol Rekerjiggered or indeed any Kopernicus related mod or failure. And with such a huge modlist there's no easy way of troubleshooting. I'm almost sure it has to be incompatibility with one or more of the many, many mods you have. Try removing ones that affect the u.i., like ClickThroughBlocker.

Share this post


Link to post
Share on other sites
On 1/16/2018 at 9:40 PM, GregroxMun said:

OK I think I've got all of the game breaking bugs fixed at the moment.

https://github.com/GregroxMun/Alternis-Kerbol-Rekerjiggered/releases/tag/2.3.0

16 Jan 2018, another ~30 minutes later: 2.3.0.4: Go through all broken planets and fix them. Duna and Eeloo were broken. The majority of these bugs seem to be related to my decision to swap file names around, which was pretty moronic in retrospect. Also fixed Minmus' white rocks. Sort of.
16 Jan 2018, half an hour later: 2.3.0.3: fix Dres being broken.
16 Jan 2018: 2.3.0.2: fix Kerbin tidal lock.

Crap. Well seeing as I at least can run the mod, I'm going to assume that it's a mod compatibility problem. Are you using any other planet mods? Are you certain you are using the prerequisites? (Kopernicus, ModuleManager, ModularFlightIntegrator). What is your mod list?

I love what you've done with Alternis Kerbol man... Such a great job! Everything looks gorgeous :D Now I should get around fixing my stuff too sometime... Would you help me a bit with some issues I've been having for a long time?

Thank you.

Edited by amarius1

Share this post


Link to post
Share on other sites

Hey @GregroxMun,

I just wanted to confirm @hendrack's report from a few posts above regarding unclickable menus in 1.4.3 on a clean install of just Alternis Kerbol Rejiggered with dependencies.

  • Alternis Kerbol Rejiggered v2.3.1
  • Kopernicus v1.4.3.2
    • Modular Flight Integrator v1.2.5.0 (bundled)
  • Module Manager v3.0.7

I did a little troubleshooting on my own and noticed two things in particular:

  1. Both @hendrack and I are running KSP in Linux (not sure for him, but Mint 17.3 for me).
  2. Also, I only have this problem when using the Making History Expansion.  I can run AKR in 1.4.3 with no problems; however, when I run 1.4.3 with Making History, the menus are not clickable.  I've uploaded both the Unity and KSP logs for both tests to Dropbox at the following link:  https://www.dropbox.com/sh/gffk281bcjhw7x1/AADyXZBMQVevPPS904bvjXWba?dl=0.  I  also included a couple screenshots there from the main menu showing that "Start Game" is highlighted in 1.4.3 and not highlighted in 1.4.3+MH.  (The cursor isn't showing but it is pointing at "Start Game" in both.)

For what its worth, this is not high priority for me personally as I decided to do my AKR playthrough without the expansion pack so it is working fine, but I did just want to share some feedback with you in case anyone else asks later on down the road.  As a side not, I do have an install using the Outer Planets mod with Making History and one with Galileo's Planet Pack and Making History as well, both of which run fine.  Maybe @Galileo can point you to a possible culprit.

Thanks for your work on this great planet pack; it is a lot of fun to play with the solar system turned on its head!

(Completely unrelated:  has anyone reported that "tabbing" through the tracking stations skips all of the planets past Jool?  Kerbin->Bop->Moho->Eve->Jool->Minmus->Laythe->Mun->Kerbin->etc.  If I click on Tylo, however, then I can cycle through the rest.)

Share this post


Link to post
Share on other sites

I tried other kopernicus mods like OPM or Kerbol Origins they all work fine. Just tag me if you want more logs.

Share this post


Link to post
Share on other sites
10 hours ago, BlkBltChemie said:

Hey @GregroxMun,

I just wanted to confirm @hendrack's report from a few posts above regarding unclickable menus in 1.4.3 on a clean install of just Alternis Kerbol Rejiggered with dependencies.

  • Alternis Kerbol Rejiggered v2.3.1
  • Kopernicus v1.4.3.2
    • Modular Flight Integrator v1.2.5.0 (bundled)
  • Module Manager v3.0.7

I did a little troubleshooting on my own and noticed two things in particular:

  1. Both @hendrack and I are running KSP in Linux (not sure for him, but Mint 17.3 for me).
  2. Also, I only have this problem when using the Making History Expansion.  I can run AKR in 1.4.3 with no problems; however, when I run 1.4.3 with Making History, the menus are not clickable.  I've uploaded both the Unity and KSP logs for both tests to Dropbox at the following link:  https://www.dropbox.com/sh/gffk281bcjhw7x1/AADyXZBMQVevPPS904bvjXWba?dl=0.  I  also included a couple screenshots there from the main menu showing that "Start Game" is highlighted in 1.4.3 and not highlighted in 1.4.3+MH.  (The cursor isn't showing but it is pointing at "Start Game" in both.)

Thomas has confirmed that it's a problem with Kopernicus and Making History (IIRC it specifically regards PostSpawnOrbit, which AKR has to use), which makes it particularly strange given that I am running MH, I assume it must be a linux+Kopernicus/PostSpawnOrbit+MH thing.

Edited by GregroxMun

Share this post


Link to post
Share on other sites
1 hour ago, hendrack said:

I tried other kopernicus mods like OPM or Kerbol Origins they all work fine. Just tag me if you want more logs.

U sure Origins is working fine in latest KSP+Kopernicus? I tried working on it today and the planets don't seem tho load. Maybe there's some deprecated stuff...

Share this post


Link to post
Share on other sites
41 minutes ago, amarius1 said:

U sure Origins is working fine in latest KSP+Kopernicus? I tried working on it today and the planets don't seem tho load. Maybe there's some deprecated stuff...

Pretty sure, I started a new sandbox game and took a quick peek in tracking station, all seems allright.

Share this post


Link to post
Share on other sites
On 6/11/2018 at 10:24 PM, BlkBltChemie said:

(Completely unrelated:  has anyone reported that "tabbing" through the tracking stations skips all of the planets past Jool?  Kerbin->Bop->Moho->Eve->Jool->Minmus->Laythe->Mun->Kerbin->etc.  If I click on Tylo, however, then I can cycle through the rest.)

This is also a problem caused by PostSpawnOrbit and Kopernicus' automatic assigning of FlightGlobalsIndex. See, the game thinks Kerbin is in orbit around the Sun, so it will try to go Kerbin (because it's the default), Moho (because it's next out in distance from Sun), Eve (ditto), Jool (ditto), Minmus (because it's a moon), Laythe (next out), Mun (next out), and Kerbin (because it's next around Jool.) But then the next after that is Moho! The only fix would be to add FlightGlobalsIndex and Thomas has made it clear in the past that we should not be specifying that on our own. I'll bring the problem to his attention though.

Share this post


Link to post
Share on other sites
18 hours ago, GregroxMun said:

This is also a problem caused by PostSpawnOrbit and Kopernicus' automatic assigning of FlightGlobalsIndex. See, the game thinks Kerbin is in orbit around the Sun, so it will try to go Kerbin (because it's the default), Moho (because it's next out in distance from Sun), Eve (ditto), Jool (ditto), Minmus (because it's a moon), Laythe (next out), Mun (next out), and Kerbin (because it's next around Jool.) But then the next after that is Moho! The only fix would be to add FlightGlobalsIndex and Thomas has made it clear in the past that we should not be specifying that on our own. I'll bring the problem to his attention though.

Has Kittopia been rewritten yet? Doesn't seem to work on latest Kopericus and it's a bit of a bummer.

Share this post


Link to post
Share on other sites
On 6/14/2018 at 3:07 AM, amarius1 said:

Has Kittopia been rewritten yet? Doesn't seem to work on latest Kopericus and it's a bit of a bummer.

Use 1.3.1 until it is rewritten. There's no major changes between the two versions.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.