tetryds

[1.2.x] Aviator Arsenal - World War 2 aircraft weaponry (v1.3)

Recommended Posts

14 hours ago, JediRangerkendor said:

Yes, but its always nice to have an official one. 

And it's being worked on, stating that you are waiting for it will not make it come any faster.

patience, young padawan.

Share this post


Link to post
Share on other sites
On 8/1/2017 at 10:30 AM, Kerbal Gamer said:

Where can I download this for 1.3 or 1.2, all i see the old Curse link.

Maybe if you click on the download link in the OP...

Share this post


Link to post
Share on other sites
1 hour ago, Murican_Jeb said:

OP = First post in a thread, aka the title page

My game keeps crashing due to it. I removed the trumpet and it works.

Edited by Kerbal Gamer

Share this post


Link to post
Share on other sites
2 hours ago, Kerbal Gamer said:

My game keeps crashing due to it. I removed the trumpet and it works.

Yeah, its because the trumpet is meant for 1.2.

Note that the weapons are made for 1.2, so damage may seem a little weird to you.

1 hour ago, Kerbal Gamer said:

Are there any mods for different wings? Instead of the straight wings for more round ones.

Airplane Plus has some wing peices that are round.

Share this post


Link to post
Share on other sites
On 8/13/2017 at 2:35 PM, Kerbal Gamer said:

My game keeps crashing due to it. I removed the trumpet and it works.

I will have to give that a try because it crashed for me too. This game really needs to be declared broken for 1.3, cause it took me forever to figure out that it was this mod that "works" for 1.3 didn't actually work. 

Share this post


Link to post
Share on other sites

I just deleted the whole Trumpet and it works fine for me. It only really matters it you want to make a Stuka with sound but.... you're S.O.L till the current release come out of testing (I don't mean to push the Mod auther, I'm just tell everyone to be patient) and if you can't wait then like I said... S.O.L

Share this post


Link to post
Share on other sites

Not sure if it is the new bdarmory update, but the guns take a phenomenal amount of shooting before anything breaks. Bringing this as a point of note but I assume we will just have to be patient.

Share this post


Link to post
Share on other sites

So just removing the Trumpet part has it working, but the guns are all seriously nerfed in 1.3?

I do have some fresh logs and crash dump from adding this mod. Could take out BDArmory, MechJeb, physics range extender, module manager and vessel mover for a completely vanilla KSP then log the crash with just... wait. Would still have to have module manager and BDArmory bare minumum to use Aviator Arsenal.

Share this post


Link to post
Share on other sites
6 hours ago, Galane said:

So just removing the Trumpet part has it working, but the guns are all seriously nerfed in 1.3?

I do have some fresh logs and crash dump from adding this mod. Could take out BDArmory, MechJeb, physics range extender, module manager and vessel mover for a completely vanilla KSP then log the crash with just... wait. Would still have to have module manager and BDArmory bare minumum to use Aviator Arsenal.

I suspect it has to do with the new ballistic damage and armor system, that is currently broken, while these guns have either no proper penetration damage or too weak to damage properly.

Share this post


Link to post
Share on other sites

@ColonelVInnie @Galane These guns will appear to be weak because they are not set up with the new bda penetration.

They need to have the line:

bulletType = //An existing bullet type from the BDA Bullets or custom mad bullets.

So yeah, they won't work unless @tetryds adds that line and uses either BDA Bullet types or custom made ones.

Share this post


Link to post
Share on other sites

20mm single barrel cannons could simply use the same bullets at the BDA 20mm Vulcan gatlings. That's the main gun I'm interested in, for WW2 and Korean War fighters.

Share this post


Link to post
Share on other sites

I have a question. 7.7 and 7.62 mm guns are far to weak. I have a mm patch to give them the proper bullets and penetration, but when they hit, no heat bar appears. Is this how they are supposed to work?

Share this post


Link to post
Share on other sites

BDArmory uses the built in heat to fail in KSP. Somehow it applies the heat permanently so BDA damaged parts don't cool off and recover. Even more interesting is BDA does that even when playing sandbox mode with heat damage disabled. So to work properly with current BDA, Aviator Arsenal needs updated to use its damage method.

Share this post


Link to post
Share on other sites

Hi all, love this mod but I'm having trouble getting drop tanks to release from the heavy ordnance mount - they appear as a decoupler stage and when activated play a sound but won't actually release. Does anyone know if this is a mod issue or am I being stupid? Ive got around the issue using stock decouplers but they don't look as nice. Thanks in advance!

Share this post


Link to post
Share on other sites
18 hours ago, Galane said:

BDArmory uses the built in heat to fail in KSP. Somehow it applies the heat permanently so BDA damaged parts don't cool off and recover. Even more interesting is BDA does that even when playing sandbox mode with heat damage disabled. So to work properly with current BDA, Aviator Arsenal needs updated to use its damage method.

All the others (20mm, 12.7mm, etc.) work.

 

Share this post


Link to post
Share on other sites
59 minutes ago, dundun92 said:

All the others (20mm, 12.7mm, etc.) work.

 

 

19 hours ago, Galane said:

BDArmory uses the built in heat to fail in KSP. Somehow it applies the heat permanently so BDA damaged parts don't cool off and recover. Even more interesting is BDA does that even when playing sandbox mode with heat damage disabled. So to work properly with current BDA, Aviator Arsenal needs updated to use its damage method.

Besides which, and correct me if I'm wrong, @tetryds has said he doesn't plan to change how weapons deal damage since he spent many hours balancing them each for their specific damage outputs, rates of fire, etc. This is why they work with the latest BDAc but don't put out the right damage based on BDAc's new damage and bullet definitions. It does, however, work perfectly well with versions of BDAc prior to the adoption of the bullet definitions.

Share this post


Link to post
Share on other sites
31 minutes ago, XOC2008 said:

 

Besides which, and correct me if I'm wrong, @tetryds has said he doesn't plan to change how weapons deal damage since he spent many hours balancing them each for their specific damage outputs, rates of fire, etc. This is why they work with the latest BDAc but don't put out the right damage based on BDAc's new damage and bullet definitions. It does, however, work perfectly well with versions of BDAc prior to the adoption of the bullet definitions.

Im currently using 1.2.2 BDA, not 1.3.0.

Share this post


Link to post
Share on other sites
10 hours ago, ElCapitan said:

Hi all, love this mod but I'm having trouble getting drop tanks to release from the heavy ordnance mount - they appear as a decoupler stage and when activated play a sound but won't actually release. Does anyone know if this is a mod issue or am I being stupid? Ive got around the issue using stock decouplers but they don't look as nice. Thanks in advance!

Are you sure you are attaching the tank to the ordnance mode using its node?

Otherwise it won't work properly.

 

About the weapons, BAD-T 3 has a module manager patch that fixes it, you can find it here: https://github.com/SuicidalInsanity/Misc/releases/download/1.101/AABulletDefs.cfg

It is not yet ported because I currently have no time to maintain the mod, and it still works, sorta. (apart from the trumpet)

Share this post


Link to post
Share on other sites
13 hours ago, tetryds said:

Are you sure you are attaching the tank to the ordnance mode using its node?

Otherwise it won't work properly.

 

About the weapons, BAD-T 3 has a module manager patch that fixes it, you can find it here: https://github.com/SuicidalInsanity/Misc/releases/download/1.101/AABulletDefs.cfg

It is not yet ported because I currently have no time to maintain the mod, and it still works, sorta. (apart from the trumpet)

Apparently I was not! I didn't realise the orientation of the drop tank had to be correct for the nodes to snap together when holding alt. Thanks for your help, it's awesome that you're still active here even if you're not currently  developing this particular mod.

Share this post


Link to post
Share on other sites
On 13/08/2017 at 8:50 PM, Murican_Jeb said:

Yeah, its because the trumpet is meant for 1.2.

Note that the weapons are made for 1.2, so damage may seem a little weird to you.

Great fan of  the mod. Have been having 'mono.dll violation' issues since 1.3. 

So is this confirmed? Using the latest  version, meant for 1.2.x, will work on 1.3 if you kill the 'trumpet' part? 

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.