Angel-125

[1.7.x] Pathfinder - Space Camping & Geoscience

Recommended Posts

12 hours ago, Sudragon said:

Why yes, yes I do.

note: the right click menus for the Casa and Hacienda both have 'Open Workshop' buttons. The Habitat doesn't.

And as far as I can tell from version numbers, I have the latest version of Workshop installed.

 

Thanks, that helps. I'll take a look. I think the MOH isn't supposed to have a workshop to begin with. That was relegated to the BOW.

7 hours ago, Sharpy said:

Did something change that GeoLab's Prospector runs on Ore and not Dirt?

 

Dirt??? The prospectors never ran on Dirt, it's always been Ore.

6 hours ago, Noel32 said:

I've got a few questions about MOLE, for starters why isn't the MOLE thread available and is there a wiki on MOLE

MOLE thread got taken out by the forums. SQUAD says missing forums should be restored next week. There is a KSPedia for MOLE that nobody ever reads.

Share this post


Link to post
Share on other sites

I'm searching the internet for the MOLE KSpedia but can't find it.. where could I find it?

Share this post


Link to post
Share on other sites
15 minutes ago, Noel32 said:

I'm searching the internet for the MOLE KSpedia but can't find it.. where could I find it?

KSPedia is the encyclopedia inside KSP. It's one of the button on the stock toolbar.

Share this post


Link to post
Share on other sites
1 hour ago, Angel-125 said:

Dirt??? The prospectors never ran on Dirt, it's always been Ore.

Wiki says dirt, and the original OSE Workshop prospector runs on Dirt (on the Geolab entry; the Resources page lists "Exotic Minerals" and "Rare Metals" as "Refined from Dirt"),

Is there *any* role for Dirt in Pathfinder currently, not involving the "stock OSE Workshop" Material Extractor?

Share this post


Link to post
Share on other sites
2 hours ago, Sharpy said:

Wiki says dirt, and the original OSE Workshop prospector runs on Dirt (on the Geolab entry; the Resources page lists "Exotic Minerals" and "Rare Metals" as "Refined from Dirt"),

Is there *any* role for Dirt in Pathfinder currently, not involving the "stock OSE Workshop" Material Extractor?

Dirt is used by the OSE Workshop converter. Pathfinder's Prospector never used dirt despite what the wiki says.

Share this post


Link to post
Share on other sites

Pathfinder 1.4.0: Gold Strike is now available!

Want to get rich? This release of Pathfinder introduces Gold Strike, a mini-game where you travel around the local biome and go prospecting for valuable resources. These resources are found wherever you find Ore, even if the local biome or asteroid doesn't have the resource in any abundance. If you find a lode, drill for Ore, and you can convert that Ore into the valuable resource- as long as you remain in the area, and as long as there are units of the resource remaining. Use the Gold Digger, Buffalo's geology lab, and of course the Pathfinder Geology Lab to go prospecting.

Features include:
- Go prospecting for ExoticMinerals, RareMetals, Karborundrum, and Aurum. If you find something, start drilling for Ore and run the drill's gold strike converter. The converter is available on the Gold Digger, the new Buffalo Drill, the Hacienda's Claimjumper, and the stock drills.
- Limited chances to find a lode in a given biome that can be reset by paying a Science cost in Career/Science Sandbox mode.
- If you don't find a lode, then travel a set distance before trying again.
- Experienced kerbals with the Science Skill (like Scientists) can improve your prospecting chances if they go EVA and run the Gold Digger.
- Geology labs staffed with those with the Science Skill also contribute to your prospecting chances.
- Several configurable options found in Pathfinder's new difficulty settings screen.
- Easily customize the various valuable resources that can be found- just add new GOLDSTRIKE config nodes.
- New Aurum resource.

New Parts
- Buffalo Drill: This inline drill is about half as good as the stock radial drill.
- Buffalo SAS Module: This inline SAS module is as good as the Advanced Inline Stabilizer, and it has a probe core.

Bug Fixes
- Fixed drilling issues with the Gold Digger. NOTE: You still need someone with the ScienceSkill to improve its efficiency.

Share this post


Link to post
Share on other sites

Is the lode persistent and exhaustible? I mean: does it make sense to move my base there if I find it, and flag the site?

Also, what's the distance between 'retry points' where I can try to find new resource in the same biome?

My Moho base is badly starved for Rare Metals; it's night, and on Moho it lasts nearly half a year, and travel outside the confines of the small valley I'm stuck in is way dangerous in the dark. This would be great if I could scour the valley, maybe even move my whole base to the lode while it's still rather small - and if the operation would provide a persistent source of Rare Metals.

 

ps. Prospector seems to be stuck. I've paused all other converters (or at least I think so...), I manually dumped some Exotic Minerals (which I normally have maxed out), I stopped all production, I have more ore supply than one might ever need, and yet with Prospector (displaying active, some 116% efficiency) I'm still without Rare Metals.

Share this post


Link to post
Share on other sites

---

Ah, I had downloaded the zip for the source code instead of Pathfinder_1_4_0.zip

Easy peasy..

Edit. Original post below.

---

 

 

Sorry for my newbish question.. but I'm loving your mod so much that I want get it right

 

When I download the zip file i get the following folders and files,

Extras

GameData

Pathfinder

Pathfinder.mxp

 

From these I of course put the contents of GameData into my local GameData folder.

 

But where exactly should I put the Extras folder, the Pathfinder folder and the Pathfinder.mxp file?

 

 

Edited by Noel32
Solved my own problem

Share this post


Link to post
Share on other sites
8 hours ago, Sharpy said:

Is the lode persistent and exhaustible? I mean: does it make sense to move my base there if I find it, and flag the site?

Also, what's the distance between 'retry points' where I can try to find new resource in the same biome?

My Moho base is badly starved for Rare Metals; it's night, and on Moho it lasts nearly half a year, and travel outside the confines of the small valley I'm stuck in is way dangerous in the dark. This would be great if I could scour the valley, maybe even move my whole base to the lode while it's still rather small - and if the operation would provide a persistent source of Rare Metals.

 

ps. Prospector seems to be stuck. I've paused all other converters (or at least I think so...), I manually dumped some Exotic Minerals (which I normally have maxed out), I stopped all production, I have more ore supply than one might ever need, and yet with Prospector (displaying active, some 116% efficiency) I'm still without Rare Metals.

What do you mean the Prospector is stuck? Do you have resources that are full besides Ore?

The lodes that you find are persistent and exhaustable. You have 20 chances to find something in any given biome or asteroid. If you find a lode, Pathfinder will set a waypoint for you. Stay within 100m of the waypoint to dig up its resources.

You will need to travel 10km away from a prospect site to try to strike it rich. The Gold Digger and geology labs will tell you how much farther you need to travel before you can prospect again.

And don't forget, you can change these conditions using the difficulty screen.

Edited by Angel-125

Share this post


Link to post
Share on other sites

Ah awesome, this looks like it'll be cool to try out!  Just want to say thanks again for all of this Angel-125, it's become a mod I don't much want to play without :)

 

Share this post


Link to post
Share on other sites

oooh. I know why the Prospector didn't dig up any Rare Metals. Because it never did. Because the "Prospector" converter simply doesn't have Rare Metals on its output resources list.

So far I've always operated either with the OSE Workshop converter, or in biomes that contained Rare Metals, and Prospector would supply Exotic Minerals just fine. Now...

eh, luckily it appears a patch of Rare Metals too small to appear on the big map is mere 5km south of the base and still on the "flats", so my tiny rover reached it just fine. Two GoldDiggers, running out of RTGs are slowly but steadily filling the Buckboard-2000.

 

OTOH I have a different problem. Whenever I start the game and load it, Watney switches back to Commercial Lab.

Edited by Sharpy

Share this post


Link to post
Share on other sites
41 minutes ago, Sharpy said:

oooh. I know why the Prospector didn't dig up any Rare Metals. Because it never did. Because the "Prospector" converter simply doesn't have Rare Metals on its output resources list.

So far I've always operated either with the OSE Workshop converter, or in biomes that contained Rare Metals, and Prospector would supply Exotic Minerals just fine. Now...

eh, luckily it appears a patch of Rare Metals too small to appear on the big map is mere 5km south of the base and still on the "flats", so my tiny rover reached it just fine. Two GoldDiggers, running out of RTGs are slowly but steadily filling the Buckboard-2000.

 

OTOH I have a different problem. Whenever I start the game and load it, Watney switches back to Commercial Lab.

The Prospector will only give you whatever resources there are in the current biome. For valueable resources (RareMetals, ExoticMinerals, Karborundrum, Aurum), you can go prospecting. You'll need to edit your persistence file and replace all instances of "shortName" with "templateName" and then make sure that there are no duplicate "templateName" fields, and finally, make sure that the "templateName" field matches the "name" field of the template (Watney in this case). Be sure to make a backup of your save first...

Edited by Angel-125

Share this post


Link to post
Share on other sites
13 minutes ago, Angel-125 said:

replace all instances of "shortName" with "templateName" and then make sure that there are no duplicate "templateName" fields,

 

uh.

Most of entries are:

Quote

                    templateName = DocScience
                    shortName = Science Lab

Sometimes shortName is empty, sometimes both are empty. I can't tell easily which is which (some are undeployed labs in flight), and I definitely don't want to convert all of them to Watney (some contain good science which I don't want lost) so I'd rather convert them to Watneys sacrificing the bit of Equipment, through in-game GUI.

(currently all 3 labs on Gilly are Science Labs, one was Fusion, one was Watney).

Should I just delete the ShortName entries everywhere or what?

Edited by Sharpy

Share this post


Link to post
Share on other sites
10 hours ago, Sharpy said:

 

uh.

Most of entries are:

Sometimes shortName is empty, sometimes both are empty. I can't tell easily which is which (some are undeployed labs in flight), and I definitely don't want to convert all of them to Watney (some contain good science which I don't want lost) so I'd rather convert them to Watneys sacrificing the bit of Equipment, through in-game GUI.

(currently all 3 labs on Gilly are Science Labs, one was Fusion, one was Watney).

Should I just delete the ShortName entries everywhere or what?

Delete the shortName field. If you're still having problems, make sure the "templateName" field matches the "name" field of the templates in the Pathfinder/tempates folder.

Unfortunately, I had to make some changes that broke existing saves. Going forward you won't have this issue with new vessels.

Edited by Angel-125

Share this post


Link to post
Share on other sites

Heya! Great mod love it :)

 

But I'm hitting a little problem, and because a log is worth a thousands words: https://hastebin.com/ojiqusawey.md

Now this happens when I try to convert a hab (gondola hab in this case) to a geology lab this goes boom. Configuring it to geology lab in the VAB produces the same error as soon as I try to click the manage operations button.

I saw it happen with the Casa IHM too but I dont seem to be able to reproduce it when no gondola is on the ship.

If I can help you more, please just ask

Thanks!

Share this post


Link to post
Share on other sites

Since nobody has mentioned it yet, let me point out that there's a typo in the thread title.

Share this post


Link to post
Share on other sites
17 hours ago, DarkGod said:

Heya! Great mod love it :)

 

But I'm hitting a little problem, and because a log is worth a thousands words: https://hastebin.com/ojiqusawey.md

Now this happens when I try to convert a hab (gondola hab in this case) to a geology lab this goes boom. Configuring it to geology lab in the VAB produces the same error as soon as I try to click the manage operations button.

I saw it happen with the Casa IHM too but I dont seem to be able to reproduce it when no gondola is on the ship.

If I can help you more, please just ask

Thanks!

How did you install Pathfinder 1.4.0? I just converted a gondo hab to a geology lab and didn't see any issues, both in the VAB and out in the field.

Share this post


Link to post
Share on other sites

Manually from the zip, just copied WildBlueIndustries folder into Gamedata, same for heisenberg

Share this post


Link to post
Share on other sites
6 minutes ago, DarkGod said:

Manually from the zip, just copied WildBlueIndustries folder into Gamedata, same for heisenberg

Try adding the following to the GondoHab.cfg, right after the INTERNAL node:

    MODULE
    {
        name = ModuleScienceContainer
        reviewActionName = Review Data
        storeActionName = Store Experiments
        collectActionName = Take Data
        evaOnlyStorage = True
        storageRange = 2
        allowRepeatedSubjects = True
    }

See if that helps.

Share this post


Link to post
Share on other sites

I'm having problems assembling the Buffalo vehicle on the Mun.

 

When I attempt to attach the Buffallo wheels onto the Buffallo chassis it goes red and says 'Target object is not allowed'.

 

Is it possible to put together the Buffallo vehicle on the Mun? Am I doing something wrong?

 

Share this post


Link to post
Share on other sites
2 hours ago, Angel-125 said:

Try adding the following to the GondoHab.cfg, right after the INTERNAL node:

    MODULE
    {
        name = ModuleScienceContainer
        reviewActionName = Review Data
        storeActionName = Store Experiments
        collectActionName = Take Data
        evaOnlyStorage = True
        storageRange = 2
        allowRepeatedSubjects = True
    }

See if that helps.

 

It does indeed seem to work now :)

 

Edit: Oh wait it worked *once*, I could see the geology UI and all, even started a research. Then I closed it, tried clicking on mange operation and it doesnt do anything anymore, instead it adds a new "Start converter" line to the menu ...

Getting this error in the log:

Quote

[EXC 20:39:13.246] NullReferenceException: Object reference not set to an instance of an object
    WildBlueIndustries.WBIProspector.prepareOutputsByLocale ()
    WildBlueIndustries.WBIProspector.prepareOutputs ()
    WildBlueIndustries.WBIProspector.GetInfo ()
    WildBlueIndustries.WBIConvertibleStorage.getStorageInfo (Int32 templateIndex)
    WildBlueIndustries.WBIConvertibleStorage.setupStorageView (Int32 templateIndex)
    WildBlueIndustries.WBIOpsManager.ReconfigureStorage ()
    BaseEvent.Invoke ()
    UIPartActionButton.OnClick ()
    UnityEngine.Events.InvokableCall.Invoke (System.Object[] args)
    UnityEngine.Events.InvokableCallList.Invoke (System.Object[] parameters)
    UnityEngine.Events.UnityEventBase.Invoke (System.Object[] parameters)
    UnityEngine.Events.UnityEvent.Invoke ()
    UnityEngine.UI.Button.Press ()
    UnityEngine.UI.Button.OnPointerClick (UnityEngine.EventSystems.PointerEventData eventData)
    UnityEngine.EventSystems.ExecuteEvents.Execute (IPointerClickHandler handler, UnityEngine.EventSystems.BaseEventData eventData)
    UnityEngine.EventSystems.ExecuteEvents.Execute[IPointerClickHandler] (UnityEngine.GameObject target, UnityEngine.EventSystems.BaseEventData eventData, UnityEngine.EventSystems.EventFunction`1 functor)
    UnityEngine.EventSystems.EventSystem:Update()

 

 

Edited by DarkGod

Share this post


Link to post
Share on other sites
3 hours ago, DarkGod said:

 

It does indeed seem to work now :)

 

Edit: Oh wait it worked *once*, I could see the geology UI and all, even started a research. Then I closed it, tried clicking on mange operation and it doesnt do anything anymore, instead it adds a new "Start converter" line to the menu ...

Getting this error in the log:

 

Are you out in the field or in the editor?

Share this post


Link to post
Share on other sites
14 hours ago, DarkGod said:

In the field

Ok, where specifically did you try to use the Prospector?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.