Angel-125

[1.7.x] Pathfinder - Space Camping & Geoscience

Recommended Posts

when I update a mod, I throw the old folder before copying the new one.

PATH_INDUSTRY
{
author = Angel-125
name = Ironworks
title = Ironworks Foundry
shortName = Ironworks
TechRequired = advMetalworks
description = The Ironworks Foundry is great for building vital rocket parts and material kits out in the field to spare you the trouble of hauling them all the way from Kerbin. It's also great for creating hot metal plates for frying eggs.
mass = 5
rocketParts = 2000
reconfigureSkill = Engineer
logoPanel = WildBlueIndustries/Pathfinder/Decals/HotMetal
glowPanel = WildBlueIndustries/Pathfinder/Decals/HotMetalGlow
toolTip = If you're tired of hauling rocket parts around, why not build them out of the local resources?
toolTipTitle = Your First Ironworks Foundry

Thank you for responding so quickly :)

Share this post


Link to post
Share on other sites

Thanks for the report. :) Oh dang. Ok, the Ironworks template needs a correction. Change FACTORY to PATH_INDUSTRY and you'll be good to go. I'll have that fixed next update.

Share this post


Link to post
Share on other sites
Hey Angel-125, here is a screenshot of the Geo-Lab Manage screen.

https://farm6.staticflickr.com/5680/22447358656_2e4aa0a541_h.jpgscreenshot143 by Bart Blommaerts, on Flickr

I took this after removing the extra planet. Started a new savegame. And installed pathfinder manually.

Hm. Ok, Have you unlocked the planet and biome yet? I think there's an issue with the biome but I'm not sure. can you post your logs? Thanks for the report. :)

Share this post


Link to post
Share on other sites

Yep, planet surface and biome are unlocked

Planet: The Mun

Biome: Highlands

I captured the KSP.log, you can find it here: https://www.dropbox.com/s/8efp964duvc6e3f/angel125.log.tgz?dl=0

I got this set up now on my DMPSerrver in a sandbox, feel free to join in and test. You can find the gamedata content i use here: http://www.ksp.cignet.be. The server is at ksp.cignet.be:6702.

Thank you for making this amazing mod! And for being so responsive in case of trouble!

Share this post


Link to post
Share on other sites

I've seen that bug too. I don't think it's in something you've touched across updates, Angel.

When I first started dinking around trying to learn the basics of pathfinder, that blank window usually appeared when I went into the Ponderosa and then clicked on the button that took me into the geology lab operations. And once the window was up, you had to leave the scene entirely to fix it.

It appeared to go away for me after one of the first updates to the mod I grabbed shortly after I started getting the hang of things, so I didn't bother.

Share this post


Link to post
Share on other sites

Thanks guys. :) I looked at the logs. I see some issues in both stock modules and my own. In the tracking center, you received a null reference exception when the stock resource map tried to get the resource list when you focused on the mun. In flight, when you focused on your base, I can see that the stock reource converters are throwing null reference exceptions while trying to process recipies. And I can see the drill switch window from Pathfinder having problems trying to draw the window. All of these I think are related to the ResourceMap. The drill switch window uses the same functionality as does the tracking station, and if there is something wrong with the resource map then that would explain why the drill switch window failed. I did not see a log entry for the geology lab but I suspect that again there is a problem with the map. I am guessing but maybe your save game's resource map data is faulty. If that is the case then we need to find a way to reset it.

I also noticed something called DarkMultiPlayer, can you shed some light on that?

Share this post


Link to post
Share on other sites

Odd, cause this is the 3rd brand new savegame i started that gives the same bug. That would mean that some mod is screwing up the resources???

DarkMultiPlayer is a mod that allows for multiple players to be active in the same environment. Or, efectivly: multiplayer Kerbal Space Program. It's in CKAN for version 1.0.4.

The last screenshot i posted, and the Log come from a sandbox game that runs on my KSP DarkMultiPlayer Server. Hence the DMP log entries.

I got 2 mods installed that, amongst others(mechjeb, graphotron, telemachus, KerbalGPS,...), integrate Scansat Modules into stock parts. Could that be the culprit?

Share this post


Link to post
Share on other sites

There might be an edge case caused by the Terrain scanner trying to verify that a planet has been unlocked after the player performs a scan and then hits F9. That is the only time Pathfinder alters the resource map instead of just reading from it. Did you perform a resource scan around the mun with the Terrain, and then hit F9 to reload your save?

Share this post


Link to post
Share on other sites

i did a resource scan with TERRAIN, but i didn't use F9.

I threw out the Scansat integration into Stock and the Extraplanetary Simplifier, see what that does.

yup, that did the trick:

- - - Updated - - -

OK, my hunch seemed to be correct... now it works22312659958_fafbd8f1eb_c.jpgscreenshot11 by Bart Blommaerts, on Flickr

21879162933_91583511ee_c.jpgscreenshot10 by Bart Blommaerts, on Flickr

Share this post


Link to post
Share on other sites

Interesting! Sounds like there is an issue with SCANsat and the stock resource modules interacting with Pathfinder. I don't do anything custom to the stock resource maps, I just use what's there in the stock game. I'm at work so I can't test, but what if you had a new save and had SCANsat installed, but only use the stock surface scanner to unlock the biome instead of the geology lab either. Don't take any core samples too. If you use the stock m700 scanner and stock surface scanner, then start using the geology lab, does that clear up the problem? I am wondering if using the geology lab with scansat installed is causing an interaction issue when you use the geology lab to unlock a biome..

Share this post


Link to post
Share on other sites
Is this compatible with UKS?

And does it support USI-LS yet?

Good question. :) The production chain is different than UKS, and none of Pathfinder's components will work with UKS parts, but it does support UIS-LS.

Share this post


Link to post
Share on other sites

Get the latest here.

0.8.9

This update brings some new parts, some more bug fixes, and minor tweaks. By popular request, the orbital construction docks from Multipurpose Colony Modules (MCM) are back as the Stockyard 250 and Stockyard 375. These parts need Extraplanetary Launchpads to function properly. To help with your orbital construction needs, the new Homestead provides the same industrial facilities as the Hacienda- minus the Hot Springs. For now these are the only orbital elements of Pathfinder; I have plans for other modules but they'll take awhile to build properly.

New Parts

- By popular request, added the Stockyard 250 and Stockyard 375. Use these parts to build vessels in orbit or recycle them.

- Added the Homestead, the orbital equivalent to the Hacienda. Unlike the Hacienda though, the Homestead lacks a Hot Springs configuration.

Spyglass

- The spotlight now rotates. :)

Clockworks

- Increased maximum part volume that can be produced to 14,500L, and increased maximum KIS storage to match it. You'll need to switch away from the Clockworks and switch back for the changes to take effect.

Buffalo Crew Cab

- Adjusted the default EVA airlock to the right side, just like the command cab.

- Adjusted the ladder colliders to make it easier to climb up.

Command Cab

- Adjusted the ladder colliders to make it easier to climb up.

Buffalo Chassis

- Increased the Chassis 2u KIS storage to 200L.

- Decreased the Chassis End Unit KIS storage to 80L.

Bug Fixes

- Fixed the rocket parts production in the Ironworks when Extraplanetary Launchpads isn't installed.

- Fixed the rocket parts to material kits production in the Ironwoks when OSE Workshop is installed.

- Fixed CLS issues with the Casa.

- Adjusted the costs of the Hacienda.

Other

- Updated to latest CommunityResourcePack and ModuleManager.

Promo images:

Bzu85Ou.jpg

pX0WLW1.jpg

Edited by Angel-125

Share this post


Link to post
Share on other sites

Whiohow! updates!

Nice going with the orbital stuff! soon your's will be the only mod i ever need! (or nearly)

Share this post


Link to post
Share on other sites
Whiohow! updates!

Nice going with the orbital stuff! soon your's will be the only mod i ever need! (or nearly)

Thanks, glad it's working for you. :)

Love the new models

Is CTT integration on your radar or is that out of scope so far?

Good question. I don't use CTT, so I've placed the parts in the early to mid portion of the stock tech tree. I'd have to look at CTT to see what nodes would be appropriate. The basic idea is that habitation elements (Ponderosa, Casa, foundation modules like Saddle, Switchback, and Buckboard) are available in the pioneering phase of exploration, followed by the science elements (Doc), and finally the industrial elements (Hacienda, Homestead, Stockyards).

Share this post


Link to post
Share on other sites

I think I found a copy&paste error in GeoEnergyResource.cfg:

//Pluto-er Eeloo is geologically active.
//See http://io9.com/breaking-geologic-activity-has-been-detected-on-the-su-1718055390
PLANETARY_RESOURCE
{
ResourceName = GeoEnergy
ResourceType = 0
PlanetName = Laythe

Distribution
{
PresenceChance = 100
MinAbundance = 1
MaxAbundance = 50
Variance = 20
Dispersal = 3
}
}

The entry is supposed to be for Eeloo, but is set for Laythe instead.

Share this post


Link to post
Share on other sites
I think I found a copy&paste error in GeoEnergyResource.cfg:

//Pluto-er Eeloo is geologically active.
//See http://io9.com/breaking-geologic-activity-has-been-detected-on-the-su-1718055390
PLANETARY_RESOURCE
{
ResourceName = GeoEnergy
ResourceType = 0
PlanetName = Laythe

Distribution
{
PresenceChance = 100
MinAbundance = 1
MaxAbundance = 50
Variance = 20
Dispersal = 3
}
}

The entry is supposed to be for Eeloo, but is set for Laythe instead.

Good spot! Thanks, I'll fix that in the next update. :)

Share this post


Link to post
Share on other sites

Get the latest here.

The Buffalo gets new wheels! The stock-based RoveMax M1A1 wheels were always interim placeholders, but now the Buffalo has its real wheels. The new M1A1 Mountain Goat is inspired by the wheels found on NASA’s MMSEV but they have been brought inline with the KSP art style. The current stock-based wheel will be going away. They are deprecated in this release (existing craft won’t break but you won’t find the wheels in the catalog) and it will be removed at a later date, so be sure to retrofit or retire your rovers that have the older wheels.

New Parts

- Added the Patio, a 3.75m muncrete slab that's useful for making landing pads and foundations for bases on uneven terrain. You can clip slabs together to form larger areas. To use it, bolt it into the ground NOTE: This is an experimental part, use at your own risk.

- Added the M1A1 Mountain Goat. The M1A1 can switch between a wide wheelbase for normal driving, and a narrow wheelbase to get in and out of cargo bays. And to top it off, it has sound effects if you have the Wheel Sounds mod installed. Thanks for the suggestion, Supermarine! :)

- Added the Tundra 200 and Tundra 400. These are conformal storage tanks for the Buffalo that are intended for ground and aerospace craft. Unlike the Wagon, they do not expand, but you can attach other parts to them.

Gold Digger

- Lowered EC requirements for the Gold Digger to reflect its lower efficiency compared to the stock Drill-O-Matic.

Buffalo Command Cab

- Increased storage slots slightly.

Interim Rover Wheel

- The existing stock-based rover wheel has been deprecated in favor of the new M1A1 Mountain Goat. Be sure to retrofit your rovers.

Other

- Moved the Mineshaft, Capstone, and Switchback to the Structural tab (they are still found under the Pathfinder category as well).

- Moved the part config files to the new Parts directory, organized by tab. Textures and mesh files remain in the Assets folder.

Bug Fixes

- The greenhouse will now retain its resources when you switch away from the vessel and switch back.

- The Spyglass can now attach KAS pipes.

- The Watney Rainmaker no longer complains about a lack of Oxidizer or MonoPropellant (you might need to transfer some into the Doc).

- Fixed GeoEnergy resource distribution for Eeloo. Thanks for pointing it out, CyberFoxx! :)

- The Switchback's KIS storage capacity is now available from inside your base as well as during EVA.

Share this post


Link to post
Share on other sites
Good spot! Thanks, I'll fix that in the next update. :)

I have a tendency to randomly go through mods to see how they work. Catching the odd bug is a good perk of that. :cool:

Share this post


Link to post
Share on other sites

This release has some hotfixes.

Watney Chemistry Lab

- Adjusted ElectricCharge output on the Rainmaker.

- Added a Rainmaker variant that creates Water from LiquidFuel and Oxidizer. It also produces ElectricCharge.

Bug Fixes

- Added collider to broken wheel mesh on the M1A1.

Edited by Angel-125

Share this post


Link to post
Share on other sites

Hey there, Angel. First of all i would like to thank you for this wonderful mod - Pathfinder combines fun, utility and nice looking models in one kickass package. Keep up the good work!

Now, there's several issues that sorta interfere with the whole pathfindin' business for me:

- Jumping bases. Despite meticulously seeking out as-flat-as-posbibble sites for construction and ensuring that most of the structures are bolted to the ground, bases keep randomly wrenching Saddles from the ground and lifting several buildings slightly above the ground. God forbid i try to accelerate time during mining or spaceship construction, then the whole installation flies good 50 meters into the air before crashing upside down. Thus, Duna and Laythe violently rebuffed any colonization attempts. Can you advise on this? Is there specific things to be avoided?

-Nullrefers. Usually start after bolting down first Saddle and persist until scene is reloaded. May sometimes return if Saddle's KAS port is disconnected, while KAS-powered Mineshaft seems to be unaffected.

-Buffalo hitch framerate drop. No exceptions thrown at all, and yet mere presence of this part in VAB or outside of editor causes FPS drop down to ~30. Have no idea what might cause this.

While we at it, i'd like to make couple of suggestions regarding hardware.

New wheels are well made overall, but still could benefit from further tuning. Just as with their predecessor, Mountain Goat are somewhat small in diameter which means that particularly steep slopes have a nasty habit of destroying front mounted equipment (like winches), so it might be a good idea to give MG larger clearance. Suspension and "wide wheelbase" mode are *kinda* lacking given that Buffalo tends to be top-heavy.

Or, perhaps, it would make more sense to leave m1a1 alone and consider making some sort of m1a2 heavy duty wheels - less portable, but more suitable for heavier utility vehicles, like mobile crane or ore hauler. Or particularly rough terrain.

Would also like to request 2 parts: 4x buffalo base and some sort rear end cover for cab, b/c slapping flatbed section to cover useless door is kinda... meh. Something like Buffalo-to-1.25 adapter, just without that ugly port.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.