Angel-125

[1.8.x] Pathfinder - Space Camping & Geoscience

Recommended Posts

So, i'm thinking of putting Pathfinder into a new game with JNSQ, and i was wondering how compatible it is with a) Kerbalism, and b) KSPI-E. Anyone have any comments?

Share this post


Link to post
Share on other sites
On 6/6/2019 at 9:59 AM, ussdefiant said:

So, i'm thinking of putting Pathfinder into a new game with JNSQ, and i was wondering how compatible it is with a) Kerbalism, and b) KSPI-E. Anyone have any comments?

It and KSPI-E ignore each other altogether. I ran them side by side for a while. Not sure about kerbalism as I have never used it.

Share this post


Link to post
Share on other sites
Posted (edited)

Hey!

I've kicked off a career game in 1.7.2 and I'm having some trouble with the Hacienda. 

If I attempt to attach the Hacienda IMF to any part via the main attachment node, the node on the part I'm attaching it to disappears and nothing happens. The Hacienda remains attached to the cursor. Behaviour is somewhat buggy in the VAB after that (I have to load up another craft file or I can't pick up or drop any parts). The game will not let me exit the VAB (the save/don't save menu refuses to dismiss), I am forced to load another craft or create a new one in order to revert to normal behaviour. 

A picture speaks a thousand words, so:

Before and after shots:

https://imgur.com/a/LM0AigP

Console output:

https://imgur.com/a/s4qgW9a

Log file (last relevant lines):

[LOG 20:21:37.576] [WBIOmniStorage] - OnStart called. resourceAmounts.Count: 0
[WRN 20:21:37.576] *PartUtils* Unable to find UIPartActionWindow list
[WRN 20:21:37.576] *PartUtils* Unable to find UIPartActionWindow list
[WRN 20:21:37.576] *PartUtils* Unable to find UIPartActionWindow list
[WRN 20:21:37.576] *PartUtils* Unable to find UIPartActionWindow list
[WRN 20:21:37.576] *PartUtils* Unable to find UIPartActionWindow list
[WRN 20:21:37.576] *PartUtils* Unable to find UIPartActionWindow list
[LOG 20:21:37.577] initModuleGUI() called
[LOG 20:21:37.577] templateManager is not null at this point
[LOG 20:21:41.539] WBI.Hacienda added to ship - part count: 2
[EXC 20:21:41.585] ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
	System.Collections.Generic.List`1[ResourceRatio].get_Item (Int32 index)
	WildBlueIndustries.WBIModuleResourceHarvester.OnSave (.ConfigNode node)
	PartModule.Save (.ConfigNode node)
	ShipConstruct.SaveShip ()
	ShipConstruction.CreateBackup (.ShipConstruct ship)
	EditorLogic.SetBackup ()
	EditorLogic.<SetupFSM>m__27 ()
	KerbalFSM.RunEvent (.KFSMEvent evt)
	KerbalFSM.updateFSM (KFSMUpdateMode mode)
	KerbalFSM.UpdateFSM ()
	EditorLogic.Update ()
[EXC 20:23:00.334] ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
	System.Collections.Generic.List`1[ResourceRatio].get_Item (Int32 index)
	WildBlueIndustries.WBIModuleResourceHarvester.OnSave (.ConfigNode node)
	PartModule.Save (.ConfigNode node)
	ShipConstruct.SaveShip ()
	ShipConstruction.CreateBackup (.ShipConstruct ship)
	EditorLogic.onExitConfirm ()
	DialogGUIButton.OptionSelected ()
	DialogGUIButton.<Create>m__7 ()
	UnityEngine.Events.InvokableCall.Invoke ()
	UnityEngine.Events.UnityEvent.Invoke ()
	UnityEngine.UI.Button.Press ()
	UnityEngine.UI.Button.OnPointerClick (UnityEngine.EventSystems.PointerEventData eventData)
	UnityEngine.EventSystems.ExecuteEvents.Execute (IPointerClickHandler handler, UnityEngine.EventSystems.BaseEventData eventData)
	UnityEngine.EventSystems.ExecuteEvents.Execute[IPointerClickHandler] (UnityEngine.GameObject target, UnityEngine.EventSystems.BaseEventData eventData, UnityEngine.EventSystems.EventFunction`1 functor)
	UnityEngine.EventSystems.EventSystem:Update()
[LOG 20:23:06.180] [KSPUpgradePipeline]: Kerpollo I updated from 1.7.1 to 1.7.2.
[LOG 20:23:06.207] [MechJeb2] Loading Mechjeb 2.8.3
[LOG 20:23:06.218] ScaleModList: listSize 369 maxListSize 1640
[LOG 20:23:06.266] [FlightGlobals]: Part persistentId changed from 2403838896 to 1098933889. Vessel PersistentId 0
[LOG 20:23:06.272] [FlightGlobals]: Part persistentId changed from 1406032273 to 2774211149. Vessel PersistentId 0
[LOG 20:23:06.279] [FlightGlobals]: Part persistentId changed from 1349694791 to 3155310653. Vessel PersistentId 0
[LOG 20:23:06.285] [FlightGlobals]: Part persistentId changed from 148313218 to 760233183. Vessel PersistentId 0
[LOG 20:23:06.289] [FlightGlobals]: Part persistentId changed from 1325122469 to 813632086. Vessel PersistentId 0
[LOG 20:23:06.292] [FlightGlobals]: Part persistentId changed from 2867460126 to 2242385426. Vessel PersistentId 0
[LOG 20:23:06.298] [FlightGlobals]: Part persistentId changed from 3282321609 to 1639145592. Vessel PersistentId 0
[LOG 20:23:06.304] [FlightGlobals]: Part persistentId changed from 3333951700 to 415510698. Vessel PersistentId 0
[LOG 20:23:06.310] [FlightGlobals]: Part persistentId changed from 3982874049 to 4004936399. Vessel PersistentId 0
[LOG 20:23:06.318] [FlightGlobals]: Part persistentId changed from 398367216 to 3821149318. Vessel PersistentId 0
[LOG 20:23:06.324] [FlightGlobals]: Part persistentId changed from 199824860 to 3126226964. Vessel PersistentId 0
[LOG 20:23:06.330] [FlightGlobals]: Part persistentId changed from 505157984 to 3440003051. Vessel PersistentId 0
[LOG 20:23:06.337] [FlightGlobals]: Part persistentId changed from 3051067996 to 2978629776. Vessel PersistentId 0
[LOG 20:23:06.342] [FlightGlobals]: Part persistentId changed from 2374693751 to 4258633802. Vessel PersistentId 0
[LOG 20:23:06.347] [FlightGlobals]: Part persistentId changed from 4090166591 to 1260902384. Vessel PersistentId 0
[LOG 20:23:06.351] [FlightGlobals]: Part persistentId changed from 2790874420 to 105157414. Vessel PersistentId 0
[LOG 20:23:06.362] [FlightGlobals]: Part persistentId changed from 4291582501 to 3964957099. Vessel PersistentId 0
[LOG 20:23:06.368] [FlightGlobals]: Part persistentId changed from 2253584548 to 3777962592. Vessel PersistentId 0
[LOG 20:23:06.372] [FlightGlobals]: Part persistentId changed from 2959474717 to 204183089. Vessel PersistentId 0
[LOG 20:23:06.376] [FlightGlobals]: Part persistentId changed from 1257165279 to 1293376008. Vessel PersistentId 0
[LOG 20:23:06.380] [FlightGlobals]: Part persistentId changed from 2059970637 to 791728534. Vessel PersistentId 0
[LOG 20:23:06.394] [FlightGlobals]: Part persistentId changed from 3050049034 to 1526427001. Vessel PersistentId 0
[LOG 20:23:06.399] [FlightGlobals]: Part persistentId changed from 1391568371 to 1004290866. Vessel PersistentId 0
[LOG 20:23:06.404] [FlightGlobals]: Part persistentId changed from 2392993334 to 1996981507. Vessel PersistentId 0
[LOG 20:23:06.409] [FlightGlobals]: Part persistentId changed from 2174419697 to 3522397747. Vessel PersistentId 0
[LOG 20:23:06.413] [FlightGlobals]: Part persistentId changed from 1287361003 to 1160534143. Vessel PersistentId 0
[LOG 20:23:06.419] [FlightGlobals]: Part persistentId changed from 807758367 to 782436061. Vessel PersistentId 0
[LOG 20:23:06.428] [FlightGlobals]: Part persistentId changed from 1477235714 to 1855758723. Vessel PersistentId 0
[LOG 20:23:06.432] [FlightGlobals]: Part persistentId changed from 4119357442 to 1146272171. Vessel PersistentId 0
[LOG 20:23:06.437] [FlightGlobals]: Part persistentId changed from 3541414197 to 3939090086. Vessel PersistentId 0
[LOG 20:23:06.446] [FlightGlobals]: Part persistentId changed from 2801381419 to 2768125695. Vessel PersistentId 0
[LOG 20:23:06.451] [FlightGlobals]: Part persistentId changed from 1538287735 to 1486917115. Vessel PersistentId 0
[LOG 20:23:06.456] [FlightGlobals]: Part persistentId changed from 2446930071 to 797064137. Vessel PersistentId 0
[LOG 20:23:06.461] [FlightGlobals]: Part persistentId changed from 3430754472 to 4083837255. Vessel PersistentId 0
[LOG 20:23:06.467] [FlightGlobals]: Part persistentId changed from 2468414267 to 648905457. Vessel PersistentId 0
[LOG 20:23:06.472] [FlightGlobals]: Part persistentId changed from 1550285449 to 3508494427. Vessel PersistentId 0
[LOG 20:23:06.478] [FlightGlobals]: Part persistentId changed from 728882547 to 1365642390. Vessel PersistentId 0
[LOG 20:23:06.483] [FlightGlobals]: Part persistentId changed from 2474543131 to 3203069343. Vessel PersistentId 0
[LOG 20:23:06.488] [FlightGlobals]: Part persistentId changed from 1064607448 to 2251064469. Vessel PersistentId 0
[LOG 20:23:06.494] [FlightGlobals]: Part persistentId changed from 1844773256 to 4227153163. Vessel PersistentId 0
[LOG 20:23:06.500] [FlightGlobals]: Part persistentId changed from 6971673 to 3753298862. Vessel PersistentId 0
[LOG 20:23:06.507] [FlightGlobals]: Part persistentId changed from 1110932722 to 2830452516. Vessel PersistentId 0
[LOG 20:23:06.513] [FlightGlobals]: Part persistentId changed from 1226287016 to 637509595. Vessel PersistentId 0
[LOG 20:23:06.519] [FlightGlobals]: Part persistentId changed from 502843991 to 325816697. Vessel PersistentId 0
[LOG 20:23:06.522] Kerpollo I loaded!
[ERR 20:23:06.574] [ModuleSrfFX]: No IThrustProvider module found at index 0!

[LOG 20:23:06.668] ScaleModList: listSize 369 maxListSize 1640
[LOG 20:23:06.668] Autogen thumbnail for C:/Program Files (x86)/Steam/steamapps/common/Kerbal Space Program/KSP_x64_Data/../thumbs/2019_3_VAB_Kerpollo I.png from C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\saves\2019_3\Ships\VAB\Kerpollo I.craft
[LOG 20:24:09.034] [000_AT_Utils: 20:24:09.034] Metric.partsBounds: WARNING! No parts were provided.
[LOG 20:24:09.034] [000_AT_Utils: 20:24:09.034] Metric.partsBounds: WARNING! No parts were provided.
[LOG 20:24:09.078] ScaleModList: listSize 369 maxListSize 1640
[WRN 20:24:10.584] *PartUtils* Unable to find UIPartActionWindow list
[LOG 20:24:10.584] initModuleGUI() called
[LOG 20:24:10.585] templateManager is not null at this point
[LOG 20:24:10.592] [MechJeb2] Loading Mechjeb 2.8.3
[LOG 20:24:10.685] ScaleModList: listSize 369 maxListSize 1640
[LOG 20:24:11.798] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,Attempting to Grab KAC Types...
[LOG 20:24:11.802] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,KAC Version:3.10.0.0
[LOG 20:24:11.806] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,Got Assembly Types, grabbing Instance
[LOG 20:24:11.806] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,Got Instance, Creating Wrapper Objects
[LOG 20:24:11.806] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,Getting APIReady Object
[LOG 20:24:11.806] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,Success: True
[LOG 20:24:11.806] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,Getting Alarms Object
[LOG 20:24:11.806] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,Success: True
[LOG 20:24:11.806] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,Getting Alarm State Change Event
[LOG 20:24:11.806] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,Getting Create Method
[LOG 20:24:11.806] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,Getting Delete Method
[LOG 20:24:11.806] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,Getting DrawAlarmAction
[LOG 20:24:11.806] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,Attempting to Grab KAC Types...
[LOG 20:24:11.810] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,KAC Version:3.10.0.0
[LOG 20:24:11.813] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,Got Assembly Types, grabbing Instance
[LOG 20:24:11.813] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,Got Instance, Creating Wrapper Objects
[LOG 20:24:11.813] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,Getting APIReady Object
[LOG 20:24:11.813] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,Success: True
[LOG 20:24:11.813] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,Getting Alarms Object
[LOG 20:24:11.813] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,Success: True
[LOG 20:24:11.813] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,Getting Alarm State Change Event
[LOG 20:24:11.813] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,Getting Create Method
[LOG 20:24:11.813] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,Getting Delete Method
[LOG 20:24:11.813] 6/12/2019 8:24:11 PM,Workshop-KACWrapper,Getting DrawAlarmAction
[LOG 20:24:11.854] [WBIOmniStorage] - OnStart called. resourceAmounts.Count: 0
[WRN 20:24:11.854] *PartUtils* Unable to find UIPartActionWindow list
[WRN 20:24:11.854] *PartUtils* Unable to find UIPartActionWindow list
[WRN 20:24:11.854] *PartUtils* Unable to find UIPartActionWindow list
[WRN 20:24:11.854] *PartUtils* Unable to find UIPartActionWindow list
[WRN 20:24:11.854] *PartUtils* Unable to find UIPartActionWindow list
[WRN 20:24:11.855] *PartUtils* Unable to find UIPartActionWindow list
[LOG 20:24:11.855] initModuleGUI() called
[LOG 20:24:11.855] templateManager is not null at this point
[LOG 20:24:13.364] WBI.Hacienda added to ship - part count: 2
[EXC 20:24:13.409] ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
	System.Collections.Generic.List`1[ResourceRatio].get_Item (Int32 index)
	WildBlueIndustries.WBIModuleResourceHarvester.OnSave (.ConfigNode node)
	PartModule.Save (.ConfigNode node)
	ShipConstruct.SaveShip ()
	ShipConstruction.CreateBackup (.ShipConstruct ship)
	EditorLogic.SetBackup ()
	EditorLogic.<SetupFSM>m__27 ()
	KerbalFSM.RunEvent (.KFSMEvent evt)
	KerbalFSM.updateFSM (KFSMUpdateMode mode)
	KerbalFSM.UpdateFSM ()
	EditorLogic.Update ()
[EXC 20:24:55.975] ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
	System.Collections.Generic.List`1[ResourceRatio].get_Item (Int32 index)
	WildBlueIndustries.WBIModuleResourceHarvester.OnSave (.ConfigNode node)
	PartModule.Save (.ConfigNode node)
	ShipConstruct.SaveShip ()
	ShipConstruction.CreateBackup (.ShipConstruct ship)
	EditorLogic.onExitConfirm ()
	DialogGUIButton.OptionSelected ()
	DialogGUIButton.<Create>m__7 ()
	UnityEngine.Events.InvokableCall.Invoke ()
	UnityEngine.Events.UnityEvent.Invoke ()
	UnityEngine.UI.Button.Press ()
	UnityEngine.UI.Button.OnPointerClick (UnityEngine.EventSystems.PointerEventData eventData)
	UnityEngine.EventSystems.ExecuteEvents.Execute (IPointerClickHandler handler, UnityEngine.EventSystems.BaseEventData eventData)
	UnityEngine.EventSystems.ExecuteEvents.Execute[IPointerClickHandler] (UnityEngine.GameObject target, UnityEngine.EventSystems.BaseEventData eventData, UnityEngine.EventSystems.EventFunction`1 functor)
	UnityEngine.EventSystems.EventSystem:Update()
[EXC 20:25:14.226] ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
	System.Collections.Generic.List`1[ResourceRatio].get_Item (Int32 index)
	WildBlueIndustries.WBIModuleResourceHarvester.OnSave (.ConfigNode node)
	PartModule.Save (.ConfigNode node)
	ShipConstruct.SaveShip ()
	ShipConstruction.CreateBackup (.ShipConstruct ship)
	EditorLogic.SetBackup ()
	EditorLogic.<SetupFSM>m__1F ()
	KerbalFSM.RunEvent (.KFSMEvent evt)
	KerbalFSM.updateFSM (KFSMUpdateMode mode)
	KerbalFSM.UpdateFSM ()
	EditorLogic.Update ()
[EXC 20:25:15.566] ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
	System.Collections.Generic.List`1[ResourceRatio].get_Item (Int32 index)
	WildBlueIndustries.WBIModuleResourceHarvester.OnSave (.ConfigNode node)
	PartModule.Save (.ConfigNode node)
	ShipConstruct.SaveShip ()
	ShipConstruction.CreateBackup (.ShipConstruct ship)
	EditorLogic.SetBackup ()
	EditorLogic.<SetupFSM>m__1F ()
	KerbalFSM.RunEvent (.KFSMEvent evt)
	KerbalFSM.updateFSM (KFSMUpdateMode mode)
	KerbalFSM.UpdateFSM ()
	EditorLogic.Update ()
[EXC 20:25:15.848] ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
	System.Collections.Generic.List`1[ResourceRatio].get_Item (Int32 index)
	WildBlueIndustries.WBIModuleResourceHarvester.OnSave (.ConfigNode node)
	PartModule.Save (.ConfigNode node)
	ShipConstruct.SaveShip ()
	ShipConstruction.CreateBackup (.ShipConstruct ship)
	EditorLogic.SetBackup ()
	EditorLogic.<SetupFSM>m__1F ()
	KerbalFSM.RunEvent (.KFSMEvent evt)
	KerbalFSM.updateFSM (KFSMUpdateMode mode)
	KerbalFSM.UpdateFSM ()
	EditorLogic.Update ()
[EXC 20:25:16.237] ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
	System.Collections.Generic.List`1[ResourceRatio].get_Item (Int32 index)
	WildBlueIndustries.WBIModuleResourceHarvester.OnSave (.ConfigNode node)
	PartModule.Save (.ConfigNode node)
	ShipConstruct.SaveShip ()
	ShipConstruction.CreateBackup (.ShipConstruct ship)
	EditorLogic.SetBackup ()
	EditorLogic.<SetupFSM>m__1F ()
	KerbalFSM.RunEvent (.KFSMEvent evt)
	KerbalFSM.updateFSM (KFSMUpdateMode mode)
	KerbalFSM.UpdateFSM ()
	EditorLogic.Update ()
[LOG 20:25:31.234] [000_AT_Utils: 20:25:31.234] Metric.partsBounds: WARNING! No parts were provided.
[LOG 20:25:31.234] [000_AT_Utils: 20:25:31.234] Metric.partsBounds: WARNING! No parts were provided.
[LOG 20:25:31.275] ScaleModList: listSize 369 maxListSize 1640
[WRN 20:25:47.750] *PartUtils* Unable to find UIPartActionWindow list
[LOG 20:25:47.750] initModuleGUI() called
[LOG 20:25:47.750] templateManager is not null at this point
[LOG 20:25:47.759] [MechJeb2] Loading Mechjeb 2.8.3
[LOG 20:25:47.850] ScaleModList: listSize 369 maxListSize 1640
[LOG 20:25:49.207] [WBIOmniStorage] - OnStart called. resourceAmounts.Count: 0
[WRN 20:25:49.207] *PartUtils* Unable to find UIPartActionWindow list
[WRN 20:25:49.207] *PartUtils* Unable to find UIPartActionWindow list
[WRN 20:25:49.208] *PartUtils* Unable to find UIPartActionWindow list
[WRN 20:25:49.208] *PartUtils* Unable to find UIPartActionWindow list
[LOG 20:25:49.208] initModuleGUI() called
[LOG 20:25:49.208] templateManager is not null at this point
[LOG 20:25:49.217] [MechJeb2] Loading Mechjeb 2.8.3
[LOG 20:25:49.227] ScaleModList: listSize 369 maxListSize 1640
[LOG 20:25:49.305] ScaleModList: listSize 369 maxListSize 1640
[LOG 20:25:50.515] WBI.DocSciLab added to ship - part count: 2
[LOG 20:25:58.660] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,Attempting to Grab KAC Types...
[LOG 20:25:58.663] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,KAC Version:3.10.0.0
[LOG 20:25:58.667] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,Got Assembly Types, grabbing Instance
[LOG 20:25:58.667] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,Got Instance, Creating Wrapper Objects
[LOG 20:25:58.667] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,Getting APIReady Object
[LOG 20:25:58.667] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,Success: True
[LOG 20:25:58.667] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,Getting Alarms Object
[LOG 20:25:58.667] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,Success: True
[LOG 20:25:58.667] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,Getting Alarm State Change Event
[LOG 20:25:58.667] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,Getting Create Method
[LOG 20:25:58.667] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,Getting Delete Method
[LOG 20:25:58.667] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,Getting DrawAlarmAction
[LOG 20:25:58.667] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,Attempting to Grab KAC Types...
[LOG 20:25:58.672] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,KAC Version:3.10.0.0
[LOG 20:25:58.676] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,Got Assembly Types, grabbing Instance
[LOG 20:25:58.676] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,Got Instance, Creating Wrapper Objects
[LOG 20:25:58.676] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,Getting APIReady Object
[LOG 20:25:58.676] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,Success: True
[LOG 20:25:58.676] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,Getting Alarms Object
[LOG 20:25:58.676] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,Success: True
[LOG 20:25:58.676] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,Getting Alarm State Change Event
[LOG 20:25:58.676] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,Getting Create Method
[LOG 20:25:58.676] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,Getting Delete Method
[LOG 20:25:58.676] 6/12/2019 8:25:58 PM,Workshop-KACWrapper,Getting DrawAlarmAction
[LOG 20:25:58.723] [WBIOmniStorage] - OnStart called. resourceAmounts.Count: 0
[WRN 20:25:58.723] *PartUtils* Unable to find UIPartActionWindow list
[WRN 20:25:58.723] *PartUtils* Unable to find UIPartActionWindow list
[WRN 20:25:58.723] *PartUtils* Unable to find UIPartActionWindow list
[WRN 20:25:58.723] *PartUtils* Unable to find UIPartActionWindow list
[WRN 20:25:58.723] *PartUtils* Unable to find UIPartActionWindow list
[WRN 20:25:58.723] *PartUtils* Unable to find UIPartActionWindow list
[LOG 20:25:58.724] initModuleGUI() called
[LOG 20:25:58.724] templateManager is not null at this point

 

Currently using a variety of mods, but nothing that should impact (KRnD is the usual suspect, I'll remove that and check now)

Pathfinder
MOLE
Snacks
ClickThroughBlocker
Better Burn Time
Bon Voyage
Community Category Kit
Community Resource Pack
Configurable Containers
Firespitter Core
FTLDrive Continued
Ground Construction (2)
Hangar
KAS
Kerbal Engineer
KIS
KRnD
KSP-AVC
Mechjeb2
Navyfish Docking Port Alignment Indicator
KBPS
ScienceAlert
StageRecovery
KAC
Universal Storage II
OSE Workshop
World Stabiliser

Curiously this only affects the Hacienda. Doesn't appear to affect, for example, the Doc Science Lab. 

Edited by Kielm

Share this post


Link to post
Share on other sites

@Kielm - I think this is the same issue I reported over on the Buffalo thread.  Do me a favor and try to attach a gold digger drill to a command pod and see if the same thing happens...  This is exactly the behavior I've been experiencing

Share this post


Link to post
Share on other sites
1 minute ago, MaxPeck said:

@Kielm - I think this is the same issue I reported over on the Buffalo thread.  Do me a favor and try to attach a gold digger drill to a command pod and see if the same thing happens...  This is exactly the behavior I've been experiencing

The gold digger drill exhibits the same behaviour - I just checked. 

Also, KRnD is not at fault, for once. 

Share this post


Link to post
Share on other sites
Just now, Kielm said:

The gold digger drill exhibits the same behaviour - I just checked. 

Also, KRnD is not at fault, for once. 

I get this with any WBI or stock part that has a drill component.  USI and KPBS drills seem to work fine.  

My mod list is similar to yours, except I don't use MOLE, Snacks, Better Burn Time, Engineer, KRnD, Navyfish, or Science Alert.  Everything worked fine on 1.7.0, the trouble started with I incremented to 1.7.1 and added Breaking Ground.  Same for you?

Share this post


Link to post
Share on other sites

@MaxPeck Yep that sounds about right. I wasn't using this exact mod list with 1.7.0 but problems seem to have started in 1.7.1. I thought it may have been related to one of the (many) bugs in 1.7.1 but after today, it seems not. 

I don't know exactly what the gold digger drill and Hacienda IMF have, that the Doc Science Lab or other inflatable parts do not. 

 

I do not envy Angel trying to track this one down. 

Share this post


Link to post
Share on other sites
Posted (edited)

@Kielm the Hacienda can be configured as a strip miner operation (a drill), so both it and the gold digger have the WBIModuleResourceHarvester module.  I don't understand why stock drills cause it, nor why USI and KPBS seem unaffected.  

The fact that there is a 2nd person experiencing this, and that we have some commonalities in our mod list is probably helpful.  Hopefully @Angel-125 can get a handle on what's going on.  My space program needs Aurum for funding!

Edited by MaxPeck

Share this post


Link to post
Share on other sites

@MaxPeck I've submitted an issue on github highlighting the problem with relevant logfiles attached, and found what might be the cause, but could be completely wrong. We'll see - fingers crossed!

Share this post


Link to post
Share on other sites
3 minutes ago, Kielm said:

@MaxPeck I've submitted an issue on github highlighting the problem with relevant logfiles attached, and found what might be the cause, but could be completely wrong. We'll see - fingers crossed!

Nice!  Let's see if that does the trick!  Well done

Share this post


Link to post
Share on other sites

Pathfinder appears to be causing an issue with Background Resources.  When Kerbals are on board my Mun base and it's unloaded (in the background), BR stops functioning and I'm getting nullref flood in the logs.  I've tried to trace it down to a specific part or combination of parts but without much luck.  A single Ponderosa hab with Kerbals on board seems to be OK, but when linked up to one or more other modules it causes the problem.  Are there any clues in the logs as to what it might be?

 

Share this post


Link to post
Share on other sites

Window bug has cropped back up when I try to open up the OSE Workshop in the Blacksmith using the Manage Operations menu. Upside there is that I can access and use the Workshop via the POW. So far I've only made the one attempt to open the Workshop via Manage Operations so this may be a fluke.

Recycler doesn't seem to want to behave via POW either.

I still can't retrain my Kerbal colonists in Castillos; Deepwater Horizon is getting filled up with useless tourists at this point. I'd rather not have to install yet another dome there. Still haven't figured out the root cause. Guessing I'm doing something stupid.

 

Using Pathfinder 1.33.2, OSE Workshop 1.2.10 and KIS 1.22 with KSP 1.7.2.

 

Share this post


Link to post
Share on other sites

I have the same problem guys, I updated latest version of  Pathfinder to 1.33.2 and in the game I cant go to space center, tracking station, even quit game. Pop up log says:

ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index

I try reload last working save and I try scrapping parts with engineer and when I scrap two golden drills the game start work correct. Guess that some parameter in that part sucks or maybe some other mod not cooperate with it. :D

Share this post


Link to post
Share on other sites

I love this mod, most base building mods seem to be excessively complex, outdated, or require complicated life-support mods which I like to avoid. But I am having one small issue, It took a while to narrow it down but this mod seems to break the stock drills. I cannot place them on any part, and if I leave them in the editor, the ghost image of the drill acts like it is attached to whatever part I tried to attach it to, but isn't, and from there attaching parts at all just breaks and I can't save or quit the game without forcing it closed. I didn't notice this issue until I tried to actually build a craft with the drills, because as long as I don't use the drills specifically, there are no issues. Is there anything I can do to fix this? Yes I have the breaking ground DLC.

Share this post


Link to post
Share on other sites
50 minutes ago, Sackboy338 said:

I love this mod, most base building mods seem to be excessively complex, outdated, or require complicated life-support mods which I like to avoid. But I am having one small issue, It took a while to narrow it down but this mod seems to break the stock drills. I cannot place them on any part, and if I leave them in the editor, the ghost image of the drill acts like it is attached to whatever part I tried to attach it to, but isn't, and from there attaching parts at all just breaks and I can't save or quit the game without forcing it closed. I didn't notice this issue until I tried to actually build a craft with the drills, because as long as I don't use the drills specifically, there are no issues. Is there anything I can do to fix this? Yes I have the breaking ground DLC.

I should have time this week to investigate 

Share this post


Link to post
Share on other sites

Ok, please give the latest WildBlueTools a try:

- Fix for drills breaking.
- New OmniConverter templates for when Air and Stress are enabled from Snacks.

On 6/14/2019 at 11:56 AM, capi3101 said:

Window bug has cropped back up when I try to open up the OSE Workshop in the Blacksmith using the Manage Operations menu. Upside there is that I can access and use the Workshop via the POW. So far I've only made the one attempt to open the Workshop via Manage Operations so this may be a fluke.

Recycler doesn't seem to want to behave via POW either.

I still can't retrain my Kerbal colonists in Castillos; Deepwater Horizon is getting filled up with useless tourists at this point. I'd rather not have to install yet another dome there. Still haven't figured out the root cause. Guessing I'm doing something stupid.

 

Using Pathfinder 1.33.2, OSE Workshop 1.2.10 and KIS 1.22 with KSP 1.7.2.

 

Regarding your tourists: can you describe in detail the steps you're taking?

Share this post


Link to post
Share on other sites
Posted (edited)
9 hours ago, Angel-125 said:

Regarding your tourists: can you describe in detail the steps you're taking?

Alright, I'll give this a try. If it's not detailed enough, I'll shoot a video and post it to YouTube when I've got some free timeTM.

1. I go to a Castillo where I've got some colonists whose contracts are completed. At this point, I've got over 40 such kerbals at DH alone; they're cutting pretty heavily into the base's productivity value.
2. I click "Retrain Kerbals" on the POW. This opens a window with a list of the colonists in the Castillo.
3. I select a kerbal to retrain, select what trait I want them to have, and then push SET. A dialogue comes up saying that changes won't take effect until I mash go.
3a. I can select any number of kerbals this way; I've tried as few as one kerbal and as many as the entire dome's worth.
4. I mash "Go".

What usually happens then is that I get a flicker from the crew portraits, same as what happens when you load up a ship. I go check the kerbal(s) I just retrained to verify their training - to date, they're still clinging to their cameras. If I go try the process again, the kerbal still has the Tourist trait.

Edited by capi3101

Share this post


Link to post
Share on other sites
2 hours ago, capi3101 said:

Alright, I'll give this a try. If it's not detailed enough, I'll shoot a video and post it to YouTube when I've got some free timeTM.

1. I go to a Castillo where I've got some colonists whose contracts are completed. At this point, I've got over 40 such kerbals at DH alone; they're cutting pretty heavily into the base's productivity value.
2. I click "Retrain Kerbals" on the POW. This opens a window with a list of the colonists in the Castillo.
3. I select a kerbal to retrain, select what trait I want them to have, and then push SET. A dialogue comes up saying that changes won't take effect until I mash go.
3a. I can select any number of kerbals this way; I've tried as few as one kerbal and as many as the entire dome's worth.
4. I mash "Go".

What usually happens then is that I get a flicker from the crew portraits, same as what happens when you load up a ship. I go check the kerbal(s) I just retrained to verify their training - to date, they're still clinging to their cameras. If I go try the process again, the kerbal still has the Tourist trait.

Cool. I learned a couple of things when working on Snacks, so I am hoping they might help with retraining. I will give it a shot tonight.

Share this post


Link to post
Share on other sites

Sadly still having issues with the hacienda in 1.33.4.  Even in a test where pathfinder is the only mod installed. If I just take a girder, and stick a Hacienda on it, I can save it, but the craft file won't reopen properly (It appears but the ship select dialogue box stays open and nothing will attach to the craft). Any attempt to launch the craft just dumps me back on the main KSC screen. T

Share this post


Link to post
Share on other sites

Hey @Angel-125, quick question - is there a parameter in a configuration file somewhere that I can adjust that determines the minimum amount the Pipeline sliders increase as you move them left to right? If not, I might have to make being able to key in specific amounts of resources to transfer via Pipeline a feature request...

Short version of the story behind this - after fiddling with the MaxKIneticEnergy parameter (again), I can shoot stuff into Eve orbit. I had set it for fifteen tonnes to a 125 kilometer orbit, or so I though -  the limit to that orbit is apparently 0.5 tonnes and if I go above that, it tells me I have insufficient delta-V (which I'm still trying to understand - the base has plenty of Electrical Charge as well as plenty of Liquid Fuel and Oxidizer). Earlier this evening I did about twelve half-tonne shots to refuel a monoprop tank in an orbital space station without issues. But the lowest tick I hcan get for liquid fuel and oxidizer is 0.8 tonnes...

Share this post


Link to post
Share on other sites
17 hours ago, Ryan_Coates said:

will this be better than USI or closer too it i love usi mod and this mod

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.