Angel-125

[1.8.x] Pathfinder - Space Camping & Geoscience

Recommended Posts

Okay, update... This also blew all three of my Conestogas off of the Hacienda and through Minmus at Na/N speed... as well as the Spyglass and the second Casa. So I only have one left. Good thing it was still packed. :(

Share this post


Link to post
Share on other sites

Wow. That's an odd one. I'd have to look at logs to know what is going on. Thanks for the report. :)

Hm, can you post your logs? I tried to replicate your issue with no luck:

5XTURpb.png

I am focused on Bill in this screenshot.

Edited by Angel-125

Share this post


Link to post
Share on other sites

Sounds like an attack of the heat bug. It seems to attack parts at random. I was flying a helicopter when it struck. The heat flux will suddenly swing wildly for no reason and a random part will develop a massive temperature spike out of nowhere leading it to exploding. Time warp makes the flux event even more extreme.

If you reproduce the event, see if you can spot a message talking about a part overheating and exploding.

If that's the case, close-out, find your physics file, and change the conduction factor from 20 to 1.

Share this post


Link to post
Share on other sites
Wow. That's an odd one. I'd have to look at logs to know what is going on. Thanks for the report. :)

Hm, can you post your logs? I tried to replicate your issue with no luck:

http://i.imgur.com/5XTURpb.png

I am focused on Bill in this screenshot.

No, the two Casa modules were in sequence, and the Spyglass was attached to the first Casa.

EDIT: Here's a screenshot of it about three or four minuted before the explosion.

2nswIxD.png

The Hacienda got a trio of Conestogas tacked onto it, with one being attached to the Hacienda proper, and the other two branching off of it. Each had a Gold Digger mounted on the side of it.

Edited by MaverickSawyer

Share this post


Link to post
Share on other sites

The random heat bug would explain a few things... Every now and then during testing, my TERRAIN satellites would explode for no reason. I tried sricking large radiators on them to no avail. Thus far me test base has had no issu s with timewarp, thanks for showing me the setup. :) If it happens again please post your logs so we can see if random heat is the factor.

Share this post


Link to post
Share on other sites

I just rescued Cari Kerman from a Ponderosa habitat in LKO. Apparently someone deflated the module with her still inside and then jettisoned it into space. I suspect foul play.

Share this post


Link to post
Share on other sites

LOL! Due to the way that KIS works I have to have crew capacity in the deflated Ponderosa in order to have an inventory module.

Share this post


Link to post
Share on other sites

Latest version is available here.

Wild Blue Industries' staff are rooting for the missions from Enorats & MaverickSawyer. Hope these fixes help. :)

I'm out for the weekend, enjoy! :)

0.8.7

Dynamically configuring Extraplanetary Launchpads continues to be a challenge. Unfortunately, once the workshops are set up, it takes reloading the scene to make changes. As a result it's not conducive to dynamic template switching, and the Fireworks template isn't going to help. The workaround is to add productivity to the Doc and Hacienda, so that all staffed base modules will contribute to at least some of the production. It also means that the Fireworks is now just a shell template; it will be removed next release, so now is a good time to switch it out for something else.

You'll also find a new part, the Captstone, to close off those unused crew ports. And there are some new alternate textures that don't have the module names on them. If you need to go anonymous during the end of the world, these new textures are for you. :) Speaking of textures, the Gold Digger has a new texture as well. Thanks for the feedback, Kottabos!

The Buffalo also gets some new additions; some mini RCS motors (with sound effects!) and a couple of animated arms (static animations, sorry) to help with asteroid exploration. There's also some new storage for the chassis end unit, and the graphics glitch in the crew cab has been fixed. Sorry, no custom wheels- yet.

Finally, this update changes how bases are built; You'll need Engineers equipped with power tools to assemble your base modules. This was my original intention, but at the time, I didn't know how to do that with KIS. To attach a module, simply drag it out of your inventory, press R to change the node to "mount" or "bottom" instead of surface-attach, and press and hold X to attach the module to the standard crew port. While it takes an engineer to assemble the base, anybody can still stack crates onto flatbeds and to each other (but you need an engineer to attach a Buckboard to the Saddle).

Base Modules

- Removed ModuleKISPartMount from the Casa, Chuckwagon, Doc, Hacienda, Ponderosa, and Saddle. These are no longer necessary, and might help with performance as well as avoid deadly Kraken attacks when you accidentally hit that Release button.

New parts

- Buffalo: Added the 5-Way Mini RCS Thruster. This is particularly helpful for exploration craft maneuvering around large objects like asteroids. It even has sound effects! You can change the volume or disable the sound effects by opening the Settings window. To do that, press Mod B simultaneously (Mod is the Modifier key, which defaults to Alt on Windows).

- Added the Buffalo Grappler Arm. Just like the stock Advanced Grabbing Unit, the Grappler Arm is useful for grabbing things like asteroids.

- Added the Asteroid Resource Composition Scanner (ARCS). This arm works like the stock Surface Scanning Module, but only for asteroids. However, it tells you the entire composition of an asteroid instead of just its Ore content. Simply right-click on the part and click Scan Asteroid to get its composition.

- Added the Capstone, a small part designed to put a cap on the exposed crew transfer ports.

Buffalo Crew Cab & Wagon

- The integrated solar panels are now more durable. If the solar panel breaks, so has your part.

Buffalo Command Cab

- Increased the crash tolerance slightly and made it consistent with the Wagon and Crew Cab.

Chassis End Unit

- Added a storage tank with some storage capacity.

Buckboards

- Buckboards show up in the Buffalo and Pathfinder parts category again.

Doc & Hacienda

- Added vessel productivity (for Extraplanetary Launchpads) to the Doc and Hacienda. As long as you staff them, you'll get worker's benefits.

Outback

- Increased storage capacity to 400L.

Templates

- Recalibrated TAC-LS storage containers to reflect containers native to TAC-LS

- Added the Organics template.

Textures

- Converted textures to dds now that things are stabilizing.

- Retextured the Gold Digger to make it easier to differentiate it from the stock Drill-O-Matic in the parts catalog.

- For the minimalists, you can find textures for the Ponderosa, Doc, and Hacienda without the module names in the Extras/ModuleTexturesNoNames folder (this is outside of the GameData folder).

Bug Fixes

- The Spyglass is now located on the Advanced Construction node.

- The Switchback is now located on the General Construction node.

- The Switchback can now be mounted to the Saddle. Don't forget your power tools...

- Updated part costs that were out of whack due to copying config files during development.

- Updated HotSprings Water requirements and capacity to their correct values.

- Increased the Wagon's storage slot capacity to 8x8.

- All Buckboards can now be mounted to the flatbeds.

- Fixed ModuleManager patches preventing converters from showing up when certain mods are installed.

- You can now see out of both windows in the crew cabin from either seat.

Edited by Angel-125

Share this post


Link to post
Share on other sites

this just keeps getting more and more awesome...... Thank you so much for your work on these mods. I love them. I got really burned out on KSP (hey I've played over 2000 hours), but this brought me back :)

BTW if someone could point me toward any kind of maybe fix or at least a method to reduce the "random heat bug" I'd appreciate it. I can't seem to get more than 1 or 2 missions before it strikes me...

Share this post


Link to post
Share on other sites
this just keeps getting more and more awesome...... Thank you so much for your work on these mods. I love them. I got really burned out on KSP (hey I've played over 2000 hours), but this brought me back :)

BTW if someone could point me toward any kind of maybe fix or at least a method to reduce the "random heat bug" I'd appreciate it. I can't seem to get more than 1 or 2 missions before it strikes me...

Glad you like the mod. :) I have some more fixes on the way I found while setting up a base on Duna. For the random heat bug, AdmiralTigerClaw has some suggestions: http://forum.kerbalspaceprogram.com/threads/134835-1-0-4-BETA-Pathfinder-0-8-7-KSP-Meets-The-Martian?p=2245083&viewfull=1#post2245083

Share this post


Link to post
Share on other sites

Get the latest version here.

This update has a bunch of bug fixes- gotta reduce that technical debt!

Templates

- Added the XenonGas storage template.

Bug Fixes

- Fixed an issue preventing the repair of the Solar Flare and Hot Springs.

- Fixed an issue with converting the Buckboard MC-1000 and Outback into a battery.

- Fixed an issue with converting the Chuckwagon into a greenhouse.

- You can now reconfigure your modules again.

- Fixed an issue with Snacks where the inflatable modules weren't adjusting their maximum amounts correctly.

- Fixed an issue with the AuxEN that prevented AntennaRange from working correctly.

- The MC-3000 now has the correct amount of KIS storage when storing something other than KIS items. NOTE: You'll need to switch our your resources for this change to take effect.

Edited by Angel-125

Share this post


Link to post
Share on other sites
Glad you like the mod. :) I have some more fixes on the way I found while setting up a base on Duna. For the random heat bug, AdmiralTigerClaw has some suggestions: http://forum.kerbalspaceprogram.com/threads/134835-1-0-4-BETA-Pathfinder-0-8-7-KSP-Meets-The-Martian?p=2245083&viewfull=1#post2245083

Thank you Angel and AdmiralTigerClaw, for me and for whatever reason, it seems to attack my probe cores most often, especially the stayputnik I've lost more than my fair share of craft when using that part. It will, as described, just randomly "poof" our of existence due to heating. I'm going to load up AIES and Necrobones mod both of these have probe cores, and see if I can just use those and get by.

Share this post


Link to post
Share on other sites

Please note, CKAN is NOT i repeat NOT installing pathfinder 0.8.8 correctly. It's leaving out the Buffalo folder. If you are having issues like I was, DELETE your Wild Blue folder in gamedata and INSTALL THE MOD manually!!!

Side note, Sorry CKAN folks, I've given you chance after chance, but you have FAILED ME FOR THE LAST TIME. ;)

Share this post


Link to post
Share on other sites
is it just me or is anyone else having issues modifying the golddigger drill?

I've repeatedly tested the Gold Digger as well as the stock Drill-O-Matic with no issues. Please be sure to install from github or kerbal stuff.

Please note, CKAN is NOT i repeat NOT installing pathfinder 0.8.8 correctly. It's leaving out the Buffalo folder. If you are having issues like I was, DELETE your Wild Blue folder in gamedata and INSTALL THE MOD manually!!!

Side note, Sorry CKAN folks, I've given you chance after chance, but you have FAILED ME FOR THE LAST TIME. ;)

Ugh. Only thing I can think of is making sure that the netkan file has the Buffalo listed as required.

Share this post


Link to post
Share on other sites
I've repeatedly tested the Gold Digger as well as the stock Drill-O-Matic with no issues. Please be sure to install from github or kerbal stuff.

i got the tools and pathfinder installed through CKAN, and the buffalo added manually. i'll install the whole thing from kerbalstuff, clean out the mod cache and see if that helps.

Currently, when i try to modify the drill, i get an empty window, which won't go away until i go back to KSC or switch to a vessel further then 2.5km away. The KSP log says nothing about it.

....

Tested, and no joy... still only get an empty window. Are there any know incompatibilities with other mods i should be looking at?

Edited by Denko666
test completed

Share this post


Link to post
Share on other sites

I will take a look when I get home. Do you have logs of your attempt? That would help. Have you unlocked the biome yet?

Share this post


Link to post
Share on other sites
I will take a look when I get home. Do you have logs of your attempt? That would help. Have you unlocked the biome yet?

Thx!

Come to think of it tho, it's a non-stock planet: 'Ascepius'. could that have something to do with it?

I'll set up a mission to the Mun to check on my side.

When i try going into the Geology's lab UI - Show ... i get this in the KSP Log:

[EXC 21:11:34.430] NullReferenceException: Object reference not set to an instance of an object

WildBlueIndustries.WBIGeologyLab.drawAbundanceGUI ()

WildBlueIndustries.WBIGeologyLab.DrawOpsWindow ()

WildBlueIndustries.WBIMultiConverter.drawTemplateOps ()

WildBlueIndustries.OpsView.DrawWindowContents (Int32 windowId)

WildBlueIndustries.Window`1[T].PreDrawWindowContents (Int32 windowId)

UnityEngine.GUILayout+LayoutedWindow.DoWindow (Int32 windowID)

UnityEngine.GUI.CallWindowDelegate (UnityEngine.WindowFunction func, Int32 id, UnityEngine.GUISkin _skin, Int32 forceRect, Single width, Single height, UnityEngine.GUIStyle style)

[ERR 21:11:34.430] GUI Error: You are pushing more GUIClips than you are popping. Make sure they are balanced)

[EXC 21:11:34.476] NullReferenceException: Object reference not set to an instance of an object

WildBlueIndustries.WBIGeologyLab.drawAbundanceGUI ()

WildBlueIndustries.WBIGeologyLab.DrawOpsWindow ()

WildBlueIndustries.WBIMultiConverter.drawTemplateOps ()

WildBlueIndustries.OpsView.DrawWindowContents (Int32 windowId)

WildBlueIndustries.Window`1[T].PreDrawWindowContents (Int32 windowId)

UnityEngine.GUILayout+LayoutedWindow.DoWindow (Int32 windowID)

UnityEngine.GUI.CallWindowDelegate (UnityEngine.WindowFunction func, Int32 id, UnityEngine.GUISkin _skin, Int32 forceRect, Single width, Single height, UnityEngine.GUIStyle style)

When i try open the modify Drill dialog:

[EXC 21:16:36.338] ArgumentOutOfRangeException: Argument is out of range.

Parameter name: index

System.Collections.Generic.List`1[system.Int32].get_Item (Int32 index)

WildBlueIndustries.DrillSwitchWindow.drawGroundDrills ()

WildBlueIndustries.DrillSwitchWindow.DrawWindowContents (Int32 windowId)

WildBlueIndustries.Window`1[T].PreDrawWindowContents (Int32 windowId)

UnityEngine.GUILayout+LayoutedWindow.DoWindow (Int32 windowID)

UnityEngine.GUI.CallWindowDelegate (UnityEngine.WindowFunction func, Int32 id, UnityEngine.GUISkin _skin, Int32 forceRect, Single width, Single height, UnityEngine.GUIStyle style)

[ERR 21:16:36.338] GUI Error: You are pushing more GUIClips than you are popping. Make sure they are balanced)

i can see what looks like the corner of a couple controls in the upper left corner of the dialog window. Also, any new dialog i want to open, like the KIS inventory gets put into that gui window of the drill that won't go away.

I know i said nothing appeared in the log earlier... i was looking in the wrong log :/ my bad

Edited by Denko666
correction

Share this post


Link to post
Share on other sites

It is a custom planet? That would explain a lot! I have not tested the mod with a custom planet. Does your planet have a biome? Do you know if it has resources?

Share this post


Link to post
Share on other sites

Cool, thanks for the link, that will help. Did you send either the Terrain or the stock M700 scanner to polar orbit before trying to use the drill? If so, did you toggle the overlay so that it would appear?

Share this post


Link to post
Share on other sites
Cool, thanks for the link, that will help. Did you send either the Terrain or the stock M700 scanner to polar orbit before trying to use the drill? If so, did you toggle the overlay so that it would appear?

I'll check the overlay, usually i use scansat's mapview.

I have a TERRAIN, multispectral and Deja-vu in polar orbit around that planet.

Share this post


Link to post
Share on other sites

I can modify the drill on the Mun...

But the Manage Operations - Show of the geology lab is screwed both on asclepius and the Mun.

Also: none of the scanners seem to work properly on any planert AND, i get this when going into the tracking station:

[LOG 16:50:36.597] [PlanetariumCamera]: Focus: Kruel

[LOG 16:50:36.609] [PlanetariumCamera]: Focus: Asclepius

[EXC 16:50:36.616] NullReferenceException: Object reference not set to an instance of an object

ResourceMap.GetResourceItemList (HarvestTypes harvest, .CelestialBody body)

KnowledgeBase.CreateResourceList ()

KnowledgeBase.OnMapFocusChange (.MapObject target)

EventData`1[MapObject].Fire (.MapObject data)

PlanetariumCamera.SetTarget (.MapObject tgt)

Kopernicus.MapViewFixer.LateUpdate ()

[EXC 16:50:36.626] NullReferenceException: Object reference not set to an instance of an object

SpaceTracking.DrawGUI ()

RenderingManager.OnGUI ()

[EXC 16:50:36.628] NullReferenceException: Object reference not set to an instance of an object

SpaceTracking.DrawGUI ()

RenderingManager.OnGUI ()

sooo.... i think i'm gonna remove the Asclepius mod.

Share this post


Link to post
Share on other sites
Hello,

I could not run the Ironworks Foundry, Ionly get "No processors are present in this configuration" in the "processors" area. the Ironworks Foundry has energy, MetallicOre, metal and storage spaces ...

A screen of the base :

http://s11.postimg.org/7362fz9b7/screenshot5.png

Is something missing ?

Did you recently update the mod and copy over an install?

Go to the folder in gamedata:

WildBlueIndustries >> Pathfinder >> Templates >> Production

Open the file there labeled 'IronWorks'

Get the first few lines of the file and past them in a

 box.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.