Jump to content

[1.12.3] Bluedog Design Bureau - Stockalike Saturn, Apollo, and more! (v1.10.4 "Луна" 19/July/2022)


CobaltWolf
 Share

Recommended Posts

Can you clarify "save breaking changes"? Does this mean any saves I have that contain any BDB parts will no longer work? If so I'm totally screwed as I play sandbox and depend on all my bases/stations/crafts being exactly as I left them each time I play.

Edited by MikeO89
Link to comment
Share on other sites

10 minutes ago, Poodmund said:

 You should be really proud of this stuff, Cobalt.

Not only do I agree whole heartedly....  I can't wait to start a new play-through... cept I have to DL the LDC parts you have so Github version it is :)

1 minute ago, MikeO89 said:

Can you clarify "save breaking changes"? Does this mean any saves I have that contain any BDB parts will no longer work? If so I'm totally screwed.

Typically that means a part has Been Depreciated and removed (Atlas and Atlas V + CEntaur parts all come to mind.)   Several Decouplers and fairingbases also had name changes.

 

Link to comment
Share on other sites

2 minutes ago, MikeO89 said:

Can you clarify "save breaking changes"? Does this mean any saves I have that contain any BDB parts will no longer work? If so I'm totally screwed.

There's a risk that crafts might not load, we tried to not remove / break old parts but it may have been necessary at some point. There are also tech tree balance improvements that might lead to a part needing to be re-unlocked or something like that.

Link to comment
Share on other sites

1 hour ago, MikeO89 said:

Can you clarify "save breaking changes"? Does this mean any saves I have that contain any BDB parts will no longer work? If so I'm totally screwed as I play sandbox and depend on all my bases/stations/crafts being exactly as I left them each time I play.

Atlas V, Delta II, some Titan variants, most Saturn variants, about 90% of all versatile upper stages (Centaur, Star, Antares etc.), all strap-on SRBs except Titan I and III's, the Gemini lander and some other miscellaneous stuff off the top of my head, it's also worth noting that all Titan variants will be revamped and Diamant will be removed in the next update. Crafts like Apollo, Gemini, Mercury, Skylab and probes will be unaffected.

Edited by golkaidakhaana
Link to comment
Share on other sites

40 minutes ago, sslaptnhablhat said:

Atlas V, Delta II, some Titan variants, most Saturn variants, about 90% of all versatile upper stages (Centaur, Star, Antares etc.), all strap-on SRBs except Titan I and III's, the Gemini lander and some other miscellaneous stuff off the top of my head, it's also worth noting that all Titan variants will be revamped and Diamant will be removed in the next update. Crafts like Apollo, Gemini, Mercury, Skylab and probes will be unaffected.

Excuse me what.

Link to comment
Share on other sites

Wow. Little (no, a lot) scared on this one, I may have to skip this version and just keep what I got. I have probably 30 bases and 5 space stations and probably 75% of them have some BDB  parts on them somewhere.  With the time I have invested in all of it, If I lost all or some of those, I would probably commit space suicide and the Kerbies would have to cremate my ass and spread my ashes on Minmus.

Edited by MikeO89
Link to comment
Share on other sites

1 minute ago, MikeO89 said:

Wow. Little (no, a lot) scared on this one, I may have to skip this version. I have probably 30 bases and 5 space stations and probably 75% of them have some BDB  parts on them somewhere.  With the time I have invested in all of it, If I lost all or some of those, I would probably commit space suicide and the Kerbies would have to cremate my ass.

All you need to find out is make a copy of your save and load that with the update. If something breaks, decide if you want to try replacing those parts or go back to the old version and load your original save.

Link to comment
Share on other sites

I found a bug: engines with verniers, such as Vanguard engines, and parts with multiple "moduleenginesfx" in general can activate only one engine (module) at a time: only the main engine or only the vernier engines.

It's a game bug and is not due to BDB.

Who found a solution please answer.

Link to comment
Share on other sites

1 hour ago, Gapone said:

I found a bug: engines with verniers, such as Vanguard engines, and parts with multiple "moduleenginesfx" in general can activate only one engine (module) at a time: only the main engine or only the vernier engines.

It's a game bug and is not due to BDB.

Who found a solution please answer.

Spacebar

Link to comment
Share on other sites

I'm enjoying the mod, but there's an issue that's bugging me. According to an image post a while back, the pog probe core is supposed to represent pioneer 5, and maybe explorer 6 as well. The one thing that's bugging me the most is the fact that there isn't any bottom piece that fits well, as pioneer 5 was spherical!

Link to comment
Share on other sites

3 hours ago, mr. engino said:

I'm enjoying the mod, but there's an issue that's bugging me. According to an image post a while back, the pog probe core is supposed to represent pioneer 5, and maybe explorer 6 as well. The one thing that's bugging me the most is the fact that there isn't any bottom piece that fits well, as pioneer 5 was spherical!

As seen in the "assembled" picture (Linked below) there is a seperate half sphere for use with it.  IDK the name of the part however...

 

Link to comment
Share on other sites

9 minutes ago, Pappystein said:

As seen in the "assembled" picture (Linked below) there is a seperate half sphere for use with it.  IDK the name of the part however...

 

I saw the part in the picture, but I have found nothing like that in the vab.

Link to comment
Share on other sites

9 hours ago, Jso said:

Spacebar

You didn't understand me: when i activate the engine via staging, only the main engine activates and not the verniers.

p.s. some parts have not defined bulkheadProfiles and it does lead to some weird NREs in the advanced filters>filter by size editor tab.

Edited by Gapone
Link to comment
Share on other sites

3 minutes ago, Gapone said:

You didn't understand me: when i activate the engine via staging, only the main engine activates and not the verniers.

p.s. some parts have not defined bulkheadProfiles and it does lead to some weird NREs in the advanced filters>filter by size editor tab.

You even said yourself that this is an issue with KSP, so why are you reporting it here?

Link to comment
Share on other sites

1 minute ago, sslaptnhablhat said:

You even said yourself that this is an issue with KSP, so why are you reporting it here?

I dunno :/. I actually have reported this in Tantares thread, and recieved similiar comments :D

Link to comment
Share on other sites

55 minutes ago, Cheesecake said:

@JsoDo you have plans for an updated PF-config? There are some parts missing/incorrect like the Atlas V 5m-fairing base

Yeah. I'm going to need to swap some nodes around to get the Atlas V 5xx base working. Is that the only one  not working?

Link to comment
Share on other sites

8 minutes ago, Jso said:

Yeah. I'm going to need to swap some nodes around to get the Atlas V 5xx base working. Is that the only one  not working?

Here is a list of the issues:

Muo 5xx 3.5 Fairingbase --> nodes to low
WOgO73m.png


Daleth-P Fairing Adapter --> nodes are too high
gQ9SYMJ.png


Sarnus-SII-5625 Fairingbase --> nodes a little bit to low
1Gfo41p.png


Sarnus-SIV-3125 Fairingbase --> nodes a little bit to low
lXqur2W.png


Sarnus-SIVB-375 Fairingbase --> nodes a little bit to low
SWsJMoV.png


Sarnus-SIVB-375 Interstage --> nodes a little bit to low
S0uL7xH.png

Link to comment
Share on other sites

1 minute ago, Deltac said:

I've searched through all of BDB parts twice now and I can't find this mysterious sphere half.  The O.R.B. must be complete!

I can confirm this, there is no part and where. In the picture it looks like a part of procedural parts.

Link to comment
Share on other sites

5 hours ago, Barzon Kerman said:

With the Peacekeeper missile, whenever I launch, it says there is no SAS control, even though I have the Peacekeeper PBV and the new rectangular probe core.

um..  Loading KSP as we speak so I can't check this just this second but my last launch (prior to the final release of 1.5.0) did not say that.  

So I Just built a MX with the OGO Cubic probe core and the MX parts only (no decoupler for the probe core and my custom SR-118 stage)  Pictures here:

 

Q6VeEE0.jpg

wXmPIYu.jpg

FxWDszF.jpg

 

I had no errors and no issues so I would look at your install @Barzon Kerman you might have a mod conflict or something.

and yes I just installed KVV and I have something wrong to figure it out... but atleast the OFFSET view worked(ish)

Edited by Pappystein
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...