Jump to content

[1.12.3] Bluedog Design Bureau - Stockalike Saturn, Apollo, and more! (v1.11.0 "вне" 22/Oct/2022)


CobaltWolf
 Share

Recommended Posts

1 hour ago, OrbitalManeuvers said:

Would any kind soul be willing to share a some VAB pictures of how you're using the Belle MPA? Since I finally figured out Fore By Throttle today, I figured I should tackle my other current mystery ... which this part.

That's how I use it:

@PART[bluedog_Agena_MultiPayloadAdapter]:AFTER[Bluedog_DB]
{
  @node_stack_bottom = 0.0, 0.29838, 0.0, 0.0, -1.0, 0.0, 1
  node_stack_bottom2 = 0.0, -0.55162, 0.0, 0.0, -1.0, 0.0, 1
}

@PART[bluedog_Agena_StandardFairingBase]:AFTER[Bluedog_DB]
{
  node_stack_MPA = 0.0, 0.921487, 0.0, 0.0, 1.0, 0.0, 0
}

@PART[bluedog_Agena_SAC]:AFTER[Bluedog_DB]
{
  node_stack_MPA = 0.0, 0.921487, 0.0, 0.0, 1.0, 0.0, 0
}

It adds an extra node to both Belle 4900 bases (stock and SAF) and moves MPA's decoupling node to the top. Basically it copies Knes Ariane 5 MPA. It also adds an extra non-decoupling node to the MPA, to allow some non-standard usage.

Use is simple: build bottom payload (use the MPA node as a height limiter), attach MPA, attach top payload to MPA.

Or attach a Star SRM (or any 0.625m engine) to the top node, and use it as a Burner stage\satellite bus\lander\whatever you like.

Link to comment
Share on other sites

1 hour ago, OrbitalManeuvers said:

Zorg's Agena from earlier reminded me of a build I wanted to redesign. Here's an Atlas-Agena delivering a rover to the moon.

  Hide contents

 

jqhrdGH.png

RF6IGr8.png

qxrlqZA.png

rmD4kyP.png

JRAliXr.png

9iO0zHV.png

44pBx95.png

 

Actually this was a plan for Atlas V light (Sorry, I can't remember its actual name) which cancelled very early like Delta IV small but as I remember it was a larger tank version of Agena with the same engine as Agena-droptank and agena was exposed in the same maner as Atlas V 4xx.

Link to comment
Share on other sites

40 minutes ago, derega16 said:

Actually this was a plan for Atlas V light (Sorry, I can't remember its actual name) which cancelled very early like Delta IV small but as I remember it was a larger tank version of Agena with the same engine as Agena-droptank and agena was exposed in the same maner as Atlas V 4xx.

err close,  It had a similarly sized, Tankage and Guidance of the 'Growth Agena" I mentioned earlier... evolved through the Lockheed Spy Sat program (IE taking lessons from KH-9) but the engine was not a Textron Bell Rocket.   It was discussed earlier, during the Titan evolution (so BDB 1.6x) but I don't remember what the Agena 2000 engine was supposed to be.

Link to comment
Share on other sites

10 hours ago, Invaderchaos said:

Haven't posted to the forums in a while, but not sure if anyone posted pics of it yet. There are Delta IV color variants now! 4m DCSS/5m DCSS/Delta IV come in white and blue now. Here's some pics:

Finally a true (blue) Delta IV is possible.

I haven't said this enough recently.   @Zorg and @Invaderchaos   I am really NOT a fan of the IRL Delta IV.   Lets make a new Titan that is Hydrolox and call it Delta?  What?   :P   But the work you have both done bringing this to life, and what @blowfish did for the DCSS earlier this/last year have made an amazing piece of art to add to BDB... even if the real life one can go hang! :D   The ONLY part of the entire "Delta IV" I have ever been interested in is the stinkin RS-68 engine.   Not only was that made... in triplicate (or was it quadruplicate?)  but you even made color switching tanks!    Thanks for each of your work on this beautiful Rocket.   I can't wait to scavenge it for parts for my own rockets, cause TBH I probably won't fly more than 3 or 4 Delta IV rockets ever in KSP.  But who knows!

 

Oh and I haven't Downloaded the Dev in a few days so I don't know if this was fixed or not but the Delta IV Heavy seperator is tagged and labled as a Titan part in the Dev Build I have downloaded ATM.

 

 

Edited by Pappystein
Link to comment
Share on other sites

26 minutes ago, Gojira said:

Is anyone else not seeing the Delta IV's first-stage engine plume with RealPlume installed?

I've not seen any issues in either KSp 1.8.1 no 1.10.1,  make sure that your B9 part switch and BDB dev install is up to date. If it is and there is still a problem, please post your module manager log and modulemanager.configcache files. 

Link to comment
Share on other sites

5 hours ago, MashAndBangers said:

The Upper Stage Thrust Buff doesn't seem to work with the RL-10 engines.  The other engines have their max thrust boosted, but the RL-10 family seems to get reverted somehow.  I made sure I'm using the latest everything for 1.10.1.  BDB Dev Build of course :P

That patch requires everything to be buffed to be specifically named in the patch. I guess its not yet been updated for the new RL10s (and Vega as well).

Link to comment
Share on other sites

@Zorg, @CobaltWolf, would that be possible to make a variant of LR-79 with an integrated steering nozzle? I always disliked the way the Jupiter one is set up, but I assumed it was because switching a gimbaled nozzle on and off was not possible. However, the RS-68 does include that functionality, so it's not that.

I'm asking because having the nozzle as a separate part, besides making no sense (the exhaust nozzle is part of the engine IRL), can lead to silly results with a part failure mod, which can cause either of them to fail separately. 

Link to comment
Share on other sites

1 hour ago, Dragon01 said:

@Zorg, @CobaltWolf, would that be possible to make a variant of LR-79 with an integrated steering nozzle? I always disliked the way the Jupiter one is set up, but I assumed it was because switching a gimbaled nozzle on and off was not possible. However, the RS-68 does include that functionality, so it's not that.

I'm asking because having the nozzle as a separate part, besides making no sense (the exhaust nozzle is part of the engine IRL), can lead to silly results with a part failure mod, which can cause either of them to fail separately. 

you mean S-3D? 

Link to comment
Share on other sites

11 hours ago, Zorg said:

That patch requires everything to be buffed to be specifically named in the patch. I guess its not yet been updated for the new RL10s (and Vega as well).

Actually, they are in the patch.  I checked and double checked, and the proper names are there! :o

 

*long drawn out sigh of frustration*   So the old RL-10's don't indicate in the config they are deprecated. 

 

I love these change notes:

1cf16e914759b42b4de0344b78265606.png

Edited by MashAndBangers
Link to comment
Share on other sites

56 minutes ago, Hypercore said:

Problem: Tweakscale errors
Using latest version of ksp
Over 900 showstopping errors, all from bdb from what I can see (uninstalled then problem disappears)

KSP.log: https://gofile.io/d/PJFuRF

Posted problem on tweakscale forum to no results
 

First off, thank you for posting the log as you did! :D

Couple things here.   Tweakscale is going through some major BETA releases right now.   And with the initial 1.10.1 release/beta of Tweakscale I only get 29* (mind you Because of all the issues with Tweakscale that are being diligently worked on, I am not currently using Tweakscale.)      This leads me to draw one of two   Three conclusions.

1) The version of Tweakscale you are using is incorrect for your KSP version (or incorrectly installed as there are about 5 other folders that need to be installed [going from memory so it may be 2 or 3])

2) If you are using the latest Beta, then it might be interacting with A DIFFERENT mod that is somehow blocking BDB functionality

3) you have something wrong with any/all of the Tweakscale patches under Bluedog_DB\Compatibility\Tweakscale

3A) Your BDB install was missing the above folder.

 

I hope this helps you in some way Hypercore.   I had to stop using Tweakscale because it was causing my monster PC to chug slower than the little train that thought it could.   Mind you I am running JNSQ with all sorts of Vis effect mods.

I am not the best at reading logs so I will leave that to someone else (cause I will likely miss about a hundred things.)  But I was concerned that in just the first few lines it says you are having problems with several other mods.

*many of the 29 parts in question were ones that I have modified in some way shape or form.

 

Link to comment
Share on other sites

3 hours ago, Pappystein said:

First off, thank you for posting the log as you did! :D

Couple things here.   Tweakscale is going through some major BETA releases right now.   And with the initial 1.10.1 release/beta of Tweakscale I only get 29* (mind you Because of all the issues with Tweakscale that are being diligently worked on, I am not currently using Tweakscale.)      This leads me to draw one of two   Three conclusions.

1) The version of Tweakscale you are using is incorrect for your KSP version (or incorrectly installed as there are about 5 other folders that need to be installed [going from memory so it may be 2 or 3])

2) If you are using the latest Beta, then it might be interacting with A DIFFERENT mod that is somehow blocking BDB functionality

3) you have something wrong with any/all of the Tweakscale patches under Bluedog_DB\Compatibility\Tweakscale

3A) Your BDB install was missing the above folder.

 

I hope this helps you in some way Hypercore.   I had to stop using Tweakscale because it was causing my monster PC to chug slower than the little train that thought it could.   Mind you I am running JNSQ with all sorts of Vis effect mods.

I am not the best at reading logs so I will leave that to someone else (cause I will likely miss about a hundred things.)  But I was concerned that in just the first few lines it says you are having problems with several other mods.

*many of the 29 parts in question were ones that I have modified in some way shape or form.

 

Hi, and thanks for your help! Unfortunately, the solutions you presented didn't work for me. Hope someone more experienced will come!

Link to comment
Share on other sites

4 hours ago, Hypercore said:

Hi, and thanks for your help! Unfortunately, the solutions you presented didn't work for me. Hope someone more experienced will come!

The "showstopper" bug happens when two patches try to patch the same part. In this case it appears you have installed BDB twice into two different locations. Make sure that BDB is only at GameData/Bluedog_DB

Link to comment
Share on other sites

22 hours ago, Dragon01 said:

@Zorg, @CobaltWolf, would that be possible to make a variant of LR-79 with an integrated steering nozzle? I always disliked the way the Jupiter one is set up, but I assumed it was because switching a gimbaled nozzle on and off was not possible. However, the RS-68 does include that functionality, so it's not that.

I'm asking because having the nozzle as a separate part, besides making no sense (the exhaust nozzle is part of the engine IRL), can lead to silly results with a part failure mod, which can cause either of them to fail separately. 

Cobalt would have the final word on this since he made that engine, its not necessarily straightforward given the engine was made without that setup in mind even *if* he wanted to.

Edited by Zorg
Link to comment
Share on other sites

Please help! I upgraded from 1.9.0.2781 to 1.10.1.2939 so that I could download BDB. I couldn't get it to download using CKAN for either version because one or more add-ons/plug-ins were not compatible. I am a newbie. What am I doing wrong? Do I need to get 1.10.99? If so how do I get it. This stuff is as clear as mud.

Link to comment
Share on other sites

15 minutes ago, DaveyJ576 said:

Please help! I upgraded from 1.9.0.2781 to 1.10.1.2939 so that I could download BDB. I couldn't get it to download using CKAN for either version because one or more add-ons/plug-ins were not compatible. I am a newbie. What am I doing wrong? Do I need to get 1.10.99? If so how do I get it. This stuff is as clear as mud.

um,  err.  Don't use CKAN?

 

Sorry BDB is one of many mods that CKAN does not do well with as the development cycles are long and BDB's main release may not be "up to date"    if you want to use CKAN with the release (not the development version) you can roll back to an older KSP by (in steam at-least) going to the BETA tab when right clicking on KSP in your steam library.

 

I have not used CKAN in 4 years so IDK if this will still work,  But back 4 years ago you could manually copy files in... CKAN just can't manage them.      

Link to comment
Share on other sites

31 minutes ago, DaveyJ576 said:

Please help! I upgraded from 1.9.0.2781 to 1.10.1.2939 so that I could download BDB. I couldn't get it to download using CKAN for either version because one or more add-ons/plug-ins were not compatible. I am a newbie. What am I doing wrong? Do I need to get 1.10.99? If so how do I get it. This stuff is as clear as mud.

It should work. We don't maintain the CKAN configuration here so try asking in the CKAN thread.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...