Jump to content

[1.12.5] Bluedog Design Bureau - Stockalike Saturn, Apollo, and more! (v1.12.0 "Песок" 13/Jan/2023)


CobaltWolf
 Share

Recommended Posts

What is this a crossover episode? Apollo capsule +Dragon2 Aerodynamic+Starliner style LES (with ring of 32 Super-Dracos) that somehow looks like Shenzou Delta-V about 1100 m/s capable of unmanned launch and flight (but not return as drone core is in USII service module) . Now have some problem with LV it suppose to be fusion between saturn and new glenn but near-fully-reuseable with only space craft/payload adapter expended for inflatable heat shield that somehow keeps explode on adapter jettison


1MaOtBZ.jpg

Edited by derega16
Link to comment
Share on other sites

4 hours ago, derega16 said:

What is this a crossover episode? Apollo capsule +Dragon2 Aerodynamic+Starliner style LES (with ring of 32 Super-Dracos) that somehow looks like Shenzou Delta-V about 1100 m/s capable of unmanned launch and flight (but not return as drone core is in USII service module) . Now have some problem with LV it suppose to be fusion between saturn and new glenn but near-fully-reuseable with only space craft/payload adapter expended for inflatable heat shield that somehow keeps explode on adapter jettison


1MaOtBZ.jpg

Delete this right now.

Gangsta Grandma Blank Template - Imgflip

Edited by alberro+
Link to comment
Share on other sites

15 hours ago, biohazard15 said:

What part is that short white tank between engine and LDC tanks?

That'd be a Rockomax X200-8 fuel tank.  Likely with Restock colouring and a bit of tweakscale.

I think I'll add an unofficial BDB Delta IV guide to the unofficial part of the unofficial BDB wiki alongside the existing unofficial Restock one.  Unofficially, of course.

Edited by Friznit
Link to comment
Share on other sites

17 hours ago, Joe.L said:

has anyone got a good tutorial on how to use the correct fuel and what to add with what on each tank, i'm struggling a bit to get it into the air...

The vast majority of engines in BDB use Liquid Fuel and Oxidizer (LFO) just like stock engines. There are a few engines that use Liquid Hydrogen and Oxidizer (LH2O) and some that run on Monoprop only. You can see which fuel type the engine uses by right clicking on the part in the part list in the VAB.

In BDB most fuel tanks are LFO by default but you can switch it to LH2O if you  would rather use an engine that requires it. 

Some tanks which in real life would be Cryogenic have LH2O by default but if you would rather use a different engine simply switch the fuel in the tank to LFO or whatever.

I am assuming you arent using another fuel mod like RealFuels or something.

Link to comment
Share on other sites

On 7/27/2020 at 4:27 PM, Beetlecat said:

You're probably running KSP 1.10?

That part won't load due to a stock bug (waiting on 1.10.1 for that fix) -- you have to remove that part, or roll your game back to 1.9.1.

I think it stopping there may not be the real problem now.  I'm on 1.10.1.2939 and I'm getting a *TON* of AVC errors in the log when it stalls at the Solar Antenna (although it's the Ranger part before that actually is where the "issue" starts).

Spoiler

[LOG 07:02:08.019] KSP-AVC -> System.ArgumentException: Getting control 4's position in a group with only 4 controls when doing repaint
Aborting
  at UnityEngine.GUILayoutGroup.GetNext () [0x000a2] in <fa6f9762ac624af092525d37c9d516c4>:0
  at UnityEngine.GUILayoutUtility.DoGetRect (UnityEngine.GUIContent content, UnityEngine.GUIStyle style, UnityEngine.GUILayoutOption[] options) [0x00150] in <fa6f9762ac624af092525d37c9d516c4>:0
  at UnityEngine.GUILayoutUtility.GetRect (UnityEngine.GUIContent content, UnityEngine.GUIStyle style, UnityEngine.GUILayoutOption[] options) [0x00001] in <fa6f9762ac624af092525d37c9d516c4>:0
  at UnityEngine.GUILayout.DoToggle (System.Boolean value, UnityEngine.GUIContent content, UnityEngine.GUIStyle style, UnityEngine.GUILayoutOption[] options) [0x00001] in <fa6f9762ac624af092525d37c9d516c4>:0
  at UnityEngine.GUILayout.Toggle (System.Boolean value, System.String text, UnityEngine.GUIStyle style, UnityEngine.GUILayoutOption[] options) [0x00008] in <fa6f9762ac624af092525d37c9d516c4>:0
  at KSP_AVC.DropDownList.DrawButton (System.String label, UnityEngine.Rect parent, System.Single width) [0x0001d] in <8584149d963f4e09b44fc3fb1513ee6f>:0
  at KSP_AVC.IssueGui.DrawActionButton (KSP_AVC.Addon addon) [0x00050] in <8584149d963f4e09b44fc3fb1513ee6f>:0
  at KSP_AVC.IssueGui.DrawUpdateIssues () [0x0006e] in <8584149d963f4e09b44fc3fb1513ee6f>:0
  at KSP_AVC.IssueGui.Window (System.Int32 id) [0x00030] in <8584149d963f4e09b44fc3fb1513ee6f>:0
[EXC 07:02:08.026] NullReferenceException: Object reference not set to an instance of an object
    UnityEngine.GUILayoutEntry.ApplyStyleSettings (UnityEngine.GUIStyle style) (at <fa6f9762ac624af092525d37c9d516c4>:0)
    UnityEngine.GUILayoutGroup.ApplyStyleSettings (UnityEngine.GUIStyle style) (at <fa6f9762ac624af092525d37c9d516c4>:0)
    UnityEngine.GUILayoutEntry.set_style (UnityEngine.GUIStyle value) (at <fa6f9762ac624af092525d37c9d516c4>:0)
    UnityEngine.GUILayoutUtility.BeginWindow (System.Int32 windowID, UnityEngine.GUIStyle style, UnityEngine.GUILayoutOption[] options) (at <fa6f9762ac624af092525d37c9d516c4>:0)
    UnityEngine.GUI.CallWindowDelegate (UnityEngine.GUI+WindowFunction func, System.Int32 id, System.Int32 instanceID, UnityEngine.GUISkin _skin, System.Int32 forceRect, System.Single width, System.Single height, UnityEngine.GUIStyle style) (at <fa6f9762ac624af092525d37c9d516c4>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

I'm going to uninstall AVC and see if that fixes the problem.

Edited by CAPFlyer
New Info
Link to comment
Share on other sites

Well, that fixed one problem.  Now I'm still getting the drag cube errors on the BDB parts, but it stalls at the Solar Antenna without throwing an additional error other than it's creating the drag cubes, which it did for all the parts prior to it without problem.

Link to comment
Share on other sites

Okay, maybe this can actually be constructive.  Here's the log error I'm getting in 1.10.1.2939 -

Quote

[EXC 10:36:23.159] NullReferenceException: Object reference not set to an instance of an object
    ModuleDeployablePart.AssumeDragCubePosition (System.String name) (at <c1858a3f77504bd1aaa946fdccf84670>:0)
    DragCubeSystem+<RenderDragCubes>d__34.MoveNext () (at <c1858a3f77504bd1aaa946fdccf84670>:0)
    UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at <5aeafee3fea24f37abd1315553f2cfa6>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

 

Link to comment
Share on other sites

On 7/29/2020 at 3:43 AM, Bellabong said:

There is literally only one part that's "broken" when it comes to RF (the most flexible) at least and that's the Thor/Delta tank extensions. No need to rip out a feature that helps BDB conserve on part count. 

 

EDIT: In your case it'd be better to just add your fuel type to B9 tank configs and then patch that config into BDB parts.

 

I will add that I have added 12 different Fuel Oxidizer types to BDB with ZERO issues by doing this.   *THIS is the most flexible fuel system because you can add anything to it without having some DEV somewhere else create a new update just for you

Thanks @blowfish  For making, Maintaining B9PartSwitch!

Thanks to both blowfish and the BDB devs for putting up with my silly questions on this. :D   

 

Link to comment
Share on other sites

Went in log, found the last references to "bluedog.solarAntenna", if you want I can upload the whole log file but here's the last thing it has before I Alt+F4ed due to a lack of progress for 5 minutes


PartLoader: Compiling Part 'Bluedog_DB/Parts/Antennas/bluedog_solarAntenna/bluedog_solarAntenna'
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

PartLoader: Part 'Bluedog_DB/Parts/Antennas/bluedog_solarAntenna/bluedog_solarAntenna' has no database record. Creating.
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

[DragCubeSystem]: Drag cubes not found or cannot be read for part Part. Generating New drag cubes.
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

DragCubeSystem: Creating drag cubes for part 'bluedog.solarAntenna'
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

 

Like I said, it stopped doing anything for a good long while when it was loading "bluedog.solarAntenna" so I decided I'd just restart, still didn't load after that

Link to comment
Share on other sites

17 minutes ago, UnhorsedGoose said:

Went in log, found the last references to "bluedog.solarAntenna", if you want I can upload the whole log file but here's the last thing it has before I Alt+F4ed due to a lack of progress for 5 minutes


PartLoader: Compiling Part 'Bluedog_DB/Parts/Antennas/bluedog_solarAntenna/bluedog_solarAntenna'
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

PartLoader: Part 'Bluedog_DB/Parts/Antennas/bluedog_solarAntenna/bluedog_solarAntenna' has no database record. Creating.
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

[DragCubeSystem]: Drag cubes not found or cannot be read for part Part. Generating New drag cubes.
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

DragCubeSystem: Creating drag cubes for part 'bluedog.solarAntenna'
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

 

Like I said, it stopped doing anything for a good long while when it was loading "bluedog.solarAntenna" so I decided I'd just restart, still didn't load after that

Yup its a known issue with KSP 1.10 plus, you can delete the part (which is the only one causing a problem) or some people have suggested deleting partdabase.cfg in your KSP root folder and letting it rebuild might help. We dont have a permanent solution just yet.

Is this in KSP 1.10 or 1.10.1? I havent tested in KSP 1.10.1 yet.

Edited by Zorg
Link to comment
Share on other sites

Just now, Zorg said:

Yup its a known issue with KSP 1.10 plus, you can delete the part (which is the only one causing a problem) or some people have suggested deleting partdabase.cfg in your gamedata and letting it rebuild might help. We dont have a permanent solution just yet.

Is this in KSP 1.10 or 1.10.1? I havent tested in KSP 1.10.1 yet.

1.10.1, I can give that a shot real quick

Link to comment
Share on other sites

3 hours ago, Zorg said:

Yup its a known issue with KSP 1.10 plus, you can delete the part (which is the only one causing a problem) or some people have suggested deleting partdabase.cfg in your KSP root folder and letting it rebuild might help. We dont have a permanent solution just yet.

Is this in KSP 1.10 or 1.10.1? I havent tested in KSP 1.10.1 yet.

It's in 1.10.1.2329 (the most current released build through Steam).  I posted on this 3 posts above Goose, including the actual error being generated.  The one that Goose posted is a level up from what is actually causing that part to fail.  You have to wait a bit and let it error and then force-close the program to get it to generate the actual error.  Otherwise, it only shows just that it was generating the drag cubes and nothing more.

It also isn't the only part.  I commented out the Solar Antenna, and then it did the same thing on the Courier probe core:

Quote

[LOG 18:57:25.793] DragCubeSystem: Creating drag cubes for part 'bluedog.Courier.Core'
[EXC 18:57:25.853] NullReferenceException: Object reference not set to an instance of an object
    ModuleDeployablePart.AssumeDragCubePosition (System.String name) (at <c1858a3f77504bd1aaa946fdccf84670>:0)
    DragCubeSystem+<RenderDragCubes>d__34.MoveNext () (at <c1858a3f77504bd1aaa946fdccf84670>:0)
    UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at <5aeafee3fea24f37abd1315553f2cfa6>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

I have a feeling that those aren't the only two.  I think whatever is causing the error with the Solar Antenna and Courier Core will reveal itself as something that exists on some parts and so you can find out which ones will have a problem without having to test via failure.

Edited by CAPFlyer
Add log for Courier Core failure
Link to comment
Share on other sites

6 hours ago, CAPFlyer said:

It's in 1.10.1.2329 (the most current released build through Steam).  I posted on this 3 posts above Goose, including the actual error being generated.  The one that Goose posted is a level up from what is actually causing that part to fail.  You have to wait a bit and let it error and then force-close the program to get it to generate the actual error.  Otherwise, it only shows just that it was generating the drag cubes and nothing more.

It also isn't the only part.  I commented out the Solar Antenna, and then it did the same thing on the Courier probe core:

I have a feeling that those aren't the only two.  I think whatever is causing the error with the Solar Antenna and Courier Core will reveal itself as something that exists on some parts and so you can find out which ones will have a problem without having to test via failure.

yeah we were looking at the problem parts in the current official release as a matter of priority, dev branch will follow later (we have identified the problem parts of which there are several in dev, just the one in the release).

Link to comment
Share on other sites

Little something new, a 3.125m to 3.5m adapter fairing base to enable you to use the Atlas V 500 series fairing on LDC/Atlas CELV etc.

screen_2560x1920_2020-07-31_22-11-44.png

screenshot85.png?width=1364&height=767

screenshot86.png?width=1364&height=767

 

Also the github MASTER branch should have a fix for the none loading issue in KSP 1.10.1 for the current release although there are more problem parts in Dev which havent been dealt with yet. Stock type fairings are functional but the base textures are broken so 1.10.1 compatibility is still a work in progress. We would continue to recommend against updating if you wish to use BDB for now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...