Jump to content

[1.12.5] Bluedog Design Bureau - Stockalike Saturn, Apollo, and more! (v1.12.0 "Песок" 13/Jan/2023)


CobaltWolf
 Share

Recommended Posts

My B9PartSwitch ceased to function on BDB parts about a month ago (works for everything else), it stopped working overnight between play sessions. I didn't add any mods in that time.
I've been giving it some time, and working on some things to see if that would fix it and I've gotten nowhere. I'm on the latest-ish dev install, about a week or so ago I reinstalled my entire GameData folder and moved to 1.12.3 (the issue popped up in 1.11.2, thought maybe it was just the old version). I've even tried older versions of B9PS, which predictably also didn't work.
Log:
https://we.tl/t-4CY2cL4jnu
GameData
https://imgur.com/a/1WaZUh3

Thanks for any help you're able to provide!

Link to comment
Share on other sites

1 hour ago, cameronisher3 said:

My B9PartSwitch ceased to function on BDB parts about a month ago (works for everything else), it stopped working overnight between play sessions. I didn't add any mods in that time.
I've been giving it some time, and working on some things to see if that would fix it and I've gotten nowhere. I'm on the latest-ish dev install, about a week or so ago I reinstalled my entire GameData folder and moved to 1.12.3 (the issue popped up in 1.11.2, thought maybe it was just the old version). I've even tried older versions of B9PS, which predictably also didn't work.
Log:
https://we.tl/t-4CY2cL4jnu
GameData
https://imgur.com/a/1WaZUh3

Thanks for any help you're able to provide!

I dont quite understand how switches for BDB parts only would not work. Could you describe the problem in more detail?

What kind of switches arent working? Fuel switch, mesh switch (part variants), texture switch? All of them?

The only B9 errors in that log are related to something called universalBalloonHP which seems to be from Kerballoons I think. 

If you could clarify as above, and also post your modulemanager.configcache (the gamedata folder) we might be able to figure it out.

Link to comment
Share on other sites

Hi! 

How easy it would it be for me to make a white version of the apollo parachute mount/parachutes and maybe even the nosecone?  Perhaps someone already has made a patch/new config?  

Reason being, that models look great and fit very well with my crew vehicle design (looking like a love-child of a ATV and Crew dragon) but the mismatched colours just feel odd :D 

 

Any help/tips are much appreciated! 

Link to comment
Share on other sites

3 hours ago, Zorg said:

I dont quite understand how switches for BDB parts only would not work. Could you describe the problem in more detail?

What kind of switches arent working? Fuel switch, mesh switch (part variants), texture switch? All of them?

The only B9 errors in that log are related to something called universalBalloonHP which seems to be from Kerballoons I think. 

If you could clarify as above, and also post your modulemanager.configcache (the gamedata folder) we might be able to figure it out.

All of them. A buddy of mine had suggested to try deleting the ConfigCache and letting it regenerate. I gave it a go, it did not help. 

MM ConfigCache
https://we.tl/t-pQJ2cAJ0dQ
Screenshot for brevity sake 
https://imgur.com/a/3ry7kEp

Thanks for taking a look at this

Link to comment
Share on other sites

Welp, I've been away from ksp quite a while but I'm back.

Nice work adding an auto jettison module to the Atlas booster skirt,  that got me thinking "those Δv maps would be very handy if they were rearranged to show TWR at skirt jettison instead of fuel used by sustainer fuel ..."

Spoiler

So I went back to the matlab file and added a new plot to show the Δv like that
4tsvwv.png

gYdSuq8.png

Vertical axis shows the TWR at booster skirt jettison, black dotted horizontal lines show the TWR after booster skirt jettison.

Link to comment
Share on other sites

37 minutes ago, cameronisher3 said:

All of them. A buddy of mine had suggested to try deleting the ConfigCache and letting it regenerate. I gave it a go, it did not help. 

MM ConfigCache
https://we.tl/t-pQJ2cAJ0dQ
Screenshot for brevity sake 
https://imgur.com/a/3ry7kEp

Thanks for taking a look at this

I just took a look for instance at that Delta IV tank and all of the B9 modules are present and accounted for. I really cannot explain this behavior unfortunately and assume it must be some kind of conflict. I have no ideas apart from removing mods until the problem is resolved (best way would be to remove half the mods, see if the problem is fixed, if not remove the other half, and then keep halving once you find it until you narrow it down). Its time consuming and annoying due to dependencies but I dont know what else could be done.

Link to comment
Share on other sites

25 minutes ago, Zorg said:

I just took a look for instance at that Delta IV tank and all of the B9 modules are present and accounted for. I really cannot explain this behavior unfortunately and assume it must be some kind of conflict. I have no ideas apart from removing mods until the problem is resolved (best way would be to remove half the mods, see if the problem is fixed, if not remove the other half, and then keep halving once you find it until you narrow it down). Its time consuming and annoying due to dependencies but I dont know what else could be done.

Thank you for your time. I guess I better get to reinstalling all my mods again (but slowly this time!)

Very unkind of the game to break despite me not having changed anything in that time...

Edited by cameronisher3
Link to comment
Share on other sites

52 minutes ago, cameronisher3 said:

Thank you for your time. I guess I better get to reinstalling all my mods again (but slowly this time!)

Very unkind of the game to break despite me not having changed anything in that time...

just one more idea, since you say nothing updated, have you tried on a different save? Could be some kind of save corruption (wild guess here, idk much about the guts of the game)

Edited by Zorg
Link to comment
Share on other sites

4 hours ago, taniel0401 said:

Hi! 

How easy it would it be for me to make a white version of the apollo parachute mount/parachutes and maybe even the nosecone?  Perhaps someone already has made a patch/new config?  

Reason being, that models look great and fit very well with my crew vehicle design (looking like a love-child of a ATV and Crew dragon) but the mismatched colours just feel odd :D 

 

Any help/tips are much appreciated! 

They already have white variants.

Link to comment
Share on other sites

5 hours ago, taniel0401 said:

Hi! 

How easy it would it be for me to make a white version of the apollo parachute mount/parachutes and maybe even the nosecone?  Perhaps someone already has made a patch/new config?  

Reason being, that models look great and fit very well with my crew vehicle design (looking like a love-child of a ATV and Crew dragon) but the mismatched colours just feel odd :D 

 

Any help/tips are much appreciated! 

There will be a white Apollo (and indeed all new Apollo parts) next release which hopefully isnt too far away.

3 hours ago, Marcelo Silveira said:

Welp, I've been away from ksp quite a while but I'm back.

Nice work adding an auto jettison module to the Atlas booster skirt,  that got me thinking "those Δv maps would be very handy if they were rearranged to show TWR at skirt jettison instead of fuel used by sustainer fuel ..."

  Reveal hidden contents

So I went back to the matlab file and added a new plot to show the Δv like that
4tsvwv.png

gYdSuq8.png

Vertical axis shows the TWR at booster skirt jettison, black dotted horizontal lines show the TWR after booster skirt jettison.

Looking forward to these!

Link to comment
Share on other sites

2 hours ago, Zorg said:

just one more idea, since you say nothing updated, have you tried on a different save? Could be some kind of save corruption (wild guess here, idk much about the guts of the game)

This was a good idea. Unfortunately did not help. 

I might go bother the B9PS thread to see if they've got any ideas before undertaking the slow reinstalling (2 days of file manager). 

Link to comment
Share on other sites

4 hours ago, cameronisher3 said:

Screenshot for brevity sake 
https://imgur.com/a/3ry7kEp

sorry for butting in .. i looked at your screenshot and can't see what's wrong? You have the B9 group collapsed so I can't see what's in there, but other than the collapsed group and the fact that you have a couple mods I don't have, your PAW looks the same as mine?

Link to comment
Share on other sites

6 hours ago, taniel0401 said:

Hi! 

How easy it would it be for me to make a white version of the apollo parachute mount/parachutes and maybe even the nosecone?  Perhaps someone already has made a patch/new config?  

Reason being, that models look great and fit very well with my crew vehicle design (looking like a love-child of a ATV and Crew dragon) but the mismatched colours just feel odd :D 

 

Any help/tips are much appreciated! 

There should already be white variants of all the command module parts in the dev branch, along with Skylab and boilerplate variants.

Link to comment
Share on other sites

43 minutes ago, OrbitalManeuvers said:

sorry for butting in .. i looked at your screenshot and can't see what's wrong? You have the B9 group collapsed so I can't see what's in there, but other than the collapsed group and the fact that you have a couple mods I don't have, your PAW looks the same as mine?

I'd like to thank you for reminding me I'm a dumbass. Somehow that section was collapsed for only BDB parts across all of my saves and somehow survived a fresh install of literally everything.

@Zorg, thank you for your help. Turns out the help I need is an optometrist and not the KSP forums 

Link to comment
Share on other sites

8 minutes ago, cameronisher3 said:

I'd like to thank you for reminding me I'm a dumbass. Somehow that section was collapsed for only BDB parts across all of my saves and somehow survived a fresh install of literally everything.

@Zorg, thank you for your help. Turns out the help I need is an optometrist and not the KSP forums 

best post ever

Link to comment
Share on other sites

19 minutes ago, cameronisher3 said:

I'd like to thank you for reminding me I'm a dumbass. Somehow that section was collapsed for only BDB parts across all of my saves and somehow survived a fresh install of literally everything.

@Zorg, thank you for your help. Turns out the help I need is an optometrist and not the KSP forums 

Lol I didnt quite get the collapse of the partswitch was the problem, I thought you were clicking switches and it wasnt doing anything :P Anyway we all have our moments. glad its sorted out.

Link to comment
Share on other sites

21 minutes ago, cameronisher3 said:

I'd like to thank you for reminding me I'm a dumbass. Somehow that section was collapsed for only BDB parts across all of my saves and somehow survived a fresh install of literally everything.

@Zorg, thank you for your help. Turns out the help I need is an optometrist and not the KSP forums 

I have to say that it happened to me as well once and I too thought my version of B9 was broken, so that could be KSP doing typical KSP stuff

Edited by Beccab
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...