Jump to content

[1.8.1-1.10.1] Bluedog Design Bureau - Stockalike Saturn, Apollo, and more! (v1.7.1 "Огромный" 18/Oct/2020)


Recommended Posts

3 hours ago, CAPFlyer said:

Thanks for the suggestion.  I will try that as well here shortly and see if that changes anything.

To kinda help as well, here is a link to a series of images of what happens -

https://imgur.com/a/MO7fUGS

Changing the Alpha limit doesn't really help.  It seems like about the time I pass 25000pa Q there is a sudden alpha and pitch command change.  MaxQ is about 28000 - 30000pa.  I'm not finding a way with MechJeb to see what its commanding or why this change.  Again, any help will be appreciated.

I haven't used FAR since we got rid of the soup-o-sphere so I'm not really prepared to diagnose this, but I threw it in to see what happens and yes, it becomes uncontrollable at max q, which was about 35 kPa at mach 1.4 and 8,400 meters. However, the Juno 1st stage tank is filled at 80% by default. If I fill it to 100% I have no issues, and max q is 27.4 kPa at mach 1.5 and 10,500 meters. This is with classic ascent profile which is what you should be using with a Juno II. Set your top of climb so the apoapsis at first stage burnout is about where you want it (a test flight or two will be required). Then turn off the Ap and coast to apoapsis where you fire the 3 solid stages in sequence.

With PVG and the settings you're using there it got a little wobbly high up but didn't lose control. But it failed to orbit because PVG doesn't know how to fly a Juno II.

I'm in KSP 1.8.1 with JNSQ.

Link to post
Share on other sites
43 minutes ago, Jso said:

I haven't used FAR since we got rid of the soup-o-sphere so I'm not really prepared to diagnose this, but I threw it in to see what happens and yes, it becomes uncontrollable at max q, which was about 35 kPa at mach 1.4 and 8,400 meters. However, the Juno 1st stage tank is filled at 80% by default. If I fill it to 100% I have no issues, and max q is 27.4 kPa at mach 1.5 and 10,500 meters. This is with classic ascent profile which is what you should be using with a Juno II. Set your top of climb so the apoapsis at first stage burnout is about where you want it (a test flight or two will be required). Then turn off the Ap and coast to apoapsis where you fire the 3 solid stages in sequence.

With PVG and the settings you're using there it got a little wobbly high up but didn't lose control. But it failed to orbit because PVG doesn't know how to fly a Juno II.

I'm in KSP 1.8.1 with JNSQ.

I do have the tanks filled to 100% on the flight; forgot to mention that. I will try using classic and see what happens.

Link to post
Share on other sites

Digging the new ICPS.  Still blown away by the detail on all of the Delta IV parts.

E03852G.png

JAjcMO1.png

(Here's a list of the other mods pictured to avoid too many off-topic posts like last time lol)
ReDirect for the Orion MPCV
Sobol's SLS Part Pack for the Orion stage adapter
Textures Unlimited and Magpie Mods for the shiny texture on the capsule.

Edited by lemon cup
Link to post
Share on other sites

I've found a few bugs with Hexagon.

Firstly, the solar panels don't appear to generate any electric charge, causing the craft to run out of EC after a few orbits.

Secondly, when trying to detach the reentry capsules, they ended up inside the truss section they were detaching from. Thankfully timewarp fixed this.

screenshot391.png

Link to post
Share on other sites
2 hours ago, OrbitalManeuvers said:

Just tested this by putting a random probe in orbit with the solar panels attached, and they definitely generate EC. What does your PAW say when you right click on the solar panel?

For some reason they generate power edge on. I haven't figured out why.

4 hours ago, KeaKaka said:

Secondly, when trying to detach the reentry capsules, they ended up inside the truss section they were detaching from. Thankfully timewarp fixed this.

I've received several reports about that myself. I might need @Jso to take a look - as far as I know the nodes are good.

Link to post
Share on other sites

A couple of small bonus parts, wanted to fill out some of the free space on the DCSS texture sheet so it doesnt go to waste.

Dual payload adapters for Delta II and Delta IV/Atlas V

These are on Github now

screen_5120x2880_2020-11-04_20-37-30.png?width=1418&height=798

The Delta II one is available in two sizes and the lower mount on the larger one is available in 2.5m (to match the Delta IV fairing base) and 1.875m to match Centaur with the optional truss for Atlas V.

screenshot44.png?width=1418&height=798

screenshot46.png?width=1418&height=798

screenshot50.png?width=1418&height=798

screenshot52.png?width=1418&height=798

screenshot54.png?width=1418&height=798

screenshot55.png?width=1418&height=798

screenshot58.png?width=1418&height=798

 

Link to post
Share on other sites
1 hour ago, Zorg said:

A couple of small bonus parts, wanted to fill out some of the free space on the DCSS texture sheet so it doesnt go to waste.

Dual payload adapters for Delta II and Delta IV/Atlas V

These are on Github now

screen_5120x2880_2020-11-04_20-37-30.png?width=1418&height=798

Are these Kerbal designs or based on real hardware?

Edited by davidy12
Link to post
Share on other sites
12 minutes ago, davidy12 said:

Are these Kerbal designs or based on real hardware?

Its based on real hardware. The bigger one is a common system offered for both Atlas V and Delta IV 5m fairings. I also wanted to do the one for the Delta and Atlas 4m fairings (2.5m fairings in game) but didnt have the texture space. Perhaps together with some other adapter parts in the future.

unknown.png

Screenshot_2020-11-05_01.40.16.png?width

Screenshot_2020-11-05_01.40.21.png?width

unknown.png?width=1268&height=798

Screenshot_2020-11-05_01.41.23.png?width

Link to post
Share on other sites

asking for a friend, who is me. So I want to mess around with NeptuneCamera. It's my (likely faulty) understanding that I can write a custom cfg that will detect both the BDB camera part and NeptuneCamera, and allow me to add the module and its values. I believe the opening would have to be some FOR or NEEDS or WANTS or THINKSABOUT statement that I have no idea how to write. The inner part with the neptune params, that part I can handle. Does any of this sound close to correct? Is that a difficult statement for someone to plonk out? Idc which BDB camera, I think I just need a small head start and I should be able to figure out what to replace where/when ... if this is even possible in the first place? Please advise. Standing by.   N e e d   d i s t r a c t  i   o   n   

Link to post
Share on other sites
5 hours ago, OrbitalManeuvers said:

asking for a friend, who is me. So I want to mess around with NeptuneCamera. It's my (likely faulty) understanding that I can write a custom cfg that will detect both the BDB camera part and NeptuneCamera, and allow me to add the module and its values. I believe the opening would have to be some FOR or NEEDS or WANTS or THINKSABOUT statement that I have no idea how to write. The inner part with the neptune params, that part I can handle. Does any of this sound close to correct? Is that a difficult statement for someone to plonk out? Idc which BDB camera, I think I just need a small head start and I should be able to figure out what to replace where/when ... if this is even possible in the first place? Please advise. Standing by.   N e e d   d i s t r a c t  i   o   n   

you want a NEEDS[NeptuneCamera]. Most of the BDB cameras should now have a cameraTransform to target. The new Mariner 10 camera actually has 3 camera transforms; 1 for UV, and 2 for the main cameras for stereo imaging with Neptune. Im not at my PC right now so I cant recall the transform names right now but you can check them using DebugStuff. I'll post it on the github issue though when I have a moment.

https://github.com/CobaltWolf/Bluedog-Design-Bureau/issues/964

Just as a bit of additional info, FOR should only ever be used by the mod in question as when FOR is declared, MM will consider that the mod exists and every other patch that has a NEEDS for it will activate. This can cause all sorts of havoc as you can imagine.  As such FOR Bluedog_DB should only exist in BDB files and FOR NeptuneCamera should only exists in Neptunes files...etc

Link to post
Share on other sites
2 hours ago, Zorg said:

you want a NEEDS[NeptuneCamera].

OK .. I haven't done that :D  I really don't know the syntax, so no idea where that goes. Here's what I've done so far that doesn't work:

Spoiler

I have this in a cfg:

@PART[bluedog_mariner10_camera]
{
    MODULE
    {
    name = ModuleNeptuneCamera
    cameraTransformName = CameraMain
    cameraType = FULL_COLOUR
    cameraFieldOfView = 60
    cameraHorizontalResolution = 128
    cameraVerticalResolution = 128
    cameraHasErrors = True
    cameraErrorRate = 5
    cameraHasNoise = True
    cameraNoiseMaxStrength = 25
    cameraHasCustomNearClipPlane = True
    cameraCustomNearClipPlane = 0.01
    }
}
 

"CameraMain" comes from DebugTools and literally guessing among the hundreds of things it was showing. 

 

This results in

[LOG 00:07:36.799] Applying update CustomConfigs/neptune/@PART[bluedog_mariner10_camera] to Bluedog_DB/Parts/ProbeExpansion/Mariner10/bluedog_mariner10_camera.cfg/PART[bluedog_mariner10_camera]
 

But this clearly isn't right yet. I expect I shouldn't have all those PAW items, and it doesn't actually work in flight, so weeeeee for a first attempt.

wHcuZdN.png

 

 

 

Link to post
Share on other sites
1 hour ago, OrbitalManeuvers said:

OK .. I haven't done that :D  I really don't know the syntax, so no idea where that goes. Here's what I've done so far that doesn't work:

  Hide contents

I have this in a cfg:

@PART[bluedog_mariner10_camera]
{
    MODULE
    {
    name = ModuleNeptuneCamera
    cameraTransformName = CameraMain
    cameraType = FULL_COLOUR
    cameraFieldOfView = 60
    cameraHorizontalResolution = 128
    cameraVerticalResolution = 128
    cameraHasErrors = True
    cameraErrorRate = 5
    cameraHasNoise = True
    cameraNoiseMaxStrength = 25
    cameraHasCustomNearClipPlane = True
    cameraCustomNearClipPlane = 0.01
    }
}
 

"CameraMain" comes from DebugTools and literally guessing among the hundreds of things it was showing. 

 

This results in

[LOG 00:07:36.799] Applying update CustomConfigs/neptune/@PART[bluedog_mariner10_camera] to Bluedog_DB/Parts/ProbeExpansion/Mariner10/bluedog_mariner10_camera.cfg/PART[bluedog_mariner10_camera]
 

But this clearly isn't right yet. I expect I shouldn't have all those PAW items, and it doesn't actually work in flight, so weeeeee for a first attempt.

 

 

 

 

Yup camera main is incorrect. Thats for the main body of the camera. The correct transforms for camera mods are cameraTransformA, cameraTransformB and UVTransform.

The PAW items look correct, I think they will be removed from being visible in the VAB in the future. 

You could theoretically have 3 separate modules, 2 identical ones for A&B for stereo imaging and then another for UV. Could be a messy PAW though but worth try it out. I did suggest to @Bealeabout giving each module a title so cameras with multiple modules on the same part are easier to handle.

I think you can give the main camera some good stats. It was very advanced camera. 832(w) x 700(h) was the real resolution of the vidicon tube, that seems reasonable to me actually for in game since its the highest tech science camera in BDB (excluding spy and observatory parts). Its a far cry from the grainy Lunar Orbiter stuff :)

PIA02446_Discovery_Scarp.jpg

900px-Planet_Mercury_-_GPN-2000-000465.j

 

Edited by Zorg
Link to post
Share on other sites
1 hour ago, Zorg said:

Yup camera main is incorrect. Thats for the main body of the camera. The correct transforms for camera mods are cameraTransformA, cameraTransformB and UVTransform.

The PAW items look correct, I think they will be removed from being visible in the VAB in the future. 

You could theoretically have 3 separate modules, 2 identical ones for A&B for stereo imaging and then another for UV. Could be a messy PAW though but worth try it out. I did suggest to @Bealeabout giving each module a title so cameras with multiple modules on the same part are easier to handle.

I think you can give the main camera some good stats. It was very advanced camera. 832(w) x 700(h) was the real resolution of the vidicon tube, that seems reasonable to me actually for in game since its the highest tech science camera in BDB (excluding spy and observatory parts). Its a far cry from the grainy Lunar Orbiter stuff :)

On the subject of this .... is there any possibility of adding official support for neptune camera in B D B in the near future ?

Link to post
Share on other sites
Just now, golkaidakhaana said:

On the subject of this .... is there any possibility of adding official support for neptune camera in B D B in the near future ?

Well I was going to do it myself eventually when I have the time to do so. If OrbitalManeuvers can figure it out I would be more than happy to include their configs instead and I would really appreciate the saved effort :P 

Link to post
Share on other sites
20 hours ago, Zorg said:

A couple of small bonus parts, wanted to fill out some of the free space on the DCSS texture sheet so it doesnt go to waste.

Dual payload adapters for Delta II and Delta IV/Atlas V

These are on Github now

screen_5120x2880_2020-11-04_20-37-30.png?width=1418&height=798

Will be much appreciated by my munar train

bY6baOD.png

Yep. An Atlas E/F With OBA/OSA engines (Called "IRAZÚ" in my game, honoring another volcano and the first satelite of my country), can put (but just barelly) a Lunar Orbiter together a Pioneer 6 with solid engines on a munar transference orbit...

wggjnFM.png

Later, i'll post images. 

Link to post
Share on other sites

@Zorg thank you for the help! Here's my updated findings, which conflict both with my earlier tests and with your suggestions, so let's see where to next...

OK, using either cameraTransformA or UVTransform, I get hit by this:

Spoiler

 public void Start()
        {
            _cameraGameObject = base.gameObject.GetChild(cameraTransformName);

            if (_cameraGameObject == null)
            {
                Debug.LogFormat("[{0}] Camera game object is missing.", DEBUG_LOG_PREFIX);
                return;
            }

- using CameraMain, there's no debug spam, and I get images created, but the images are not showing where the camera was pointing, which doesn't surprise me if there's transform confusion.

So my config and my results:

Spoiler

@PART[bluedog_mariner10_camera]
{
    MODULE
    {
    name = ModuleNeptuneCamera
    cameraTransformName = CameraMain
    cameraType = FULL_COLOUR
    cameraFieldOfView = 60
    cameraHorizontalResolution = 832
    cameraVerticalResolution = 700
    cameraHasErrors = False
    cameraHasNoise = False
    }
}

With this camera orientation:

2bgBvo4.png

I get this image:

yHGaGon.png

In case it's hard to tell, the camera direction is directly upwards through the camera mast - again, not surprising.

edit: also, do you guys have magic tricks for testing minor cfg changes? 10-minute game reload time make head go boom. maybe i need a pared down install?

Edited by OrbitalManeuvers
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...