Jump to content

[1.8.1-1.11.2] Bluedog Design Bureau - Stockalike Saturn, Apollo, and more! (v1.7.3 "Огромный" 19/Apr/2021)


Recommended Posts

33 minutes ago, rcollier said:

Having a small issue I can't seem to figure out what's going on when using @Zorg's wonderful fairings. When I select a fairing base, everything works as advertised, even resizing the height. However, when I select a different fairing using part switcher, I get misshapen fairings.


Make absolutely sure both SAF and B9PS are fully up to date, versions meant for ksp 1.9 will work on ksp 1.8 as well keep in mind. The BDB github has the correct versions of those or you can download direct from the relevant thread/github.

 

Link to post
Share on other sites
21 hours ago, AlphaMensae said:

Atlas-Agena launch, MLP v2.1 style!

The Atlas-Centaur umbilical arm is next :) 

Where's the Brown smoke from the NTO/Nitric Acid?   :D   Seriously that looks awesome!

Link to post
Share on other sites

XOCnwJz.jpg

Paying my screenshot tax. (It ended up as a night launch, but it certainly looks more impressive during the day.) Click the spoiler for a dark and murky launch!

Spoiler

ZmOcOIs.png

 

I don't want to stretch this page out too much. Huge shout out to @Zorg for his TUFX presets! I made a few tweaks here and there, but overall they're still basically your settings. 

Link to post
Share on other sites
3 minutes ago, OrbitalManeuvers said:

Can I ask what you have directly on top of the centaur core? Wasn't sure what to do with the hole there when trying to fly a 0.9m payload.

Looks like a 0.9375m decoupler and a Star-37 with the 0.9375m autoshroud. I believe we're (read:probably Zorg) doing some of the IRL Centaur payload adapters. There's also a truss-type one that makes it a straight 1.875m, for stuff like Titan 3E.

NUwwZ1r.gif

Link to post
Share on other sites
On 7/12/2020 at 5:33 AM, linuxgurugamer said:

That's a stock bug, need to wait for 1.10.1.  This mostly showed up in non-stock fairings, but it looks like the same issue as the fairings

The fairing thing is actually different (the fairing module looks for a specifically named object on the model), has this been reported too?

Edited by blowfish
Link to post
Share on other sites
45 minutes ago, blowfish said:

The fairing thing is actually different (the fairing module looks for a specifically named object on the model), has this been reported too?

It looks like the same issue with a different part module.

I just reported it on the bugtracker

https://bugs.kerbalspaceprogram.com/issues/25781

Link to post
Share on other sites
10 hours ago, LawnDartLeo said:

Maybbe this is a question for the KIS/KAS forum, or one for the PRC forum... but how might I make the suitcases just a bit bigger on the LEM so that I can carry along the PRC?

You can change the KIS patch on Kerbal Space Program\GameData\Bluedog_DB\Compatibility\KIS.
Just look for "bluedog_LEM_Descent_Tanks" and change the maxVolume to whatever volume you might need for your thing :) 

 

@PART[bluedog_LEM_Descent_Tanks]:NEEDS[KIS] // Sina-MEM-DST Descent Stage Assembly
{
	%MODULE[ModuleKISInventory]
	{
		maxVolume = 400
		externalAccess = true
		internalAccess = false

<~snip~>


 

Link to post
Share on other sites
@PART[bluedog_LEM_Descent_Tanks]:NEEDS[KIS]:FINAL // Sina-MEM-DST Descent Stage Assembly
{
	%MODULE[ModuleKISInventory]
	{
		maxVolume = ###
    }
}

There's a patch that won't get overwritten when the mod updates.  Just replace ### with the desired volume, name it whateverYouLike.cfg, and drop it in a personal folder.

Link to post
Share on other sites

@CobaltWolf It's been 5 pages since we've had a picture on your progress. :mad: 

You have committed crimes against the KSP Community and her people! Pay the toll or pay with your life! The toll is update pictures! 

JK, I'm not really trying to pressure you, but  on a serious note, are there any updates on your progress?
 

Edited by GoldForest
Link to post
Share on other sites
14 hours ago, GoldForest said:

@CobaltWolf It's been 5 pages since we've had a picture on your progress. :mad: 

You have committed crimes against the KSP Community and her people! Pay the toll or pay with your life! The toll is update pictures! 

JK, I'm not really trying to pressure you, but  on a serious note, are there any updates on your progress?
 

I mean, fair question so have an honest answer - I haven't really touched much past what has been put on Github recently for Centaur. Haven't really started work on anything since then - Have a lot of Centaur stuff to do as well as Vega still. Been busy with work stuff (and will continue to be for the next few weeks) getting ready for big presentations. What time I've had has mostly been going into a small side project I'm doing as a favor for another modder:

Te3L3VF.png

Link to post
Share on other sites
2 hours ago, CobaltWolf said:

I mean, fair question so have an honest answer - I haven't really touched much past what has been put on Github recently for Centaur. Haven't really started work on anything since then - Have a lot of Centaur stuff to do as well as Vega still. Been busy with work stuff (and will continue to be for the next few weeks) getting ready for big presentations. What time I've had has mostly been going into a small side project I'm doing as a favor for another modder:

That's fine. Take your time. Like I said, I was just joking around. IRL comes first and foremost, always. Most of us understand that and we'll happily wait for your next update. :D

Link to post
Share on other sites
11 hours ago, GoldForest said:

How low are you? IIRC, the higest point on the Mun at a 0 inclination orbit is 14K? So you're what? 14.1K?

About 9000-14000 iirc, but the camera tools make the craft appear lower. By the way, I’m using JNSQ.

Edited by alberro+
Link to post
Share on other sites
50 minutes ago, mrtagnan said:

Who is responsible for the BDB antenna RemoteTech configs? The dev branch doesn't seem to work with remote tech. Is it possible to make them on your own?

Any interested party may help with the compatibility configs.

Link to post
Share on other sites

I'm trying to run the latest build on KSP 1.10 but it keeps freezing during the loading screen, anyone have any ideas what this means?

Log:

Spoiler

[LOG 19:13:28.293] PartLoader: Compiling Part 'Bluedog_DB/Parts/Antennas/bluedog_solarAntenna/bluedog_solarAntenna'
[LOG 19:13:28.300] [RemoteTech] ModuleRTAntenna: Found TRANSMITTER block.
[LOG 19:13:28.314] [RemoteTech] ModuleRTAntenna: OnDestroy
[LOG 19:13:28.314] [RemoteTech] ModuleSPUPassive: OnDestroy
[LOG 19:13:28.315] PartLoader: Part 'Bluedog_DB/Parts/Antennas/bluedog_solarAntenna/bluedog_solarAntenna' has no database record. Creating.
[LOG 19:13:28.315] [DragCubeSystem]: Drag cubes not found or cannot be read for part Part. Generating New drag cubes.
[LOG 19:13:28.318] DragCubeSystem: Creating drag cubes for part 'bluedog.solarAntenna'
[EXC 19:13:28.397] NullReferenceException: Object reference not set to an instance of an object
    ModuleDeployablePart.AssumeDragCubePosition (System.String name) (at <c168e21ec56346b082f89043e76162e1>:0)
    DragCubeSystem+<RenderDragCubes>d__34.MoveNext () (at <c168e21ec56346b082f89043e76162e1>:0)
    UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at <5aeafee3fea24f37abd1315553f2cfa6>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

 

Link to post
Share on other sites
12 minutes ago, mrtagnan said:

I'm trying to run the latest build on KSP 1.10 but it keeps freezing during the loading screen, anyone have any ideas what this means?

Log:

  Reveal hidden contents

[LOG 19:13:28.293] PartLoader: Compiling Part 'Bluedog_DB/Parts/Antennas/bluedog_solarAntenna/bluedog_solarAntenna'
[LOG 19:13:28.300] [RemoteTech] ModuleRTAntenna: Found TRANSMITTER block.
[LOG 19:13:28.314] [RemoteTech] ModuleRTAntenna: OnDestroy
[LOG 19:13:28.314] [RemoteTech] ModuleSPUPassive: OnDestroy
[LOG 19:13:28.315] PartLoader: Part 'Bluedog_DB/Parts/Antennas/bluedog_solarAntenna/bluedog_solarAntenna' has no database record. Creating.
[LOG 19:13:28.315] [DragCubeSystem]: Drag cubes not found or cannot be read for part Part. Generating New drag cubes.
[LOG 19:13:28.318] DragCubeSystem: Creating drag cubes for part 'bluedog.solarAntenna'
[EXC 19:13:28.397] NullReferenceException: Object reference not set to an instance of an object
    ModuleDeployablePart.AssumeDragCubePosition (System.String name) (at <c168e21ec56346b082f89043e76162e1>:0)
    DragCubeSystem+<RenderDragCubes>d__34.MoveNext () (at <c168e21ec56346b082f89043e76162e1>:0)
    UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at <5aeafee3fea24f37abd1315553f2cfa6>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

 

as has been stated, 1.10 is broken right now.  You might be able to trim parts to get it to load, but we recommend going back to 1.9.1 till 1.10.1.. has been tested.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...