Angel-125

[1.8.1 - 1.9.x] Deep Space Exploration Vessels - Build NASA Inspired Ships In KSP

Recommended Posts

Hi

If I attach the Trinity and right click it, this happens:

[LOG 17:59:06.248] wbiTrinity added to ship - part count: 39
[EXC 17:59:06.346] NullReferenceException: Object reference not set to an instance of an object
	RUI.Algorithms.SCCFlowGraphUCFinder.IsEntryPointRequest (.Part part, .Callback`1 requestCallback)
	RUI.Algorithms.SCCFlowGraphUCFinder.IsEntryPoint (.Part part, .Callback`1 deliveryCallback, .Callback`1 requestCallback)
	RUI.Algorithms.SCCFlowGraphUCFinder.BuildEntrySets ()
	RUI.Algorithms.SCCFlowGraphUCFinder..ctor (System.Collections.Generic.List`1 ship)
	KSP.UI.Screens.EngineersReport+<RunTests>c__Iterator0.MoveNext ()
	UnityEngine.SetupCoroutine.InvokeMoveNext (IEnumerator enumerator, IntPtr returnValueAddress)

It may have to do with other mods, I am looking for Explodium, not sure where to find it ;-)

Share this post


Link to post
Share on other sites
11 minutes ago, MacLuky said:

Hi

If I attach the Trinity and right click it, this happens:


[LOG 17:59:06.248] wbiTrinity added to ship - part count: 39
[EXC 17:59:06.346] NullReferenceException: Object reference not set to an instance of an object
	RUI.Algorithms.SCCFlowGraphUCFinder.IsEntryPointRequest (.Part part, .Callback`1 requestCallback)
	RUI.Algorithms.SCCFlowGraphUCFinder.IsEntryPoint (.Part part, .Callback`1 deliveryCallback, .Callback`1 requestCallback)
	RUI.Algorithms.SCCFlowGraphUCFinder.BuildEntrySets ()
	RUI.Algorithms.SCCFlowGraphUCFinder..ctor (System.Collections.Generic.List`1 ship)
	KSP.UI.Screens.EngineersReport+<RunTests>c__Iterator0.MoveNext ()
	UnityEngine.SetupCoroutine.InvokeMoveNext (IEnumerator enumerator, IntPtr returnValueAddress)

It may have to do with other mods, I am looking for Explodium, not sure where to find it ;-)

I haven't seen that error, does that happen with a game that only has DSEV and its support mods?

Explodium comes from Classic Stock Resources which is included with DSEV. Are you using Classic Stock or CRP or both or neither?

Share this post


Link to post
Share on other sites

soyuz:WildBlueIndustries macluky$ ls -l
total 0
drwxr-xr-x@  5 macluky  staff  160 Mar  1 15:57 000ABARISBridgeDoNotDelete
drwxr-xr-x@ 23 macluky  staff  736 Mar 21 09:54 000WildBlueTools
drwxr-xr-x@ 11 macluky  staff  352 Mar 17 12:59 001KerbalActuators
drwxr-xr-x@ 19 macluky  staff  608 Mar 17 12:59 Buffalo
drwxr-xr-x@  7 macluky  staff  224 Mar  1 15:57 ClassicStockResources
drwxr-xr-x  18 macluky  staff  576 Mar 28 07:41 DSEV
drwxr-xr-x   8 macluky  staff  256 Mar 25 23:11 KerbalKISItems
drwxr-xr-x@ 21 macluky  staff  672 Mar  1 22:58 MOLE
drwxr-xr-x@ 21 macluky  staff  672 Mar 17 12:59 Pathfinder

No, I'm a fan of your work, but I did have it set to Lite Blue, I'll try switching to CRP

Share this post


Link to post
Share on other sites

Did some more digging, shouldn't there be templates for water and explodium when running CRP? I can find explodium only in classic stock resources (re-reading your post, I guess you said that ;-) I'll try switching and see if that resolves the issue

Share this post


Link to post
Share on other sites
4 hours ago, MacLuky said:

Did some more digging, shouldn't there be templates for water and explodium when running CRP? I can find explodium only in classic stock resources (re-reading your post, I guess you said that ;-) I'll try switching and see if that resolves the issue

Water yes, Explodium no.  It's not a CRP resource.

Share this post


Link to post
Share on other sites

BTW: The centrifuges when in-physics but not part of the active vessel appear to throw about 40 exceptions a second.  (I play with Exception Detector, since my long modlist tends to lead to conflicts.  Entering a physics area with a WBI centrifuge immediately pops up a window.)

Share this post


Link to post
Share on other sites

I'm not able to find a version IR that works with the Centrifuge, does anyone know a version of IR that works with this and with 1.6.1?

Share this post


Link to post
Share on other sites
On 4/16/2019 at 1:18 PM, GooglyNarga said:

I'm not able to find a version IR that works with the Centrifuge, does anyone know a version of IR that works with this and with 1.6.1?

Not sure, IR has been broken for awhile. But DSEV has two centrifuge parts, one for 3.75m and one for 2.5m.

Speaking of which, DSEV 3.3.1 is now available:

- Fixed NREs produced by centrifuge when it's spinning and the vessel isn't the active vessel.

Share this post


Link to post
Share on other sites
39 minutes ago, Angel-125 said:

Not sure, IR has been broken for awhile. But DSEV has two centrifuge parts, one for 3.75m and one for 2.5m.

Speaking of which, DSEV 3.3.1 is now available:

- Fixed NREs produced by centrifuge when it's spinning and the vessel isn't the active vessel.

Is this likely to work in 1.6?  (I'm still waiting on a couple of other mods before upgrading, and I'd like to test.)

Share this post


Link to post
Share on other sites
2 minutes ago, DStaal said:

Is this likely to work in 1.6?  (I'm still waiting on a couple of other mods before upgrading, and I'd like to test.)

Theoretically...

Share this post


Link to post
Share on other sites
22 hours ago, Angel-125 said:

Not sure, IR has been broken for awhile. But DSEV has two centrifuge parts, one for 3.75m and one for 2.5m.

Speaking of which, DSEV 3.3.1 is now available:

- Fixed NREs produced by centrifuge when it's spinning and the vessel isn't the active vessel.

Ah darn, thanks man for the response though, I'll look into solutions to fix my problem in the meantime! :D

Share this post


Link to post
Share on other sites

WHY ARE THE ONLY PARTS DISPLAYED FOR 1.7.0 RESCALED STOCK PARTS?!!

DSEV Partlist:

RBCC-8 Scimitar

LSC-30 Air intake

Compact ISRU Converter

But where are the spacecraft parts?

Edited by Infinity_XT

Share this post


Link to post
Share on other sites
On 4/19/2019 at 4:17 PM, GooglyNarga said:

Ah darn, thanks man for the response though, I'll look into solutions to fix my problem in the meantime! :D

There is a glimmer of hope: With the upcoming DLC, I might be able to get the IR-based centrifuge parts working again with stock robotics.

Share this post


Link to post
Share on other sites
On 5/14/2019 at 8:34 PM, Infinity_XT said:

WHY ARE THE ONLY PARTS DISPLAYED FOR 1.7.0 RESCALED STOCK PARTS?!!

DSEV Partlist:

RBCC-8 Scimitar

LSC-30 Air intake

Compact ISRU Converter

But where are the spacecraft parts?

Most of the WBI parts don't appear in the stock categories. I assume you did not install WildBlueTools which generates the custom categories where the parts do appear (and which contains all of WBI custom functionality).

Share this post


Link to post
Share on other sites

I just noticed that the Trinity has a hover controller, and I had a brief moment of awe/terror before realizing it was probably not meant for use with the engine in explodium mode.

Share this post


Link to post
Share on other sites

With DSEV & Community Tech Tree installed, I am not getting either the Zen Greenhouse or the D2 Greenhouse showing up.  All the other parts assigned to either short or long term habitation in the CTT tree are showing up.  I created a new KSP copy & installed just DSEV & CTT, and they showed up as expected.  Then I went back to my existing game, deleted & reinstalled both CTT & DSEV and deleted the MM config cache.  Started KSP, loaded my career and.... no Zen or D2 greenhouse.    Looking in my output log, I found this when searching for "Zen"

Spoiler

PartLoader: Compiling Part 'WildBlueIndustries/DSEV/Parts/Utility/StationParts/ZenGreenhouse/wbiZenGreenhouse'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartLoader: Encountered exception during compilation. System.NullReferenceException: Object reference not set to an instance of an object
  at PartResourceDefinitionList.get_Item (System.String name) [0x00000] in <filename unknown>:0
  at PartResourceLibrary.GetDefinition (System.String name) [0x00000] in <filename unknown>:0
  at ShipConstruction.GetPartCostsAndMass (.ConfigNode partNode, .AvailablePart aP, System.Single& dryCost, System.Single& fuelCost, System.Single& dryMass, System.Single& fuelMass) [0x00000] in <filename unknown>:0
  at ShipConstruction.SanitizePartCosts (.AvailablePart aP, .ConfigNode partNode) [0x00000] in <filename unknown>:0
  at PartLoader.ParsePart (.UrlConfig urlConfig, .ConfigNode node) [0x00000] in <filename unknown>:0
  at PartLoader+<CompileParts>c__Iterator1.MoveNext () [0x00000] in <filename unknown>:0
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartCompiler: Cannot compile part

And something similar for the D2 Greenhouse:

Spoiler

PartLoader: Compiling Part 'WildBlueIndustries/DSEV/Parts/Utility/D2Greenhouse/WBI_D2Greenhouse'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartLoader: Encountered exception during compilation. System.NullReferenceException: Object reference not set to an instance of an object
  at PartResourceDefinitionList.get_Item (System.String name) [0x00000] in <filename unknown>:0
  at PartResourceLibrary.GetDefinition (System.String name) [0x00000] in <filename unknown>:0
  at ShipConstruction.GetPartCostsAndMass (.ConfigNode partNode, .AvailablePart aP, System.Single& dryCost, System.Single& fuelCost, System.Single& dryMass, System.Single& fuelMass) [0x00000] in <filename unknown>:0
  at ShipConstruction.SanitizePartCosts (.AvailablePart aP, .ConfigNode partNode) [0x00000] in <filename unknown>:0
  at PartLoader.ParsePart (.UrlConfig urlConfig, .ConfigNode node) [0x00000] in <filename unknown>:0
  at PartLoader+<CompileParts>c__Iterator1.MoveNext () [0x00000] in <filename unknown>:0
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartCompiler: Cannot compile part

Anyone have any ideas?

 

Share this post


Link to post
Share on other sites

So, I apologise if this has been asked before but, I can't find this mod on CKAN. Is it unavailable there?

Share this post


Link to post
Share on other sites
On 6/19/2019 at 1:47 AM, ChrisSpace said:

So, I apologise if this has been asked before but, I can't find this mod on CKAN. Is it unavailable there?

CKAN is not supported.

DSEV 3.3.3. is now available:

- Added support for Air and Stress from Snacks.

Share this post


Link to post
Share on other sites

Hi @Angel-125,

Loving the Wild Blue mods!

I'm Updating from DSEV 3.3.3 to 3.3.4 on KSP 1.7.1.  It looks like KSP is locking up when loading wbiMiniCupola. A look at the logs suggests there may be a string missing, but the KSP log isn't showing which file. Not sure if you've seen this before or not. 

MM logs appear to be clean.

I updated Snacks and DSEV at the same time and encountered this issue. Rolling back DSEV to 3.3.3 resolved the issue for me at this point. I'm happy to help troubleshoot as needed. Next step for me is to verify on a clean install of 1.7.1. I'll let you know if that yields any results.

PartLoader: Compiling Part 'WildBlueIndustries/DSEV/Parts/Utility/StationParts/MiniCupola/wbiMiniCupola'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartLoader: Part 'WildBlueIndustries/DSEV/Parts/Utility/StationParts/MiniCupola/wbiMiniCupola' has no database record. Creating.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

DragCubeSystem: Creating drag cubes for part 'wbiMiniCupola'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

KeyNotFoundException: The given key was not present in the dictionary.
  at System.Collections.Generic.Dictionary`2[System.String,Snacks.SnacksRosterResource].get_Item (System.String key) [0x00000] in <filename unknown>:0 
  at Snacks.SnacksConverter.GetInfo () [0x00000] in <filename unknown>:0 
  at PartLoader.CompilePartInfo (.AvailablePart newPartInfo, .Part part) [0x00000] in <filename unknown>:0 
  at PartLoader+<CompileParts>c__Iterator1.MoveNext () [0x00000] in <filename unknown>:0 
  at UnityEngine.SetupCoroutine.InvokeMoveNext (IEnumerator enumerator, IntPtr returnValueAddress) [0x00000] in <filename unknown>:0 
 
(Filename:  Line: -1)

Any suggestions?

UPDATE:  I did some testing with a clean installation and began adding mods one by one to narrow down the culprit. DSEV standalone is fine.  Adding Snacks appears to cause the issue. So right now having DSEV 3.3.4 with Snacks (tested with both 1.16.4 and 1.20.0) seems to cause the issue. Installing either DSEV or Snacks works just fine.  Let me know if you would like me to do something specific to help out. :)

Edited by Joviah
Added additional info

Share this post


Link to post
Share on other sites
1 hour ago, Joviah said:

Hi @Angel-125,

Loving the Wild Blue mods!

I'm Updating from DSEV 3.3.3 to 3.3.4 on KSP 1.7.1.  It looks like KSP is locking up when loading wbiMiniCupola. A look at the logs suggests there may be a string missing, but the KSP log isn't showing which file. Not sure if you've seen this before or not. 

MM logs appear to be clean.

I updated Snacks and DSEV at the same time and encountered this issue. Rolling back DSEV to 3.3.3 resolved the issue for me at this point. I'm happy to help troubleshoot as needed. Next step for me is to verify on a clean install of 1.7.1. I'll let you know if that yields any results.

Any suggestions?

UPDATE:  I did some testing with a clean installation and began adding mods one by one to narrow down the culprit. DSEV standalone is fine.  Adding Snacks appears to cause the issue. So right now having DSEV 3.3.4 with Snacks (tested with both 1.16.4 and 1.20.0) seems to cause the issue. Installing either DSEV or Snacks works just fine.  Let me know if you would like me to do something specific to help out. :)

If you're using Classic Stock Resources, then I think all you need to do is edit the DSEV/Templates/ClassicStock/MM_Snacks.cfg file, find the patch for the mini cupola, and add ":NEEDS[SnacksStress]" without the quotes so the config node starts with: @PART[wbiMiniCupola]:NEEDS[SnacksStress]

I should have a patch later this morning.

Share this post


Link to post
Share on other sites
6 minutes ago, Angel-125 said:

If you're using Classic Stock Resources, then I think all you need to do is edit the DSEV/Templates/ClassicStock/MM_Snacks.cfg file, find the patch for the mini cupola, and add ":NEEDS[SnacksStress]" without the quotes so the config node starts with: @PART[wbiMiniCupola]:NEEDS[SnacksStress]

I should have a patch later this morning.

Yep, that fixes it!  Thanks @Angel-125!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.