Jump to content

[1.0.5] Sigma: OPM Tilt


Sigma88
 Share

Recommended Posts

1 minute ago, Geschosskopf said:

OPMTilt seems to work just fine in 1.1.2 with OPM 2.0.  At least, Urlum and all its moons and rings are sideways, and show up in the tracking center, and I can interact with them with ships.

I do have one problem, however.  OPM comes with a CustomAsteroids config which adds asteroid moonlets to Jool and all the OPM planets.  This file gives Urlum 2 sets of moonlets, one in the rings and a more distant cloud of captured asteroids out beyond Wal.  The outer group works fine, but I can't make ring moonlets incline to match tilted Urlum.  No matter what I do, the ring moonlets remain in the ecliptic plane 90^ to Urlum's rings.

Here's the applicable part of the OPM_CustomAsteroids.cfg file (unmodified):

	ASTEROIDGROUP
	{
		name = urlumRingMoonlets
		title = Urlum

		centralBody = Urlum

		spawnRate = 0.0125

		orbitSize
		{
			type = SemimajorAxis
			min = Ratio(Urlum.rad, 2.3)
			max = Ratio(Urlum.rad, 2.9)
		}

		eccentricity
		{
			avg = 0.0001
		}

		inclination
		{
			avg = 0.5
		}
	}

 

And here's what I tried to fix it:

@CustomAsteroids:NEEDS[SigmaOPMTilt]:AFTER[SigmaOPMTilt]
{
	@ASTEROIDGROUP[urlumRingMoonlets]
	{
		@inclination
		{
			min = 89
			max = 90
		}
	}
}

 

NOTE:  I managed a similar MM patch to make the Plock moonlets orbit Plock-Karen if you have SigmaBinary installed, so I'm kinda at a loss here.

 

maybe you need to delete the avg key

like this:

@CustomAsteroids:NEEDS[SigmaOPMTilt]:AFTER[SigmaOPMTilt]
{
	@ASTEROIDGROUP[urlumRingMoonlets]
	{
		@inclination
		{
			min = 89
			max = 90
			!avg = DEL
		}
	}
}

but I don't know anything about Custom Asteroids

Link to comment
Share on other sites

1 hour ago, Sigma88 said:

maybe you need to delete the avg key

Well, that didn't work, either.  So then I edited the OPM_CustomAsteroids.cfg directly, changing the inclination to min/max 89/90.  And THAT didn't work.  Still, the moonlets were in the ecliptic plane.  I'm beginning to think you seriously warped space at Urlum :)

 

Link to comment
Share on other sites

1 minute ago, Geschosskopf said:

Well, that didn't work, either.  So then I edited the OPM_CustomAsteroids.cfg directly, changing the inclination to min/max 89/90.  And THAT didn't work.  Still, the moonlets were in the ecliptic plane.  I'm beginning to think you seriously warped space at Urlum :)

 

maybe custom asteroids doesn't change inclination that way, you need to ask the devs of that mod

Link to comment
Share on other sites

Random suggestion: try not using 90? Instead make it like 85 to 89. An exact 90 degree orbit is "special" in a sense (it's not defined whether it's prograde or retrograde).

Another possibility, unlikely but maybe worth trying? is that it's taking inclination in radians.

Edited by cantab
Link to comment
Share on other sites

1 hour ago, cantab said:

Random suggestion: try not using 90? Instead make it like 85 to 89. An exact 90 degree orbit is "special" in a sense (it's not defined whether it's prograde or retrograde).

Another possibility, unlikely but maybe worth trying? is that it's taking inclination in radians.

if inclination was in radians then avg = 0.5 would be ~60 deg

Link to comment
Share on other sites

  • 7 months later...
11 hours ago, Adstriduum said:

Very nice mod. Really added a challenge to my Urlum mission :). Might I asked how you edited the texture to make the planet appear tilted at 90 degrees?  I could really use that technique for some of my modding projects.

I followed the instructions I received on this forum

Link to comment
Share on other sites

  • 2 months later...

@Sigma88, would there be any possibility that this would be updated for OPM 1.2.1? Wal's terrain and therefore textures changed quite a bit so when this mod is installed, Wall get's reverted back to its older self and with its previous biome map.

I would also considering changing the TiltClouds.cfg to:

@EVE_CLOUDS:FOR[SigmaOPMTilt]
{
	@OBJECT:HAS[#body[Urlum],#offset[*,*]]
	{
		%offset[0] -= 90
		%offset[1] -= 90
	}
}

As if the default offset it used for a cloud layer that is generated through EVE's GUI, an offset key will not be listed in the config. Does the above change to the config work (changing the @ to % in front of the x and y offset values).

I've added rudimentary support for it back into OPM-VO and its definitely a great addition when playing with OPM.

Link to comment
Share on other sites

10 minutes ago, Poodmund said:

would there be any possibility that this would be updated for OPM 1.2.1? Wal's terrain and therefore textures changed quite a bit so when this mod is installed, Wall get's reverted back to its older self and with its previous biome map.

I'm not sure how much time I can get to update this, I'll try if I get some time off but I can't promise any ETA sorry

 

11 minutes ago, Poodmund said:

%offset[0] -= 90

you can't subtract 90 from something that doesn't exist so this will not work

 

I'll take a look for that as well when I have time

Link to comment
Share on other sites

9 minutes ago, Sigma88 said:

you can't subtract 90 from something that doesn't exist so this will not work

Yeah thats the issue. :/  If the offset = 0,0,0 is used it doesn't generate in the config... so maybe a pass could be done to identify all cloud layers that exist for Urlum that don't have an 'offset' key, and then add an offset key for those with values of 0,0,0. Afterwards, the the existing code can be run.

@EVE_CLOUDS:FOR[SigmaOPMTilt]
{
	@OBJECT:HAS[#body[Urlum],~#offset[*]]
	{
		offset = 0,0,0
	}
	@OBJECT:HAS[#body[Urlum],#offset[*,*]]
	{
		@offset[0] -= 90
		@offset[1] -= 90
	}
}

My Module-Manager-fu is not strong like yours so what I'm saying is probably a load of tosh. :D 

As for an ETA, no worries. It still "works" as is... just a bit funky is all.

Edited by Poodmund
Link to comment
Share on other sites

  • 7 months later...
  • 3 months later...
  • 1 year later...

Appears to work for me so far in 1.6.1, though I've only been in 1.6.1 for a few days.

I'm running about 100 or so other mods along with this, but haven't actually started playing a save yet, just slowly adding mods and testing for crashes/bugs right now.

Link to comment
Share on other sites

  • 2 years later...

Have been trying to get it to work in 1.12.2; the orbits get tilted correctly it seems, however Urlums texture doesn't want to tilt 90°, or is it not supposed to?

Mods: EVE-Redux; Kopernicus, OPM, Rescale (2,5x), scatterer, OPMtilt, SigmaDimensions, Spectra, PoodsOPMVO (both tried with and without).

Link to comment
Share on other sites

  • 3 months later...

I was able to get this working in 1.12.2 by modifying GameData/Sigma/OPMTilt/Configs/UrlumTilt.cfg to read as follows:

 

@Kopernicus:FOR[SigmaOPMTilt]
{
	@Body[Urlum]
	{
		@Properties
		{
			@description = It took a while for Kerbal astronomers to realize Urlum was not a far away star, but in fact another planet. Since then scientists have been weary of making claims about Urlum, for fear of being wrong yet again. The ice giant is unusual in that it rotates around a very tilted axis making it impossible for astronomers to decide if it's rotating prograde or retrograde.
			@rotationPeriod = 1e100
		}
		@Rings
		{
			@Ring
			{
				@angle = 90
				@lockRotation = false
			}
		}
		@ScaledVersion
		{
			!ProceduralGasGiant {}
			@OnDemand
			{
				@texture = Sigma/OPMTilt/PluginData/Textures/Urlum_color.dds
				@texture:NEEDS[SigmaOPMRecolor] = Sigma/OPMTilt/PluginData/Textures/Urlum_recolor.dds
			}
		}
	}
}

Should you also be using Sigma OPMRecolor, this config will tilt the recoloured Urlum texture, as well.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...