Angel-125

[1.7.x] Buffalo: NASA Inspired Modular Space Exploration Vehicle

Recommended Posts

It sort of sounds like there is something wrong with either EVA in general or in how the ladder and airlocks are positioned on the Buffalo, ARES rover, and MAV. I may need to wait to fix this until KSP itself is stable again. Thanks for the reports. :)

Share this post


Link to post
Share on other sites

Yeah...Changed or broken for sure :) I think I recall Roverdude saying he had to move his airlock on the Karibou rover too...But i need to check if that was for 1.0.5 or 1.1...He def had to move it for some reason tho. 

Glad to help...Its way better little glitches get identified now than after 1.1 gets its full release :)

Edit...I checked RoverDudes thread on the karibou...and, if he did make a change to the airlock, it was before his 1.1 release.

Edited by Solospirit
Adding comment.

Share this post


Link to post
Share on other sites

I confirm the issue with being fired into the air when the physics loads.  Pretty funny, but also wrong :) Also when I deploy the ladders, I also get fired into the air.

Share this post


Link to post
Share on other sites

OK, tried this again with the latest KSP 1.1pre build (1196 or some such).

In this, the Griz's habit of tripping over terrain is much less, and the traction of all wheels going up a slope is much improved.  The Goat still kills the launchpad on contact, however.  The Cub and Griz still have problems with physical warp and returning to them from other scenes or ships but not quite as bad as before.   The Goat is strange in this, usually surviving no problem but sometimes the whole rover just flat vanishes and its crew shows as KIA.  In general, however, Buffalo wheels work better than stock, being less fragile, having more traction, and going faster for the same power hauling the same mass.

Share this post


Link to post
Share on other sites
31 minutes ago, Geschosskopf said:

OK, tried this again with the latest KSP 1.1pre build (1196 or some such).

In this, the Griz's habit of tripping over terrain is much less, and the traction of all wheels going up a slope is much improved.  The Goat still kills the launchpad on contact, however.  The Cub and Griz still have problems with physical warp and returning to them from other scenes or ships but not quite as bad as before.   The Goat is strange in this, usually surviving no problem but sometimes the whole rover just flat vanishes and its crew shows as KIA.  In general, however, Buffalo wheels work better than stock, being less fragile, having more traction, and going faster for the same power hauling the same mass.

Glad to hear they suck less. ;) Once KSP 1.1 stabilizes I can do what I can with the wheels and ladders. It's a learning experience to be sure...

Share this post


Link to post
Share on other sites
8 minutes ago, Angel-125 said:

Glad to hear they suck less. ;) Once KSP 1.1 stabilizes I can do what I can with the wheels and ladders. It's a learning experience to be sure...

Squad did some work with with wheel colliders to make all wheels suck less.  In these new conditions, your wheels suck rather less than stock in some ways.  Stock wheels break crossing very slight changes in terrain slope which they used to handle no problem.  Yours don't.  Stock wheels, OTOH, are very, very slightly less prone to exploding, jumping, or breaking under warp (physical or regular) and when returning to the rover from another scene or ship.

Still, wheels in general suck right now in 1.1.  Landing gear excepted.  They now actually work fairly well.  So 3 or 4 pre-release builds down the road, I hope rover wheels will be more or less OK.

Edited by Geschosskopf

Share this post


Link to post
Share on other sites

Yep..Looks like that is the culprit for sure...Phoenix Industries Rover and AV have the same issues and i linked to that thread on -ctn-'s.

Share this post


Link to post
Share on other sites

Did some testing with box colliders for ladders and airlocks tonight. Looks promising. Wheels still a mess, but Squad is having a tough time with wheels in general right now. Send them words of encouragement, they'll appreciate the cheers instead of hearing endless complaining. :)

Share this post


Link to post
Share on other sites

In the current pre-release, the Buffalo parts group doesn't appear so I have to hunt the parts through all the default categories.  I think this might be a conflict with another mod but I'm not sure.

Share this post


Link to post
Share on other sites
1 hour ago, Geschosskopf said:

In the current pre-release, the Buffalo parts group doesn't appear so I have to hunt the parts through all the default categories.  I think this might be a conflict with another mod but I'm not sure.

Thanks for the report. :) 1209 broke some stuff that I'm sorting through still. I should have an update soonish.

Share this post


Link to post
Share on other sites

Also the latest Is it just me or can I not change the contents of the Wagon? Also with 1.1 release (official) I cannot even deploy or retract the wagon. This might be an issue with wildblue tools? Because breadbaord switching is not working either - even though I know pathfinder is not updated yet. 

I do have ISfuel switch installed - not sure if that could be the root of the issue.

Share this post


Link to post
Share on other sites

Buffalo is currently pre-official KSP 1.1 release. I'm aiming for late this week to have everything ready. Still have bugs to sort out with the wheels.

Share this post


Link to post
Share on other sites

Is the module 

WBIResourceSwitcher

broken for anybody else in 1.1 x64? KIS_v1.2.7_build4 is working fine with all parts, the resources don't show up.

Share this post


Link to post
Share on other sites

Buffalo is currently pre-official KSP 1.1 release. I'm aiming for late this week to have everything ready. Still have bugs to sort out with the wheels.

Share this post


Link to post
Share on other sites

Well, I've reached my deadline for trying to figure out the Grizzly wheels. The biggest problem I have is that they stop working when you put them under a cab or flatbed. I think I have to retire the current design and revisit them in the future. The Mountain Goat and Bear Cub work great though. :) So this is a heads up that the Grizzly wheels will be going away.

Share this post


Link to post
Share on other sites
14 hours ago, Angel-125 said:

...The biggest problem I have is that they stop working when you put them under a cab or flatbed. ...

I had this behavior with the bearcub wheels too.    Wheel context menu indicates wheels are blocked.

 

Also noticed bearcub wheels deflection is more when turning left than when turning right, Buffalo 0.2.8 on KSP 1.1.

Edited by Gristle

Share this post


Link to post
Share on other sites
44 minutes ago, Gristle said:

I had this behavior with the bearcub wheels too.    Wheel context menu indicates wheels are blocked.

 

Also noticed bearcub wheels deflection is more when turning left than when turning right, Buffalo 0.2.8 on KSP 1.1.

Interesting. In what circumstances does that occur? I used then like an ATV wheel and they roll just fine. ATV as in nothing is above them.

Share this post


Link to post
Share on other sites

It just has to make me laugh how this game works. I see the news about the new release, I download it. Play it a few minutes and say, well that's cool can't wait to play it. I then go back and open my old version and continue waiting for the day when my essential mods are ready to go. :)

Not saying rush or I'm impatient. By all means, take your time. I know this community all have real lives and more important things than a game. I just had to comment.

You do amazing work by the way.

Share this post


Link to post
Share on other sites

I here that! I get the same way, only these days I wait on mods to update that my own stuff depends upon so I can make sure everything still works. And no worries, I'm trying to take my time to get things right. I'm debating making a release soon and not fixing ladders right away and holding off to redo ladders. Truthfully I'm wanting to put out an update sooner rather than later, mostly because I want to get the rest of my mods up to date with 1.1. We'll see, depends on how hard it will be to fix the ladders.

Share this post


Link to post
Share on other sites
16 hours ago, Angel-125 said:

Interesting. In what circumstances does that occur? I used then like an ATV wheel and they roll just fine. ATV as in nothing is above them.

Jtjo3YI.pngzHH4MgF.pngWMaYCKS.png

Share this post


Link to post
Share on other sites

Thanks, that definitely helps. :) Now I just have to figure out why that happens, it's really bizarre. I ran into last night doing some part testing, definitely odd. These screenshots will help me narrow down what's happening. :)

Edited by Angel-125

Share this post


Link to post
Share on other sites

AHA! I know what is going on. The new wheel system is pretty sensitive. If you have something near the wheel, then the wheel gets grumpy and claims that it is blocked. However I found a way to cheat!

Cjoe71s.png

In this picture, the wheels on the right are blocked while the wheels on the left are not. The ones on the left aren't blocked because I cheated and set all the colliders on the inflatable module to layer 26, WheelCollidersIgnore. This means that all I need to do is rebuild my models so that the colliders will be ignored by the wheels, and it means those pesky Grizzly wheels are back in business!

The only caveat to this is that in the future, you'll need to be careful about how you design your rovers when not using Buffalo parts.

Share this post


Link to post
Share on other sites
4 hours ago, Angel-125 said:

Thanks, that definitely helps. :) Now I just have to figure out why that happens, it's really bizarre. I ran into last night doing some part testing, definitely odd. These screenshots will help me narrow down what's happening. :)

Was kind of rushed when I posted the pics.  All the wheels on the body in first pic show as blocked.  The 2nd pic shows the wheel with full right deflection.  The 3rd pic is same wheel with full left deflection, much wider arc than right deflection.

 

EDIT:  This change log note might explain the differences in wheel deflection

* Steering model features true Ackermann steering.

Ackerman steering is inside and outside wheels having different turn radii.  I wonder how the game determine which wheel  is the inside wheel and which is the outside wheel?

Edited by Gristle
additonal info

Share this post


Link to post
Share on other sites

Back from a nice day with the lady. :) Annnnd... The Grizzly wheels on the Buffalo go round and round...

2pXu8k0.png

I used my WheelCollidersIgnore cheat on the Buffalo parts. There's definitely something going on with wheels that get blocked by other parts. While the problem is fixed for Buffalo, using the wheels (including stock wheels) might have issues with other parts.

@Gristle found this about wheel colliders:

So there might be another solution in the future. Meanwhile, my hack works :)

Now to see what I can do about the ladders...

 

Edited by Angel-125

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.