Angel-125

[1.7.x] Buffalo: NASA Inspired Modular Space Exploration Vehicle

Recommended Posts

33 minutes ago, CatastrophicFailure said:

I've figured out exactly when it happens, it's when I click and drag the window over a MechJeb window, so that it gets "small" for an instant. This is in the game screen. Looks like it's only the Guppy window that does it. Then I can't seem to click on anything except the buttons in the Guppy window. Make any sense? I'll see if I can duplicate it on a bare install.

My guess is that if you used, say the operations window from MOLE, you'd run into the same problem. I've no idea why dragging the window over a MechJeb window would cause that. I'd suggest not doing that. :)

Share this post


Link to post
Share on other sites

Small complaint about the Outback: Difficult to configure its storage for TAC life-support supplies. It thinks oxygen, water, and food each consume one liter of space per storage unit of resource, making its oxygen supply MUCH too small, and its food and water supplies too ample, even when you dial the food and water storage all the way down. Would be nice to have a bit of extra TAC life-support storage plus storage space for inventory in the Outback.

Share this post


Link to post
Share on other sites
On 5/6/2018 at 1:58 AM, Angel-125 said:

Here is the Mk2 Buffalo Recycler Arm:

what i see here? 5pages ago a new cute COOL robotarm ,whhaaaaa yeeesss

very cool)

thx

Share this post


Link to post
Share on other sites

@Angel-125

I have a small problem with the Buffalo rover.  I have a small Buffalo with the M1-A2 grizzley wheels.  The problem is that when I extend the ladders, the wheel seems to pop up, when I retract the ladders, the wheels drop down.  Is this a known problem?

This is a 1.4.5 game, Buffalo version 2.6.4, with all recommended mods installed.

I'm working on a video with this rover.

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
36 minutes ago, linuxgurugamer said:

@Angel-125

I have a small problem with the Buffalo rover.  I have a small Buffalo with the M1-A2 grizzley wheels.  The problem is that when I extend the ladders, the wheel seems to pop up, when I retract the ladders, the wheels drop down.  Is this a known problem?

This is a 1.4.5 game, Buffalo version 2.6.4, with all recommended mods installed.

I'm working on a video with this rover.

Sounds like a new issue. Do you have a picture of the rover?

Share this post


Link to post
Share on other sites
4 hours ago, Angel-125 said:

@linuxgurugamer Found the issue, should be fixed by the weekend. :)

Whew!   Always nice when a bug can be replicated.

Just curious, what was it and how did you find it?

Share this post


Link to post
Share on other sites
2 hours ago, linuxgurugamer said:

Whew!   Always nice when a bug can be replicated.

Just curious, what was it and how did you find it?

The problem was with the colllider for the wheel itself. It was too large for the wheel. It is set to wheelcollidersignore so not sure why it still affected the rover...

Share this post


Link to post
Share on other sites

Buffalo MSEV 2.6.5 is now available.
GitHub URL: https://github.com/Angel-125/Buffalo/releases/tag/v2.6.5
 
Changes
 
- Fix for Grizzly colliding with extended ladders.
- Fixes Play Mode failing to rename certain files. NOTE: You might need to reset your current play mode. Simply open the WBT app from the Space Center, choose another mode, press OK, and again open the app, selecting your original play mode. Then be sure to restart KSP.

Share this post


Link to post
Share on other sites

It has been a while since the last rover trip but I took a Buffalo out for a drive and it reminded me again what a great vehicle it is. It handled jumps, swerves, turns, and bumps, uphill and down, all over 60 mph. I even hit 83 mph with nothing exploding.

Thank you, again, for making this.

1Raeiyu.png

Share this post


Link to post
Share on other sites
On 8/12/2018 at 5:17 PM, Angel-125 said:

Go to the 000WildBlueTools/Templates folder and delete ClassicStock.cfg. Be sure that you're in CRP play mode before doing that.

Meanwhile, after a lot of prototyping, it's clear to me that making SeaQuest as a lego-like parts mod isn't going to work. So I did some more research and have come up with something more workable:

GqEKFm4.jpg

Just saw this....  Really starting to miss KSP....  make these sharks have freakin' lazers, and this will be an absolute hit!!

Share this post


Link to post
Share on other sites

Buffalo MSEV 2.6.6 is now available.
GitHub URL: https://github.com/Angel-125/Buffalo/releases/tag/v2.6.6
 
Changes
 
- Fixed NRE produced by converters when BARIS isn't installed.
- WBIHoverController now handles hover state updates instead of WBIVTOLManager. This allows multiple craft within physics range of each other to independently hover.

Share this post


Link to post
Share on other sites
On 9/26/2018 at 11:02 AM, Angel-125 said:

Buffalo MSEV 2.6.6 is now available.
GitHub URL: https://github.com/Angel-125/Buffalo/releases/tag/v2.6.6
 
Changes
 
- Fixed NRE produced by converters when BARIS isn't installed.
- WBIHoverController now handles hover state updates instead of WBIVTOLManager. This allows multiple craft within physics range of each other to independently hover.

@Angel-125 I just checked and tried to install your mod with CKAN and it shows that it is not Compatible with this version. I know you have it updated to be used with KSP v1.4.5 but the meta-data information CKAN uses shows that it's Max KSP Version is 1.1.3.

Yes, i still can install it manually but, i just wanted to let you know.

Share this post


Link to post
Share on other sites
9 hours ago, Gryffen1971 said:

@Angel-125 I just checked and tried to install your mod with CKAN and it shows that it is not Compatible with this version. I know you have it updated to be used with KSP v1.4.5 but the meta-data information CKAN uses shows that it's Max KSP Version is 1.1.3.

Yes, i still can install it manually but, i just wanted to let you know.

My mods don’t support CKAN. If it is listed there then hopefully @linuxgurugamer Can get it delisted.

Share this post


Link to post
Share on other sites
2 minutes ago, Angel-125 said:

My mods don’t support CKAN. If it is listed there then hopefully @linuxgurugamer Can get it delisted.

Ok, just wanted to let you know about it. Would you like me to ask linuxgurugamer?

 

Share this post


Link to post
Share on other sites

I'll work on this later this evening.  Actually, @HebaruSan is really the right one to do this, hopefully this ping will get his attention

Share this post


Link to post
Share on other sites
15 hours ago, Gryffen1971 said:

@Angel-125 I just checked and tried to install your mod with CKAN and it shows that it is not Compatible with this version. I know you have it updated to be used with KSP v1.4.5 but the meta-data information CKAN uses shows that it's Max KSP Version is 1.1.3.

Yes, i still can install it manually but, i just wanted to let you know.

Please do not bother mod authors with CKAN problems. Take them to the CKAN thread.

(This is why CKAN users sometimes can't have nice things.)

1 hour ago, linuxgurugamer said:

I'll work on this later this evening.  Actually, @HebaruSan is really the right one to do this, hopefully this ping will get his attention

I'll get it removed as soon as I figure out what the identifier is.

EDIT: It's already frozen from looking for new updates; that's why the version @Gryffen1971 found is so old. There are just a couple of those older releases in the archive to purge...

... should be gone now.

Edited by HebaruSan

Share this post


Link to post
Share on other sites
1 hour ago, HebaruSan said:

Please do not bother mod authors with CKAN problems. Take them to the CKAN thread.

(This is why CKAN users sometimes can't have nice things.)

I'll get it removed as soon as I figure out what the identifier is.

EDIT: It's already frozen from looking for new updates; that's why the version @Gryffen1971 found is so old. There are just a couple of those older releases in the archive to purge...

... should be gone now.

@HebaruSan Github was my first step to submit an issue.

Thanks for your help on this from all of you. All of you are under appreciated in your hard work. Big Thanks!

Edited by Gryffen1971

Share this post


Link to post
Share on other sites

I have been discussing the following fatal error with Blowfish (b9partswitch) and it seems that the Classic Stock Resources is generating said fatal error.

[ERR 16:38:00.363] [ModuleManager] Exception while calling B9PartSwitch.B9TankSettings.ModuleManagerPostLoad()

[EXC 16:38:00.364] PartResourceNotFoundException: No resource definition named 'Oxium' could be found

https://www.dropbox.com/sh/g14v99ts5x7ensz/AADrA7TcCYARCZPnodTqXC-4a?dl=0

Please advise, G

Share this post


Link to post
Share on other sites
1 hour ago, FuzzyG said:

I have been discussing the following fatal error with Blowfish (b9partswitch) and it seems that the Classic Stock Resources is generating said fatal error.

[ERR 16:38:00.363] [ModuleManager] Exception while calling B9PartSwitch.B9TankSettings.ModuleManagerPostLoad()

[EXC 16:38:00.364] PartResourceNotFoundException: No resource definition named 'Oxium' could be found

https://www.dropbox.com/sh/g14v99ts5x7ensz/AADrA7TcCYARCZPnodTqXC-4a?dl=0

Please advise, G

Haven’t heard of this. Does B9psrtswitch define Oxium?

Share this post


Link to post
Share on other sites
52 minutes ago, Angel-125 said:

Haven’t heard of this. Does B9psrtswitch define Oxium?

This is what keeps popping on my screen:

B9PartSwitch - Fatal Error

B9PartSwitch has encountered a fatal error and KSP needs to close.

No resource definition named 'Oxium' could be found

Please see KSP's log for additional details

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.