Angel-125

[1.8.1 - 1.9.x] Buffalo: NASA Inspired Modular Space Exploration Vehicle

Recommended Posts

EDIT:  Never mind.  Turned out to be something unrelated to Buffalo,.

Edited by Geschosskopf

Share this post


Link to post
Share on other sites
1 hour ago, Space Kadet said:

do you need pilots on both craft to make the resource transfer work?

Resource distribution doesn't require anybody to be aboard. You simply go to each part, turn on resource distribution, and select the desired distribution method for each resource. Both craft need to have storage containers with resource distribution turned on. If you've turned on resource distribution and nothing happens, try doing a quick save and reload; there might be a bug in the system that doesn't immediately recognize a change in distribution status.

For individual resources you can:

Ignore: don't do anything with the resource.

Share: Offers up the resource to be distributed evenly among any craft that also shares its resource. There's an exception though..

Consume: This is the exception. A resource set to Consume will be filled to capacity by any resource container that's set to Share. After said resource is filled to capacity, the remainder is divided up evenly among all resource containers that are sharing the resource.

Share this post


Link to post
Share on other sites
12 minutes ago, Angel-125 said:

Resource distribution doesn't require anybody to be aboard. You simply go to each part, turn on resource distribution, and select the desired distribution method for each resource. Both craft need to have storage containers with resource distribution turned on. If you've turned on resource distribution and nothing happens, try doing a quick save and reload; there might be a bug in the system that doesn't immediately recognize a change in distribution status.

For individual resources you can:

Ignore: don't do anything with the resource.

Share: Offers up the resource to be distributed evenly among any craft that also shares its resource. There's an exception though..

Consume: This is the exception. A resource set to Consume will be filled to capacity by any resource container that's set to Share. After said resource is filled to capacity, the remainder is divided up evenly among all resource containers that are sharing the resource.

thats exactly what i thought but it wasent working, ill try the quick saving and reloading thing, it could be an issue with the fact im bringing a new vehicle into range of a base every time im trying to do a transfer.

Playing with your mods is like the old days of distruction testing for risk assessments. i seem gifted at breaking things :P sorry :D 

Share this post


Link to post
Share on other sites
3 hours ago, Space Kadet said:

thats exactly what i thought but it wasent working, ill try the quick saving and reloading thing, it could be an issue with the fact im bringing a new vehicle into range of a base every time im trying to do a transfer.

Playing with your mods is like the old days of distruction testing for risk assessments. i seem gifted at breaking things :P sorry :D 

No worries, I think I know what's going on with resource distribution and should have a fix in a day or two.

Meanwhile, although I'm hip deep in finishing up DSEV right now, I'm still planning for Buffalo's final parts update. One thing I've wanted to do for awhile now is a kerbalized version of this:

RABBIT.jpg

The RABBIT was my version of the iconic Space: 1999 Eagle. Now that I've been playing KSP awhile, I realized that the design wouldn't fly right. So, back to the drawing board:

z9wxO0V.png

olP1pxc.png

This is a mockup of the RABBIT Mk2. It's powered by four "Firebird" Nuclear Tilt Jet engines. The engines run on Atmosphere/CoreHeat or LiquidFuel/CoreHeat and generate 30kn of thrust apiece. The smallest versions won't be powerful enough to launch the craft into the sky on Kerbin, but they'll be fine for the Mun.

Share this post


Link to post
Share on other sites

No idea where to post this or if this even has anything to do with your mods, sorry - but I am getting some kind of weird contract behavior and an error message that includes "WBIResearchContract". In game, under circumstances I don't understand, certain contract parameters (like successfully getting into Munar orbit, in my case) stop being recognized, and seemingly at the same time, solar panels stop producing power even though they're in direct sunlight.

I have an eclectic set of mods, and it certainly could be some weird interaction / nothing at all to do with WBI, but thought I'd stop here first since the thing with WBIResearchContract was the most recent (but not only!) nullref I noticed in my logs after pausing the game to go try to figure out what was going on.

OutputLog: https://www.dropbox.com/s/0ijppslqmrlwfgp/output_log_BTWnode.txt?dl=0

KSP.log: https://www.dropbox.com/s/mfuzo5cbsz2m7tx/KSP.log?dl=0

 

Share this post


Link to post
Share on other sites

Buffalo 2.3.3 is now available:

- Added new Double-wide Saddle Tank. It's just like its predecessor, but twice the width and storage capacity.
- WBT Update

ARP Icons
Added new Alternate Resource Panel icons courtesy of JadeOfMaar. These look great! :)

Edited by Angel-125

Share this post


Link to post
Share on other sites

With USI-LS I am getting some nullrefs ("baseconverter getdeltatime") when activating LifeSupport Recyclers on parts such as WBI_CrewCab.

I checked the Recylcer definitions from USI-LS, and have changed the MM_USI.cfg of Buffalo accordingly like this (for parts WBI_CrewCab and WBI_LongPassengerCab):

Quote

    MODULE
    {
        name = ModuleLifeSupportRecycler
        CrewCapacity = 2
        RecyclePercent = .275
        ConverterName = Life Support
        tag = Life Support
        StartActionName = Start Recycler
        StopActionName = Stop Recycler

        INPUT_RESOURCE
        {
            ResourceName = ElectricCharge
            Ratio = 1
        }    

        //removed input resource replacementparts
    }

Not quite sure why your old definition (which seemed completely legit) doesnt work any more, and I am too lazy to debug USI-LS right now, so just letting you know if you wanna change the MM patch.

I can also send you a pull request if you want, would need to github fork first though...

Share this post


Link to post
Share on other sites
9 hours ago, Zyme said:

2.3.3 crashes my KSP.

What file do you need to check what is wrong?

Make sure you are running ksp 1.3.1.

43 minutes ago, TheDog said:

With USI-LS I am getting some nullrefs ("baseconverter getdeltatime") when activating LifeSupport Recyclers on parts such as WBI_CrewCab.

I checked the Recylcer definitions from USI-LS, and have changed the MM_USI.cfg of Buffalo accordingly like this (for parts WBI_CrewCab and WBI_LongPassengerCab):

Not quite sure why your old definition (which seemed completely legit) doesnt work any more, and I am too lazy to debug USI-LS right now, so just letting you know if you wanna change the MM patch.

I can also send you a pull request if you want, would need to github fork first though...

USI LS is horrendously out of date,in my mods and will likely be removed when ksp 1.4 is released. I don’t use it and nobody is willing to step up and remake them. I do have support for Snacks and TAC Life Support though, and they’re up to date.

Share this post


Link to post
Share on other sites
27 minutes ago, Angel-125 said:

USI LS is horrendously out of date,in my mods and will likely be removed when ksp 1.4 is released. I don’t use it and nobody is willing to step up and remake them. I do have support for Snacks and TAC Life Support though, and they’re up to date.

Ohhhh, sad, but understandable...

Share this post


Link to post
Share on other sites
15 hours ago, Zyme said:

2.3.3 crashes my KSP.

What file do you need to check what is wrong?

Read this then post the file(s) online and ping me. A little explanation like what you do at the exact time (and if it's the same thing you do every time) that causes the crash is helpful.

Edited by JadeOfMaar

Share this post


Link to post
Share on other sites
2 hours ago, JadeOfMaar said:

Read this then post the file(s) online and ping me. A little explanation like what you do at the exact time (and if it's the same thing you do every time) that causes the crash is helpful.

I fixed it by running 64-bit. Seems it was a memory problem.

Share this post


Link to post
Share on other sites
2 hours ago, Zyme said:

I fixed it by running 64-bit. Seems it was a memory problem.

Ah.  Good to know. Launching KSP in 32-bit became a no-no when it stabilized for 64-bit. :P 

Share this post


Link to post
Share on other sites

Ahhh, I think I am halluzinating...

I swear by my dead dog that I do not have the AirPark mod by gomker installed, but somehow in Buffalo this keeps appearing: (imgur)

Anyone an idea where this comes from?

EDIT:

disregard, found it, comes from buffalo config itself...

	MODULE
	{
		name = WBIAirParkController
	}

 

Edited by TheDog
found it...

Share this post


Link to post
Share on other sites
1 hour ago, TheDog said:

Ahhh, I think I am halluzinating...

I swear by my dead dog that I do not have the AirPark mod by gomker installed, but somehow in Buffalo this keeps appearing: (imgur)

Anyone an idea where this comes from?

EDIT:

disregard, found it, comes from buffalo config itself...


	MODULE
	{
		name = WBIAirParkController
	}

 

I created my own version of it when it appeared that the mod was dead.

Share this post


Link to post
Share on other sites
9 hours ago, Angel-125 said:

I created my own version of it when it appeared that the mod was dead.

unfortunately seems to suffer the same issue as in the latest build of the actual mod

Share this post


Link to post
Share on other sites
On 2/13/2018 at 10:06 AM, mostlydave said:

Where can I find the craft file for the osprey?

Look in the SampleCraft folder.

Share this post


Link to post
Share on other sites

OK, I found it, I would never have drilled down the folders looking for it, I thought a samplecraft folder would be in the same folder as gamedata since craft files don't go in the gamedata folder.

Share this post


Link to post
Share on other sites

This is a great mod!  Some of the essential core parts seem to be missing that were shown in the demo video though (like the crew cabin, and the chassis parts...)   Is this mod still being maintained and updated? 

Share this post


Link to post
Share on other sites
23 minutes ago, Astro-Droid said:

This is a great mod!  Some of the essential core parts seem to be missing that were shown in the demo video though (like the crew cabin, and the chassis parts...)   Is this mod still being maintained and updated? 

You must've had an install issue. They're all there! And it's definitely still being updated.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.