Sigma88

[1.0.5] Sigma: Antennas

Recommended Posts

Sigma-Antennas.svg KSP-1.0.5-orange.svg dev.version-%40GitHub-lightgrey.svg total.svg


 
Sigma: Antennas

 
A set of 4 antennas, recolored and resized versions of the stock Comms DTS-M1
because color coding is fun!

If RemoteTech is installed these antennas can be used
to set up a comm system around Jool's moons.
 
kM3aK75.png




 
Dependencies

Requires ModuleManager



Supported Mods

KSP-AVC: Warns you when a new patch is released.


 
RemoteTech: Unmanned vessels require a connection to KSC in order to be controlled.

AntennaRange: Specifies a nominal range at which the antennas work.




 

Images

 
 

 

 






 

 

 

 

 

 

 

 

 

 

 

 

How to install this mod

1 - Download the mod
2 - If you have an old version installed, delete the folder GameData/Sigma/Antennas
3 - Install the mod by merging the GameData folder from the archive with the one in your KSP install
4 - Make sure you have ModuleManager installed. If not, you can find it here.

or

Install it using CKAN



 

Downloads

 

Latest Release
OF8kwwW.png
@GitHub

If you want to contribute to my caffeine addiction:
iSFDI5f.png r8916yD.png
Don't expect anything in return other than my sincere gratitude. :)

 

 


ChangeLog
v1.1.0
- Added Sigma Dimensions compatibility


v1.0.0
- First Release (non beta)
 

 



Credits

- Sarbian & Co. for ModuleManager
- Cybutek for KSP-AVC
- the RemoteTech team for RemoteTech
- toadicus for AntennaRange

 



License

88x31.png
Edited by Sigma88

Share this post


Link to post
Share on other sites
This isn't working for me in CKAN :/

CKAN may need some time to get up to date, I'll ask around to see if I can get an ETA

Share this post


Link to post
Share on other sites
this should work fine with 1.0.5 so I'm updating the compatibility tag

if there are any problems just report them here ;)

Share this post


Link to post
Share on other sites

I am updating this mod to make it compatible with SigmaDimensions

if anyone is still using it and has some feature request, now is the time to ask :D

Share this post


Link to post
Share on other sites

Sigma: Antennas v1.1.0

is now available, download links in the OP

Share this post


Link to post
Share on other sites
5 hours ago, Sigma88 said:

Sigma: Antennas v1.1.0

is now available, download links in the OP

You forgot to update the .version file of this and Outer Space Comms. They show max version of 1.04

Share this post


Link to post
Share on other sites
2 hours ago, armegeddon said:

You forgot to update the .version file of this and Outer Space Comms. They show max version of 1.04

Thanks, I'll fix that asap :)

edit:

@Armageddon I have checked and in the KSPAVC database it is saved as 1.0.5, that info should override the 1.0.4 setting is the .version file. are you getting an error from it?

Edited by Sigma88

Share this post


Link to post
Share on other sites
On 19.03.2016 at 3:07 AM, Sigma88 said:

Thanks, I'll fix that asap :)

edit:

@Armageddon I have checked and in the KSPAVC database it is saved as 1.0.5, that info should override the 1.0.4 setting is the .version file. are you getting an error from it?

Yes, in the KSPAVC database " Sigma: Antennas" and " Sigma: OuterSpaceComms" are saved as 1.0.5.

But zip file in https://github.com/Sigma88/Sigma-OuterSpaceComms/releases/tag/v1.1.0 contains file "Sigma-OuterSpaceComms.version" with string:

"KSP_VERSION":{"MAJOR":1,"MINOR":0,"PATCH":4}

 

Is it reason why CKAN bot doesn't recognise this plugin as compatible for 1.0.5?

Sigma88, did you update compatibility tag?

Share this post


Link to post
Share on other sites
1 hour ago, gal20040 said:

Yes, in the KSPAVC database " Sigma: Antennas" and " Sigma: OuterSpaceComms" are saved as 1.0.5.

But zip file in https://github.com/Sigma88/Sigma-OuterSpaceComms/releases/tag/v1.1.0 contains file "Sigma-OuterSpaceComms.version" with string:

"KSP_VERSION":{"MAJOR":1,"MINOR":0,"PATCH":4}

 

Is it reason why CKAN bot doesn't recognise this plugin as compatible for 1.0.5?

Sigma88, did you update compatibility tag?

I wasn't aware CKAN used that file, and KSP AVC doesn't need it to be updated, that's why I didn't update in the last version.

@politas has now put in a change that should fix this issue (at least untill 1.1 is released I guess)

in the next release I'll make sure to update the .version file so CKAN can get it's notification from there

Edited by Sigma88

Share this post


Link to post
Share on other sites

I have decided to open a KSP Mods related Twitter account

If you want news on the development of my mods, as well as cool screenshots I take when I am checking them, you can find those here:

Sigma88Mods&style=social

Share this post


Link to post
Share on other sites

 

5 hours ago, blu3wolf said:

Will these work with 1.1.2 as is?

I have not tried them yet

I think they should work, but I have a lot of other mods to fix before trying this one. If you decide to try, make sure to backup your saves :)

And feel free to report here if they work or not

Share this post


Link to post
Share on other sites

These seem to work fine! I might object a little to their power, weight and cost ratios, but they do work as advertised.

Share this post


Link to post
Share on other sites

I can confirm this is working in 1.1.2 so I bumped the version up from 1.0.4 to 1.1.2

:wink:

Share this post


Link to post
Share on other sites
On 5/19/2016 at 2:34 AM, Sigma88 said:

I can confirm this is working in 1.1.2 so I bumped the version up from 1.0.4 to 1.1.2

:wink:

Hey Sigma, any plans to update to 1.2.1?

Share this post


Link to post
Share on other sites

Yes but as always other mods have the priority over this one

I think that if you install this you will still get the parts, so you can load old saves. The antennas just won't have any funcionality

If you loase crafts when loading a save pls let me know

Edited by Sigma88

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.