Sigma88

[1.0.5] Sigma: OuterSpaceComms

Recommended Posts

Sigma-OuterSpaceComms.svg KSP-1.0.5-orange.svg dev.version-%40GitHub-lightgrey.svg total.svg


 
Sigma: OuterSpaceComms

 
A set of 3 antennas designed to probe deep into outer space.

If you have one or more mods that add planets in orbit outside Jool
you will be able to reach them with this set of dishes.
 
4F0lGSH.png


 
Dependencies

Requires RemoteTech* and ModuleManager

*(since the models of the antennas are not released to the general public this mod does NOT redistributes them)



Supported Mods

KSP-AVC: Warns you when a new patch is released.
 



 

Images

 
 






 

 

 

 

 

 

 

 

 

How to install this mod

1 - Download the mod
2 - If you have an old version installed, delete the folder GameData/Sigma/OuterSpaceComms
3 - Install the mod by merging the GameData folder from the archive with the one in your KSP install
4 - Make sure you have RemoteTech installed. If not, you can find it here.
5 - Make sure you have ModuleManager installed. If not, you can find it here.

or

Install it using CKAN


 

 


Downloads
Latest Release
T1wr2yR.png
@GitHub

If you want to contribute to my caffeine addiction:
iSFDI5f.png r8916yD.png
Don't expect anything in return other than my sincere gratitude. :)

 

 


ChangeLog
v1.1.0
- Added Sigma Dimensions compatibility


v1.0.0
- First Release (non beta)
 
 
 
 

Credits

- Sarbian & Co. for ModuleManager
- the RemoteTech team for RemoteTech
- Cybutek for KSP-AVC

 

 

 

 



License

88x31.png

 

Edited by Sigma88

Share this post


Link to post
Share on other sites
this should work fine with 1.0.5 so I'm updating the compatibility tag

if there are any problems just report them here ;)

Share this post


Link to post
Share on other sites

I am updating this mod to make it compatible with SigmaDimensions

if anyone is still using it and has some feature request, now is the time to ask :D

Share this post


Link to post
Share on other sites

Sigma: Outer Space Comms v1.1.0

is now available, download links in the OP

Share this post


Link to post
Share on other sites

CKAN needs to be updated. Still shows 1.0.4: https://yadi.sk/i/qPMg3ID1qXxdV

 

update 2016.03.28:

In the file "Sigma-OuterSpaceComms.version" i've found this:

"KSP_VERSION":{"MAJOR":1,"MINOR":0,"PATCH":4}

 

Is it reason why CKAN bot doesn't check this plugin compatible for 1.0.5?

Sigma88, did you update compatibility tag?

 

update 2016.03.28:

conversation of old plugin's version in CKAN:

http://forum.kerbalspaceprogram.com/index.php?/topic/123049-105-sigma-antennas/#comment-2464622

Edited by gal20040

Share this post


Link to post
Share on other sites

Yes, CKAN is using the included .version file to know which versions of KSP are supported by this mod. I can code in an override so that v1.1.0 is marked as 1.0.5 compatible, but AVC will throw up an incompatibility message for anyone who has it installed.

Share this post


Link to post
Share on other sites
2 minutes ago, politas said:

Yes, CKAN is using the included .version file to know which versions of KSP are supported by this mod. I can code in an override so that v1.1.0 is marked as 1.0.5 compatible, but AVC will throw up an incompatibility message for anyone who has it installed.

Hi, politas!

http://forum.kerbalspaceprogram.com/index.php?/topic/123049-105-sigma-antennas/#comment-2476980 - another one conversation of that issue with " Sigma: Antennas".

What can you offer for solving this issue?

Why "AVC will throw up an incompatibility message"?

Share this post


Link to post
Share on other sites

Ah, reading in that other post I have realised that the database change will probably prevent AVC from complaining about the information in the .version file. CKAN doesn't use the AVC database, though, only the information contained in the .version file. I've put in a change to address both mods

Share this post


Link to post
Share on other sites
49 minutes ago, politas said:

Ah, reading in that other post I have realised that the database change will probably prevent AVC from complaining about the information in the .version file. CKAN doesn't use the AVC database, though, only the information contained in the .version file. I've put in a change to address both mods

Thanks,

I didn't know CKAN was using the .version file, that's why I didn't bother changing it in the last release

From the next release I'll make sure to update the version file

Share this post


Link to post
Share on other sites
3 hours ago, gal20040 said:

Sigma88, politas, thank you!

Waiting for new release.
 

you don't need to wait for a new release, the changes politas added to CKAN will make this release work fine on 1.0.5

the next release will probably come after both KSP 1.1 and the relative RT patch have been released

Share this post


Link to post
Share on other sites

I have decided to open a KSP Mods related Twitter account

If you want news on the development of my mods, as well as cool screenshots I take when I am checking them, you can find those here:

Sigma88Mods&style=social

Share this post


Link to post
Share on other sites

same as with the other antennas, do these need updating to work with 1.1.2?

Share this post


Link to post
Share on other sites
5 hours ago, blu3wolf said:

same as with the other antennas, do these need updating to work with 1.1.2?

Same as the others:

I have not tried them yet

 

I think they should work, but I have a lot of other mods to fix before trying this one. If you decide to try, make sure to backup your saves 

 

And feel free to report here if they work or not

Share this post


Link to post
Share on other sites

will do (for both) when Ive sorted out my current mod issue. Downloaded a bunch of mods, one of them must not play nice with the others (horrible stuttering).

Cheers for the quick reply!

Share this post


Link to post
Share on other sites

Looks like the parts are there in the tech tree, although they are all in the same node (Advanced Science Tech). Havent gotten far enough to use them yet. I might see about writing a MM config to move them around the tree a bit.

Share this post


Link to post
Share on other sites

All in the same? I thought they were spread in 2 nodes

Edit: no you are right, they are all in the same node

 

You could check if they are working on a sandbox game. I've still got a bunch of mods to update, but I guess I could do a quick test to see if these work out of the box

Edited by Sigma88

Share this post


Link to post
Share on other sites

I could, but I havent started a sandbox game since career mode was added :P

Share this post


Link to post
Share on other sites

the last post was 1 hour prior... did this need a bump?

Share this post


Link to post
Share on other sites

I can confirm this is working in 1.1.2 so I bumped the version up from 1.0.4 to 1.1.2

:wink:

Share this post


Link to post
Share on other sites

If we plan to use this with Antenna Range, what steps should we take to get the high ranged antenna?

I like the limitations of Antenna Range, having to set up relays, but I don't like the realisticness of RemoteTech, I preffer having a 1:1 reaction time with my ships, and accidentally flying behind a planet, loosing control of the ship, only to have it crash into a moon or burn up in re-entry, doesn't really appeal to me. Would it be as simple as ripping the mod part from RT to make this work? or would we need to do some slighly more cheatsy things to make it work? (IIRC I had ripped the seismic sensor from Interstellar Quest back in uh... Beta I think, maybe .90? maybe earlier I can't remember. For the most part the single part I ripped worked, I just got an error saying the mod was installed incorrectly every time I started the game XD)

Share this post


Link to post
Share on other sites
6 minutes ago, Drakoflame said:

If we plan to use this with Antenna Range, what steps should we take to get the high ranged antenna?

I like the limitations of Antenna Range, having to set up relays, but I don't like the realisticness of RemoteTech, I preffer having a 1:1 reaction time with my ships, and accidentally flying behind a planet, loosing control of the ship, only to have it crash into a moon or burn up in re-entry, doesn't really appeal to me. Would it be as simple as ripping the mod part from RT to make this work? or would we need to do some slighly more cheatsy things to make it work? (IIRC I had ripped the seismic sensor from Interstellar Quest back in uh... Beta I think, maybe .90? maybe earlier I can't remember. For the most part the single part I ripped worked, I just got an error saying the mod was installed incorrectly every time I started the game XD)

last time I checked AntennaRange diabled itself when remote tech was installed, and you need remote tech to install this mod.

so it shouldn't be possible to use this mod with AntennaRange

(unless things have changed)

Share this post


Link to post
Share on other sites
Just now, Sigma88 said:

last time I checked AntennaRange diabled itself when remote tech was installed, and you need remote tech to install this mod.

so it shouldn't be possible to use this mod with AntennaRange

(unless things have changed)

Dang... I was really hoping I'd be able to fudge something... I wanted to use it with OPM (and a few others, I just discovered you "Galactic Neighborhood" mod and am looking at the thread with a list of compatible mods XD)

Share this post


Link to post
Share on other sites

I just upgraded to 1.1.3 and I'm getting vessels failing to load due to their missing these dishes.

Which is weird, this hugely outdated version worked fine in 1.1.2 but no longer

Prehaps it is no longer syncing well with the latest version of remote tech? Or community tech tree? Please fix this really is vital for the OPM IMO

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.