r4m0n

[PART, 1.0.2] Anatid Robotics / MuMech - MechJeb - Autopilot - Historical thread

Recommended Posts

Since you talk about sat you must be using RT2. You need the dev version of MJ to fix that bug. Or disable delay in RT2 config.

Share this post


Link to post
Share on other sites
OK, upgraded to the 123 build this AM and found a minor oddity in Smart A.S.S.. When I select ORBT/Normal +, it orients the vehicle to the proper attitude, but unlike 102 (which I was upgrading from) it leaves the vehicle with a roll rate.

(And thanks for warp-to-time!)

Another build already? I used 122 last night and saw a similar issue. Enable kill rotation or use one of the orbit pointing functions with force roll then turn SASS off and the ship will start rolling without any control inputs and the pitch/yaw/roll meters all in the middle.

Turn SASS on and it goes back to holding orientation, off and it immediately begins to roll again.

What would be nice is if KSP simulated what happens to the orientation of things in orbit, they align to point radially out from the planet they're orbiting because of tidal effect. Objects like the Hubble telescope and the ISS have to constantly use reaction wheels or thrusters to counteract the gravity tidal effect trying to orient them like spokes on a wheel. The effect can be used to advantage for things like communication satellites by making them long enough and distributing mass towards the ends so they'll keep the antenna aimed down without needing constant attitude control.

Share this post


Link to post
Share on other sites

Hello to all. I am / have been trying to get MJ and FAR to work together, just a little bit.... I am only working with rockets, no planes, ssto or shuttles. All working great,,,,, until time to deorbit and try to use landing guidance. I have all tabs on FAR turned off, but still problems when trying to use LG to get me down. I have loaded latest MJ, FAR, MJFAR and all other that i know of.

Am I just wasting my time for now and would be better just to pull FAR, or is there some 'special' trick or something that I am doing wrong.

Many thanks for all previous support and all work that Sarbian has done. This is my #1 MUST HAVE mod.... Cheers.

Share this post


Link to post
Share on other sites

@sarbian

I am pleased to say that the latest release of MechJeb fixes the problem with warping to the SOI transition point from an enclosed SOI to an outer SOI. (i.e., from orbiting Mun to a Kerban orbit) I am still having problems with the return from moon failing to generate an orbit that has a periapsis at the correct distance. It appears to be worse for orbits that are highly inclined from the equatorial orbit.

skips

Share this post


Link to post
Share on other sites
Since you talk about sat you must be using RT2. You need the dev version of MJ to fix that bug. Or disable delay in RT2 config.

thanks a bunch

Share this post


Link to post
Share on other sites

Build 122. Another landing test on Eve. Almost working.

Since I'll be needing to do on-surface refueling, I got out the functional but pointless* drill rover I tested on Mun and added four more of the white radial mount engines, bringing the total to six.

First test it was going down nicely, almost down to the right landing speed... then it began to rapidly wobble back and forth with the engines at full throttle, eventually hard landing, breaking all four landing legs in the down position, breaking 7 of the 8 wheels and breaking off some of the engines and fuel tanks. It's built to jettison them with separatrons after landing. There's no RCS on it, just reaction wheels.

Second test I stuck on four radial mount parachutes on the fuel tanks. Comes down nice and stable... hey, is it going to light up or not? Gear down... engines? Hello computer? We could use some thrust about now! Hard landing at 8 meters per second after yet another too late burn at less than full throttle, only broke one landing leg which I was able to get rid of by driving forward a bit to make it explode. But still unsatisfactory because the design uses the legs for stability and if needed a bit of extra height to connect to the lander.

Perhaps using only a couple of chutes would keep enough vertical velocity to push MechJeb into starting the burn higher and harder to get the speed down to the requested .5 meter/second? Or perhaps going up to 1 would change things?

Fuel tanks used are an X200-8 and four FL-T400. MechJeb is a miserly user of this supply. Without the parachutes it landed with over 70% of it left. It has enough engine thrust, it has more than enough fuel to make a safe one way trip down to Eve, but MechJeb is being too conservative on the final landing burn.

I've had landers run out of fuel many times testing on Kerbin, Mun and Duna with MechJeb, so why can't I get it to burn it all landing on Eve? This is a situation where I'd be happy if it'd burn almost all the way down, as long as it'd calculate the trajectory to leave just fumes in the tanks at touchdown.

When running out of fuel on other planets, the solution is to add more fuel, then add more engine if the additional weight makes it crash. Eve appears to need little fuel but lots of engine to land, but requires a supertanker's worth of fuel to get back to orbit.

It should be possible to put together a single stage orbit to surface to orbit Eve lander with a TWR greater than 1 in Eve gravity with full tanks. Give it just enough fuel to land with an aggressive burn profile then refuel on the surface, filling up all the tanks so the engines can run long enough to push the ship back up.

*No fuel savings moving the heavy drills from the lander to the separate rover on Mun, but a bunch of work to get the rover's arm docked to the lander. Before I added the additional four engines I tried it as-is to see how bad it would fail with only 2. I don't consider that a test flight since it was known in advance it wasn't going to be able to land slow enough. If it had been able to kill horizontal velocity and hadn't flipped upside down after crashing it would've worked for an intentionally hard landed stationary probe.

Share this post


Link to post
Share on other sites
Hello to all. I am / have been trying to get MJ and FAR to work together, just a little bit.... I am only working with rockets, no planes, ssto or shuttles. All working great,,,,, until time to deorbit and try to use landing guidance. I have all tabs on FAR turned off, but still problems when trying to use LG to get me down. I have loaded latest MJ, FAR, MJFAR and all other that i know of.

Am I just wasting my time for now and would be better just to pull FAR, or is there some 'special' trick or something that I am doing wrong.

Many thanks for all previous support and all work that Sarbian has done. This is my #1 MUST HAVE mod.... Cheers.

FAR changes the stock drag model, that is everythin atmosphere related. Because of that, MJ won't do the calculations for the landing guidance correctly.

Even though that does not work, that's no reason to uninstall FAR, FAR is awesome! and MJ still works for everything except landing on bodies with atmospheres!

A technique I use: Press F5, set periapsis to, let's say 30Km (for example's sake), with the surface tab check my longitude when I perform the burn, wait until I land, then check my final longitude. Press F9, find the difference between initial and final longitude, let's say it's 150 deg. Now you have to make your deorbit burn 150 deg before your target longitude, and that's it :)

Share this post


Link to post
Share on other sites

Ok, sounds good. I really want to keep FAR in and this is the type of 'fix' that will help me do that. Many thanks AbeS..... And to Farram and Sarbian.... Really good stuff....

Share this post


Link to post
Share on other sites

Thanks the original author, without them MJ would not be here :)

Share this post


Link to post
Share on other sites

I got a question for you guys; I just downloaded the newest version of mechjeb then started a Career mode game, and am powering through it. Only thing is, I can't seem to find the radially attached Mechjeb in my parts list ( I'm nearly done the techtree, the only thing left is Mod tech tree stuff like the Interstellar engines mod), just the actual Mechjeb command pod and the ar202 case that only does attitude control. AM I missing something stupidly obvious or does the Default AR202 case take the place of the fully functional one?

Share this post


Link to post
Share on other sites

Do you play with a modded tree ? The case use the node name to unlock function, so if you use a tree with different node name then the function won't unlock.

Share this post


Link to post
Share on other sites

Been a while since I used mechjeb, but I've just installed 2.1 on a clean install of 0.22 and can not find the 'Ascent statics' or what ever it was called that used to tell you how much DV you had burnt since launch and where it went to ie Speed, Gravity loss, Steering, Drag.. Has this been removed or is it hidden?

Never mind, found options in the customers window section!

Edited by sjwt

Share this post


Link to post
Share on other sites

It's not here by default. You can rebuild it with by adding a window with the custom window editor and adding item from the Recorder category (and maybe others, not in front of KSP now)

Share this post


Link to post
Share on other sites

Finally got the Tinker landing instead of crashing on Eve.

Added some RCS thrusters and a small 50 unit mono tank and a single parachute. Landing on Eve is still a very dicey process. It tries to wobble back and forth but the chute keeps enough drag and stability on it without having *too much* drag - making MechJeb use enough thrust to cut the vertical speed down to the point where things won't break.

Strange that with four parachutes it wouldn't use enough throttle to cut vertical speed enough for a damage free landing but with one it does. With no parachutes it will use full throttle but not soon enough and it's very unstable, makes three or four swoops then crashes and flips upside down. With only the two center engines (and pipes to them from the side tanks) it would land perfectly stable on Mun.

I also test landed this on Kerbin from 71KM and when it came time to start the landing burn it went right to full throttle, which had the chute dragging below the lander for a bit.

http://pastebin.com/jJ1VDBch Uses KSPX, ReStock, Quantum Struts, Kethane, Infernal Robotics, DROMOMAN.

After landing, transfer fuel to the center tank then hit the spacebar a couple of times to jettison the engines and fuel tanks. The remains of the decouplers will vanish when you switch away and back to the rover. Raise and unfold the arm then decouple the RCS tank. Drop it from high enough and you won't have to delete the debris.

Next step, convert this to a rover (Evers) with a Kethane converter, using the same robot arm plus add a docking port somewhere to connect the drill rover's arm to.

The manned lander (to be named Chance) is going to be the hard one to do.

Share this post


Link to post
Share on other sites
Do you play with a modded tree ? The case use the node name to unlock function, so if you use a tree with different node name then the function won't unlock.

Well, I have the tree modded so I can use the Interstellar stuff.....

Also, assume like a I'm a idiot and explain a little more; I haven't played KSP for a few months so I'm not up on all the new tricks to mods and stuff.

Share this post


Link to post
Share on other sites

Some people don't like it when I assume there are idiot :D

First the only part available in 2.x is the pod and ar202. I forgot that there was more part in 1.x ^^

The current version of mechjeb use the tree to unlock the case and then unlock some function. The case unlock at the "flightControl" node and then other function unlock at advFlightControl, fieldScience, unmannedTech and advUnmanned (Those are the node internal name but you should match them easily with the displayed name). So the menu won't show all its options until you have all those node.

If you use the "Interstellar" tree from treeloader those node should be present and the function should unlock since it's not that different from the stock tree.

I understand you unlocked a lot already but did you unlock those ? Or maybe you did not check the AR case since earlier in the tree ?

Galane : I'll take a look at your newer creation. If I replace the monoprop and 1 parachute by 4 parachute it should crash ?

Share this post


Link to post
Share on other sites
Some people don't like it when I assume there are idiot :D

First the only part available in 2.x is the pod and ar202. I forgot that there was more part in 1.x ^^

The current version of mechjeb use the tree to unlock the case and then unlock some function. The case unlock at the "flightControl" node and then other function unlock at advFlightControl, fieldScience, unmannedTech and advUnmanned (Those are the node internal name but you should match them easily with the displayed name). So the menu won't show all its options until you have all those node.

If you use the "Interstellar" tree from treeloader those node should be present and the function should unlock since it's not that different from the stock tree.

I understand you unlocked a lot already but did you unlock those ? Or maybe you did not check the AR case since earlier in the tree ?

Galane : I'll take a look at your newer creation. If I replace the monoprop and 1 parachute by 4 parachute it should crash ?

I unlocked the AR202 case, yes, but when I try to use it it's the "Attitude control" variant, not the full up autopilot one. I CAN make a usable craft with the pod, but it's clunky as hell and I hate having to put it on the top of my craft where the (Manned) pod should go....

Share this post


Link to post
Share on other sites

Ok, something is strange.

For now : Edit your GameData/Mechjeb2/Parts/MechJeb2_AR202/part.cfg and replace this part :


MODULE
{
name = MechJebCore
MechJebLocalSettings {
MechJebModuleCustomWindowEditor { unlockTechs = flightControl }
MechJebModuleSmartASS { unlockTechs = flightControl }
MechJebModuleManeuverPlanner { unlockTechs = advFlightControl }
MechJebModuleNodeEditor { unlockTechs = advFlightControl }
MechJebModuleTranslatron { unlockTechs = advFlightControl }
MechJebModuleWarpHelper { unlockTechs = advFlightControl }
MechJebModuleAttitudeAdjustment { unlockTechs = advFlightControl }
MechJebModuleThrustWindow { unlockTechs = advFlightControl }
MechJebModuleRCSBalancerWindow { unlockTechs = advFlightControl }
MechJebModuleRoverWindow { unlockTechs = fieldScience }
MechJebModuleAscentGuidance { unlockTechs = unmannedTech }
MechJebModuleLandingGuidance { unlockTechs = unmannedTech }
MechJebModuleSpaceplaneGuidance { unlockTechs = unmannedTech }
MechJebModuleDockingGuidance { unlockTechs = advUnmanned }
MechJebModuleRendezvousAutopilotWindow { unlockTechs = advUnmanned }
MechJebModuleRendezvousGuidance { unlockTechs = advUnmanned }
}
}

by


MODULE
{
name = MechJebCore
}

This will change you AR202 to have all the module unlocked whatever your progression in the tech tree.

Then could you send me you /save/<nameofSaveGame>/tree.cfg and /save/<nameofSaveGame>/persistent.sfs (not sure of the name) so I can try to understand you bug.

Use dropbox or pastebin. Thanks

Share this post


Link to post
Share on other sites

-Snip-

Then could you send me you /save/<nameofSaveGame>/tree.cfg and /save/<nameofSaveGame>/persistent.sfs (not sure of the name) so I can try to understand you bug.

Use dropbox or pastebin. Thanks

Okay, got it posted.

http://pastebin.com/3iUmN12H

http://pastebin.com/Ch3GJLFt

Haven't had time to test out the fix, but when I have the chance I'll try it out.

Share this post


Link to post
Share on other sites

Am I doing something wrong here? I installed mechjeb and all the plugins, but I only have Custom Window Editor and Settings. What am I missing here? How do I get access the ascent autopilot, landing autopilot, docking autopilot, etc?

Share this post


Link to post
Share on other sites

Galane : I'll take a look at your newer creation. If I replace the monoprop and 1 parachute by 4 parachute it should crash ?

It'll land hard enough to break one or more of the landing legs. I put the radial chutes on top of the four side mounted tanks. The last time I tried it with four chutes I had a quantum core on the end of the arm (where the mono tank is) and used the larger clampotrons instead of the juniors. Dunno if weight is enough different to have an effect.

What I posted on pastebin will land without breakage but it gets very unstable. Try it without using the parachute to see how bad it can get. Leave on just the two middle engines, connect the side tanks to them with fuel pipes and it's a perfectly stable Mun lander, even without RCS.

Share this post


Link to post
Share on other sites
Edit bis : and added a new "Resonant Orbit" option in the Manoeuver Planner. It puts you in a new orbit having an orbital period equal to fraction of your original orbit. So you can launch a ship with 3 satellites attached, go to a synchronous orbit and ask MJ to put you in a 2/3 resonant orbit. Then if you launch a sat each time you are at the AP they'll be at a 120° angle from each other.

That is all kinds of awesome, thanks!

Share this post


Link to post
Share on other sites

Oddness - I have four inertial stabilizers and mechjeb 2 on a ship comprised of 7 orange tanks (one orange surrounded by 6 outer), all interconnected with fuel lines. This group of tanks is powered by 7 nerva engines. I use this setup to push probes and landers to all parts of the Kerbol system.

Sometimes, even when mechjeb is in control and the engines are gimbling and thusting away the roll pitch and yaw indicators will start to creep to the extremes, and then finally the ship tumbles wildly out of control. Turning off the engines and turning SAS -on- sometimes helps, and other time the gyrations will continue until the ship tears itself apart!

Three smaller inertial stabilizers are at the top of the orange tanks, distributed in a triangle pattern on three thanks, with a tank spaced between and a docking port on the central tank. A forth, large stabilazer is mounted on the end of the central core just above the engines. The ship, sans attached probe or lander, weighs about 260 tons.

Has anyone else experienced this oddness?

Share this post


Link to post
Share on other sites

Galane & Lazurkri : I'll look at your problem later. Less free time than anticipated.

Briarknit : you'll have to read my post on the previous page.

Gaius : nice to have some feedback on that one :)

AstroRick can I get a picture of the ship ?

Edited by sarbian

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.