r4m0n

[PART, 1.0.2] Anatid Robotics / MuMech - MechJeb - Autopilot - Historical thread

Recommended Posts

Question. Is there any way to obtain a geosynchronous orbit with Mechjeb? I've tried to find it in the comments here- but I think I missed it somewhere.

Share this post


Link to post
Share on other sites
Question. Is there any way to obtain a geosynchronous orbit with Mechjeb? I've tried to find it in the comments here- but I think I missed it somewhere.

Use the Ascent Computer to get to a 475km orbit. Once you're in orbit, wait until you are 90° before your target longitude and use the Orbital Operations to set your Apoapsis to 4868. Warp to Apoapsis. Circularize.

Edited by Nibb31

Share this post


Link to post
Share on other sites

would be ok if i release my freetrack enabled version of mumechlib (il call it a beta since its to the tweak it till it feels right stage). it would come with a virtual cockpit part and instructions for usage. rules say i need permission to do that though, and im not quite sure if dynamically linked things is allowed either. :D

Share this post


Link to post
Share on other sites
would be ok if i release my freetrack enabled version of mumechlib (il call it a beta since its to the tweak it till it feels right stage). it would come with a virtual cockpit part and instructions for usage. rules say i need permission to do that though, and im not quite sure if dynamically linked things is allowed either. :D

It would be better if you make a new DLL with just the camera module (and make that a new class, so to not conflict with the camera module). You can either reference mumechlib or just copy and alter the source, I'm OK with it.

Share this post


Link to post
Share on other sites

Is anyone else getting constant plugin crashes with the latest MechJeb?

Share this post


Link to post
Share on other sites
That geosynchronous orbit is at 2868400 metres, isn't it? At least that's where my sats are.

Correct. I have many geostat satellites at this altitude.

Share this post


Link to post
Share on other sites

Use the Ascent Computer to get to a 475km orbit. Once you're in orbit, wait until you are 90° before your target longitude and use the Orbital Operations to set your Apoapsis to 4868. Warp to Apoapsis. Circularize.

Okay. Testing this out. Kinda afraid I'll botch it, but we'll see. What do you mean by 90° before your target longitude though? Won't that put me -way- off orbit? o.o

Share this post


Link to post
Share on other sites

I suggest you read all the posts after your own, but if you dont, please post screenies for my own warped enjoyment.

Share this post


Link to post
Share on other sites

Okay, so that didn't work. I started the burn 90 degrees early, ended up 90 degrees early, and moving slower than Kerbin.

In case anyone's wondering just what the heck I'm up to, I'm trying to get a RemoteTech sat in orbit synced to the KSP Command unit, so that I don't have to use eight trillion satellites in that area.

Also: That geosynchronous orbit is at 2868400 metres, isn't it? At least that's where my sats are.

How the hell do you get into individual meter calculation? MechJeb only lets me operate in Kilometers!

Edited by Tassyr

Share this post


Link to post
Share on other sites

Hi all, newbie here seeking help please.

The screenshot at the start of this thread shows a rocket with a mechjeb command module fitted. The command module shows engines fitted. Also i have watched a mechjeb tutorial on youtube by 'szyzyg' which has a similar command module described as a 'composite module complete with engines, thrusters,decoupler and fuel tank'.

:rolleyes:My recently installed mechjeb has 2 mechjeb command modules but they have no engines etc. There are some mechjeb engines in the propulsion locker which look similar to those fitted to the module in your screenshot, but i cannot get them to install to the module. Any help appreciated.

Share this post


Link to post
Share on other sites

Okay. Is there some way to tell Mechjeb "PUT THE APOAPSIS HERE?" it always seems to have the dang thing on the wrong side of the planet- I can't get it to anwhere near where I need to be. I also still can't actually get into the geosynchronous orbit- I'm always just above or below, making my sat move out of range.

Share this post


Link to post
Share on other sites

If I knew how to help you Tassyr then I would but I'm simply out of options. Sorry.

Share this post


Link to post
Share on other sites

No worries, Just frustrating. And thanks for the help!

I'd've thought it'd be easier than this, is all. >.< My other option was to get them evenly spaced and orbiting Kerbin at about 250km, but I can't figure out how to do that either.

Share this post


Link to post
Share on other sites
Use the Ascent Computer to get to a 475km orbit. Once you're in orbit, wait until you are 90° before your target longitude and use the Orbital Operations to set your Apoapsis to 4868. Warp to Apoapsis. Circularize.

Okay. Testing this out. Kinda afraid I'll botch it, but we'll see. What do you mean by 90° before your target longitude though? Won't that put me -way- off orbit? o.o

Sorry, I screwed up. Yes, the magic altitude for GSO is 2868.4km, not 4868, but 2868 is as close as the MechJeb will get you. You can later fine-tune your orbit by looking at the Orbital Information pane. It's pretty hard to get a perfect orbit and some drift is inevitable, which is why you will need to do some station-keeping over time. You should equip your GSO sat with RCS and fuel for station keeping, like in real life.

The 90° angle from the 475km transfer orbit works like this: KSC is at -74°.6 longitude, so if you want to get your satellite above that target, you want to start your burn at -164.6°. You can see your current position in the Surface Information pane. Depending on your rocket, this should get you between plus or minus 1 or 2 degrees of your target longitude.

Edited by Nibb31

Share this post


Link to post
Share on other sites
How the hell do you get into individual meter calculation? MechJeb only lets me operate in Kilometers!

Divide is by 1000 and enter as a decimal fraction, i.e. "2868.4".

Share this post


Link to post
Share on other sites
Okay. Is there some way to tell Mechjeb "PUT THE APOAPSIS HERE?" it always seems to have the dang thing on the wrong side of the planet- I can't get it to anwhere near where I need to be. I also still can't actually get into the geosynchronous orbit- I'm always just above or below, making my sat move out of range.

Raise your apoapsis when you are on the opposite side of where you want it to be (assuming you are in a nearly circular orbit of course, if not, then circularize first.)

Share this post


Link to post
Share on other sites

Tried that, Nibb31. Ended up on the opposite side again, because the dang planet rotated. >.< I just can't get this thing to work, it seems. :(

Share this post


Link to post
Share on other sites
Tried that, Nibb31. Ended up on the opposite side again, because the dang planet rotated. >.< I just can't get this thing to work, it seems. :(

What are you trying to do ? The only way to counter Kerbin's rotation is to go up to geostationary altitude, which is 2868km. To get a good aim, first you must get a circular orbit around 475km (geostationary transfer orbit), and burn when you are 90° before your target, as described in my previous post. If you want to be above KSC at -74.6°, then burn when you are at -164.6°.

Share this post


Link to post
Share on other sites

honestly I was just trying to get into geosynch at any point where the RemoteTech would have a link to KSP, so roughly at that point on the equator. Thing is I HAVE tried your way. For some reason it likes to get to geostationary altitude then flip me the middle finger and refuse to go stationary. =P

I mean, even ignoring the fact that I've just done test-flights to get it into geostationary orbit to begin with, I -cannot- achieve that. The planet rotates and the ship orbits- and they are at -different- speeds, even when I hit the prescribed altitude, and have circularized. =P

Where I end up, following your directions: -146 longitude, which begins changing instantly. 4867908m altitude (Give or take a few) meters. With an orbital period of 12 hours, approx.

Edited by Tassyr

Share this post


Link to post
Share on other sites

@Tassyr Just to remind you, we're not talking about Earth here, we're talking about Kerbin, where the altitude for a Kerbosynchronous orbit would be roughly 2868.4 km[1]. So if you instead go to 4867,9 km you'd end up with a slower orbital speed than is required for a stationary orbit.

Share this post


Link to post
Share on other sites

GSO is 2868km, not 4868km. I'm sorry for causing the confusion.

Share this post


Link to post
Share on other sites

*FACEPALM.*

WOw. I've been shooting for the wrong altitude, and somehow completely missed that it was changed in -all those posts.- Man, I feel dumb. That's what I get for playing at 4 am. >.< sorry for the trouble, testing now.

It worked! I now have the first of what will become four geosynched satellites, providing constant remotetech control! Thank you!

Edited by Tassyr

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.