Jump to content

[PART, 1.0.2] Anatid Robotics / MuMech - MechJeb - Autopilot - Historical thread


Recommended Posts

Update to autostaging problem...

Auto-stage works... and it doesn't...

Two identical landers, using identical parts, but assembled with different sequences. The first lander is built straight-up as a single unit, starting with a MJ-equipped component and working down to the booster engine. The second has an initial MJ-equipped component used as a base, with the lander constructed separately on it, having its own MJ-equipped component. This lander is then separated into a subassembly for use later on different launchers.

The straight-up lander assembly goes through auto-stage without a hitch, punching the carrier stage (sustainer) just before rotation to vertical (I timed out the delta-V in the sustainer tank to run out just before this point in the landing) and finishing the de-orbit burn with the lander's engine.

The subassembly lander runs out of delta-V but does not auto-stage. The trigger is not being sent. I have to manually hit the space bar to get the lander to finish. The engine fires up and the landing is otherwise routine, but the staging event has to be done manually every time.

The issue has to do with the difference between a "standard" build and a "subassembly" build. I can't see why there should be a difference, as the "subassembly" version still only has one MJ-equipped component, and the rest of the flight goes as it should. Even the ascent AP auto-stages correctly, so the system should work either way. But in the LGAP, the auto-stage isn't occurring.

Link to post
Share on other sites
Update to autostaging problem...

Auto-stage works... and it doesn't...

Two identical landers, using identical parts, but assembled with different sequences. The first lander is built straight-up as a single unit, starting with a MJ-equipped component and working down to the booster engine. The second has an initial MJ-equipped component used as a base, with the lander constructed separately on it, having its own MJ-equipped component. This lander is then separated into a subassembly for use later on different launchers.

The straight-up lander assembly goes through auto-stage without a hitch, punching the carrier stage (sustainer) just before rotation to vertical (I timed out the delta-V in the sustainer tank to run out just before this point in the landing) and finishing the de-orbit burn with the lander's engine.

The subassembly lander runs out of delta-V but does not auto-stage. The trigger is not being sent. I have to manually hit the space bar to get the lander to finish. The engine fires up and the landing is otherwise routine, but the staging event has to be done manually every time.

The issue has to do with the difference between a "standard" build and a "subassembly" build. I can't see why there should be a difference, as the "subassembly" version still only has one MJ-equipped component, and the rest of the flight goes as it should. Even the ascent AP auto-stages correctly, so the system should work either way. But in the LGAP, the auto-stage isn't occurring.

I thought lander staging wasn't implemented yet; that the GUI options were just placeholders.... did I miss something?

Link to post
Share on other sites
I thought lander staging wasn't implemented yet; that the GUI options were just placeholders.... did I miss something?

The landing gear deploy function works quite well. It triggers the gear at 1 Km above the terrain. I haven't tried the parachute function yet because my crew ships need to punch off the service module before the re-entry begins. I can't do that while the AP is working.

As for landing accuracy at Mun or Minmus, I like it. I'm generally within a second or two in any direction of the target coordinates, and more often than not, I'm dead on in at least one of the directions. Landing at KSC is never the same trip twice, however. I generally try to overshoot the center by about 3 minutes and go for a water landing, but still wind up in the hills west of the center.

Edited by BARCLONE
Link to post
Share on other sites
The landing gear deploy function works quite well. It triggers the gear at 1 Km above the terrain. I haven't tried the parachute function yet because my crew ships need to punch off the service module before the re-entry begins. I can't do that while the AP is working.

As for landing accuracy at Mun or Minmus, I like it. I'm generally within a second or two in any direction of the target coordinates, and more often than not, I'm dead on in at least one of the directions. Landing at KSC is never the same trip twice, however. I generally try to overshoot the center by about 3 minutes and go for a water landing, but still wind up in the hills west of the center.

gears and chutes work yes

Link to post
Share on other sites
Post LOGS or pics it will be easier for sarbian to diagnose than random rants

Up-thread a bit I posted a craft specifically designed to spectacularly fail at deorbiting every time. The purpose being so it could be used for debugging because whatever it's doing to fail will always show up nice and clear, unlike crafts that have intermittent problems.

Link to post
Share on other sites

Is anyone else having an issue where the mechjeb 2 compact GUI skin is broken in the latest dev build? Or have I borked it somehow on the install? Want to hear if anyone else has this issue before I go klotzing around in the files and mess something else up.

Link to post
Share on other sites
Is anyone else having an issue where the mechjeb 2 compact GUI skin is broken in the latest dev build?

Nope, checks out all ok either as a clean installation from the full zipfile or just replacing the DLL (usually replacing the DLL is all that is needed)

Link to post
Share on other sites
Nope, checks out all ok either as a clean installation from the full zipfile or just replacing the DLL (usually replacing the DLL is all that is needed)

:huh: Crap. I'll do a clean reinstall of mechjeb. :mad: Bov etanoda ui sevth.

Edit: Yep, clean install fixed the problem, don't know what I borked in there. I hate having to redo all my settings... :huh:

Edited by vardicd
Link to post
Share on other sites

was using version 180 and it seems there may be a bug with the rendezvous autopilot. When it disengages I have no keyboard control at all. I have to switch to the ksc then prey that the tracking station will not hang and let me back to my ship before it smashes into the target. This happened 10 for 10 tries yesterday. Rolled back to official spaceport release. Nearly RAGE smashed keyboard this is the worst kind of bug. Denial of control is infuriating!

Also, is it possible to make some kind of config to remember my custom menus. I am tired of having to rebuild them every time I install a new mechjeb release. unless the file already exists and I just cannot find it.

Link to post
Share on other sites
was using version 180 and it seems there may be a bug with the rendezvous autopilot. When it disengages I have no keyboard control at all. I have to switch to the ksc then prey that the tracking station will not hang and let me back to my ship before it smashes into the target. This happened 10 for 10 tries yesterday. Rolled back to official spaceport release. Nearly RAGE smashed keyboard this is the worst kind of bug. Denial of control is infuriating!.

Step 1: Take a deep breath, it's only a game.

Step 2: Set your final distance in the rendezvous autopilot to something more reasonable (e.g. further away). That way you have plenty of time to switch to the space center and come back without risking a collision.

Step 3: You don't need to switch scenes anyhow, do a quickload by quicksaving (F5) and then as soon as the quicksave finishes (watch the top right corner of your screen) use F9 to load the quicksave. Control will be restored.

Link to post
Share on other sites

@DerekL1963

Oh, I didn't know about that workaround. I'm also running into that problem (except for the rage smash part :P), plus something which I think might be related - some options like "control from here" go missing from the right click menu right after a rendezvous, but I can still select the docking port using RasterPropMon. A quick visit to the space center fixes that as well.

Edit: I think I figured out what causes it: I could right-click and interact with my two orbiting satellites just fine, *until* I switched between them using [ and ]. That's when things went wonky and I had to switch to the map view and back to get control again. Hope that helps.

Edited by OrbitalDebris
Link to post
Share on other sites

Is it possible the orbit period could be put to one decimal place? Its main for me is for aligning satellites in RT2 so they don't disalign after a long time, and it would be nice to have some more accurate figures so I can make the alignment last even longer :P Can I somehow set this myself?

Link to post
Share on other sites

Quick question and I am sorry if this was posted already. My search'fu didn't find anything and there is 500+ pages here so kinda hard to read all this ;-).

The question is rather simple. Is there a way to lock mechjeb's window positions? I keep dragging them off by mistake!

Thanks

Link to post
Share on other sites
Is it possible the orbit period could be put to one decimal place? Its main for me is for aligning satellites in RT2 so they don't disalign after a long time, and it would be nice to have some more accurate figures so I can make the alignment last even longer :P Can I somehow set this myself?

The dev release has had this for a while. Orbital period is displayed to milliseconds (centi?) 23h59m59.87s for example.

Link to post
Share on other sites

Since Sarbian told me about small amounts of residual fuel amounts left in fuel tanks and MJ wont auto stage these, I have managed to fix most of the auto staging woes that have been plaguing me, Soyuz Fixed, Buran Fixed, KSO shuttle fixed which has made me very happy. So if youre having auto staging issues check your tanks to make sure they dont hold 0.1+ fuel in them if they do adjust the tanks fuel amounts 9:1.1 ratio and MJ will do its job

Link to post
Share on other sites

Hello, sorry for my english.

I am doing an app for my little daughter, that make in the ipad a remape of a keys for control the game with the tablet.

I want to add some functions of mechjeb in the tablet. I need one "acces key?/pf keys?" that i can add to the app.

Can i modify the mechjeb sorcer for make a reaction at specific keys? exemple: "when my daughter press key Ñ the mechjeb ASS do it prograde"

Thank you for read.

Link to post
Share on other sites

#184 fix the locked control with the Rendez-vous AP.

Why are you stuck on 168 Starwaster ?

limonlee : MJ uses an open source licence. You can modify it for your use as you please.

Link to post
Share on other sites

Why are you stuck on 168 Starwaster ?

Because of the docking AP problems that I reported and because I'd tweaked the approach vector of the AP in 168

That's why I was asking if anything further had been done on docking since 170. You did see the post I made about it, right?

Link to post
Share on other sites
Yes, I saw your post. No more change were made and none will come for at least 5 days since I have my right wrist in a cast and family visiting.

Now see, if this were 2053 that wouldn't be a problem because you'd have a datajack and you'd be plugged in. You'd do your coding without your hands while simulaneously running a subroutine to nod your head enthusiastically periodically whenever your family speaks.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...