r4m0n

[PART, 1.0.2] Anatid Robotics / MuMech - MechJeb - Autopilot - Historical thread

Recommended Posts

Ah great, I ll have a look at his code and ask him.

lincourtl : did you do a clean install with the full zip ? I had to move the icon directory.

Share this post


Link to post
Share on other sites

A big thank you to r4m0n and all the MechJeb team.

In addition to the dV problems everyone else has been having, I'm also still having issues with MJ and Blizzy's toolbar. The MJ tab is still showing, but now the MJ icons in the toolbar are all blank, and sometimes the MJ icons fail to appear at all.

The blank icons seems to be caused by the change in folder location. Before the icons were in MechJeb2/Plugins/Icons and in the later release they are located MechJeb2/Icons. If you install them in the new location for the latest builds then they are not blank. On the other matter, I think the behaviour I am seeing is the icons disappear after all the main windows (i.e. excluding the custom windows... odd???) have been closed. Hope this helps.

Share this post


Link to post
Share on other sites
Ah great, I ll have a look at his code and ask him.

lincourtl : did you do a clean install with the full zip ? I had to move the icon directory.

Oh! Doh! Nope. I just grabbed the new DLL. I'll go delete my MJ, and grab the full package instead. Thanks.

Share this post


Link to post
Share on other sites
Ah great, I ll have a look at his code and ask him.

lincourtl : did you do a clean install with the full zip ? I had to move the icon directory.

I did, and I still can't get MJ to work with the toolbar in the new version.

Edit: Ah, wait, if I upgrade on a game already in progress, would there be anything in the persistant files to break the toolbar support?

Re-Edit: Yep, brand new game works fine, any games already in progress won't accept mechjeb's new toolbar configs. Crap. Have to start all over again.

On the positive side, Jeb and Alemone won't be dead, so they get another go.

Edited by vardicd

Share this post


Link to post
Share on other sites

New game doesn't fix it for me. The mechjeb button is still there and the toolbar icons only show up after I open the menu with it. This needs to be at every scene change it seems, at least reverting to launch removes the buttons. I'm reverting to the old method because it's really annoying right now.

Edited by AndreyATGB

Share this post


Link to post
Share on other sites
Confirmed that the auto docking feature in not working

Clunks head on desk. I've been saying that for 6 days...

Share this post


Link to post
Share on other sites

Riftmann : Oh great. Then maybe you did read that I added a fix yesterday. Obvouisly it does not work but I did work on it. It's people like you that made me take a 3 weeks break from this. Always complaining and not helping all.

Fix it yourself ...

Share this post


Link to post
Share on other sites
Riftmann : Oh great. Then maybe you did read that I added a fix yesterday. Obvouisly it does not work but I did work on it. It's people like you that made me take a 3 weeks break from this. Always complaining and not helping all.

Fix it yourself ...

I can promise you that for every idiot waste of space lacking the good sense to keep his dumb mouth shut, there are 30 others who are in awe of what you've made for us, and are very grateful for all the work you've done for us. Thank you for giving us your time, effort, and patience with no strings attached for so long, I for one am deeply grateful.

Share this post


Link to post
Share on other sites

Thank you for working hard on this!

I picked KSP again when 0.23.5 hit, and shortly after used mechjeb. I then introduced the game to several of my friends [specifically with mechjeb]. This would not be possible without your hard work on this -- mechjeb makes the game playable for me and many more.

For example, instead of telling people to "drag this maneuver until you hit Duna" we can do "match plane, transfer to planet, fine-tune". It's just like magic [as opposed to with delta-v, which is actual magic]!

Share this post


Link to post
Share on other sites
Riftmann : Oh great. Then maybe you did read that I added a fix yesterday. Obvouisly it does not work but I did work on it. It's people like you that made me take a 3 weeks break from this. Always complaining and not helping all.

Fix it yourself ...

Sarbian,

I have been using your MechJeb since I first started playing in 0.17. Your algorithms helped get me into space, perform basic orbital maneuvers, land on the moon and host of other things. Thanks to you a game that would have been daunting and unplayable suddenly became open and available. Pretty soon I understood all the things I needed to do. All the while watching MechJeb grow alongside KSP becoming better. Next thing I knew I was no longer relying on you for my enjoyment. But please do not worry, I still have you with me on nearly every mission. I have even extended into unintended uses. I have can now use MechJeb on missiles and repeatedly hit within 20m's of the target. All in All I couldn't have done it without you and I thank you.

Share this post


Link to post
Share on other sites

Yeah, don't get stressed over our sake. :)

Sarbian, if it is any help I am still using the .dll from our last chat and it has been calculating DeltaV fine for all the new parts, (I have tried over a hundred combinations now), so I guess you could always use the code from that. If you're not sure which .dll it is now I have it uploaded if you need a copy.

Share this post


Link to post
Share on other sites

Yay, great work!!

dV stats back with 213

Thank you an god bless you sir!

Share this post


Link to post
Share on other sites
Clunks head on desk. I've been saying that for 6 days...

Don't get discouraged, Sarbian. I and many others on here truly appreciate the hard work, effort and the time you and the rest of the MJ team take to bring us this mod and all it's revisions. And I definitely appreciate the work despite those who complain because I'm sure you aren't doing this for pay and therefore, we should all be very grateful.

Share this post


Link to post
Share on other sites

KSP 23.5

MJ 213

No other mods

I am still having problems with the RCS Balancer Smart Translate.

I have spent about 30 minutes just moving my craft to and fro between the VAB and the launchpad without changing any setting or opening/closing other MJ modules. I have been trying to make the problem reproduceable, but I just can't do it. It seems to be totally random

With the RCS Balancer deactivated, all the thrusters always work.

With the Balance activated:-

- sometimes it works perfectly

- sometimes it doesn't work at all

- sometimes a single thruster works and when I take my finger off the key, there will be a puff from some of the other thrusters.

- sometimes two thruster work and when I take my finger off the key, there will be a puff from from the other thrusters

- sometimes if I turn the balancer off and back on again, it will work perfectly

- sometimes if I turn the balancer off and back on again, it won't work perfectly

I probably lack the rigour of a developer, but I am danged if I find a way to predict how the RCS Balance is going to behave on the launch pad. It seems totally random. It can't be random, I realise that, but it won't behave consistently for me.

Here is the craft file in the hope that someone can help me make sense of what is happen. It is my laptop? Is the problem with MJ2? Is there an invisible pixie standing behind my shoulder??

http://ubuntuone.com/6uMvZYwBn3xBaSuMc6tYRL

I would be really grateful for any ideas

Polly

Share this post


Link to post
Share on other sites

my mj isnt working. the tab loads but there isnt any options in it. i cant select any commands or anything. its just a blank box. this is in sandbox mode.

Share this post


Link to post
Share on other sites
my mj isnt working. the tab loads but there isnt any options in it. i cant select any commands or anything. its just a blank box. this is in sandbox mode.

I've never tried it with sandbox. Are you using the latest dev build (213) with the additional .dll file? Also, more details would be helpful so we all can assist you.

Share this post


Link to post
Share on other sites

yes using the dev build and its not displaying the mech jeb tool bar. its just the button to access the bar but there are not icons to click on to go into docking or smartass or anything.

Share this post


Link to post
Share on other sites

Couple of things:

1, MJ starts a manoeuvre burn when the counter reaches 0, not 50/50 either side.

2, The new toolbar integration is great, but after putting some buttons like Ascent Guidance, Smart A.S.S etc in a folder toggled by the main MJ button, when I switch away and back again, none of the folder buttons show up. The folder does, but it doesn't get filled unless I click on the MJ menu on the right hand side of the screen.

Talking of that, is there a way to make the new toolbar integration act like the old one? Literally just moving the screen-right button to the toolbar so when you press it, the right hand menu pops up.

Not sure of the build number I'm on, but according to the 'Date Modified' column, I downloaded it at 1am on the 7th (almost 10 hours ago) so it can't be that far behind.

Share this post


Link to post
Share on other sites
KSP 23.5

MJ 213

No other mods

I am still having problems with the RCS Balancer Smart Translate.

I have spent about 30 minutes just moving my craft to and fro between the VAB and the launchpad without changing any setting or opening/closing other MJ modules. I have been trying to make the problem reproduceable, but I just can't do it. It seems to be totally random

With the RCS Balancer deactivated, all the thrusters always work.

I would be really grateful for any ideas

Polly

As a work around, switch away from the craft. Exit to Space Center then back to that craft again. That's what I do when the RCS starts doing that.

Share this post


Link to post
Share on other sites

Mechjeb doesn't work at all for me. I downloaded the 2.2 release. I don't have a button. No other addons.

Share this post


Link to post
Share on other sites

The Docking AP from dev build #198 works. Also i like the way the optional tool bar module works better than the new one thats built in

Share this post


Link to post
Share on other sites
Is anyone having a problem with MechJeb2-2.2.0.0-212 in KSP 23.5 in which the Docking Guidance is burning through RCS at a wild rate? It also appears that MJ isn't able to locate the docking port correctly and seems to be about 20 meters off on where it thinks the port is? The port has five nodes, one is occupied, and the ones that are open are radial from the main ship.

Watching the RCS bursts, MJ seems to be trying to fire all of the jets around the circumference of the ship over and over again in sequence as if it is searching for the target and missing it. Watching the navball while this goes on, MJ seems to be aiming for a point on the outer edge of the target icon.

Any thoughts?

I'm having this issue as well, build 213, and a clean 23.5. It's not just RCS in docking guidance, it's happening whenever MJ is trying to stay on a node (or docking), whether RCS is on or off. Both large and small vessles of mine can be seen oscillating when zoomed in. It seems to oscillate around the target, and cannot seem to stop on the target. I get the impression that it corrects to get on target, but fails to slow rate of turn until the target has passed, thereby pushing it into a perpetually correcting loop.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.