r4m0n

[PART, 1.0.2] Anatid Robotics / MuMech - MechJeb - Autopilot - Historical thread

Recommended Posts

When will any patch, auto-land doesn't work, and orbital transfer menu not showing the new planet and i really want make flyby to Mars that mean Duna ;-)

Share this post


Link to post
Share on other sites

If you want to go land on any of the inner planets you need a orbit that is with its periapsis closer to the sun than the planet. (BTW: Auto-Land does work for me. But I never managed it to get close to one of the new planets, so no new try there.)

But the problem that I have is that its moving to the injection burn point and after setting Time Warp to 1 I instantly hear an explosion and my rocket is just blown apart in all pieces...

Looks like we have a new space kraken :D

Edited by Byter
small mistakes :P

Share this post


Link to post
Share on other sites

this needs work; I've had mechjeb consistently do the "moving to injection burn point" thingy nearly constantly, and burning for the inner planets is bugged

Share this post


Link to post
Share on other sites
this needs work; I've had mechjeb consistently do the "moving to injection burn point" thingy nearly constantly, and burning for the inner planets is bugged

The TRANS module was never meant to go to lower orbits, I'll see if it can be changed without a total rewrite.

In the mean time, another beta update: selecting the location to land is back again, MechJeb uses physical warp better and should stop losing the configuration.

Download here: http://www.mumech.com/uploads/MuMechLib.dll

Share this post


Link to post
Share on other sites

Actually, it seems to be bugged, period; I've tried to transfer to Duna for over a hour now, no go. No option to transfer ever comes up.

Share this post


Link to post
Share on other sites
If you want to go land on any of the inner planets you need a orbit that is with its periapsis closer to the sun than the planet. (BTW: Auto-Land does work for me. But I never managed it to get close to one of the new planets, so no new try there.)

But the problem that I have is that its moving to the injection burn point and after setting Time Warp to 1 I instantly hear an explosion and my rocket is just blown apart in all pieces...

Looks like we have a new space kraken :D

That happened to me too.

To the creator of MechJeb, can you please reprogram the deceleration of the time warp so it clicks down at a slower speed? Because currently, the whiplash of the sudden jump from hyperspeed to 1x speed is causing rockets to rip up.

Also I've found a bug where SAS won't turn off while transferring between planets during warp to course correction burn, and consequently the warp no longer works, meaning that you have to abort the trip and go around the sun for at least another lap before doing it again.

Share this post


Link to post
Share on other sites
That happened to me too.

To the creator of MechJeb, can you please reprogram the deceleration of the time warp so it clicks down at a slower speed? Because currently, the whiplash of the sudden jump from hyperspeed to 1x speed is causing rockets to rip up.

Also I've found a bug where SAS won't turn off while transferring between planets during warp to course correction burn, and consequently the warp no longer works, meaning that you have to abort the trip and go around the sun for at least another lap before doing it again.

having this issue too... unless I constantly keep turning the speed down, when it comes time to transfer, the capsule is stripped of all attached parts.... perhaps put in a way to select the amount of warp we want to use? I don't mind waiting a while.... i DO mind it when my rocket, which has thus far performed beautifully, becomes a useless pile of crap between planets.

Share this post


Link to post
Share on other sites

I don't have any options to transfer to any planets, just Mun and Minmus. When will this be fixed?

Share this post


Link to post
Share on other sites

I am having no problems transfering to the planets..... I just blow up from the warp issue. If there was a micro second between warp steps, I think it will work great..... I can put it to full warp and bring it down to 1X as fast as I can manually and not blow it up, but it will blow up going from full warp to 1X at the speed of MechJeb.

I find it works pretty good by getting into orbit around Kerbin like you would to go to the moon, then when on the dark side go to pro grade and go 100% throttle until you see your orbit turn yellow and go as far out as you want the warp until the orbit turns green. Now you can see the planets instead on Mun/Minmus to transfer to.

Share this post


Link to post
Share on other sites

Last update for today, still in experimental status: http://www.mumech.com/uploads/MuMechLib.dll

Features:

  • Added a "Angle to Prograde" to the Orbital Information window. That is the ejection angle from Olex's calculator. Click on the label to change to "Angle to Retrograde";
  • Added a new Phase Angle window, to see the current phase angles (also for the calculator);
  • More random fixes;

Share this post


Link to post
Share on other sites
Last update for today, still in experimental status: http://www.mumech.com/uploads/MuMechLib.dll

Features:

  • Added a "Angle to Prograde" to the Orbital Information window. That is the ejection angle from Olex's calculator. Click on the label to change to "Angle to Retrograde";
  • Added a new Phase Angle window, to see the current phase angles (also for the calculator);
  • More random fixes;

Kraken still feasts with this, the other new features work great!

Thanks for the good work, hopefully the Kraken can be defeated soon. With these distances not using warp makes things quite dull.

Share this post


Link to post
Share on other sites

I would be really cool if the target you selected for rendez-vous showed up in the TRANS window for a Hohmann transfer (if its orbit is circular enough).

Edited by gosnold

Share this post


Link to post
Share on other sites

Still disintegrating upon warp cessation, is there any way to change MechJeb so it DOESN'T instantly change warp rate from max to off when transferring to one of the planets?

Share this post


Link to post
Share on other sites

For me it doesn't do that; it goes to 10000x just before starting the transfer and all works fine.

Share this post


Link to post
Share on other sites

AUTO LAND dont work at all. (not only map selection)

or

dont work at Bop

Share this post


Link to post
Share on other sites
For me it doesn't do that; it goes to 10000x just before starting the transfer and all works fine.

Same for me it does step betweem speeds. Just never selects 100k wrap

Share this post


Link to post
Share on other sites

I have been making changes to the MechJeb Autopilot for Kerbal Space Program to help reduce the jitter or twitchyness of the Roll/Yaw/Pitch controls.

Comparison video:

The file I have been working on can be found here:

MechJebCore.cs - http://pastebin.com/ed6Z4azN

If you are interested in checking out my version of MechJeb Autopilot you can get the Plugin DLL here:

https://dl.dropbox.com/u/94067015/MuMechLib.zip

You can find the original source code here:

http://svn.mumech.com/KSP/trunk/

Using Visual Studio, make it a .NET 3.5 solution as the .NET 4.0 solutions cause problems. Mono developers may have similar problems but there are work around on forums.

Also if you know how I can get into touch with the developers to see if they would be interested in integrating my changes, that would be much appreciated.

Share this post


Link to post
Share on other sites

My vehicle is also disintegrating during course corrections. first the ASAS and before the mid course correction one of the new atomic drives...

I'm using the MuMechLib.dll from this morning.

Edited by Gunhed
forgot something

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.