r4m0n

[PART, 1.0.2] Anatid Robotics / MuMech - MechJeb - Autopilot - Historical thread

Recommended Posts

I'm having a weird problem when doing a transfer From a near-kerbin orbit to Duna. For some reason, when it's warped into the correct burn position, instead of burning properly it just detaches the command pod from the rest of the vessel, claiming that there was a structural failure. I do not have this problem with manual burns at the same position, as I loaded a quicksave and was able to burn without any problems.

Any tips? (Or any more information needed?)

Share this post


Link to post
Share on other sites
I'm having a weird problem when doing a transfer From a near-kerbin orbit to Duna. For some reason, when it's warped into the correct burn position, instead of burning properly it just detaches the command pod from the rest of the vessel, claiming that there was a structural failure. I do not have this problem with manual burns at the same position, as I loaded a quicksave and was able to burn without any problems.

Any tips? (Or any more information needed?)

Congratulation, you won a prize for being the 100th. reporter of this problem! :)

Share this post


Link to post
Share on other sites
Congratulation, you won a prize for being the 100th. reporter of this problem! :)

Hooray! What do a get? :)

Sorry about that, but I browsed quite a few pages without seeing it, so I figured it couldn't hurt to ask. Any solutions? Just tested a Munar burn, and that worked fine, so I guess it's a 0.17 issue.

EDIT: Tried Jool too, same problem.

Edited by larsmaehlum

Share this post


Link to post
Share on other sites
how do you get top Duna with Mechjeb?

The way I was getting around the solar system was getting into orbit around the sun, then in the orbit panel hitting transfer and it comes up with the names of the planets.

Share this post


Link to post
Share on other sites
Yea, I am having the issues with the SAS not turning off for the gravity turn, and it is on a ship that it was working fine on earlier today. MechJeb's is acting all sorts of weird. Sometimes it works fine, others it puts me on a 10 degree inclination for no reason, even turns on the SAS and holds it there when I am pointing 40 degrees off target. Another odd thing, with the end turn altitude in the ascent control, the input box is screwed up. I cannot click at the end of the numbers and backspace them out, I have to delete from the left side of them, and if I type "150" it comes out "051" so I have to input the numbers backwards. **edit** well that last issue fixed itself. Also, these issues are with the latest beta release of MechJeb. The 1.9.2 works fine, but is missing some features I like.

I had that locked reverse entering bug too for a few times yet, it never affected all input fields, just some. A restart fixes it though.

Share this post


Link to post
Share on other sites

I must be stupid. Whenever i download the latest mumech, it just says ''The type part isn't available in this version of KSP''.

Share this post


Link to post
Share on other sites
I must be stupid. Whenever i download the latest mumech, it just says ''The type part isn't available in this version of KSP''.

Sounds like you haven't installed 1.9.2 first. The beta is only the dll, you still need the parts the full install has. It could also be that you haven't put things in the right directories if you are using the full .zip, either way the error indicates KSP isn't finding the parts.

Share this post


Link to post
Share on other sites
Sounds like you haven't installed 1.9.2 first. The beta is only the dll, you still need the parts the full install has. It could also be that you haven't put things in the right directories if you are using the full .zip, either way the error indicates KSP isn't finding the parts.

I did have 1.9.2 installed first and did have the parts. And i did put the mumech in the plugins folder. So, IDK.

Edit: It's only the MechJeb themselves. Things like landings supports still work. And i also have the NovaPunch mod installed.

Edited by 42undead2

Share this post


Link to post
Share on other sites

Would it be possible to expose the values of the phase angle to the LUA interface? That way one could automate Transfer Burns...

Share this post


Link to post
Share on other sites

Transfer burns are automated, put yourself in a solar orbit, then select the planet you want to go to. Unless you are thinking of something different. I kinda know where you are going with that, it would be nice to have that info available for manual burns as well. The planetary phase grade and your angle from planetary prograde/retrograde would be really nice.

Edited by NolanSyKinsley

Share this post


Link to post
Share on other sites

I mean the treansfers while you are in orbit around a planet. I like to do my burns from inside a gravity well of a planet to reduce the delta-v need as much as possible.

Share this post


Link to post
Share on other sites

I would like to see sliders to control how mechjeb steers. The way it's set up now is fine for smaller ships but if we could use a slider to slow how quickly it reacts, and one to control how harshly it actuates the controls, we could fine-tune it to our individual ships and completely get rid of control lag and wobble.

On a side note, something has to be done about how mechjeb has no finesse with the controls. When it steers it's either all or nothing. There's no gentle easing in to the targeted position. It already displays the steering error, how about having it reduce the turn rate to match that as it approaches it's targeted direction?

Share this post


Link to post
Share on other sites
Transfer burns are automated, put yourself in a solar orbit, then select the planet you want to go to. Unless you are thinking of something different. I kinda know where you are going with that, it would be nice to have that info available for manual burns as well. The planetary phase grade and your angle from planetary prograde/retrograde would be really nice.

Yeah, but the automated transfer burns have have a high tendency to blow your ship up from going out of warp too quickly. My best craft do it every time. And it's hard to properly time a transfer burn so you hit the planet, even with charts (or at least I haven't gotten the hang of it). Without this working I've got a much less efficient way I have to intercept planets with, but I need all the fuel I can spare, so having the data would be nice.

Share this post


Link to post
Share on other sites
There are no page 62 or 61 only 18

I'm guessing you have modified the number of posts on each page? Well, on the default it is 61 or 62. What number are you using?

Share this post


Link to post
Share on other sites

I'm having some problems with the targeted (coordinate) landing. I managed to land two landers next to each other on Mun but now when I try to land a third mechjeb deorbits way too early and lands 100s of Kms off. I've got the cords right but it just messes up.

Share this post


Link to post
Share on other sites

Just out of curiosity, does anyone have an idea when transferring to other planets will be added? No rush or anything. Just thinking if I should start designing a new ship or not.

Share this post


Link to post
Share on other sites
Just out of curiosity, does anyone have an idea when transferring to other planets will be added? No rush or anything. Just thinking if I should start designing a new ship or not.

It already is in. You just need to put yourself in a REALLLY big orbit ( Like 35,000 KM or so seemed to work for me) then the option to transfer will come up. But yes, I too would like the option to transfer as soon as you leave Kerbins atmosphere.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.