r4m0n

[PART, 1.0.2] Anatid Robotics / MuMech - MechJeb - Autopilot - Historical thread

Recommended Posts

I have had the issue with it landing on duna. It mostly happens when the angle of attack is too steep. I have used it successfully to land on duna a few times by taking a more parabolic trajectory, or taking control about 5-10k up and slowing it down a bunch manually, then letting it take control again.

The main issue I have with mechjeb is its use of RCS. I need it to use RCS on larger ships so it is at the desired angle when it needs to start the burn. But when I use it, it fires the RCS until right before it reaches the angle it needs to be, then my ship wildly over shoots the angle, by up to 90 degrees, then fires the RCS continuously until it is almost at the desired angle and over shoots again, over and over again. When it fires the RCS it needs to fire it again the same amount of time in the opposite direction to come to a stop at the desired angle. It can be a bit tricky to implement in the code, but not too hard. Just note the starting angle and the desired angle, fire the thrusters towards the desired angle until half way, then reverse the thrust for the second half. That should bring it to a nice stop at the desired angle, while reaching the desired angle quickly, and save a ton of RCS fuel. This may be an over simplification because you are orbiting and the angles change as you move, but the concept is there. I would love to see this implemented in mechjeb. I may take a look at the code, I do not know C++, but I do know some java and I learn rather quickly.

Edited by NolanSyKinsley

Share this post


Link to post
Share on other sites

Awesome mod, quite useful, but I run into a problem with some ships at 20,000m or so. And by problem I mean the ship just starts spinning wildly out of control, this doesn't happen to all ships, it seems to be completely random.

Also, I have no idea how to make the Mk 2 pod actually look like a capsule, like it does in the picture. I don't know if I'm missing parts or not. All I have is the new S.A.S modules, the tiny engines, fuel tank, and landing support rig thing.

Share this post


Link to post
Share on other sites

If you don't like the MechJeb pods, then you've clearly never played Portal 2. You should remedy that at once.

Share this post


Link to post
Share on other sites

Hi guys. I'm having a bit of a problem with Mechjeb 1.9.1 as on takeoff, my engines won't fire. Is there a reason why? Am I doing something wrong?

Thanks

Share this post


Link to post
Share on other sites

You need to throttle up and engage mechjebs ascent autopilot then you need to ignite them. After that it should stage properly.

Share this post


Link to post
Share on other sites

I noticed the manual hasn't been updated for the new features...not sure how to use MechJeb to rendezvous with things like space debris...

Share this post


Link to post
Share on other sites

Am I the only one to find that the Orbital Operations screws up when I'm trying to make it to Eve or Moho? It's time to injection burn goes down unrealistically slowly, and then when it's getting close, it decides it needs a couple million seconds now.

Share this post


Link to post
Share on other sites
Am I the only one to find that the Orbital Operations screws up when I'm trying to make it to Eve or Moho? It's time to injection burn goes down unrealistically slowly, and then when it's getting close, it decides it needs a couple million seconds now.

I have noticed this as well. Does your display also indicate the delta-v necessary is 0 m/s? I suspect there is a problem to do with calculating transfers to SoIs with an orbit lower than the current one.

You can work around this by lowering your periapsis to just inside the orbit of Eve or Moho, circularizing there, then transferring normally once your orbit is inside the orbit of the target.

Share this post


Link to post
Share on other sites

Yes, many people have had trouble with transfers to orbits lower than their own. MechJeb does seem to be incapable of doing the proper calculations. I assume that it was programmed with Kerbin -> Mun transfers in mind. I have had success by transferring to a 9 Gm orbit and then transferring to Eve. In those circumstances it behaves perfectly.

On another note, I have noticed that the Smart A.S.S now seems to come into effect only once you leave the ground. Was this intentional? It is problematic for me because I usually use it to keep unruly spaceplanes on the runway during liftoff, and that doesn't work anymore.

Share this post


Link to post
Share on other sites

Ok so i've tried to to read all of these but i cant seem to get the SMART A.S.S. system into target mode...mostly cuz i don't know how to target things

Share this post


Link to post
Share on other sites

Another thing, still, Mechjeb sucks at is landing on Duna. Unless I use parachutes, the stupid "Land at Target" option screws the pooch royally. Strangely, hitting just "Land" usually works, as the engines actually FIRE in time to slow my speed for landing.

Share this post


Link to post
Share on other sites
Another thing, still, Mechjeb sucks at is landing on Duna. Unless I use parachutes, the stupid "Land at Target" option screws the pooch royally. Strangely, hitting just "Land" usually works, as the engines actually FIRE in time to slow my speed for landing.

I second that, I can't wait until they fix this.

Share this post


Link to post
Share on other sites
Ok so i've tried to to read all of these but i cant seem to get the SMART A.S.S. system into target mode...mostly cuz i don't know how to target things

Just open the Rendezvous module and choose your target. The extra options appear in the SMART A.S.S panel then.

Share this post


Link to post
Share on other sites

For those having trouble landing at target, after MechJeb says Safe to warp, just switch to the Land button instead of Land at Target.

Share this post


Link to post
Share on other sites
For those having trouble landing at target, after MechJeb says Safe to warp, just switch to the Land button instead of Land at Target.

After MUCH painful experimentation. I second this!

Share this post


Link to post
Share on other sites

@Hawn, this has been dealt with as much as possible in Mechjeb (it happens to me also without mechjeb), only a KSP update can fix this.

Share this post


Link to post
Share on other sites

Suggestion: Allow a dialogue box that specifies lead time for leaving time warp for ascent and orbital operations APs, as well as a means of specifying maximum warp speed, because it wouldn't be the first time since the new update that MechJeb decided it has to go at 1,000,000,000x when there's only an hour left or something.

Share this post


Link to post
Share on other sites
Suggestion: Allow a dialogue box that specifies lead time for leaving time warp for ascent and orbital operations APs, as well as a means of specifying maximum warp speed, because it wouldn't be the first time since the new update that MechJeb decided it has to go at 1,000,000,000x when there's only an hour left or something.

Duh, I should have thought about adding a box for the pre-circularizing burn lead-time. I'll do that until I can reasonably calculate the needed time.

As for the max warp, it really shouldn't be going into 100kx unless there is plenty of time for it, I'll go back and correct the warp tables again.

Share this post


Link to post
Share on other sites
Fairly recent addition to the forums here, and i have a question regarding the latest version of MechJeb.

For some reason, whenever i attempt to do polar orbit (heading 0 or 180), the ship enters an orbit that is NOT polar, but a normal east-west orbit. The same happens if i set inclination to + or - 90. I'm not sure if there is any particular "trick" to using MechJeb to do polar orbits, as i really didn't find anything on the forums.

I've tried doing polar orbits without Mechjeb, but to say the least those didn't end well.

I would appreciate any helpful advice on obtaining polar orbits (with or without MechJeb), i would really appreciate it.

Thanks.

No matter what I set heading or inclination to on the ascent autopilot it always goes with a 90 heading/0 inclination orbit. I can't seem to figure out why this is.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.