Jump to content

[PART, 1.0.2] Anatid Robotics / MuMech - MechJeb - Autopilot - Historical thread


r4m0n
 Share

Recommended Posts

First and easiest guess would be that one vessel is not being controlled from the correct aspect....you know, it's being controlled from a part that has it oriented incorrectly to do what you want. Check each one and see that 'control from here' is where it should be :)

I already thought of that and I checked that both ships were controlled by their capsules.

Besides all other functions work just fine.

Link to comment
Share on other sites

With MechJeb, since the early versions, it stutters my game even if I do not have the autopilot engaged. I don't know why, it especially does this when the height of my rocket hits about 6100km. The game just freezes and wakes up every few seconds. It's horrid.

Link to comment
Share on other sites

Having a MechJeb module on any craft is causing regular lag spikes, both in framerate, and more importantly in physics rate.

This is most noticeable as a regular 'flicker' of the game clock into the yellow, with an otherwise good framerate (100+FPS), camera rotation also 'hitches' at these intervals.

This occurs with no mechjeb windows open, becomes worse as soon as _any_ MechJeb window is displayed, including the menu.

On a Windows Machine here, i'm having the exact same problems in flight; in VAB too. I'm pretty sure this wasn't around back in 0.23.5, where my only limit was part count of 1500 and game crashes with mostly similar addons. I don't have that much addons installed, overall ksp got far more stable since 0.25. Maybe there's some incompability with another widespread addon? Currently installed: ModuleManager, [x]Science!, BTSM, Deadly Reentry, EditorExtensions, KSP-AVC, MJ2 (stable), ShowFPS, TacFuelBalancer, KerbalAlarmClock, MJ for every ship MM Code-snippet.

One word to sarbian: you're doing an awesome job here, can't live without this, and i won't uninstall even if this gets worse.

Edited by Tahib
Link to comment
Share on other sites

I (and other) am looking into it but I find the claim that it was better before strange. Can you try with only MJ (and MM if you use it to enable MJ for all pods) and see if it change anything ?

Link to comment
Share on other sites

Ahh, seems I've stirred the anthill some :D.

*Maybe* relevant data point:

I recompiled mono with --enable-parallel-mark, the slowdown is still there (going by the game clock) but it doesn't seem to 'stop the world' nearly as much (subjective, as always).

On the other hand, it also appears to introduce a massive memory leak... I didn't notice this untill the framerate tanked, ohh look KSP is using 12GB of RAM - that'd explain it.

Suspect I broke the garbage collector ;)

Does anyone know of a way to log the physics rate? It'd be real handy...

Edited by steve_v
Link to comment
Share on other sites

Greetings

I wonder why isn't it possible to use the advanced planet transfer to transfer from one moon to another in the same planet (e.g. I'm orbiting Laythe and I want to capture Vall, or capture Minmus while orbiting the Mun).

The maneuver planner shows the graphic with the optimal transfer windows an all , but when I try to create a node it says "Object reference not set on an instance of an object". This would be great, the maneuver planner seems to plan the transfer window perfectly but due to what I assume is a bug, when I press create node or create node and execute it complains with that error.

Here's a screenshot that shows the message in question.

Yg4ClBg.png

Notice how both optimal transfer windows are plotted and looks like a mere problem when setting the node up.

Is there a way to fix this? Because it really looks like something that would be something really easy to fix.

Thank you very much in advance.

Post-edit: I wanted to add, limited time does plot a node that intercepts the destination moon perfectly, but I would very much like to use as little fuel as possible. Really useful for example, when doing asteroid capture operations and gravity assists.

Post-edit 2: Nvm, it did work for a moment, but upon deleting the node and creating it again I'm getting the same error.

Edited by jebodiah1976
Link to comment
Share on other sites

Currently we do not have enough debug information to address such errors, I have just submitted a change to have the precise error in the logs. If you have a save to reproduce the error, keep it safe to test it when the new dll is available.

If you just need to create the cheapest node, the limited time transfer finds the cheapest maneuver that arrives at most at the desired time.

Link to comment
Share on other sites

Okay, anyone else have this issue?

With the MechJeb box attached to the craft, in the VAB the little option boxdoes not appear. And on launch, while the "MJ" toggle button is there up top by fuel and engineer, it doesn't make the interface appear.

Link to comment
Share on other sites

Hello, I have question. I used to use mechjebs ascent to rendevouz quite often but now I can't, it always misses, by alot in fact. In Kerbin, when I launch ship, the target is almost on the other side. Does anyone have an idea what could be causing this? As far as I know only FAR breaks mechjeb ascent, but i dont have that.

Link to comment
Share on other sites

Hello, I have question. I used to use mechjebs ascent to rendevouz quite often but now I can't, it always misses, by alot in fact. In Kerbin, when I launch ship, the target is almost on the other side. Does anyone have an idea what could be causing this? As far as I know only FAR breaks mechjeb ascent, but i dont have that.
Link to comment
Share on other sites

Is there any way to reduce the space between info lines in any given window? I find the amount of "white space" between lines to be too large for my taste and would like to reduce it. Thanks!
Link to comment
Share on other sites

Open the MJ settings menu. There are options to change the GUI type. I can't remember off the top of my head which option to change so mess around with them and you'll find the right one that makes a very tight and concise menu like on the fist page of this thread. If you're already using the tighter version then I guess you're outta luck unless there's a variable you can change in a file but IDK, that's just me speculating.

Ya, I am already using the Compact GUI option. Other than scale, these look to be the only 2 options. Guess I will just make some custom windows in Engineer to replace the Orbital, Surface and Vessel windows from MechJeb since that mod has tighter spacing between lines.

Link to comment
Share on other sites

Hey All,

I'm very sorry to probably be the umpteenth person to ask this but, I cant seem to get mechjeb to work. I feel like I've tried every "fix" I've been able to find from scouring the web, but nothing seems to get it done. So, I'm hoping someone can help.

I've downloaded the latest version (mechjeb 2.4) and I'm also using the latest KSP file (.25)

I copied the unzipped folder and placed it into my Game Data folder, just as I've done with every other mod I've downloaded. And yes, I've even tried installing it into a version without any other mods in case there was some conflict. No change in result. I've also broken up the main Mechjeb mod folder into the respective Plugins, Icons, etc folders. I've tried installing it outside of the game data folder & in the Squad folders, still nothing.

Now I do get the parts. Both the pod and the Case Module in my parts section In-Game. But neither open any window to control the actual mechjeb features. The eye at the top of the pod doesnt even open. I can control the flight from the case, but it's no different than the normal pod controls during normal flight.

I've tried this in Career & Science mode. Both have the entire tech tree unlocked. I've even gone back to try and re-research the links in the tree but there is no option to unlock anything new. All the mechjeb parts say owned already. The case & the "function" parts show in my science tree as owned.

I'm at a loss with this and need some help please. I've never had trouble with any mods before.

Link to comment
Share on other sites

Hey All,

I'm very sorry to probably be the umpteenth person to ask this but, I cant seem to get mechjeb to work. I feel like I've tried every "fix" I've been able to find from scouring the web, but nothing seems to get it done. So, I'm hoping someone can help.

I've downloaded the latest version (mechjeb 2.4) and I'm also using the latest KSP file (.25)

I copied the unzipped folder and placed it into my Game Data folder, just as I've done with every other mod I've downloaded. And yes, I've even tried installing it into a version without any other mods in case there was some conflict. No change in result. I've also broken up the main Mechjeb mod folder into the respective Plugins, Icons, etc folders. I've tried installing it outside of the game data folder & in the Squad folders, still nothing.

Now I do get the parts. Both the pod and the Case Module in my parts section In-Game. But neither open any window to control the actual mechjeb features. The eye at the top of the pod doesnt even open. I can control the flight from the case, but it's no different than the normal pod controls during normal flight.

I've tried this in Career & Science mode. Both have the entire tech tree unlocked. I've even gone back to try and re-research the links in the tree but there is no option to unlock anything new. All the mechjeb parts say owned already. The case & the "function" parts show in my science tree as owned.

I'm at a loss with this and need some help please. I've never had trouble with any mods before.

Link to comment
Share on other sites

Oh my god. Starwaster you are my hero.

I didn't have the MJ buttons you mentions. BUT I had at some point moved the KSP into Program Files for some reason. Amazingly, all my other mods still worked so I had no idea what was happening when I tried this one.

Thank you so much! I owe you a beer!

Link to comment
Share on other sites

Oh my god. Starwaster you are my hero.

I didn't have the MJ buttons you mentions. BUT I had at some point moved the KSP into Program Files for some reason. Amazingly, all my other mods still worked so I had no idea what was happening when I tried this one.

Thank you so much! I owe you a beer!

Actually, make it a blood orange sorbet. (Ciao Bella or Talenti please)

And if you've never had one, you don't know what you're missing.

Link to comment
Share on other sites

Hello All!

The first time I use mechjob and want to perform vertical takeoff at ~ 11000m, but at an altitude of 5000m ~ rocket leans over and starts orbital maneuver. Exhibited in the Ascent Path Editor Turn start Attitude and Turn End Attitude to 11km and Turn Shape to 0%, but it does not work. Help, what am I doing wrong. :(

Sorry for the bad english.

Link to comment
Share on other sites

Is there a way to move mech jeb to another location or unlock it so player can move.

When in vab its covers staging. When in game it covers resoruce panel. .25 I have been looking at resouces and contract panel more than before.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...