r4m0n

[PART, 1.0.2] Anatid Robotics / MuMech - MechJeb - Autopilot - Historical thread

Recommended Posts

I would like to learn how to use the PorkChop Plot function. Is there any info available that explains how to use it?

The manual is under construction so the Advanced transfer to another plant module has not been covered yet.

Any scraps of info would be greatly appreciated:) also many thanks to the author of MJ2

Share this post


Link to post
Share on other sites
This already kinda exists. Change inclination and Change Surface Longitude of Apsis.

hmm yes, good point. I can use landing guidance marker to get the longitude then type that in to the man plan. Thanks :)

- - - Updated - - -

I would like to learn how to use the PorkChop Plot function. Is there any info available that explains how to use it?

The manual is under construction so the Advanced transfer to another plant module has not been covered yet.

Any scraps of info would be greatly appreciated:) also many thanks to the author of MJ2

select a planet as your target.

The calcs will run (as long as you aren't in Kerbol's SOI) and show you a heat map.

The x axis is time until the transfer (e.g. the burn will take place in 100 days).

The y axis is time the transit will take (e.g. after the burn, the craft will take 150 days to arrive at the target SOI).

The colours show the cost in m/s dV for the burn (for example, you can go at an optimal transfer time or transit time for 2k m/s dV burn or spend 5k m/s dV to leave sooner or fly faster). Dark blue is optimal with respect to m/s dV, green through red is increasingly inefficient. However, note that sometimes the optimal flight can take twice as long travel time as only a slightly less efficient flight, so think about the trade-offs.

Click on the part of the heat map you want.

If you want the optimal flight, then rather than trying to click on the darkest bluest bit, you can switch from porkchop selection to "limited time" mode which will choose the best time to burn such that you arrive within a certain time.

Bear in mind you will need to brake once you reach your target SOI assuming you don't want to flyby. This can be very expensive in dV unless you can aerobrake. If you burn 5k m/s to do the faster transfer, in the example above, you will need to burn (or aerobrake), approximately, an additional 3k m/s compared to the optimal burn in order to decelerate and be captured in the SOI, for a total extra cost compared to the optimal transfer of about 6k m/s (3k m/s extra initial burn then 3k m/s extra deceleration needed).

Also, you may need a small correction burn to fine tune your intercept. I generally leave these burns until I enter the sun's SOI. They should cost from a few m/s to 50 m/s but rarely more. This will be for things like a small plane change or a radial burn.

Edit: a cool feature that I didn';t realise about but read in a post above is that you can zoom in to the porkchop chart with mousewheel to better select.

Edited by CorBlimey

Share this post


Link to post
Share on other sites

While we're explaining new, rather obtuse options in the MechJeb dev builds ... can someone explain two new-ish items in the Ascent Guidance module? First, the Force Roll check box and associated roll angle make sense but what of the next box to the immediate right? What does that control?

And second, "Limit Angle of Attack to 5º" makes sense as-is, but what are the units in the field that appears below it regarding dynamic pressure fade-out? Is that altitude in meters? Dynamic pressure in kilopascals? Etc.

Thanks in advance ...

Share this post


Link to post
Share on other sites

The first one is the roll while in the vertical climb phase. The second one is the roll while in the turn phase.

It's the Dynamic pressure in pascals

I pushed a new dev build that tweak the solar panel auto deploy feature. It's now disabled by default and you can enable it in the Ascent AP and Utilities windows.

I also converted it and the Differential throttle in an InfoItem so you can add them to custom windows.

And I added 2 Expand/Retract All Solar Panels button in the InfoItems for custom windows.

Edited by sarbian

Share this post


Link to post
Share on other sites
The first one is the roll while in the vertical climb phase. The second one is the roll while in the turn phase.

It's the Dynamic pressure in pascals

I pushed a new dev build that tweak the solar panel auto deploy feature. It's now disabled by default and you can enabled it in the Ascent AP and Utilities windows.

I also converted it and the Differential throttle in an InfoItem so you can add them to custom windows.

And I added 2 Expand/Retract All Solar Panels button in the InfoItems for custom windows.

Gotcha! As always, thanks for all you do to make MJ2 as awesome as it is, Sarbian.

Share this post


Link to post
Share on other sites

Hello again. Long Post. I wanted to test MechJeb again after being away from it for about what 11 days give or take. Here is what I did prior to starting the 6 tests you see below: I deleted MechJeb 2.4.2 from the game. Deleted its dev variant. Deleted the zip files as well. I then went and re-down loaded MechJeb 2.4.2 and placed it into the game as per install instructions. I also, will re-list the version of KSP for these tests below this introduction as well as mods that are installed. KSP and the mods as listed are the most up-to-date versions I can locate for KSP 0.90.0.705. I was attempting to see if my prior issues would occur. Those being: Failing to launch at the correct time, Pre-firing the Launch Clamps, Getting Locked into Auto-Warp. I was able to varify only a few of these, and two of the issues happened only ONCE out of 6 times.

I want to go on record here, stating, that, there is an issue with MechJeb, as this was a fresh install of MechJeb and some of the bugs once again occurred. Below you will find: 6 Tests, their notes, and the related Output Log for that test. Below the tests and their respective logs, you will find a link to my vessel, a small imgur album OF said vessel. Below THAT, you shall find a copy of the persistent save file these tests were conducted in. Below THAT, you will find a copy of the MechJeb 2.4.2 that was used for these tests.

My request is this: Is my save itself borked or possibly the game? If it is either, a full restart of the save and or game would be sad, but, would be done. If 100% needed, I can ask Steam to provide me with a fresh copy of the game, and I can re-install my mods and go on with my life in KSP. If this is in fact an issue with MechJeb, I hope it can be found and repaired as it is my fear that this will propagate further down the road and perhaps become a big issue at some point.

To those who would suggest I learn to fly w/out MechJeb, I state this: Why should I? I can in fact perform all the required actions for a mission, just not as smoothly as MechJeb, but, prefer to use MechJeb. To me, MJ is as vital to my personal enjoyment of the game as what ever mod<s> YOU see as vital components to YOUR space program. If your a fan of FAR and I asked YOU to learn to fly w/out it, you would rightly laugh me right out of the conversation. As such, my use of MechJeb is akin to your use of what ever mod<s> YOU prefer to use.

Second On Record Statement: I realize that my issues are exceptionally rare, with only one or two other players speaking up and saying they are seeing similar issues. Just because these issues are NOT replicating for you in YOUR save files does NOT mean they are NOT happening in MY save file. I am trying to provide all of you with as a detailed account of my findings tonight as I can, as well as provide all the relevant files to aid in coming to some sort of conclusion and action plan for resolution of this and its similar issues. I am seeing this happen, and it is frustrating as it is making the game unenjoyable and unplayable for me. I do not wish to be forced to wait for .91 to come out and then HOPE that these issues somehow are resolved when Sarbian or r4m0n upgrade MechJeb to 2.4.3 <assuming thats the logical numbers progression for the next update of KSP when ever that is>.

KSP 32 Bit for Windows. 0.90.0.705 BETA

Mods: MechJeb 2.4.2, Romfarers Lazor Docking Camera, NovaPunch, Procedural Fairings. Again, all mods updated to current versions for 0.90.0.705 KSP Beta.

1. First Test: Target: Polar Orbtial Sciences One. Mission test MechJeb 2.4.2. Test flight 500km Polar orbit targeted to station. Launch To Rendezvous.

MJ Prefired Launch Clamps and stayed in AUTO-WARP thru launch window. Terminating Auto-Warp resulted in a launch but so much time had elapsed that being

on course to the target was not going to happen. Reverted to VAB, then to Main Menu. Closed KSP. Logged first output log.

Test One Output Log: http://www.filedropper.com/outputlog1

-----------------

2. Second Test: Target P.O.S.O. Mission test MechJeb 2.4.2. Test Flight 500km polar orbit targeted to station. Launch into Plane of target. Results:

Launch into Plane proved to work...this time. Launched smoothly...for the most part...perhaps I was overzealous with my launch clamps, as it caused it

to buck wildly as it cleared. After Launch tower clear, launch went as expected and fairly smoothly. Discovered I need some RCS tanks on the test

vehicle, but, after 2 tests, with 1 full mission profile, I think, I will not add them in order to keep things all equal. Should be noted that with each

iteration I am shutting the game down completely.

Test Two Output Log: http://www.filedropper.com/outputlog2

-----------------

3. Third Test: Target: K.I.S.S. Mission test MechJeb 2.4.2. Test Flight: 500km equatorial orbit targeted to station. Launch to Rendezvous. Results as

was expected, MechJeb failed to perform a Launch to Rendezvous. I chose my K.I.S.S. which is in an equatorial orbit at 250km. To stay even with tests 1

and 2, I launched to 500KM or rather, targeted that altitude. Of note: There is an issue with LtR command. In all prior cases before KSP .90 no matter

the target a LtR command would alter the orbital inclination box to match the targets orbital inclination. Now, it is not doing so. Perhaps the issue,

or atleast ONE is with the coding of that particular function of the 2.4.2 mechjeb? That i suppose is for the coders to figure out. Suffice it to say,

the next 3 tests will be interesting. Also of Note: Auto-Warp engaged and disengaged as per mod design.

Test Three Output Log: http://www.filedropper.com/outputlog3

-----------------

4. Fourth Test: Target: K.I.S.S. Mission test MechJeb 2.4.2. Test Flight: 500km equatorial orbit targeted to station. Launch to Plane. Results as was

expected MechJeb performed a full mission profile from launch, to orbital insertion, rendezvous to 100m from the target to a deorbit. As with tests 1-3

once the test was concluded, a revert to VAB was performed, followed by a quit to main menu then full shutdown of the game. Log was obtained and stored.

Test Four Output Log: http://www.filedropper.com/outputlog4

-----------------

5. Fifth Test: Target: K.O.S.C. Mission test MechJeb 2.4.2. Test Flight: 500km inclined orbit, 43.47 degrees inclined, targeted to station. Launch to

Rendezvous. Results as expected, the LtR failed to alter orbital Inclination box. Ship did launch, and as expected got hung up on the launch "tower" and flew oddly, but, MechJeb recovered and I allowed the

flight to go to stage sep and gravity turn, however launched into the prior tests inclination. Given that Launch To Rendezvous is now as of KSP .90 failing to alter the inclination box, this was expected.

Test Five Output Log: http://www.filedropper.com/outputlog5

-----------------

6. Sixth Test: Target: K.O.S.C. Mission test MechJeb 2.4.2. Test Flight: 500km inclined orbit, 43.47 degrees inclined, targeted to station. Launch into

Plane. Results after 6 tests total and the third using Launch into Plane were as expected. Full launch profile, orbital insertion and rendezvous to 100m of the target were as completed as expected. I

initiated a deorbit burn, then reverted to VAB, then main menu and finally closing down KSP completely.

Test Six Output Log: http://www.filedropper.com/outputlog6

-----------------

I want to state on the record: There IS an issue with MechJeb 2.4.2. There is no denying this. The issue that I can confirm at this time, is this. In

prior KSP versions for MechJeb from KSP .21 thru .25 MechJeb would perform any flight operation you asked of it, regardless of what button or

combination of buttons pressed there in. It would, if you chose, any of those stations and orbital inclinations from my 3 tests above as targets for

orbital inclinations, would adjust the parameters for MechJeb accordingly. If I chose Launch to Rendezvous lets say, using the Polar orbital station, it

would adjust the orbital inclination to match the targets inclination and launch accordingly. Now? It does not. I think this is an error in MechJeb to

not do this. Launch to Plane now, oddly seems to function as LtR used to. This begs me ask: If Launch into Plane now functions as LtR did, why still

have LtR on the mod as now, a launch to rendezvous requires some tweaks user side to work as desired. This isnt a big issue, but, it is something to

take note of never the less. Also, I have as yet to reproduce prior reported issues, but, I will continue to track and record as I go along. My test

vehicle is 100% stock with the single exception of MechJeb 2.4.2 being bolted to the side of the capsule. I have an RTG burried in the capsule itself

for power. I have now provided with this post, 6 (SIX) varying output logs, each is provided with its particular test. Included below this, is the

vehicle as well as the related persistent save file.

What I ask now is this: what can be done to repair this issue. Sadly, the steps to reproduce the Auto-Warp lock, are unknown to me, as with each test, I

did the same exact steps: Chose my launch vehicle inside the VAB, hit M, selected my target for the test, hit M to return to the visual of the vessel on the pad, hit the Launch to Rendezvous/into Plane

(depending on which iteration of course) and then hit engage autopilot. ONLY ONCE this time in 6 tests did it Auto-Warp lock with a launch clamp pre-fire and that was test 1.

I can upon request perform these tests again using the steps: engage autopilot THEN tell it which launch mode to use.

Vessel Craft File: http://www.filedropper.com/mechjeb242experimental

Picture of Mechjeb242experimental vessel:

Javascript is disabled. View full album

as you can see, I perhaps over did the struts and clamps, but, I wanted to make absolutely dead on certain that it wasnt going to sway in the SLIGHTEST on pad. IF you use this thing to test my tests, be warned: it is TOUCHY leaving the pad with all those blasted clamps.

The persistent save file that the above tests were conducted in: http://www.filedropper.com/persistent Please take special note: IF you wish to actually USE this persistent save, you MUST have: MechJeb, Lazor Docking Camera, Procedural Fairings and NovaPunch installed or the file may act in undesirable ways and contaminate the bug hunt.

The copy of MechJeb 2.4.2 that was used for these 6 tests: http://www.filedropper.com/mechjeb2-2420

Share this post


Link to post
Share on other sites
Hello again. Long Post.

Whoa! That's an understatement. Higgs, you should really editted down those long posts to focus on the important details. It's a rule of thumb that even after you've have a good copy, you can reduce a document by 30% or more by editting for brevity. Otherwise people will just at most skim and often just ignore the post.

As well, you should use

Hidden stuff!

to reduce the length of the post on the page. Have to put them in by hand, like this (with the extra space after the "[" and before the "]" removed):



[ spoiler="Visible text, have to have something in the quotes" ]
Temporarily hidden text
[ /spoiler ]

Big thing to remember about KSP 0.90 is a *lot* of things were changed in stock. Many mods have yet to completely adapt to these changes. Some of those stock changes force the mod writers to completely change the mechanisms and even the manner in which to use their functions (like Vertical Snap in the Editor Extensions mod). Other changes are currently unmoddable except in trivial ways (e.g. the new Building Upgrades: a mod can change the cost of upgrading them and what level a building starts a new game at and so far nothing else). MechJeb had to change a lot, especially with the changes to the Tracking Station, and I'm sure those changes aren't finished yet.

One thing I'll suggest is that you quote the Build # of the MechJeb you use, as from the Changes page (where you can follow the links on the left to get a download page for each build). The latest as of this post is #388. That MechJeb copy you have on FileDropper appears to be the 2.4.2.0 release build, which is #367 I believe.

Edited by Jacke

Share this post


Link to post
Share on other sites

1. so THATS how those spoilers work. Never have been able to get them to function lol.

2. given the time table in which i have been seeing issues with MechJeb brevity isnt my friend anymore. Ive found that I just need to bludgeon my issue with as many details as I can think of. Does this make for some...LONG posts? absolutely.

3. me and "dev build" mechjeb variants do not get along with them usually trying to microwave my saves. I had one nerf a save which stunk. And, for the record, 2.4.2 that was given on filedropper, was the version I was using direct from the curse webpage.

at this point Jacke, I am nearing the: I just give up" phase of all this as it has hamstrung my ability to play. You do make one good point, and I sincerely HOPE that all of what I am experiencing is a facet of what you said: that there is a tremendous amount of things that got whacked with the change stick. if it ISNT part of that, it needs to be hunted down, regardless of just how rare this is proving to be.

did it? if it did, thanks jacke!!

all of this being said, is the error 1. mechjeb 2. my persistent save 3. my copy of the game? 4. something other?

Share this post


Link to post
Share on other sites

Is there a debug version of MechJeb that will create its own log of everything it does, including every maneuver and engine thrust?

Share this post


Link to post
Share on other sites

Big thing to remember about KSP 0.90 is a *lot* of things were changed in stock. Many mods have yet to completely adapt to these changes. Some of those stock changes force the mod writers to completely change the mechanisms and even the manner in which to use their functions (like Vertical Snap in the Editor Extensions mod). Other changes are currently unmoddable except in trivial ways (e.g. the new Building Upgrades: a mod can change the cost of upgrading them and what level a building starts a new game at and so far nothing else). MechJeb had to change a lot, especially with the changes to the Tracking Station, and I'm sure those changes aren't finished yet.

You're late to the party. ;) The areas in which he's having trouble haven't seen alteration in quite a while.

Rendezvous / Launch Into Plane haven't changed since 0.25

The manner in which he's trying to use them is the source of his trouble.

Share this post


Link to post
Share on other sites

I'm gonna go out on a limb and say half the problems Higgs is having is ship design.

The screenshotted one has struts going to the launch clamps instead of actually strutting the ship properly.

Struts should be going from the outer tanks to the middle tank and from the top of the outer tanks to somewhere as high as possible on the upper stage.

Said ship only needs a maximum of 6 launch clamps (basically 2 per orange tank on symmetry) to hold it perfectly stable, half the problems with it not being "touchy" is the amount of physics calculations being done to separate all the pointless joints those struts and clamps are making.

Share this post


Link to post
Share on other sites

We already had the whole Higgs talk. We explained what Higgs was not doing right and I even made a change in the dev build to try and fix the warp problem. Higgs still want to use the release and not test the bugs and our advice. So be it. Next.

Share this post


Link to post
Share on other sites
Guest Jay83

Is there a way to remove the large Red/Blue markers after you use Landing assistance??

Share this post


Link to post
Share on other sites
Is there a way to remove the large Red/Blue markers after you use Landing assistance??

Turn off the landing predictor

Share this post


Link to post
Share on other sites

Some new on the current changes. I wrote some code to display pretty arrows so I can see more easily what is going on with the new code.

The new velocity code works. KSP vessel.obt_velocity report the velocity of the current active command pod/probe/port. It means that if your rocket wobble and your command pod move laterally the game report that lateral velocity even if your Center of Mass is moving in a perfect straight line. So I made some code change to get the actual velocity at the CoM.

The nice gif show the velocity reported by KSP in red and the new one computed by MJ in orange. The vessel is a long succession of empty tank with a command pod at both side and some RCS.

Next step will be doing the same for the "forward" vector so MJ can have something more stable on wobbly rockets.

MJ_Obt_Vel.gif

Share this post


Link to post
Share on other sites

Not sure if this is the correct place to post this, I searched the forums and think this is the thread, however, I'm sure someone will correct me.

I'm not able to get Mechjeb 2.4.2 working under KSP 90 -

I purchased the full version off of the KSP site, and am able to get the game to run; game seems to work fine in Career and Sandbox mods, however, MechJeb2 doesn't show up.

I extracted the zip file in KSP_win/GameData it extracted into a MechJeb2 sub-directory.

I'm running Windows 8.1 and the 32 bit version of KSP.

Any help, or a pointer to where to find help would be nice.

Thanks,

Denis

Share this post


Link to post
Share on other sites

I'm not able to get Mechjeb 2.4.2 working under KSP 90 -

....

Any help, or a pointer to where to find help would be nice.

Was MechJeb missing from a sandbox game too?

You need to at least provide the appropriate log file. Read the first post on this thread which will tell you how to find it.

- - - Updated - - -

did it? if it did, thanks jacke!!

all of this being said, is the error 1. mechjeb 2. my persistent save 3. my copy of the game? 4. something other?

Glad you got spoiler tags working, Higgs.

As for Launch to Rendezvous, I did a bit of research. As well, I'm familiar with the orbital mechanics involved. While I can see generating a solution for an orbit inclined a small amount, I don't see how it can work for a large inclination, especially 90 degrees. I don't know how you had it working under 0.25, as it's not a function I've used so far.

But you've found something that works. What I suggest to you is: 1. Launch into Plane but to a lower orbit than the target. 2. Use either the Rendezvous Autopilot or a few maneuvers from the Maneuver Planner to rendezvous (Adjust Close Approach and Match Orbit I think they're called). 3. Dock manually (which I like due to low RCS use) or use the Docking Autopilot.

That gets your new spacecraft docked with the orbital station and allows you to get on with your game. :)

- - - Updated - - -

[ Getting MJ to work with CoM velocity instead of stock's Control Point velocity ]

Very cool, sarbian! Looking forward to this as I suspect it will improve a lot of things.

Edited by Jacke

Share this post


Link to post
Share on other sites
Was MechJeb missing from a sandbox game too?

As for Launch to Rendezvous, I did a bit of research. As well, I'm familiar with the orbital mechanics involved. While I can see generating a solution for an orbit inclined a small amount, I don't see how it can work for a large inclination, especially 90 degrees. I don't know how you had it working under 0.25, as it's not a function I've used so far.

I can report to you that "launch into plane of target" works just fine in the current dev builds, even for an asteroid target at 143º (essentially west/northwest of KSC). There's nothing magical about it. I did it earlier today. There' s nothing in the physics of orbital mechanics to prevent launching into a direct rendezvous provided the eccentricity (not the inclination) isn't very great.

Share this post


Link to post
Share on other sites

Jacke,

MechJeb was missing from Sandbox mode as well.

- - - Updated - - -

Jacke,

I was able to install Enhanced Nav Ball, so I assume I'm doing the install correctly.

Share this post


Link to post
Share on other sites
We already had the whole Higgs talk. We explained what Higgs was not doing right and I even made a change in the dev build to try and fix the warp problem. Higgs still want to use the release and not test the bugs and our advice. So be it. Next.

Sarbian, expect a PM in response from this post of yours.

Respect and Frustration,

Higgs

Share this post


Link to post
Share on other sites
Jacke,

MechJeb was missing from Sandbox mode as well.

- - - Updated - - -

Jacke,

I was able to install Enhanced Nav Ball, so I assume I'm doing the install correctly.

The log show nothing wrong with the install. You did put the AR-202 part on your ship ? MJ does not show up by default until you do that.

AR202.png

Share this post


Link to post
Share on other sites

Well, finding this issue is turning into a sisyphean task. No matter how far I seem to get that boulder up the mountain, it keeps slamming back into me. SO. I ask you, the general population, coders with a working knowledge of not only the games code, but the code with in MechJeb for help. I am going to tear links from my post on page 881, post 8807 for ease of posting.

http://www.filedropper.com/outputlog1 test 1 using launch to rendezvous

http://www.filedropper.com/outputlog2 test 2 using launch into plane

http://www.filedropper.com/outputlog3 test 3 using launch to rendezvous 2nd target

http://www.filedropper.com/outputlog4 test 4 using launch into plane 2nd target

http://www.filedropper.com/outputlog5 test 5 using launch to rendezvous 3rd target

http://www.filedropper.com/outputlog6 test 6 using launch into plane 3rd target

http://www.filedropper.com/mechjeb242experimental ship used for all 6 tests, all stock parts save mechjeb

http://www.filedropper.com/persistent persistent save file that all 6 tests were conducted in, as well as being my main sandbox. mods needed: proc fairings, novapunch, lazor docking cam, mechjeb

http://www.filedropper.com/mechjeb2-2420 the EXACT copy of mechjeb used for all 6 tests.

Inside that spoiler as you can see are links. For full information, see page 881 post number 8807.

Here is what happening if you are not up to date.

I am getting odd glitches with MechJeb. I have been told multiple times I am doing something wrong, that the issue does not exist. Well, riddle me this: if what I am doing is wrong, see: using a visible feature of the mod, namely: Launch to Rendezvous, Launch into Plane of target, Engage Auto-Pilot, of course not in any particular order other than how they came to me as I type, how am I doing something wrong? Further question is: IF, the following procedure has worked from KSP .21 thru KSP .25: Put rocket to launch on the pad, hit M, select a target, hit M to return to seeing the pad, then clicking launch to rendezvous THEN Engage Auto Pilot OR reversing those last two steps as either direction of button presses would work w/out fail for 6 versions of KSP/MechJeb how is this suddenly not viable now in .90? Further Further question: IF the button: Launch to Rendezvous is NO LONGER a viable function, why does it yet remain? Would not logic dictate that, if such a function no longer is valid, it would be removed? Its like building a car today with not only an electric starter but a hand cranked-wrist breaking starter. Granted that comparison is a bit over the top, but the point remains the same, why have an invalid function still there, still very visible?

The glitches I am seeing are varied, but, are happening. The glitches are in no particular order: Auto-Warp failing to disengage, Launching into an incorrect inclination regardless of what the ascent guidance states, Launch Clamps pre-firing <this usually goes with the Auto-Warp failing to disenge. I could list more, but, to do that, i would need to make this post far longer, so, instead, I will direct you to another post of mine: same thread as this, page 863 post number 8628 and page 853 post number 8526 for a FULL litany of the issues I am encountering. A word of warning, both of those referenced posts in this paragraph are very very long posts, and contain yet more links to files.

A fellow player, who will remain nameless messaged me with the following message: "I have the same issue as you do (or did). Mechjeb auto fires even if I do not hit the timed launch option. I also have a problem where my planned orbits move all over the place with larger rockets so it might not be entirely a Mechjeb issue but I do not know for sure. Anyway, did you ever find a fix? Didn't feel like reading where everyone was bashing you for a legitimate problem just because they don't have it."

I have obviously removed this persons identifiers from this post out of respect for the player. IF said player sees this post and my use of the message they may feel absolutely free to state who they are.

With all this said, I seek anyones help on this. Please, I beg you, I know my posts are long, link infested things. I have been suggested to not use mechjeb, but, that is not going to happen, as it is a key mod to my game, and I am sure you would not fly w/out mods you see as key or vital to your game, so dont suggest the same to me. I am willing to completely delete my game and start from scratch with new mods and the like if the issue is in my copy of the game, or delete the save file and start again with that, but, both are drastic moves, and I hope for a more...easy solution. Also, if it wasnt clear, I am not a programmer, so, asking me to alter code isnt a wise thing, as that can lead to me screwing something else up lol.

I am at my very wits end with this, I have been chided, derided and maligned thru the course of this issue. All I seek is a resolution to this problem, what ever that may be. Please help me get back to enjoying a game I love.

Regards and pleas for help,

Higgs

Edited by Higgs

Share this post


Link to post
Share on other sites

Hello,i found this in my output_log.

MechJeb module MechJebModuleLandingGuidance threw an exception in OnStart: System.NullReferenceException: Object reference not set to an instance of an object

at MuMech.MechJebModuleLandingGuidance.InitLandingSitesList () [0x00000] in <filename unknown>:0

at MuMech.MechJebModuleLandingGuidance.OnStart (StartState state) [0x00000] in <filename unknown>:0

at MuMech.MechJebCore.OnStart (StartState state) [0x00000] in <filename unknown>:0

also,i would like to know if it's possible for MJ spaceplane guidance/autoland to land more to the middle of runway,maybe 50-100m from the edge.Because right now i must manually pitch up every time i use it.

i'm using dev build 388,KSP 32bit,Win7 X64

Thank you

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.