Boris-Barboris

[1.2.2-1.7.3] AtmosphereAutopilot 1.5.15

Recommended Posts

I've been having an odd problem: If I build a seaplane and start from the water the autopilot doesn't work. On on off there's no difference. Seems to work fine if you start on the ground. Is this a known issue?

Share this post


Link to post
Share on other sites
48 minutes ago, Boris-Barboris said:

@Citizen247
 

Idk. Maybe bug in stock KSP and vessel landedOrSplashed flag is not reset by the game. Try with this dll to check this (but try to enable AA right after liftoff, not on the ground):

https://www.dropbox.com/s/fzmrgz9k7o4cc10/AtmosphereAutopilot.dll?dl=0

Yep that seems to work! Thanks!

Edited by Citizen247

Share this post


Link to post
Share on other sites

I have been wanting something like this for so long!  I really hate spending hours babysitting flights across the planet, I basically just have this for cruise control, but it is perfect!

Thank you!

Share this post


Link to post
Share on other sites

@Boris-Barboris Has anyone offered to maintain this mod?

This is an awesome mod, I really hope someone takes it on.

I know a new feature getting implemented is not likely to happen, but an option to have the plane stay at a set distance above terrain (AGL) would be awesome.

Share this post


Link to post
Share on other sites
5 minutes ago, TheKurgan said:

Has anyone offered to maintain this mod?

I'm fine with keeping it compilable throughout patches. I'd say the mod is in need of a very specific kind of developer. There will be no suprise if he never comes.

@linuxgurugamer offered his help, but, realistically, AA needs full attention, and a lot of it.

5 minutes ago, TheKurgan said:

I know a new feature getting implemented is not likely to happen, but an option to have the plane stay at a set distance above terrain (AGL) would be awesome.

Yeah, see the above. Probably will not happen.

Edited by Boris-Barboris

Share this post


Link to post
Share on other sites

First off, his is in my top 5 favorite mods. But I need help. I've lost my Cruise Flight controller GUI...it won't come up. I think it might be hidden off screen or something. Help?

Share this post


Link to post
Share on other sites
Just now, Zapo147 said:

First off, his is in my top 5 favorite mods. But I need help. I've lost my Cruise Flight controller GUI...it won't come up. I think it might be hidden off screen or something. Help?

lol.

GameData/AtmosphereAutopilot/Global_settings.txt should contain window coordinates, look for cruise controller and window_x\y fields there and set them to zero or something like that. Config should be reloaded on each scene change. If not, restart the game.

Share this post


Link to post
Share on other sites

It worked in 1.4 for me last night.  Thanks for your fantastic plugin; I literally can't enjoy planes in Kerbal without it anymore!

Share this post


Link to post
Share on other sites

Ever since installing 1.4 my Spaceplanes would constantly turn left when I activated Fly-By-Wire. I've tried reinstalling the mod, but since it appears to still work for others after 1.4 I assume there's a simple fix? If so, could someone please tell me? Thanks in advance.

Share this post


Link to post
Share on other sites

Well, looks like there's no more need.

I'm not sure why, but it's working fine now. So at least we've got that out of the way.

Really sorry for the trouble. Thanks for helping.

Share this post


Link to post
Share on other sites

Hi all,

I have a problem with the KSP planes and I don't know where to ask, so please accept my aplogies for asking here as I'am using the autopilot for my test fligths to fly as precisely as possible.

I am trying to construct a plane that can fly in heigths of around 20000m  (around 65616 feet) at very high speed long distances very fuel efficient.

Made a plane that flies around 1340m/s (~Mach 4.3), but the main problem is that the wings start to overheat more and more  which draws my current line for the speed limit.  I tried to add radiators  to the wings, but the radiatores do not work at all. The radiator stays at 500° core/skin temperature and the wing is at around 950°/1050°.  Switching it on/off during the fligth does not change the wings temperature at all. I s this a bug or what is wrong ?

Have you found another way of cooling wings ?

TIA, Joe

Edited by JoeeoJ
typos

Share this post


Link to post
Share on other sites

Still working on 1.4.1 + MakingHistory with ModuleManager 3.0.6.

Share this post


Link to post
Share on other sites

Thank you so much Sir for this awesome mod!!!!I hope you can keep updating cause it gives flying in ksp a purpose!

Thank you again!

Edited by Boyster

Share this post


Link to post
Share on other sites

Sorry to disturb you, but I think your mod is amazing and very useful, but I have encountered small issue. I have done some skimming through this thread to see if anyone else has encountered the following issue, but I have not found any comment about it. Even when removing all other mods, Atmosphere Autopilot seems to remove inactive control surface directions. One example is that when flying the stock Aeris 3A, when I roll without any edits to the craft in flight or not. There is a bit of wobble left and right because the fins that by stock unmodified are just for yaw, the pitch and roll are active. I can always modify this in flight be deactivating the pitch and roll, but it is mildly annoying having edit the control surfaces for the stock and downloaded craft. Sorry if someone else has already found this, but I would be very appreciative if you or someone else would reply to this comment. 1.4.2 and other previous versions including ~1.2.

Share this post


Link to post
Share on other sites

@AlchemicRaven it is an unfortunate technical limitation, caused by my need to use custom control surface class. When you reconfigure your crafts and save them, settings will persist. With AA it has to be done unfortunately.

Share this post


Link to post
Share on other sites
On 3/12/2018 at 7:36 PM, JoeeoJ said:

Hi all,

I have a problem with the KSP planes and I don't know where to ask, so please accept my aplogies for asking here as I'am using the autopilot for my test fligths to fly as precisely as possible.

I am trying to construct a plane that can fly in heigths of around 20000m  (around 65616 feet) at very high speed long distances very fuel efficient.

Made a plane that flies around 1340m/s (~Mach 4.3), but the main problem is that the wings start to overheat more and more  which draws my current line for the speed limit.  I tried to add radiators  to the wings, but the radiatores do not work at all. The radiator stays at 500° core/skin temperature and the wing is at around 950°/1050°.  Switching it on/off during the fligth does not change the wings temperature at all. I s this a bug or what is wrong ?

Have you found another way of cooling wings ?

TIA, Joe

I am guessing that the altitude you mention is a limit for air breathing engines that you are using?

Otherwise I would say go higher, as the heating of parts like wings is from air resistance, which you probably already know.

Other wise I would suggest looking at other mods that add plane parts. I think the stock plane parts are limited to 2000K. I know some mods have parts that are much higher, as they are meant for space plane builds.

You might want to take a look at heat mods. I am not sure which but I think one has plane parts, like tail rudder that are radiators themselves. Not only do they have higher temperature ratings but they actually suck heat from other parts nearby. Hopefully that might bring down your hot spots enough.

Then there is plane design, sometimes it is possible to move wings etc back a little which reduces the temperature they experience by kind of being 'in the wash' rather than front line exposed. This does mean sometimes really changing you plane build as moving CoL and CoM by merely sliding the wings etc backwards will hugely alter the performance/handling.

@Boris-Barboris I am very happy to read that this works with 1.4.2. I was worried that this would not get updated, as I fly things that are shall we say very tricky to fly without this mod, specifically stuff that tends to pitch up and down at certain air speeds. I am still waiting on some other mods to be updated before I can fly in 1.4.2. But I am happily playing 1.3.1 until they are.

Edited by Apaseall

Share this post


Link to post
Share on other sites

@Boris-Barboris Thank you, Boris-Barboris, for replying to my comment. I was unaware that that was an intended feature. I will be sure to only download craft not in the stock ships folder. As for the stock craft, I could always just edit the .craft files or edit them before or in flight.

Share this post


Link to post
Share on other sites

Hey,

I was curious if anyone is have a problem with this mod working on version 1.4.2. When ever I try to apply any form of AA to an aircraft, all the flight control go hay-wire and the aircraft doesn't seem to respond to any manual inputs. Is anybody else having this problem, and is there a way to fix it? Thanks!

Share this post


Link to post
Share on other sites
6 hours ago, TScott said:

Hey,

I was curious if anyone is have a problem with this mod working on version 1.4.2. When ever I try to apply any form of AA to an aircraft, all the flight control go hay-wire and the aircraft doesn't seem to respond to any manual inputs. Is anybody else having this problem, and is there a way to fix it? Thanks!

No. Screenshots and logs should tell.

Share this post


Link to post
Share on other sites
6 hours ago, TScott said:

Hey,

I was curious if anyone is have a problem with this mod working on version 1.4.2. When ever I try to apply any form of AA to an aircraft, all the flight control go hay-wire and the aircraft doesn't seem to respond to any manual inputs. Is anybody else having this problem, and is there a way to fix it? Thanks!

Are trying to fly with both AA and SAS

I’ve had planes “go crazy” with AA before too, but I think that was caused by SAS because I was too used to turning it on. 

Other than that, works fine with SAS off. I can circle Kerbin in a minute with 16x time warp and 1500-1600m/s speed at 20k with no issues :D

Edited by Jognt

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.